Go Back   Team-BHP > Under the Hood > In-Car Entertainment

Thread Tools Search this Thread
Old 15th September 2008, 19:56   #16
Join Date: Aug 2008
Location: Dehra Dun
Posts: 153
Thanked: 7 Times

it is a dvc sub , i wanted to know that whether its a spl or a sq sub, anyway what about the real problem of mine guys, is it my hardware which is at fault or what, please advise
makanaka is offline   Reply With Quote
Old 15th September 2008, 20:40   #17
Magma's Avatar
Join Date: Nov 2007
Location: mumbai
Posts: 355
Thanked: 2 Times

Originally Posted by gunbir View Post
How did you manage to run a 2ohm load on the bridged output on that amp???

your answer may lie in what the above person says

your amp is a 4 channel amp. 2 channels bridged together are running the DVC sub correct.?
when the sub is wired in parallel ,the 2 coils -(4 ohm and 4ohm) present a 2 ohm load correct?
now your amp in bridged mode may not be stable at 2 ohms ( much like many 4 channel amps ) and hence you may be having this problem

do as navinji has suggested. wire the sub in series.
alternatively use all 4 channels for the sub
Alternatively get a mono
Alternatively get a 4ohm SVC sub

Alterantively wait for more guru advice because im learning too so i may be wrong
Magma is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Some Good Low Bass Songs I've heard! headers In-Car Entertainment 16 20th March 2008 15:17
Could someone identify a few songs for me? Sheruken Shifting gears 5 28th July 2004 18:58
Phoebe's Songs! Pferdestärke Shifting gears 9 8th June 2004 21:44
top 5 driving songs souled Shifting gears 2 18th May 2004 14:10

All times are GMT +5.5. The time now is 15:40.

Copyright ©2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks