Go Back   Team-BHP > Around the Corner > Shifting gears > Gadgets, Computers & Software


Reply
 
Thread Tools Search this Thread
Old 4th January 2007, 22:08   #1
Senior - BHPian
 
manveet's Avatar
 
Join Date: Jul 2006
Location: New Delhi
Posts: 1,059
Thanked: 581 Times
Default USB Drive GHOST on my Desktop: Most Perplexing Problem EVER.

Somehow I seem to land up with the weirdest problems. The story is about an 80 GB USB drive

1. Connected it to my Laptop (hereafter LT)
2. It got detected but not showing on "My Computer". (showing perfectly fine on "Device Manager")
3. Connected it to my Desktop (hereafter DT) - shows up on "My Computer"
4. Copy 500MB of data on it and then remove it

Now the funny part.

5. The DT My Computer IS STILL SHOWING THE USB DRIVE. What's spooking me out is that I can even ACCESS the 500 MB data and run the Data files WITHOUT THE DRIVE connected.

I have tried formatting it - get a msg saying some Disk Utilities program is running it so exit that and try again.

I have deleted everything, emptied Recyle Bin, Norton Protected Recycle Bin - EVERYTHING - It is showing some 90MB being used which I can't see.

6. Now when I connect the 80GB to the DT, nothing happens - it's NOT showing even in the Device Manager. It's not being detected in the LT so that problem continues.

What do I do? How do I remove the 80 GB ghost space from my DT and make my USBHDD run on other computers.

I'm lost. and Spooked.

Help me !!

manveet is offline   Reply With Quote
Old 4th January 2007, 22:41   #2
BHPian
 
gkrishn's Avatar
 
Join Date: Aug 2004
Location: Bangalore
Posts: 584
Thanked: 36 Times
Default

Dude,
Before physically removing the usb drive from PC, try doing this...

In the system tray, there will be a icon "safely Remove Hardware". Right click on it. It will list the removable devices. your usb drive should be there. Click on it. This will unload the drive. It should. then phsyically remove the USB from PC. This is how the USB drive are supposed to be removed.

Try this and let me know if it is working...

Last edited by gkrishn : 4th January 2007 at 22:49.
gkrishn is offline   Reply With Quote
Old 4th January 2007, 23:29   #3
BHPian
 
sreenivass's Avatar
 
Join Date: Oct 2006
Location: Bangalore India
Posts: 872
Thanked: 6 Times
Default

gkrishn is spot on, you have to unmount (I am from unix world with windows knowledge) by clicking hardware detected icon in sys tray and stop the device before physically removing it. until then data supposed to be written remains in buffers.

What are the OSes installed on LT and DT. Try running hardware detection wizard (Control Panel -> Computer Management -> USB Controller right click and scan for hardware changes).
sreenivass is offline   Reply With Quote
Old 5th January 2007, 00:09   #4
Senior - BHPian
 
manveet's Avatar
 
Join Date: Jul 2006
Location: New Delhi
Posts: 1,059
Thanked: 581 Times
Default

Ok, a little background is in order.

I am quite a comp-savvy fellow, been hooked onto the PC ever since I had my own 286 in 1989 or so. Am also a computer engineer so have done my share of tinkering etc.

No offence, I have tried these pretty obvious things.

As per your specific suggestions ..

Quote:
Originally Posted by gkrishn View Post
Dude,
Before physically removing the usb drive from PC, try doing this...

In the system tray, there will be a icon "safely Remove Hardware". Right click on it. It will list the removable devices. your usb drive should be there. Click on it. This will unload the drive. It should. then phsyically remove the USB from PC. This is how the USB drive are supposed to be removed.

Try this and let me know if it is working...
Ofcourse it's working. It gets removed but still shows 80GB in the "My Computer". I can also copy new data into the 80GB and delete it as well. The 80GB is practically functioning as a new partition !! - why do you think I'm spooked

This problem had persisted for 5 days and over 20 reboots.
manveet is offline   Reply With Quote
Old 5th January 2007, 00:16   #5
Senior - BHPian
 
iraghava's Avatar
 
Join Date: Oct 2005
Location: Bhaiyyaland
Posts: 8,028
Thanked: 150 Times
Default

Quote:
Originally Posted by manveet View Post
Ofcourse it's working. It gets removed but still shows 80GB in the "My Computer". I can also copy new data into the 80GB and delete it as well. The 80GB is practically functioning as a new partition !! - why do you think I'm spooked
Manveet PM the Geek Lord Speedonline , He should be able to help you out!!

Last edited by iraghava : 5th January 2007 at 00:20.
iraghava is offline   Reply With Quote
Old 5th January 2007, 00:22   #6
Senior - BHPian
 
manveet's Avatar
 
Join Date: Jul 2006
Location: New Delhi
Posts: 1,059
Thanked: 581 Times
Default

Quote:
Originally Posted by sreenivass View Post
gkrishn is spot on, you have to unmount (I am from unix world with windows knowledge) by clicking hardware detected icon in sys tray and stop the device before physically removing it. until then data supposed to be written remains in buffers.
Been there done that. 80GB still remains.

Quote:
Originally Posted by sreenivass
What are the OSes installed on LT and DT.
LT and DT both are on XP.

Quote:
Originally Posted by sreenivass
Try running hardware detection wizard (Control Panel -> Computer Management -> USB Controller right click and scan for hardware changes).
In LT and DT both - When the USB is plugged in, it shows up with no problem (no yellow asterisk etc) as a "Hitachi Disk Drive" in "Device Manager" but still not appearing in "My Computer"

Let's solve this problem step at a time ..

Problem 1: I plug it in, it gets detected, shows up in Device Manager but nothing at all in My Computer - whats the solution to this?

Problem 2: The buffer/ghost bit - we'll deal with this in phase 2 ..

sounds like an ok approach ?

Your suggestions?
manveet is offline   Reply With Quote
Old 5th January 2007, 00:37   #7
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,850
Thanked: 15,406 Times
Default

Step 1 :
Right click on "My computer"
Choose Manage
See if USB drive appears there. If it does, assign it a drive letter.
This process should happen automatically for XP, but since its not, you do it manually

Also, do you have a network drive in your XP?
If you do, then disconnect the network drive and and the USB drive will appear.

A permanent solution to this problem is to have a gap between the network drive letter and normal disk drives.
For example you have c: and d: as your HDD drives.
If your network drive is e:, there will be a problem, but if you have your network drive as q: or something like that, this will leave a gap for your network drive.

The ghost problem is related.
I am suspecting that you are moving your files between your network drive and HDD, and not really the USB.

Cheers
tsk1979 is offline   Reply With Quote
Old 5th January 2007, 00:46   #8
Senior - BHPian
 
manveet's Avatar
 
Join Date: Jul 2006
Location: New Delhi
Posts: 1,059
Thanked: 581 Times
Default Hope this Helps

A screen-shot that better explains the problem :



Last edited by manveet : 5th January 2007 at 00:47.
manveet is offline   Reply With Quote
Old 5th January 2007, 00:56   #9
Distinguished - BHPian
 
CrAzY dRiVeR's Avatar
 
Join Date: Jun 2006
Location: Bangalore / TVM
Posts: 8,407
Thanked: 14,160 Times
Default

Man!

i dont know much about these things... But... Sure like to know how this gets solved... he he...

One more thing... I have a 40GB hard disk only... Man, i wish i had this probelm... Could have really used an extra spooky free 80 GB...

CrAzY dRiVeR is offline   Reply With Quote
Old 5th January 2007, 00:57   #10
Senior - BHPian
 
manveet's Avatar
 
Join Date: Jul 2006
Location: New Delhi
Posts: 1,059
Thanked: 581 Times
Default

Quote:
Originally Posted by tsk1979 View Post
Step 1 :
Right click on "My computer"
Choose Manage
See if USB drive appears there. If it does, assign it a drive letter.
This process should happen automatically for XP, but since its not, you do it manually
Within Manage > Device Manager > Universal Serial Bus Controller .. it's showing as Universal Mass Storage Device ..

Where specifically did you mean in Manage ..?

Quote:
Also, do you have a network drive in your XP?
This method used to work in my college where I used to disconnect and it solved the issue, not this time - as of now I have no n/w drive to disconnect on either LT or DT

.. but you are on the right track in terms of identifying the problem atleast ...

Quote:
If you do, then disconnect the network drive and and the USB drive will appear.
Like mentioned, pop-up says no n/w to disconnect.

Quote:
A permanent solution to this problem is to have a gap between the network drive letter and normal disk drives.
For example you have c: and d: as your HDD drives.
If your network drive is e:, there will be a problem, but if you have your network drive as q: or something like that, this will leave a gap for your network drive.
I remember many years ago I used to do this via the autoexec.bat on the DOS .. am out of touch so don't know how to do this on XP.

Please tell the steps


Quote:
The ghost problem is related.
I have my Fingers crossed.

Last edited by manveet : 5th January 2007 at 00:59.
manveet is offline   Reply With Quote
Old 5th January 2007, 01:00   #11
Senior - BHPian
 
Join Date: Mar 2006
Location: Faridabad
Posts: 6,814
Thanked: 293 Times
Default

manveet which casing you are using.........
low_bass_makker is offline   Reply With Quote
Old 5th January 2007, 01:00   #12
Senior - BHPian
 
manveet's Avatar
 
Join Date: Jul 2006
Location: New Delhi
Posts: 1,059
Thanked: 581 Times
Default

Quote:
Originally Posted by CrAzY dRiVeR View Post
Man i wish i had this probelm... Could have really used an extra spooky free 80 GB...
I don't mind it at all .. provided my USB gets detected .. desperately need to offload data from LT to DT ..
manveet is offline   Reply With Quote
Old 5th January 2007, 01:02   #13
Senior - BHPian
 
manveet's Avatar
 
Join Date: Jul 2006
Location: New Delhi
Posts: 1,059
Thanked: 581 Times
Default

Quote:
Originally Posted by low_bass_makker View Post
manveet which casing you are using.........
"zippys"

it worked fine initially .. so i don't think thats the prob.

plus my trusty 6 yr old 20GB external is also not getting detected :(
manveet is offline   Reply With Quote
Old 5th January 2007, 01:23   #14
Senior - BHPian
 
Join Date: Mar 2006
Location: Faridabad
Posts: 6,814
Thanked: 293 Times
Default

here is the mange tsk is telling about



and inside this there is a disk manangement in which you can see which disks are connected...you can connect the disk but it will not show in the my computer ......by remove disk name....



the problem of not show usb hdd in my computer can be also but to some util which can hide drive names in my computer
low_bass_makker is offline   Reply With Quote
Old 5th January 2007, 01:36   #15
Senior - BHPian
 
manveet's Avatar
 
Join Date: Jul 2006
Location: New Delhi
Posts: 1,059
Thanked: 581 Times
Default

Yippee !!

So, we've got the problem now. Here's my screen-shot:





So how do I now allocate this?

How to assign a drive letter? Where is the allow access option coming from?
manveet is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ghost Busters Drive anyone? 2nd & 3rd October, 2015 (Bangalore - Sathyamangalam) PatchyBoy The Team-BHP Meet Section 4 30th September 2015 19:35
USB/iPod support for a OEM HU w/o USB Support MadRash In-Car Entertainment 26 2nd August 2014 00:40
All about USB Flash Drives a.k.a Pen Drive / Thumb Drive / Memory Stick / Jump Drive KSM-Vtec Gadgets, Computers & Software 1 28th February 2012 12:04
Have you ever played full volume of your ICE? Ever?? xingamazon In-Car Entertainment 27 5th January 2011 02:41
External USB Jack for my Non USB HU thedreamcatcher In-Car Entertainment 10 25th March 2009 13:10


All times are GMT +5.5. The time now is 01:21.

Copyright ©2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks