Go Back   Team-BHP > Around the Corner > Shifting gears > Gadgets, Computers & Software


Reply
 
Thread Tools Search this Thread
Old 14th December 2007, 13:54   #1
BHPian
 
Join Date: Jun 2005
Location: New Delhi
Posts: 613
Thanked: 116 Times
Default Incompetent Altec Lansing India

Hi,

Sharing a really terrible experience I had with Altec Lansing India. I was looking for a dockable speaker for my iPod Video. The main requirements were good sound, portability and ability to play video in that order.

I zeroed in on Altec Lansing iM7 and Bose SoundDock. iM7 can play iPod Videos and can run on batteries but the Bose dock can't. I searched the web for comparisons between the two and the opinions differed. Some say Bose is better and others prefer iM7. iM7 costs 9,800/0 with a carry bag whereas Bose is Rs. 17,888/- without a carry case.

So I decided to buy iM7 and contacted Trifin Technologies - Altec Lansing's Indian distributor. They directed me to Cosmos Infotec, one reseller. I bought the system from Cosmos and tried it at home. Sound quality was pretty good for a non-audiophile like me, but it wasn't able to play videos as published over in manual and brochure.

I called up Altec Lansing support and had to first convince their support guy that it is a published feature. Anyways he was not much help and promised to send a technical person to my home. I waited for 2 days, and then wrote a mail to Trifin and CCed it to Altec Lansing Asia and Global sales.

To Trifin's credit, I immediately got a response from one of their senior guys and he offered to exchange the system. I exchanged that and the new one also isn't able to play video. When I contacted Trifin again, they offered to get back the system and refund me the money.

I pointed out that I have spend substantial time and energy in the buying process and will be happier if they can help me in resolving the issue.

I am quoting a mail send from Trifin to the reseller -

"Dear ****

I am really sorry to say but frankly as of now i do not have any other way but to request you to take this back and make refund to Mr. Tomar.

Regret all the inconvenience caused to all of you.

Best Regards
****"

I accept that Trifin tried to help me as best as they could and even now offering to take back the system. But isn't it ridiculous that Altec Lansing technical expertise is so limited in India that they can't resolve a simple problem like this. I will now have serious reservations about buying any Altec product in future.

Cheers

Nitin
ntomer is offline   Reply With Quote
Old 14th December 2007, 15:10   #2
BHPian
 
Amey's Avatar
 
Join Date: Sep 2006
Location: Pune
Posts: 679
Thanked: 189 Times
Default

This is not limited to Altec Lansing only.Its valid for almost all computer hardwares parts available in India.
The technical support is almost non existent.
Amey is offline   Reply With Quote
Old 14th December 2007, 15:48   #3
BHPian
 
Join Date: Jun 2005
Location: New Delhi
Posts: 613
Thanked: 116 Times
Default

And the irony is that I might still have to keep the product even after Trifin's offer of return.

There is no alternative product available in India at similar prices. Bose SoundDock is about twice the cost and doesn't play video, so no point returning iM7 and buying Bose :-(

\N
ntomer is offline   Reply With Quote
Old 14th December 2007, 16:18   #4
BHPian
 
mohit's Avatar
 
Join Date: Sep 2004
Location: Toronto / Kurukshetra
Posts: 640
Thanked: 119 Times
Default

Did you try PMing Sam?
mohit is offline   Reply With Quote
Old 14th December 2007, 16:36   #5
Senior - BHPian
 
Join Date: Mar 2006
Location: Faridabad
Posts: 6,814
Thanked: 293 Times
Default

Quote:
Originally Posted by mohit View Post
Did you try PMing Sam?
I dont understand why? If tomer has any question he can post it here so that every body can gain knowledge from it.
low_bass_makker is offline   Reply With Quote
Old 14th December 2007, 17:29   #6
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,850
Thanked: 15,406 Times
Default

Quote:
Originally Posted by ntomer View Post
And the irony is that I might still have to keep the product even after Trifin's offer of return.

There is no alternative product available in India at similar prices. Bose SoundDock is about twice the cost and doesn't play video, so no point returning iM7 and buying Bose :-(

\N
Did you try googling on "How to play video". Maybe its not that difficult.
tsk1979 is offline   Reply With Quote
Old 14th December 2007, 17:32   #7
BHPian
 
Join Date: Jun 2005
Location: New Delhi
Posts: 613
Thanked: 116 Times
Default

Quote:
Originally Posted by tsk1979 View Post
Did you try googling on "How to play video". Maybe its not that difficult.
Tried all that, could not find a clue.

maybe google_guru (LBM) will help me ;-)

\N
ntomer is offline   Reply With Quote
Old 14th December 2007, 20:02   #8
BHPian
 
Join Date: May 2007
Location: Navi Mumbai
Posts: 185
Thanked: 46 Times
Default

ntomer,
One clarification needed:
whether
A. videos not playing at all
OR
B. The videos play on the ipod but video signal is not being output from the dock?
Asking becoz it could be something related to connectivity rather than a technical fault, because it is very unlikely that both the pieces had the same problem.
anuragn is offline   Reply With Quote
Old 15th December 2007, 08:21   #9
BHPian
 
Join Date: Jun 2005
Location: New Delhi
Posts: 613
Thanked: 116 Times
Default

Quote:
Originally Posted by anuragn View Post
ntomer,
One clarification needed:
whether
A. videos not playing at all
OR
B. The videos play on the ipod but video signal is not being output from the dock?
Asking becoz it could be something related to connectivity rather than a technical fault, because it is very unlikely that both the pieces had the same problem.
iPod plays video but output is not passed to tv by dock.
ntomer is offline   Reply With Quote
Old 15th December 2007, 09:15   #10
BHPian
 
Join Date: Nov 2007
Location: Pune
Posts: 69
Thanked: 15 Times
Default

Altec has service in India but just barely. I have series 100 from Altec but one day it just conked off. Took it to the altec service station through a dealer. It took them two and a half months to replace the unit. No intimation of the problems or the solution. I was the one who was calling them after every two days. And then also the box was returned all torn up with the unit barely safe in it. Really pathetic.
hell_raiser is offline   Reply With Quote
Old 15th December 2007, 11:54   #11
BHPian
 
Join Date: May 2007
Location: Navi Mumbai
Posts: 185
Thanked: 46 Times
Default

@ntomer,
How are you connecting to your TV? s-video or RCA composite?
And also give any other details that might help me in troubleshooting.
anuragn is offline   Reply With Quote
Old 15th December 2007, 12:33   #12
Team-BHP Support
 
navin's Avatar
 
Join Date: Mar 2004
Location: mumbai
Posts: 22,230
Thanked: 3,642 Times
Default

Quote:
Originally Posted by mohit View Post
Did you try PMing Sam?
Sam represents Harman Intl and not Altec. Altec of today is not related to JBL although both companies were founded by Mr. Lansing.
navin is offline   Reply With Quote
Old 17th December 2007, 09:44   #13
BHPian
 
Join Date: Jun 2005
Location: New Delhi
Posts: 613
Thanked: 116 Times
Default

Quote:
Originally Posted by anuragn View Post
@ntomer,
How are you connecting to your TV? s-video or RCA composite?
And also give any other details that might help me in troubleshooting.
I am connecting TV to iM7 using RCA cable. The video plays fine but there is no output at TV.

\N
ntomer is offline   Reply With Quote
Old 17th December 2007, 10:17   #14
Team-BHP Support
 
navin's Avatar
 
Join Date: Mar 2004
Location: mumbai
Posts: 22,230
Thanked: 3,642 Times
Default

Quote:
Originally Posted by ntomer View Post
I am connecting TV to iM7 using RCA cable. The video plays fine but there is no output at TV.
try an S-video cable.
navin is offline   Reply With Quote
Old 17th December 2007, 12:08   #15
BHPian
 
Join Date: May 2007
Location: Navi Mumbai
Posts: 185
Thanked: 46 Times
Default

Quote:
Originally Posted by ntomer View Post
I am connecting TV to iM7 using RCA cable. The video plays fine but there is no output at TV.

\N
I assume that you have tried fiddling with all settings at the TV-end.
But just to be double-sure, check that you are connecting to the correct inputs of the TV e.g not video into audio-in or video into video-out of TV and whether you are selecting the right source e.g. AV-1 or 2 etc

Just now discovered (not sure though):
It plays only jpegs on the TV...nowhere is it mentioned that it plays videos. So just view any photos on your ipod and check whether they are displayed on your TV.
anuragn is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Altec Lansing MX 5021 subtitute revvedup Gadgets, Computers & Software 6 26th October 2009 00:19
Altec Lansing MX 5021 sub gone bad revvedup Gadgets, Computers & Software 13 25th July 2008 22:12
Philips dvp5106k - Altec lansing 251 - Still no 5.1 channel Output Knight Rider Gadgets, Computers & Software 0 9th April 2007 15:38
ipod speakers - Altec IM3 and IM7 navin Gadgets, Computers & Software 4 1st September 2005 10:35
Altec Lansing 5.1 in My Santro Car... ! webjunk In-Car Entertainment 10 27th December 2004 12:30


All times are GMT +5.5. The time now is 11:01.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks