Go Back   Team-BHP > BHP India > The Indian Car Scene


Reply
 
Thread Tools Search this Thread
Old 7th August 2010, 23:31   #346
BHPian
 
Mehul1100's Avatar
 
Join Date: Nov 2009
Location: Kangayam, TN
Posts: 240
Thanked: 13 Times
Default

Quote:
Originally Posted by samsag12 View Post
Nothing can be done to prevent the oil on the plug apart from a engine rebore. New ones with the adaptor will work very good for sometime and pickup will be good too( experienced myself on S1 engine) but after sometime they too will loose their optimal functionality. Best you can do is to add some engine oil additive like Nulon Engine treatment which forms a 0.5 micron coating on each and every part like piston rings, seals et al which in turn will help to reduce the oil consumption. The cost is around 500 Rs for a 350 ML can and can be bought online at a discount. Have heard that it works wonders, reduces engine noise, overheating issues, and white smoke.
Regarding the rust on pipe and muffler, get the underbody of the car coated with rubber sealant. Rust cannot acumulate on the insides of the exhaust parts of your car as the engine is consuming oil so just get the underbody coating done.
Yeh I am using Nulon, its wonderfull, top speed increased, engine temperature reduced. My both car are having it.
Mehul1100 is offline   Reply With Quote
Old 18th September 2010, 12:11   #347
BHPian
 
jaisha8's Avatar
 
Join Date: Mar 2009
Location: Trichur, Kerala
Posts: 358
Thanked: 98 Times
Default

I have rectified the problem with my S1. The problem was on one of the Delco cables. So got the Delco cup replaced and also put 5 new cables (4 going into the plugs and 1 to the coil). After replacing this, the car started in the very first ignition itself.
Later went to the fabricator and changed the the complete tail pipe assembly including the muffler.
Also the wheel cap sent by Anmol was untouched. Also replaced the swift wheel caps with original S1 wheel caps. Now the car is running superbly. Once again my special thanks to Anmol for his initiative to get the wheel caps and send it across to me.
Attaching some photos of my S1 taken this time when I was home.
Attached Images
         

Last edited by jaisha8 : 18th September 2010 at 12:13.
jaisha8 is offline   Reply With Quote
Old 18th September 2010, 14:40   #348
BHPian
 
Join Date: Jun 2007
Location: -_-
Posts: 313
Thanked: 113 Times
Default

Nice nice. your cars looking as good as new. Love the sparkling red tailights. here in delhi i have never seen a fiat with both tail lights working and with lenses that were not faded(except my own perhaps. i spent days on it, making sure everything on my car worked after we got it, even the handbrake and cabin light) too bad , i dont have that car anymore :(

so now you have seven s1 type wheel caps? And your very welcome.sorry for making you wait more than a month before you got it. I have never sent parcels by post , that along with my exams led to the delay, but alls well that ends well.
mycarhasablower is offline   Reply With Quote
Old 18th September 2010, 18:23   #349
Senior - BHPian
 
samsag12's Avatar
 
Join Date: Dec 2009
Location: City of Nawaabs
Posts: 1,611
Thanked: 198 Times
Default

Now your car's looking complete and original jaisha8. Just curious to know does your wiper motor has a faulty park switch ? Asked this as your wipers are struck in the middle. BTW i hope you and MCB remember remember my requirement of the S1 badges. Do help me out as i will be changing the dicky lid of my S1 and would need the same. My requirement is of 3 sets i.e. 3x2.
samsag12 is online now   Reply With Quote
Old 18th September 2010, 18:54   #350
BHPian
 
Join Date: Aug 2008
Location: mumbai
Posts: 176
Thanked: 11 Times
Default

I require some help. I reside in Andheri East at Mumbai. I need to repaint and carry out some odd problems for my Premier Padmini. Just waiting for the rain to subside. Can anyone suggest a good, trustworthy and not so costly repair shop where I can leave my vehicle. I need only original parts to be put the bumpers have also rusted and would require a coating or replacement battery is new replaced in August this year no big mechanical problems except clutch would require replacement and need to check / replace the fan groove. Some oil leak is there in the engine bay.

Note from the Team-BHP Support Team : Please take the time to use proper punctuation as per Team-BHP rules. Avoid...typing...like...this. Thanks.

Last edited by Rudra Sen : 18th September 2010 at 23:04.
gururaj r is offline   Reply With Quote
Old 18th September 2010, 19:14   #351
BHPian
 
jaisha8's Avatar
 
Join Date: Mar 2009
Location: Trichur, Kerala
Posts: 358
Thanked: 98 Times
Default

Quote:
Originally Posted by samsag12 View Post
Now your car's looking complete and original jaisha8. Just curious to know does your wiper motor has a faulty park switch ? Asked this as your wipers are struck in the middle. BTW i hope you and MCB remember remember my requirement of the S1 badges. Do help me out as i will be changing the dicky lid of my S1 and would need the same. My requirement is of 3 sets i.e. 3x2.
No, the switch is not faulty. The wiper was slipping and falling out of the windshield frame when we fitted it lower, so my mechanic fitted it this way. Regarding the S1 badges, I m abroad now at work place, shall buy and send it when I get home next month. It's the same one as fitted on my car's dicky lid, isnt it?
jaisha8 is offline   Reply With Quote
Old 18th September 2010, 19:29   #352
Senior - BHPian
 
samsag12's Avatar
 
Join Date: Dec 2009
Location: City of Nawaabs
Posts: 1,611
Thanked: 198 Times
Default

Jaisha8 ok so problem lies either with the wiper arm's milling or the wiper box which is causing the blades to slip. Anyways i am happy to see that atleast both of them are working simultaneously.
Regarding the badges, yeah they are the same which are sticked to the dicky lid of your car. I may be needing atleast 3 sets i.e. 3 PREMIER and 3 PADMINI S1 badges. Hope i am not troubling you with this. BTW do share the cost of a set.
samsag12 is online now   Reply With Quote
Old 24th December 2010, 11:59   #353
BHPian
 
jaisha8's Avatar
 
Join Date: Mar 2009
Location: Trichur, Kerala
Posts: 358
Thanked: 98 Times
Default Re: The lovely Premier Padmini S1 (Fiat 1100-D)

The hot FIAT sisters. Envy of the neighbourhood & of course owner's pride. The Premier Padmini S1 & the blue eyed baby FIAT Linea...
Attached Images
     

Last edited by jaisha8 : 24th December 2010 at 12:04.
jaisha8 is offline   Reply With Quote
Old 24th December 2010, 22:27   #354
BHPian
 
freakmuzik's Avatar
 
Join Date: Dec 2009
Location: Trivandrum
Posts: 459
Thanked: 387 Times
Default Re: The lovely Premier Padmini S1 (Fiat 1100-D)

@jaisha8: Wow, both cars are looking fabulous. You can indeed feel proud to own FIAT's of two different generations! Awesome.
freakmuzik is offline   Reply With Quote
Old 25th December 2010, 09:32   #355
Senior - BHPian
 
IQBAL VEERJI's Avatar
 
Join Date: Apr 2009
Location: SAAT BUNGLA, BAMBAI.
Posts: 1,040
Thanked: 282 Times
Default Re: The lovely Premier Padmini S1 (Fiat 1100-D)

Quote:
Originally Posted by jaisha8 View Post
The hot FIAT sisters. Envy of the neighbourhood & of course owner's pride. The Premier Padmini S1 & the blue eyed baby FIAT Linea...
One good thing I noticed that both cars have Reg. No. begining with 4 and ending with 7..In Mumbai I too own a Linea Emotion in Red colour , very good car.. Regards......

Last edited by IQBAL VEERJI : 25th December 2010 at 09:35.
IQBAL VEERJI is offline   Reply With Quote
Old 25th December 2010, 10:23   #356
BHPian
 
jaisha8's Avatar
 
Join Date: Mar 2009
Location: Trichur, Kerala
Posts: 358
Thanked: 98 Times
Default Re: The lovely Premier Padmini S1 (Fiat 1100-D)

Quote:
Originally Posted by IQBAL VEERJI View Post
One good thing I noticed that both cars have Reg. No. begining with 4 and ending with 7..In Mumbai I too own a Linea Emotion in Red colour , very good car.. Regards......
Dear Iqbal, frankly speaking even I didnt notice this till u pointed it out. What a strange coincidence. Thanx for pointing it out.
jaisha8 is offline   Reply With Quote
Old 4th January 2011, 13:26   #357
BHPian
 
jaisha8's Avatar
 
Join Date: Mar 2009
Location: Trichur, Kerala
Posts: 358
Thanked: 98 Times
Default Re: The lovely Premier Padmini S1 (Fiat 1100-D)

I own a 1996 model Padmini S1. I had restored the car recently and it is working fine. When I was home last time, I was trying to start the car, but only click, click sound was coming. So my father advised me to pour 2-3 ml petrol on the air filter cover which would flow down into the carburettor. As soon as this was done the car started in the first ignition itself. Everyday morning I have to do this to start the car.
Also there is missing in the car and the driving is not smooth at all. I have to push the pedal to the carpet when I take the car in the mornings. Only after the engine heats up, the car is driveable, but still I can feel the missing.
Any help on this from the gurus would be of great help.
jaisha8 is offline   Reply With Quote
Old 4th January 2011, 13:46   #358
Senior - BHPian
 
samsag12's Avatar
 
Join Date: Dec 2009
Location: City of Nawaabs
Posts: 1,611
Thanked: 198 Times
Default Re: The lovely Premier Padmini S1 (Fiat 1100-D)

Hello Jaisha8 If your car's timing is set right then i think the problem must be in either carburetor or fuel pump.But as you pointed out that the car runs fine when its warm, you can eliminate the fuel pump as a culprit as it acts up when the car gets hot. Regarding the carburetor ( i hope its the original S1 one) it must need some cleaning and setting. Also have a look at the fuel filter and fuel pipes.
The above documentation is as per my view (have faced some similar problems) and there can be some other reason for your car's problem so do keep an eye on the expert comments.

Last edited by samsag12 : 4th January 2011 at 13:47.
samsag12 is online now   Reply With Quote
Old 4th January 2011, 14:39   #359
BHPian
 
Lucas_2007's Avatar
 
Join Date: Jul 2007
Location: GUWAHATI
Posts: 67
Thanked: 12 Times
Default Re: The lovely Premier Padmini S1 (Fiat 1100-D)

Quote:
Originally Posted by jaisha8 View Post
I own a 1996 model Padmini S1. I had restored the car recently and it is working fine. When I was home last time, I was trying to start the car, but only click, click sound was coming. So my father advised me to pour 2-3 ml petrol on the air filter cover which would flow down into the carburettor. As soon as this was done the car started in the first ignition itself. Everyday morning I have to do this to start the car.
Also there is missing in the car and the driving is not smooth at all. I have to push the pedal to the carpet when I take the car in the mornings. Only after the engine heats up, the car is driveable, but still I can feel the missing.
Any help on this from the gurus would be of great help.
Dear Jaisha,
Regarding your problem I would suggest you to get the carb. checked by a good mechanic. Moreover while doing so please change the fuel filter too. Do not forget to check the plugs. Bad plugs hamper smooth driving. I faced the same problem in my padmini. Cleaned the carb, changed the carb. shaft as it was worn and leaking air;(used to give jerky acceleration) then changed condenser and plugs too. Plug wires were new so didn't change them. Now it is running as smooth as ever.
Lucas_2007 is offline   Reply With Quote
Old 5th January 2011, 14:11   #360
BHPian
 
jaisha8's Avatar
 
Join Date: Mar 2009
Location: Trichur, Kerala
Posts: 358
Thanked: 98 Times
Default Re: The lovely Premier Padmini S1 (Fiat 1100-D)

Quote:
Originally Posted by Lucas_2007 View Post
Dear Jaisha,
Regarding your problem I would suggest you to get the carb. checked by a good mechanic. Moreover while doing so please change the fuel filter too. Do not forget to check the plugs. Bad plugs hamper smooth driving. I faced the same problem in my padmini. Cleaned the carb, changed the carb. shaft as it was worn and leaking air;(used to give jerky acceleration) then changed condenser and plugs too. Plug wires were new so didn't change them. Now it is running as smooth as ever.
Thanx samsag & lucas for your valuable comments. My plugs are new and I have changed the Fuel filter and oil only recently. Anyway I will look at the carb and the filter again. Also I changed the delco point as well recently as it was not firing properly. Shall look into it when I go this time and give my feedback.
jaisha8 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
The FIAT 1100/Premier Padmini Technical Information thread adheesh Post-War 1617 13th November 2017 16:40
Fiat 1100 / Premier Padmini - Parts to Stock for FUTURE! arun1100 Post-War 343 11th May 2017 16:57
My 1973 (FIAT 1100) Premier President President Post-War 208 17th September 2015 00:13
Bangalore Fiat 1100 Club-Original 1974 Premier President arun1100 Post-War 49 21st January 2015 19:15
Used Maruti800, premier padmini , premier 118ne ? sakharamcool Hatchbacks 8 27th May 2008 11:17


All times are GMT +5.5. The time now is 21:43.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks