Go Back   Team-BHP > BHP India > Team-BHP Reviews > Long-Term Ownership Reviews


Reply
 
Thread Tools Search this Thread
Old 16th August 2007, 16:48   #16
BHPian
 
Knight Rider's Avatar
 
Join Date: Oct 2005
Location: Bangalore
Posts: 267
Thanked: 11 Times
Default

Gee, I went and wasted last saturday getting my friends xeta serviced, The only issue we had was some sort of sound from the left hand side of the car,

Took the car back from concord, The service advisor took the work-order form from my friend, I didnt notice it, Before giving the car for service it had two scractches, and viola, The car came back with three scratches, I am not blaming anyone for this, Entirely our fault, Oh also you should have seen the way the service advisors were playing around with other's cars.

Well, Coming to the point, I was driving the car after taking the delivery, After a while I noticed that the Engine-check light was on, My friend called up the advisor and he said 'water' must have gone inside and will be okay if you the car out for a 'Sunbath' Well after a while the speedometer refused to move,

The next day the car started to knock, So this is perfect, You give the car for service without any technical fault's and you get the car back with a deep scratch, Engine light on, No speedo And in the end car started knocking, Me and my friend fillup fuel from Shell, that too only one particlular pump.

Hat's off to these guys.
Knight Rider is offline   Reply With Quote
Old 16th August 2007, 17:01   #17
Team-BHP Support
 
Zappo's Avatar
 
Join Date: Oct 2005
Location: Hyderabad
Posts: 5,650
Thanked: 2,010 Times
Default

Quote:
Originally Posted by Steeroid View Post
You're kidding, right?


It reads like one naa? But surprisingly it seems to work. At least has worked with 2 people I know who have now got rid of this problem as of this date. They were plagued with this problem in the 1st month of purchase and had to run to the service center 4-5 times. In each case it transpired that the car stalled while reversing or crawling in the bumper to bumper traffic and thereafter an immediate attempt to crank brought this light on.

What seems to happen is that if the running car with gears engaged and RPM above idle all of a sudden stalls (with the key in the ignition on position) the ECU apparently is in an unstable state. If the driver just turns the ignition off and then restarts the ECU seems to behave. However if the driver tries to crank the car directly the Check Engine light seems to come up immediately. Probably turning the ignition completely off lets the ECU to rectify its state. One thing I know is that this jugaad tech seems to work surprisingly well.

It looks to me something akin to the old windows crash. A power failure and the next time you try to boot it it used to throw up that blue screen with memory dump.
Zappo is offline   Reply With Quote
Old 17th August 2007, 09:42   #18
BHPian
 
msharma_79's Avatar
 
Join Date: Aug 2007
Location: Gurgaon
Posts: 262
Thanked: 22 Times
Default

Quote:
Originally Posted by Zappo View Post
I did not understand what you are saying. Are you saying that the front door does not lock when you engage the lock lever from inside and come out and shut the door?

If that is what you are saying the......
thanks bro,
big help understanding the car, but the locking system you have mentioned is something which i have been doing the same but some how it does not work with this car. every now and then my car cleaner climbs up to embarrass me " saab gadi aaj phir khula tha, sambhal ke chori ho jayega".

anyways i think i should get the central locking for the car any specific brand you guys can recommand??. although i am a bit scared of those because of the cars catching fire in delhi now and then and passenger get stuck in because of the central locking..scary..


abouth the suspension if it is going to be like that then what the hell i am never sitthing at the back anyways.


thanks again
take care
God bless

Manu
msharma_79 is offline   Reply With Quote
Old 21st August 2007, 10:31   #19
Newbie
 
Join Date: Jun 2007
Location: pune
Posts: 6
Thanked: 0 Times
Default

I am really happy to share this ..... my INDICA XETA GLE touched 160km/hr. very smoothly when I was driving on MUM-PUNE EXP highway....and the way car was responding .... really awesome...very smooth and very steady.....I had a very gr8 experience ......
abhishekkk is offline   Reply With Quote
Old 4th September 2007, 11:23   #20
Newbie
 
Join Date: May 2007
Location: Hyderabad
Posts: 9
Thanked: 2 Times
Default Xeta - U must be dumb to by it

I too had similar experiences - Manipal Motors Sales and Service in Bangalore is just as pathetic. Heard Prerana is better but cannot be too sure. I too had the "IC" problem with the car stalling within 2 weeks of purchase - in fact, the first month was hell. Now I have been driving for 17 months - mileage is a hopeless 10-11 in whatever conditions. And water leaks in from the bottom through the bushes. As I am now in Hyderabad, I took it to Malik Cars for repair - they assured me that what were small leaks have been repaired. The next day, I drove through water and could scoop out mugs of water from the front left side.
I do not trust any Tata product or service now.
By the way, I work for a Tata company!!!


Quote:
Originally Posted by ashj View Post
Hi TBHPians,
Today I completed 1 month with my Salsa Red Indica Xeta GLX and I thought this is the right time to write a review about the car. Since 1 month and 500 kms is not a big time to judge the performance of any car, this review will be limited to the problems that I've faced so far with the car. I'll keep updating the review from time to time.

Day-1: The car looked good and I was happy to make the decision to buy this car. But the dealer (Concorde Motors, Bangalore) service really sucked and by the time I took the delivery and drove out I was half mad at them and myself for choosing Concorde. The pre-inspection on car was near to zero and the sales girl tried to take me for a ride by saying that the promised sun-film is on the car but since it is of very light color I'm unable to distinguish it! Come on, I'm not a fool who cannot find a difference between a car with sun-film and one without one. After lot of arguments, she finally agreed that the sun-film is not there. Then I started pointing out on lot of other minor things that were missing. All is all, it was one painful evening for me.

Day-2: The car is back to Concorde Motors for fixing up the number plate. I also informed them that I heard some noise from the rear left door whenever car is on bad roads. Also the front left power window gets stuck sometime when it is powered up. They said that both the problems have been rectified.

Day-3-30: The front left power window still gets stuck and after close observation I realized that it is because the angle of the glass changes as it goes up and about 1 inch from the top, it gets tilted so much that it gets stuck. Later I realized that the same problem is there with front right window too (I don't use the rear windows so cannot comment on those). Also, the sound that seemed to be coming from the rear left door is actually coming from the rear left shock absorber and it is still very much there. Also the "Check Engine" light turned on after about 10 days and I had to made several calls to the Concorde only to be told that it is normal and is caused due to some minor electrical fault and I can continue to drive the vehicle normally!!! I hope all these problems will be rectified in the first service.

Apart from these, I didn't face any other major problem and I'm getting about 11kmpl with AC on for 20% of the time in city driving conditions. I'm not very happy with the vehicle because of these niggling issues but apart from that there is no reason to be unhappy either. If anyone has faced these problems on the forum, please let me know your experience.

Please feel free to ask any questions that you may have and I would try to answer them all.
tomjoe is offline   Reply With Quote
Old 4th September 2007, 12:41   #21
BHPian
 
msharma_79's Avatar
 
Join Date: Aug 2007
Location: Gurgaon
Posts: 262
Thanked: 22 Times
Default

Got The Problem Fixed At The Third Service, Without Any Hassle
msharma_79 is offline   Reply With Quote
Old 5th September 2007, 01:37   #22
BHPian
 
Nimz's Avatar
 
Join Date: May 2007
Location: Bangalore
Posts: 468
Thanked: 11 Times
Default

Quote:
Originally Posted by abhishekkk View Post
I am really happy to share this ..... my INDICA XETA GLE touched 160km/hr. very smoothly when I was driving on MUM-PUNE EXP highway....and the way car was responding .... really awesome...very smooth and very steady.....I had a very gr8 experience ......
160 Kmph in a Xeta? What was the RPM at this speed? Was A/C on? I have barely crossed 120 kmph with AC on and passengeres inside in my dad's Xeta..

Nimz
Nimz is offline   Reply With Quote
Old 5th September 2007, 17:14   #23
BHPian
 
msharma_79's Avatar
 
Join Date: Aug 2007
Location: Gurgaon
Posts: 262
Thanked: 22 Times
Default

Quote:
Originally Posted by Nimz View Post
160 Kmph in a Xeta? What was the RPM at this speed? Was A/C on? I have barely crossed 120 kmph with AC on and passengeres inside in my dad's Xeta..

Nimz
Here we go again, there is whole discussion on the same topic at one of those xeta threads. please have a look at that.
msharma_79 is offline   Reply With Quote
Old 10th September 2007, 10:12   #24
Newbie
 
Join Date: Jun 2007
Location: pune
Posts: 6
Thanked: 0 Times
Default

Quote:
Originally Posted by Nimz View Post
160 Kmph in a Xeta? What was the RPM at this speed? Was A/C on? I have barely crossed 120 kmph with AC on and passengeres inside in my dad's Xeta..

Nimz


Yes 160 KMPH...A/C was on too...and there were 4 passengers in the car...touch wood ....but my car is responding in a very nice manner to me....
abhishekkk is offline   Reply With Quote
Old 10th September 2007, 12:02   #25
BHPian
 
msharma_79's Avatar
 
Join Date: Aug 2007
Location: Gurgaon
Posts: 262
Thanked: 22 Times
Default

Quote:
Originally Posted by abhishekkk View Post
Yes 160 KMPH...A/C was on too...and there were 4 passengers in the car...touch wood ....but my car is responding in a very nice manner to me....
ok is it 1.4 or 1.2 ???? and let us know about the RPM also while you did 160.
msharma_79 is offline   Reply With Quote
Old 10th September 2007, 12:36   #26
BHPian
 
msharma_79's Avatar
 
Join Date: Aug 2007
Location: Gurgaon
Posts: 262
Thanked: 22 Times
Default

oh one more thing i have 1.4 and i could never go beyond 145 till now, after that stearing wheel start shaking.
tell me how you managed that?

regards,

Manu
msharma_79 is offline   Reply With Quote
Old 17th September 2007, 10:19   #27
Newbie
 
Join Date: Jun 2007
Location: pune
Posts: 6
Thanked: 0 Times
Default

Quote:
Originally Posted by msharma_79 View Post
ok is it 1.4 or 1.2 ???? and let us know about the RPM also while you did 160.

It is 1.4....I was so scared that I didn't see the RPM....I was just concentrating on the speedometer and the road...
abhishekkk is offline   Reply With Quote
Old 17th September 2007, 10:21   #28
Newbie
 
Join Date: Jun 2007
Location: pune
Posts: 6
Thanked: 0 Times
Default

Quote:
Originally Posted by msharma_79 View Post
oh one more thing i have 1.4 and i could never go beyond 145 till now, after that stearing wheel start shaking.
tell me how you managed that?

regards,

Manu
I never faced this problem....as mine was very smooth....
abhishekkk is offline   Reply With Quote
Old 28th February 2011, 22:56   #29
Newbie
 
Join Date: Jul 2009
Location: Hyderabad
Posts: 9
Thanked: 0 Times
Default Re: Indica Xeta GLX (1.4L) - 1 month ownership report

Quote:
Originally Posted by msharma_79 View Post
oh one more thing i have 1.4 and i could never go beyond 145 till now, after that stearing wheel start shaking.
tell me how you managed that?

regards,

Manu
I drove back from Bangalore to Hyderabad today morning on my XETA GLX 1.4 (Purchased Nov 2007) and touched 160 several times. The rpm was a shade above 4000. Thanks to the upgraded tyres GIII Potenza 175/60 R13 and alloys. The guys did a fantastic balancing and alignment and NH7 has several stretches where you can do that kind of speeds for more than 15-20 mins.

Prior to this, on my stock wheels and tyres, never dared above 140. At 140 km/hr my car seemed to be floating with no traction at all. Scary.

Steering wheel shaking is an issue of wheel balancing. Get your wheels balanced and aligned at a good place, that should do.
drive2live is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tata Indica e-xeta petrol with 17.1 kmpl and e-xeta LPG sidindica The Indian Car Scene 7 9th July 2011 12:39
Which battery for Indica Xeta GLX Petrol? rajesh.palaria Modifications & Accessories 1 14th May 2010 14:14
Indica Xeta - First Experience-How Xeta won the race nirmalkumar Test-Drives & Initial Ownership Reports 12 20th April 2008 16:41
Indica Xeta 1.2 GLG vs 1.4 GLX Haste Hatchbacks 1 15th March 2008 14:32
Indica DLG TC / Xeta GLX / Swift VXi jpm Hatchbacks 11 15th November 2006 21:23


All times are GMT +5.5. The time now is 01:28.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks