Go Back   Team-BHP > BHP India > Team-BHP Reviews > Long-Term Ownership Reviews


Reply
 
Thread Tools Search this Thread
Old 28th November 2011, 13:10   #271
BHPian
 
RajeswaranK7's Avatar
 
Join Date: Oct 2009
Location: Chennai
Posts: 81
Thanked: 26 Times
Default re: 5 years with the Ford Fiesta 1.6 sxi ABS & still going Fida

Quote:
Originally Posted by vnabhi View Post
I got a bit scared a couple of days back, when I started the car after a gap of 4 days. It was a cold morning start. The only thing that alarmed me was that the Engine system warning light (the exclamation mark within a circle on top of the ABS light) did not go off, though other warning lights like ABS, handbrake, engine malfunction, etc went off.

I waited for a few seconds, but it was glowing constantly. So I switched off the engine and re-started again, but the light did not go off. I also found that throttle inputs on the stationary car were not resulting in correspoding revvs from the engine, but somewhat muted.

As I never encountered this before, I switched off and fished out the manual. The manual says one can drive the car if it glows constantly, but speeds would be restricted. It also says not to drive if the light flickers, which was not the case with my car. It also said the light concerns engine system and drive train issues.

I started the car again, and the light disappeared along with the other lights! Phew, what a relief! I drove normally to work and the car was perfect in the entire trip of 15 kms, including some high revvs on 2nd gear. I called the SA of Mody Ford a little later, and he said it could be an issue with fuel not flowing freely becuase the car was not used for few days. He asked me to observe if the light comes on again, and take it to them only if it does.

I did not have the same issue over the past 2 days. The only noticeable difference is a bit of body vibration and the tacho going up to 1250 rpm on early morning starts, but I've had that symptom few times earlier in winters. The vibrations stop soon after the car is in motion, or after the engine warms up.
Apologies for hijacking this thread. Even I am facing this issue, actually for a couple of months. When I start the car when its cold or if I had left it in a ran, the engine warning light would come up and the RPM will shoot to around 1250. If I restart the car, it would go off. My car is jut 1year and 9 months old and has done about 21K kms. I had told the SA in my earlier service about it and they said it is nothing to worry about. Infact i was about to create a thread for asking about this issue, when I stumbled upon this thread. I will send the car right away for service with a printout of this discussion.

Thanks Suman for clearing up the issue.
RajeswaranK7 is offline   Reply With Quote
Old 28th November 2011, 18:21   #272
Senior - BHPian
 
vnabhi's Avatar
 
Join Date: May 2007
Location: DC -> DC
Posts: 5,036
Thanked: 1,038 Times
Default re: 5 years with the Ford Fiesta 1.6 sxi ABS & still going Fida

Quote:
Originally Posted by RajeswaranK7 View Post
Apologies for hijacking this thread. Even I am facing this issue, actually for a couple of months. When I start the car when its cold or if I had left it in a ran, the engine warning light would come up and the RPM will shoot to around 1250. If I restart the car, it would go off. My car is jut 1year and 9 months old and has done about 21K kms. I had told the SA in my earlier service about it and they said it is nothing to worry about. Infact i was about to create a thread for asking about this issue, when I stumbled upon this thread. I will send the car right away for service with a printout of this discussion.

Thanks Suman for clearing up the issue.
Since your car appears to be under warranty, better rush and get the scan done a.s.a.p.

Further, I suppose you are referring to the light on top of the ABS light, that has an exclamation mark enclosed within a circle, and not the engine management system light. In either case, please get it checked.

I was out of station last weekend, and the problem did not recur. I will get it checked the very next time the light recurs.
vnabhi is offline   Reply With Quote
Old 28th November 2011, 18:33   #273
BHPian
 
RajeswaranK7's Avatar
 
Join Date: Oct 2009
Location: Chennai
Posts: 81
Thanked: 26 Times
Default re: 5 years with the Ford Fiesta 1.6 sxi ABS & still going Fida

Quote:
Originally Posted by vnabhi View Post
Since your car appears to be under warranty, better rush and get the scan done a.s.a.p.

Further, I suppose you are referring to the light on top of the ABS light, that has an exclamation mark enclosed within a circle, and not the engine management system light. In either case, please get it checked.

I was out of station last weekend, and the problem did not recur. I will get it checked the very next time the light recurs.
@vnabhi
Yes My car is still under warranty and I have arranged for my brother to take the car to the service station tommorow.

The light I am refering to is the same one that you mentioned, the Drivetrain Warning light. Lucky that I stumbled into your thread
RajeswaranK7 is offline   Reply With Quote
Old 28th November 2011, 19:11   #274
Senior - BHPian
 
vnabhi's Avatar
 
Join Date: May 2007
Location: DC -> DC
Posts: 5,036
Thanked: 1,038 Times
Default re: 5 years with the Ford Fiesta 1.6 sxi ABS & still going Fida

Quote:
Originally Posted by RajeswaranK7 View Post
@vnabhi
Yes My car is still under warranty and I have arranged for my brother to take the car to the service station tommorow.

The light I am refering to is the same one that you mentioned, the Drivetrain Warning light. Lucky that I stumbled into your thread
Great. Do keep us updated on the developments.
vnabhi is offline   Reply With Quote
Old 29th November 2011, 18:41   #275
BHPian
 
RajeswaranK7's Avatar
 
Join Date: Oct 2009
Location: Chennai
Posts: 81
Thanked: 26 Times
Default re: 5 years with the Ford Fiesta 1.6 sxi ABS & still going Fida

This is what happened today.

I had arranged my former driver to take the car to the service station with my brother. Prior to sending the car, I took a video of the Drivetrain warning light in my brother's mobile.The guys at the service station as usual wanted to take a test drive when my brother showed the video of the issue and explained them about it.

Finally the SA said they will be able to check the issue only by 4:00 PM and will let us know what the issue is.

After repeated phone calls I am informed that they have cleared the errors in the ECU and will check the car for the issue morning before proceeding.

Really don't have a good feeling about this.

Will update tommorow on how they are fixing the issue.
RajeswaranK7 is offline   Reply With Quote
Old 30th November 2011, 17:17   #276
BHPian
 
RajeswaranK7's Avatar
 
Join Date: Oct 2009
Location: Chennai
Posts: 81
Thanked: 26 Times
Default re: 5 years with the Ford Fiesta 1.6 sxi ABS & still going Fida

I got a call from the SA just now.

The car is still with the service station. Earlier in the morning when I spoke to him he said the engine warning light has coem up again when he started the car, so he has taken a pic of it and has requested FORD India's help by mailing the technicians. Till now they haven't responded it seems and only after they respond he will be able to work on the car.

He says that this should not happen in a car that is less than 2 years old so he is wary of doing any fixes without approval from FORD.

I am really at a loss as to what to do next.
RajeswaranK7 is offline   Reply With Quote
Old 30th November 2011, 23:03   #277
Senior - BHPian
 
vnabhi's Avatar
 
Join Date: May 2007
Location: DC -> DC
Posts: 5,036
Thanked: 1,038 Times
Default re: 5 years with the Ford Fiesta 1.6 sxi ABS & still going Fida

Quote:
Originally Posted by RajeswaranK7 View Post
I got a call from the SA just now.

The car is still with the service station. Earlier in the morning when I spoke to him he said the engine warning light has coem up again when he started the car, so he has taken a pic of it and has requested FORD India's help by mailing the technicians. Till now they haven't responded it seems and only after they respond he will be able to work on the car.

He says that this should not happen in a car that is less than 2 years old so he is wary of doing any fixes without approval from FORD.

I am really at a loss as to what to do next.
They can't make you wait indefinitely. They should provide you with a substitute car in the meanwhile. I suggest you take this up with them, and if necessary with Ford India management.
vnabhi is offline   Reply With Quote
Old 2nd December 2011, 12:55   #278
BHPian
 
RajeswaranK7's Avatar
 
Join Date: Oct 2009
Location: Chennai
Posts: 81
Thanked: 26 Times
Default re: 5 years with the Ford Fiesta 1.6 sxi ABS & still going Fida

@vnabhi

Thanks for the concern. My office is very near to my home, just a bus stop away and I actually had stopped taking the car to office, so no need for the car on weekdays.

They replaced the "Throttle Body" under warranty. The actual diagnosis and confirmation from ford to replace the part under warranty took 2 days. The SA confirmed that they have replaced the part under warranty yesterday evening and will check the car today morning before giving it to me. I wanted to be there when he checks, so I went there @8:30 AM and checked whether the engine warning light comes on when I start the car, it did not. Was happy and told him about two other issues with the power windows switch and the boot lamp. The power windows switch was replaced under warranty.

Took a long test drive with one of their guys. He showed me the sheet which contains the warranty claim sheet which had the entry for the throttle body and the power windows switch. When speaking to him, he told me that the ECU does not have any memory and does not store the error codes and the error has to occur right in front of them to diagnose the issue with the scanner. I was a bit sceptical with that, but other than that the drive was fine. I am yet to get the bill as they can give it to me only when the warranty claim is settled. It had the error code which occurred, will update it once I get the bill copy.

I came back to office just now travelling around 30 kms in a bye pass road. The engine just responds eagerly to the throttle input . Happy to have my car back.
RajeswaranK7 is offline   Reply With Quote
Old 13th December 2011, 16:10   #279
BHPian
 
ruchirtnt's Avatar
 
Join Date: Oct 2009
Location: Lucknow/Gurgaon
Posts: 986
Thanked: 74 Times
Default re: 5 years with the Ford Fiesta 1.6 sxi ABS & still going Fida

Quote:
Originally Posted by RajeswaranK7 View Post
Apologies for hijacking this thread. Even I am facing this issue, actually for a couple of months. When I start the car when its cold or if I had left it in a ran, the engine warning light would come up and the RPM will shoot to around 1250. If I restart the car, it would go off. My car is jut 1year and 9 months old and has done about 21K kms. I had told the SA in my earlier service about it and they said it is nothing to worry about. Infact i was about to create a thread for asking about this issue, when I stumbled upon this thread. I will send the car right away for service with a printout of this discussion.

Thanks Suman for clearing up the issue.
I too had the same issue with my car from last few months, last month after getting the same warning message twice each morning, i took fiesta to the service station and asked them to look into it, they scanned the car and diagnosed cleaning for throttle body, they bought some carburetor/ throttle body cleaner spray and cleaned that part thoroughly and removed all black stains, since then there is no issue with the car and all is well.
ruchirtnt is offline   Reply With Quote
Old 13th December 2011, 18:22   #280
Senior - BHPian
 
vnabhi's Avatar
 
Join Date: May 2007
Location: DC -> DC
Posts: 5,036
Thanked: 1,038 Times
Default re: 5 years with the Ford Fiesta 1.6 sxi ABS & still going Fida

Thanks for the update, @ruchirtnt. I am happy all is well.

Here is an update from me :-
  1. 1st time the engine drive train warning light came on was on Nov 21st. Everything was fine for 2 weeks after that.
  2. In Dec 1st week, when I started the car after returning from an outstation trip of 3 days, some kind of rattling sounds were heard from the engine bay. I felt embarrassed and switched the engine off. I opened the engine bay and found everything seemed fine, including the fan belt. I started again and the same sound appeared. I went to the open engine bay and found it was coming from the engine, but it vanished in a few seconds, never to return again.
  3. Last Friday, I got the same engine light warning on starting a cold engine. I switched off and re-started, and that light vanished alongwith others.
Since I did not want to take chances, I called my SA in Mody Ford and sought his advice. He asked me to take the car on Tuesday morning for a thorough scan. So I gave it to them this morning and explained the symptoms.

The SA introduced me to their senior level expert, who said that light could come on due to 3 reasons:-
  1. Weak battery
  2. Foul fuel
  3. Throttle body issues
I felt item 1 was feasible, as the car was nearing 5 years. But on item 2 I told him that I invariably tank up from the same bunk, and the FE has always been between 11 to 13.

He said they'd do their best and apprise me in the afternoon.

I got a call some time ago stating that their initial scan reported some wiring issue. But after they erased it and tested the car futher, the issue did not resurface. They also took the car for a 10 km drive and could not spot that issue. The battery was fine. Therefore, they advised me to take the car back and get back if it recurs in future. I will be collecting it tomorrow as I don't have time to go there now (have a call at 7 pm).

Let us see how it goes.

Meanwhile, as it was 9 months since last service, I'd asked them to get the car serviced and oils and filters changed. It was during that task that they found a leakage from the power steering hose. I was told that the hose would need to be replaced and it costs around 4800 INR .

I immediately told the SA that in Oct 2009 Mody Ford, under orders from Ford India, had inspected my car at home to check if the hose was ok. I believe most petrol Fiestas or 2007 make were vulnerable to hose leakage.
At that point of time, I was told it was ok, and that in future if it ever were to leak, Ford would replace it free of cost.

The SA cross-checked with their warranty personnel, but they had no idea if a car out of warranty could be extended that benefit.

Not taking any chances, I contacted MD of Ford India. My updates on that issue are in the thread that I wll post below. I will take some time to update it there:-

http://www.team-bhp.com/forum/indian...l-fiestas.html (Ford India orders inspection of power steering of all petrol Fiestas)

Last edited by vnabhi : 13th December 2011 at 18:26.
vnabhi is offline   Reply With Quote
Old 14th December 2011, 13:47   #281
Senior - BHPian
 
vnabhi's Avatar
 
Join Date: May 2007
Location: DC -> DC
Posts: 5,036
Thanked: 1,038 Times
Default re: 5 years with the Ford Fiesta 1.6 sxi ABS & still going Fida

Got my car back today and I am delighted to see the way it drives now. The replaced power steering hose and joint seemed to have made the difference. I had mentioned a couple of months ago that after getting the wheels rotated and balanced, I felt some kind of over-eagerness to turn on the steering during full lock to either side. I now think that was caused by the leakage of power steering fluid, which might have started at that point of time. And I was foolish to think it was caused by WB and WA.

The SA, Mr Viswanath apprised me that all seemed to be well with the engine scan they had performed. He also advised me NOT to top up the fuel tank when the car was not going to be used for few days. I do remember that the light first came on after I had topped up the fuel tank and re-started the car after a gap of 4 days. Point to be noted. I believe there are many complaints of fuel contamination nowadays. I think I"ll keep this in mind. At least I will use the car for a couple of days after topping up in future.

I am content with the service provided by Mody Ford and the timely intervention of Ford India. The Senior Tech from the dealer, Mr Murthy also seems to have taken the correct approach in getting my power steering parts changed free of cost. In the process I avoided a cost of nearly 5 grand! I sent a note of appreciation to MD of Ford also.

As regards service cost, it was around Rs 4250 including oil change, filter change, pollen and air filter change, gear bush replacement, waxoyl touch up, etc. The cost of oil change itself was around 1500 INR, owing to oil prices.

I will update further after a time gap.

Last edited by vnabhi : 14th December 2011 at 13:49.
vnabhi is offline   Reply With Quote
Old 19th December 2011, 11:50   #282
BHPian
 
rapideffect's Avatar
 
Join Date: Jun 2005
Location: mumbai
Posts: 147
Thanked: 4 Times
Default re: 5 years with the Ford Fiesta 1.6 sxi ABS & still going Fida

Hi Guys,

My Fiesta 1.6S is 18 months old and I have taken the service from SC ford Malad, Mumbai on 14th Dec. Since then this new issue as mentioned by RajeswaranK7 started and it's still persisting as of today. The engine warning light comes in cold start and goes of if switch off and on again.

Last edited by rapideffect : 19th December 2011 at 11:52.
rapideffect is offline   Reply With Quote
Old 2nd January 2012, 15:41   #283
Senior - BHPian
 
vnabhi's Avatar
 
Join Date: May 2007
Location: DC -> DC
Posts: 5,036
Thanked: 1,038 Times
Default re: 5 years with the Ford Fiesta 1.6 sxi ABS & still going Fida

Yesterday the car was washed and also the interiors cleaned by the car cleaner, as on every other Sunday.

But when I started the car in the evening, I found the CD from the 6th slot getting ejected. I pushed it back in and it popped out again with a message 'CD error'. But I was playing the same CD on Friday, so I thought the cleaner guy might have pressed some button while cleaning. So I pressed the load button and the CD went in. I switched off the car after that.

But this morning, when I tried to play that CD, I got a 'initializing' message for a few moments and then a 'no disc' message !! No matter how much I tried, the CD, or for that matter, any other CD in the remaining 5 slots would not play. It kept taking me to the FM radio. The AM button also works, but the CD button remained recalcitrant.


Any clues will be helpful. I will take it to the *** only on the weekend if the problem persists.
vnabhi is offline   Reply With Quote
Old 9th January 2012, 13:44   #284
Senior - BHPian
 
vnabhi's Avatar
 
Join Date: May 2007
Location: DC -> DC
Posts: 5,036
Thanked: 1,038 Times
Default re: 5 years with the Ford Fiesta 1.6 sxi ABS & still going Fida

Here's an update on the stock 6-CD player. I googled Ford forums to see if there is any post on this topic, and was surprised to find many, mostly on the F150 forums. But none of the suggestions posted helped.

I called my SA in Mody Ford and was dismayed to learn that they do not have the know how to repair CD players. Instead, they dismantle sets and send them to Ford Chennai for repair. I was told that it costs around 4500 INR to replace the defective part, and around a couple of weeks for the whole thing. I kept this as the last option, and started scouting around.

Based on a fellow bhpians suggestion (sparsh) I went to a local expert at Lakdikapul area. He set it right for Rs 1500. He also took great care while removing the unit, and did not dis-connect the wires at any time. He also told me that after it is re-inserted, despite best care, there would be a slight gap which cannot be avoided. I was prepared for this, and told him to ensure that the dash was not scratched, especially the chrome surrounding the player.

He did a neat job and the player is back to glory. He also told me that the timing and the eject mechanism in most cars gets fouled in a few years, and this includes Beemers, Mercs, Skodas, etc.
vnabhi is offline   Reply With Quote
Old 15th February 2012, 13:25   #285
Senior - BHPian
 
vnabhi's Avatar
 
Join Date: May 2007
Location: DC -> DC
Posts: 5,036
Thanked: 1,038 Times
Default re: 5 years with the Ford Fiesta 1.6 sxi ABS & still going Fida

Guys

Here is an update on the Engine system/ drive train warning light.

Even after the car was checked in mid-December, the light used to come on around 80% of the early morning cold starts, but vanish on second start! And the car would drive normally always, including high revvs and high speed runs (touched even 180 once)

As the car was scanned only recently, I tried the following permutations:-
  1. Starting early morning when the car was with full tank of fuel
  2. Half tank of fuel
  3. Minimal fuel (DTE around 120 kms)
  4. Starting the car for the first time, not in the morning, but late evening.
None of the above had any effect on the light coming on during cold starts: it would still come on most of the time. But vanish on second start Therefore I thought it fit to call my SA and speak to him. He asked me to bring the car over on any weekday for another inspection. But I told him that I would have the leave the car overnight, as the light comes on only during early morning cold starts, and does not come on after that.


He also told me not to switch off the engine and see if the light persists. I tried and found that even if I left the engine running for 2 minutes, the light would still glow. But the magical disappearance on second start was always the trend.



Sheer laziness prevented me from visiting the A.S.S. But mysteriously, the light has not come on for the past 10 days. I am not sure if this is due to the increase in outside temperature. It used to be 20 to 22 Degrees earlier, but nowadays it is 24 to 27.


I'd be glad if other Fiesta owners update this thread on how this problem got sorted out on their cars. I do know that a couple of them had their throttle body replaced under warranty, and another couple had their throttle bodies cleaned.
vnabhi is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ford Figo TDCi Titanium Nine months and 70,000 Kms of falling in Love dhanushmenon Long-Term Ownership Reviews 81 10th June 2015 20:18
NEED Inputs to FINALISE: Fiesta Petrol 1.6 SXi or Diesel 1.4 TDCi SXi. Specific query sachinchavan Sedans 17 26th September 2012 00:00
ford fiesta SXI after Ford IKON nxt amolathalye Sedans 10 24th February 2009 10:19
Ford Fiesta 1.6 Sxi/ Honda City Gxi / VTEC udit78 Sedans 58 31st August 2006 13:52


All times are GMT +5.5. The time now is 03:41.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks