Go Back   Team-BHP > BHP India > Team-BHP Reviews > Long-Term Ownership Reviews


Reply
 
Thread Tools Search this Thread
Old 5th December 2008, 17:49   #586
BHPian
 
abhik's Avatar
 
Join Date: Aug 2007
Location: New Delhi
Posts: 848
Thanked: 8 Times
Default

Quote:
Originally Posted by kpzen View Post
I'm also facing the problem of fog formation on windscreen. Planning to get the Bosch blades.
The last time we four were in your car the fog formation was on the inside due to the humidity inside!!
abhik is offline   Reply With Quote
Old 9th December 2008, 10:33   #587
Newbie
 
Join Date: Oct 2008
Location: Bangalore
Posts: 12
Thanked: 0 Times
Default Gear Shifting problem..

I got my car back from the Trident Hyundai Hosur road showroom yesterday and so far it seems good... The service engineer said that they have bled the clutch which has sorted the problem. They also confirmed that this is a first time that they have found such a problem!!!

I just hope that this works out and I don't get the problem again
birashis is offline   Reply With Quote
Old 10th December 2008, 18:55   #588
Senior - BHPian
 
trrk's Avatar
 
Join Date: Feb 2004
Location: Alleppey, Kerala
Posts: 2,113
Thanked: 12 Times
Default Guys having fog on the outside

Hi,

Could you people try this for fog forming outside the windshield with continuous AC operation?

Reduce the temperature control knob towards the white / red side as much as needed, usually the junction of blue/white or blue/red.

The fog outside is due to the higher temperature outside the windshield in comparison to the temperature inside.
trrk is offline   Reply With Quote
Old 5th January 2009, 11:52   #589
Newbie
 
Join Date: Oct 2008
Location: Bangalore
Posts: 12
Thanked: 0 Times
Default Getz CRDi - Suspension Noise

Hi Friends I am having some problem with my car's rear suspension. Last weekend I went on a trip from Bangalore to Coorg. As some of you may be aware the road from Kushal Nagar to Madikeri is not in a good shape. I got some noise from the rear suspension (particularly from the left side) while negotiating bends on the uneven and broken ghat roads. There were 4 adults and some luggage so I can assume it to be a full load...

The noise was as if the springs and suspension was not able to take the pressure on the bends and something was hitting... like some loud and distinct thudding noise. Here I must mention that this was happening only on the bends on the hillside with uneven road surface - even when I was travelling at very low speeds - 20-30 KmPH

In Bangalore city I have never driven with a full load and there are no such bends and uneven road surfaces... So this is the first time I am experiencing this type of noise..

Any help/suggestions
birashis is offline   Reply With Quote
Old 5th January 2009, 17:38   #590
Senior - BHPian
 
djay99's Avatar
 
Join Date: Jun 2007
Location: Cork, Ireland
Posts: 1,456
Thanked: 491 Times
Default

I dont think its a major issue. I have driven many times with 4 guys on the rear seat and never heard such noise. Still visit a service centre and expalin them if possible.
FYI, I am getting noise from rear suspension (left side) from many days. I think some of the getz have this problem.
djay99 is offline   Reply With Quote
Old 5th January 2009, 18:37   #591
BHPian
 
dRaGsTerrr's Avatar
 
Join Date: Jul 2008
Location: Trivandrum
Posts: 56
Thanked: 2 Times
Default

Quote:
Originally Posted by birashis View Post
I got some noise from the rear suspension (particularly from the left side) while negotiating bends on the uneven and broken ghat roads.
Are you running on stock tyres or have you upsized?? Ensure that the wheels are not scrapping the wheel arches. Also try driving folding the rear seats to the maximum inclined position. I was getting a strage noise from the rear and later found the cluprit to be the rear seats. This started after removing the seats for fixing the seat covers and I assume they haven't fixed it back properly

Anyway get the suspension checked by your service center as soon as possible.
dRaGsTerrr is offline   Reply With Quote
Old 5th January 2009, 19:07   #592
Senior - BHPian
 
undead's Avatar
 
Join Date: Jan 2008
Location: Bhavani - Komarapalayam
Posts: 1,187
Thanked: 165 Times
Default

Well. Seems all Getz CRDi vehicles are having this problem in suspension.
Dragsterrr : I started getting this noise when i was running in stock tires and that too after few weeks of purchase . I got the noise sooner as the roads in my area are under construction for 4 laning and horrible to drive on them.
undead is offline   Reply With Quote
Old 6th January 2009, 09:59   #593
Newbie
 
Join Date: Oct 2008
Location: Bangalore
Posts: 12
Thanked: 0 Times
Default

Hi Guys, Thanks for your replies...

I am still running on stock tyres although I had upgraded to alloy wheels. But as I have mentioned it is not the normal tyre noise that you get... rather it is as if the rear coil springs are not able to take the load on the sharp bends (with uneven/broken surface) and there is a loud thudding noise as if it is hitting something. I am annoyed because the car has done only 6.5 K so far and even smaller cars such as Zen, fully loaded Indicas, Wagon R etc were also travelling on the same roads at higher speeds without any problems... I presume !!

Anyways I have spoken to the service center guys and I am taking the vehicle for a checkup on coming Saturday.. Will keep you guys posted on the outcome.
birashis is offline   Reply With Quote
Old 6th January 2009, 12:09   #594
Senior - BHPian
 
vkochar's Avatar
 
Join Date: Aug 2006
Location: Delhi / Agra / London
Posts: 2,031
Thanked: 214 Times
Default

Getz Suspension has problems. DO NOT ride the car on full load. The suspension is the old Getz's and the CRDi engine and other bits are from a much stronger car.

Show it to the service centre and they should do the job for you for free.

My friend in Delhi also went to Manali recently in his Getz Diesel and he also reported a suspension noise. HMP in delhi did the job for him free. I think they changed one shocker and something else ( Do not know what )
vkochar is offline   Reply With Quote
Old 6th January 2009, 22:18   #595
Senior - BHPian
 
undead's Avatar
 
Join Date: Jan 2008
Location: Bhavani - Komarapalayam
Posts: 1,187
Thanked: 165 Times
Default

Hope you guys get the solution for the suspension problem . Because i have went to the service centre for this same problem around 5 times. But couldnt get a permanent solution. They fix the noise , but within a week , the noise starts again.
undead is offline   Reply With Quote
Old 6th January 2009, 22:26   #596
BHPian
 
white_vdi's Avatar
 
Join Date: Sep 2008
Location: new delhi
Posts: 842
Thanked: 17 Times
Default

undead you have been to the service center 5 times already for the same problem. escalate it to higher authorities. this is no way of treating customers.
white_vdi is offline   Reply With Quote
Old 7th January 2009, 07:57   #597
Senior - BHPian
 
undead's Avatar
 
Join Date: Jan 2008
Location: Bhavani - Komarapalayam
Posts: 1,187
Thanked: 165 Times
Default

Quote:
Originally Posted by white_vdi View Post
undead you have been to the service center 5 times already for the same problem. escalate it to higher authorities. this is no way of treating customers.
well , i just got used to it. No time for that. And i stopped focusing on that problem while driving. I just switch on the music system and the noise disappears.
undead is offline   Reply With Quote
Old 7th January 2009, 12:38   #598
Senior - BHPian
 
djay99's Avatar
 
Join Date: Jun 2007
Location: Cork, Ireland
Posts: 1,456
Thanked: 491 Times
Default

undead, before 2 weeks i had been to trident hyundai service and explained the issue to service advisor.
One of the mechanic worked on left rear suspension and now its working fine. No noise.
djay99 is offline   Reply With Quote
Old 7th January 2009, 16:10   #599
Senior - BHPian
 
undead's Avatar
 
Join Date: Jan 2008
Location: Bhavani - Komarapalayam
Posts: 1,187
Thanked: 165 Times
Default

Quote:
Originally Posted by djay99 View Post
undead, before 2 weeks i had been to trident hyundai service and explained the issue to service advisor.
One of the mechanic worked on left rear suspension and now its working fine. No noise.
Well , see if u get it again after some 10 days or driving some 50 kms .
undead is offline   Reply With Quote
Old 8th January 2009, 14:41   #600
BHPian
 
vabs78's Avatar
 
Join Date: Mar 2007
Location: Pune, India
Posts: 551
Thanked: 11 Times
Default

Quote:
Originally Posted by djay99 View Post
I dont think its a major issue. I have driven many times with 4 guys on the rear seat and never heard such noise. Still visit a service centre and expalin them if possible.
FYI, I am getting noise from rear suspension (left side) from many days. I think some of the getz have this problem.
What kind of noise are you getting DJ? A 'thud' noise or 'sqwak' noise?
I was getting some sqwaking noise from my Getz rear suspention but it went away after lubrication.
vabs78 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hyundai Getz 1.3 Prime. EDIT : 81,449 kms Service Report PatienceWins Long-Term Ownership Reviews 174 25th November 2017 11:10
My Hyundai Getz Crdi - Dark Grey Metallic. Update: 50,000 kms done ShyamSCrdi Test-Drives & Initial Ownership Reports 190 6th March 2011 22:28
Verna Crdi Vs GetZ Crdi. EDIT : Finalising on Getz! aks_karthik Hatchbacks 74 17th May 2009 10:22
Silver Getz Prime CRDi VGT djay99 Test-Drives & Initial Ownership Reports 157 2nd April 2009 13:55
Accessories for Bright Silver Getz mangywarez Modifications & Accessories 7 26th July 2005 11:32


All times are GMT +5.5. The time now is 01:58.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks