Go Back   Team-BHP > BHP India > Team-BHP Reviews > Long-Term Ownership Reviews


Reply
 
Thread Tools Search this Thread
Old 31st December 2008, 13:16   #286
Senior - BHPian
 
simply_sunny001's Avatar
 
Join Date: Jun 2007
Location: London & Rohtak
Posts: 1,339
Thanked: 15 Times
Default

i think we are discussing a topic thats totally irrelevant.

and i'm sure nobody of us drives safari for mileage figures but i just calculate it for my zen and safari and i always do the tankfuls so its easy and you know whats going on with mileage figures.
its always around 11-12 in normal day to day life.

Though i was surprised and cross checked again the calculations when the beast returned 15+.

For me driving safari is almost at par(only cost per km wise) with driving my zen so never bothered much.
simply_sunny001 is offline   Reply With Quote
Old 31st December 2008, 15:00   #287
Senior - BHPian
 
raj_5004's Avatar
 
Join Date: Jan 2008
Location: Dubai/Mumbai
Posts: 5,078
Thanked: 2,031 Times
Default

with everybody claiming 15+ for their safaris, i think i am doing a big mistake in calculating the FE figures or as i said, my fuel tank is leaking. else, there is a problem with my safari.
when we talk about FE, we talk about normal driving habits, not the one with light foot and without AC, so in such conditions, if the safari gives 15 kmpl, that i think is pretty understandable. anything more than that, then i think my brother should learn driving all over again.
raj_5004 is offline   Reply With Quote
Old 31st December 2008, 15:51   #288
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,955
Thanked: 15,648 Times
Default

Nobody is claiming 15kmpl. If you actually read the excel sheets we posted, you will see my FE is slightly above 11, and harjeev is getting around 12.5.
Its only on some light footed runs, figures like 17 and 18 are coming up. The point was that it is indeed possible to approach 20kmpl when driven with a light foot.
For the record, my 17kmpl was with AC on 100% of the time, mixed with heater to defog the front windshield
tsk1979 is offline   Reply With Quote
Old 31st December 2008, 16:40   #289
BHPian
 
ram.west's Avatar
 
Join Date: Oct 2008
Location: Chennai
Posts: 418
Thanked: 20 Times
Default

people its all in driving style. Thought it may be OT just citing it as an example , A friend of mine achieved 19.2km in just 100ml of petrol in a boxer bike. That come out like 190kmpl. So lets leave the FE discussion here as it differs from person to person.
ram.west is offline   Reply With Quote
Old 31st December 2008, 17:38   #290
Senior - BHPian
 
harjeev's Avatar
 
Join Date: May 2006
Location: New Delhi
Posts: 1,896
Thanked: 256 Times
Default

Quote:
Originally Posted by tsk1979 View Post
mixed with heater to defog the front windshield
Hey tanveer,
Is there any special way of switching on the heater other than turning the knob (like we do in any other car)?
I tried to turn it on yesterday but it was cold air all the way and Ive never used it before!!
harjeev is offline   Reply With Quote
Old 31st December 2008, 17:43   #291
BHPian
 
ram.west's Avatar
 
Join Date: Oct 2008
Location: Chennai
Posts: 418
Thanked: 20 Times
Post

@harjeev: did you turn off the cooling button??
ram.west is offline   Reply With Quote
Old 31st December 2008, 19:55   #292
Senior - BHPian
 
Join Date: Sep 2007
Location: New Delhi
Posts: 3,083
Thanked: 252 Times
Default

Quote:
Originally Posted by ram.west View Post
@harjeev: did you turn off the cooling button??
The cooling should not need to be turned off.
Bi-level heating/cooling is possible on most cars.
anupmathur is online now   Reply With Quote
Old 31st December 2008, 21:01   #293
Senior - BHPian
 
raj_5004's Avatar
 
Join Date: Jan 2008
Location: Dubai/Mumbai
Posts: 5,078
Thanked: 2,031 Times
Default

Quote:
Originally Posted by tsk1979 View Post
Nobody is claiming 15kmpl. If you actually read the excel sheets we posted, you will see my FE is slightly above 11, and harjeev is getting around 12.5.
Its only on some light footed runs, figures like 17 and 18 are coming up. The point was that it is indeed possible to approach 20kmpl when driven with a light foot.
For the record, my 17kmpl was with AC on 100% of the time, mixed with heater to defog the front windshield

as a matter of fact, i do agree that when driven with a loght foot and without AC, it can return 16-17 kmpl but if driven normally with AC, i think anything more than 13 kmpl is a bonus.
this is according to my FE figures.
anyways, lets end this boring FE topic here. like somebody said, nobody buys heavy SUVs for FE.
raj_5004 is offline   Reply With Quote
Old 31st December 2008, 21:30   #294
Senior - BHPian
 
harjeev's Avatar
 
Join Date: May 2006
Location: New Delhi
Posts: 1,896
Thanked: 256 Times
Default

Quote:
Originally Posted by ram.west View Post
@harjeev: did you turn off the cooling button??
Yes I did, Infact I tried it both ways with the cooling button on and off but there was no warm air, just normal outside temp air.
harjeev is offline   Reply With Quote
Old 1st January 2009, 15:55   #295
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,955
Thanked: 15,648 Times
Default Back to relevance, service light again, and bug can be reproduced at will

Last night while driving back from friends place, I noticed service light. What a way to ring in the year.
I decided to find out how it comes. After little experimentation, I figured it out. Accelerate to 1800-2000rpm in 4th-5th gear, and leave throttle and let her coast.

As rpm drops to around 1400rpm, the service light starts glowing, and goes off after 2-3 seconds.
After multiple refuels, all from very reputed pumps which I have used in past without issues, I am getting service light, and I get get it to turn on anytime.
Looks like saturday I will visit Autolinks.
Have to get the idle surging problem also fixed, which has been there since past 9000kms, and multiple workshops have not been able to do anything about it.
tsk1979 is offline   Reply With Quote
Old 1st January 2009, 16:43   #296
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,752
Thanked: 7,478 Times
Default

It's winter water condensation can happen, check fuel stained before anything else for check light issue.
Jaggu is offline   Reply With Quote
Old 1st January 2009, 18:17   #297
Senior - BHPian
 
Join Date: Mar 2005
Location: N.A
Posts: 6,834
Thanked: 1,503 Times
Default

I think its time to clean your sedimenter, tsk. Its an easy DIY job that takes about 10 mins or less.
Steeroid is offline   Reply With Quote
Old 1st January 2009, 21:19   #298
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,955
Thanked: 15,648 Times
Default

Isn't there a separate sedimenter warning light.
Anyways I am heading to Autolinks on saturday for
1. Idle surging. On cold start rpm keeps fluctuating between 800-1100 rpm whereabouts. This problem has been there since the start. Multiple services and visits have not solved this
2. Pull towards right on braking. On skidding now its straight, but when you brake hard, but not hard enough to skid, you can feel the vehicle pulling towards right.
3. Suspension creaking sound, there since the very beginning
4. The HVAC controls. You have to really strugged to accurately aim where you want. For example if I want airflow at feet and defroster, its impossible to get to that setting, I have to fiddle hard. In a parked vehicle, its okay I can take time, but on the highway I can't hope to adjust it
5. Wiper blade leaving streak. If they don't cover it under warranty. then I won't get it changed, and get bosch
tsk1979 is offline   Reply With Quote
Old 2nd January 2009, 11:52   #299
Senior - BHPian
 
simply_sunny001's Avatar
 
Join Date: Jun 2007
Location: London & Rohtak
Posts: 1,339
Thanked: 15 Times
Default

Quote:
Originally Posted by tsk1979 View Post
Isn't there a separate sedimenter warning light.
Nopes,there is only the same orange light in left hand side which usually glows on for a flash and then goes off and TASS does the first thing of cleaning the sedimenter.

I hope you are seeing this light only.And dont panic much for this light.

The Engine oil light(red one in middle) is something which should never glow when vehicle has been started.

And like Steer said you can clean the Sedimenter yourself and drive the beast today and see if the light glows again.

just to make you feel relieved,though in any case you are going to go to Autolinks

I'm also thinking as my safari is rattling like hell and suspension doesnt seem to be OK.

lets see how it goes.
simply_sunny001 is offline   Reply With Quote
Old 2nd January 2009, 12:00   #300
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,955
Thanked: 15,648 Times
Default

according to the owners manual, the service light is not same as sedimenter light
Safari EX 4x4 120000kms update-safari.jpg

Last edited by tsk1979 : 2nd January 2009 at 12:01.
tsk1979 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
The Abominable (Skoda) Yeti *UPDATE* 20,000Kms Update on Pg.14 SushilBajpai Test-Drives & Initial Ownership Reports 281 8th December 2016 16:08
4x4 Power, My Skoda Yeti Elegance. UPDATE: 63k kms up on page 6 Akshay1234 Long-Term Ownership Reviews 91 8th December 2016 01:11
Jonga 4x4 or M&M Jeep CJ3B 4x4 gd1418 SUVs, MUVs & 4x4s 49 24th May 2013 13:57
Black Storm-Safari GX 4x4. EDIT : 70k Kms update Lukeskywalker Long-Term Ownership Reviews 49 6th May 2013 16:58
Opinion wanted - Dicor VX 4X4 vs Endeavour XLT 4X4...updated Now Booked Dicor VX 4X suman SUVs, MUVs & 4x4s 80 1st April 2009 14:11


All times are GMT +5.5. The time now is 22:02.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks