Go Back   Team-BHP > BHP India > Team-BHP Reviews > Long-Term Ownership Reviews


Reply
 
Thread Tools Search this Thread
Old 2nd January 2009, 12:43   #301
Senior - BHPian
 
Join Date: Sep 2007
Location: New Delhi
Posts: 3,083
Thanked: 252 Times
Default

Quote:
Originally Posted by tsk1979 View Post
according to the owners manual, the service light is not same as sedimenter light
That is correct. Take a look here: http://www.team-bhp.com/forum/techni...ml#post1097173 (some light glowing in dash - dont know why)

In the Scorpio too, the water in fuel indicator is separate.
anupmathur is online now   Reply With Quote
Old 2nd January 2009, 16:06   #302
Senior - BHPian
 
simply_sunny001's Avatar
 
Join Date: Jun 2007
Location: London & Rohtak
Posts: 1,339
Thanked: 15 Times
Default

Thanks for pointing out,i seem to be confused between 2 lights.

will go and check
simply_sunny001 is offline   Reply With Quote
Old 4th January 2009, 15:19   #303
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,955
Thanked: 15,648 Times
Default Problem child...

I always expected niggles out of Tata, but this one has exceeded all expectations.
On saturday I took her to autolinks with the following issues
1. Slight pulling towards right on braking
2. 4x4 noise issue(I was hearing some noises)
3. Service light and idle surging
4. Suspension squeak
5. Wiper leaving streaks

Went for the trial, and all this was noticeable, even the service light could be brought on by the procedure.

hook her upto the computer, and it says "rail pressure sensor"(I think its the ICMP).
Their procedure is to refix the controls etc., and if it still comes, Delphi engineers have to come.
As luck would have it, the fault is not going away. The possiblities are endless
a. sensor fault
b. ECU fault
c. Common rail fault.....

Next the 4x4. Well its failed. Dead Nana. The entire hub locking mechanism(basically everything except the transfer case) has to be replaced. And parts are not in stock, they come from TML pune

As for suspension squeak, its looking like a damper fault. All 4 dampers may have to be changed.

So the plan of action is, wait till parts come from pune, give vehicle for 2 days as engineers from TML/Delphi etc., come in and fix everything.

right now its Langra ghora, with 4x2.
Apparently this sensor issue is not a problem, and I can drive normally.

So its a visit in the future, maybe after 10 days or so
tsk1979 is offline   Reply With Quote
Old 4th January 2009, 15:47   #304
BHPian
 
kkdelhi's Avatar
 
Join Date: May 2007
Location: Delhi
Posts: 230
Thanked: 15 Times
Default

Quote:
Originally Posted by tsk1979 View Post
I always expected niggles out of Tata, but this one has exceeded all expectations...
Here's hoping that the problems you listed go away asap.

Quote:
...Apparently this sensor issue is not a problem, and I can drive normally. So its a visit in the future, maybe after 10 days or so
Thank God for that! It'd be a pity if one was left without a vehicle, especially if there wasn't another vehicle to fall back on.
kkdelhi is offline   Reply With Quote
Old 4th January 2009, 16:07   #305
BANNED
 
Join Date: Jul 2008
Location: NA
Posts: 513
Thanked: Once
Default

Quote:
Originally Posted by tsk1979 View Post
I always expected niggles out of Tata, but this one has exceeded all expectations.
So its a visit in the future, maybe after 10 days or so
Not a start to a new year you would have wished for!
Best of luck for future!
Try to avoid serious offroading with the vehicle, otherwise niggles are likely to be multiplied/magnified!
bhp1 is offline   Reply With Quote
Old 4th January 2009, 16:29   #306
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,955
Thanked: 15,648 Times
Default

Quote:
Originally Posted by bhp1 View Post
Not a start to a new year you would have wished for!
Best of luck for future!
Try to avoid serious offroading with the vehicle, otherwise niggles are likely to be multiplied/magnified!
Serious offroading? Well 4x4 has to work for that.
tsk1979 is offline   Reply With Quote
Old 4th January 2009, 16:42   #307
Team-BHP Support
 
Eddy's Avatar
 
Join Date: Apr 2007
Location: Delhi
Posts: 7,402
Thanked: 4,680 Times
Default

Thats bad Tanveer. Your experience, coupled with my my brothers (with the 2x2) has really really put me off from this car which was once one of my dream cars.

Tata, it seems, will never learn.
Eddy is online now   Reply With Quote
Old 4th January 2009, 17:50   #308
Senior - BHPian
 
raj_5004's Avatar
 
Join Date: Jan 2008
Location: Dubai/Mumbai
Posts: 5,078
Thanked: 2,031 Times
Default

Quote:
Originally Posted by tsk1979 View Post
I always expected niggles out of Tata, but this one has exceeded all expectations.



So its a visit in the future, maybe after 10 days or so
glad that the car is still running tanveer! how come so many problems crop up in your safari's 4x4 tranny? do you torture it with intense mud plugging?

and why cant TATA stock spares? have you tried any other A.S.S?

Quote:
Originally Posted by Eddy View Post
Thats bad Tanveer. Your experience, coupled with my my brothers (with the 2x2) has really really put me off from this car which was once one of my dream cars.

Tata, it seems, will never learn.
4x2 bro!
raj_5004 is offline   Reply With Quote
Old 4th January 2009, 17:53   #309
Team-BHP Support
 
Eddy's Avatar
 
Join Date: Apr 2007
Location: Delhi
Posts: 7,402
Thanked: 4,680 Times
Default

Quote:
Originally Posted by raj_5004 View Post
4x2 bro!
He bhagwan !!! Stupid typo. Thanks for correcting
Eddy is online now   Reply With Quote
Old 4th January 2009, 17:55   #310
Distinguished - BHPian
 
condor's Avatar
 
Join Date: Jun 2006
Location: Speed-brkr City
Posts: 10,752
Thanked: 4,345 Times
Default

@TSK, this is not happening !

Any chance of changing service centers ? Would it help ?

Hope the ghoda kicks A.S.S soon.
condor is offline   Reply With Quote
Old 4th January 2009, 18:08   #311
Team-BHP Support
 
Samurai's Avatar
 
Join Date: Jan 2005
Location: B'lore-Manipal
Posts: 22,385
Thanked: 14,314 Times
Default

Quote:
Originally Posted by raj_5004 View Post
and why cant TATA stock spares? have you tried any other A.S.S?
His dealer has sold only one 4WD until now, that's why.

Is there no way you can chuck that automatic hubs and just put Lamda manual locking hubs? Since you actually take this on offroad terrain, that may be a safe option. Yes, you have to get down from the throne to lock it.
Samurai is offline   Reply With Quote
Old 4th January 2009, 23:07   #312
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,955
Thanked: 15,648 Times
Default

Quote:
Originally Posted by raj_5004 View Post
glad that the car is still running tanveer! how come so many problems crop up in your safari's 4x4 tranny? do you torture it with intense mud plugging?

and why cant TATA stock spares? have you tried any other A.S.S?



4x2 bro!
First time I had problem with 4x4 during rajasthan trip when I heard a weird whine. Showed it to A.S.S.
They repaired the bent pin, and then told me to watch out for any funny sounds. They had never seen this problem before.


Quote:
Originally Posted by condor View Post
@TSK, this is not happening !

Any chance of changing service centers ? Would it help ?

Hope the ghoda kicks A.S.S soon.
The tata warehouse does not have this part. It has to come from pune. No luck

Quote:
Originally Posted by Samurai View Post
His dealer has sold only one 4WD until now, that's why.

Is there no way you can chuck that automatic hubs and just put Lamda manual locking hubs? Since you actually take this on offroad terrain, that may be a safe option. Yes, you have to get down from the throne to lock it.
That dealer was different, this circus is happening in NCR
Anyways manual hubs will mean I loose warranty!
Anyways, the problem is not electronic, its mechanical, some part inside is cracked, due to which 4x4 does not engage. The transfer case and electronics etc.,(Borg Warner) are doing their job. Right where the wheel is, there are the hubs, which have some part cracked(earlier same part had bent pin. So according to them its some manufacturing defect in the hub(LHS) and they are going to change the set.

Apart from that I am scared what will Delphi engineers find. I hope its just a faulty sensor, and not the rail.

Other thing is the suspension, I think I will have to push hard to get all 4 dampers new along with the entire bush kit etc.,
tsk1979 is offline   Reply With Quote
Old 4th January 2009, 23:40   #313
BHPian
 
Join Date: Dec 2008
Location: Delhi
Posts: 269
Thanked: 9 Times
Default

Sad to hear this Tanveer. Its high time for TML.
WanderNomad is offline   Reply With Quote
Old 5th January 2009, 11:20   #314
Distinguished - BHPian
 
condor's Avatar
 
Join Date: Jun 2006
Location: Speed-brkr City
Posts: 10,752
Thanked: 4,345 Times
Default

@TSK, your truck has done 10k (6k miles) so far. Give or take. As many of us have read & heard when we were driving in the US, it is possible for a new car to have problems, and these problems typically crop up in the first 10000 miles. Let's hope this is one of them.

Hopefully, during those few off-roading trips, you have put the truck through it's paces sufficiently that there will be no further problems. Wishing you that the problem is sorted out fast & the new year is exactly that for the truck - new, clean & problem free.
condor is offline   Reply With Quote
Old 7th January 2009, 17:11   #315
Senior - BHPian
 
architect's Avatar
 
Join Date: Apr 2008
Location: Ghaziabad, U. P
Posts: 1,275
Thanked: 448 Times
Default

Sad to hear all this, Tanveer bhai.

I can understand the 4X4 specific parts not being in stock (Very few 4X4 Safaris being sold) but the whole idea of having so many issues within the first 10,000 kms is not very comforting. Especially when the Safari was one of my dream "sometime in the future" vehicles.

Tata, it seems, will never learn!
architect is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
The Abominable (Skoda) Yeti *UPDATE* 20,000Kms Update on Pg.14 SushilBajpai Test-Drives & Initial Ownership Reports 281 8th December 2016 16:08
4x4 Power, My Skoda Yeti Elegance. UPDATE: 63k kms up on page 6 Akshay1234 Long-Term Ownership Reviews 91 8th December 2016 01:11
Jonga 4x4 or M&M Jeep CJ3B 4x4 gd1418 SUVs, MUVs & 4x4s 49 24th May 2013 13:57
Black Storm-Safari GX 4x4. EDIT : 70k Kms update Lukeskywalker Long-Term Ownership Reviews 49 6th May 2013 16:58
Opinion wanted - Dicor VX 4X4 vs Endeavour XLT 4X4...updated Now Booked Dicor VX 4X suman SUVs, MUVs & 4x4s 80 1st April 2009 14:11


All times are GMT +5.5. The time now is 22:02.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks