Go Back   Team-BHP > Under the Hood > Modifications & Accessories

Thread Tools Search this Thread
Old 7th July 2006, 22:13   #1
Join Date: Mar 2006
Location: Trivandrum
Posts: 164
Thanked: Once
Default battery issue

i got my baleno lxi serviced yesterday, but i have some problems with starting now. seems to me that the battery is down.. it is not starting even if i have my foot on brake pedal or with just fan on or player..... even if nothing is there the car sometimes take 3 - 4 times of turning for starting. my car is just one month old. is this common with ole exide batteries..... tomorrow the service guys agreed to check the battery............
premdiv is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery dealer installs 3-wheeler battery in my car!! Now what? Soumyajit9 Technical Stuff 28 12th June 2016 18:36
PICS: SF Sonic Battery Factory. Detailed report on the making of a Car Battery S2!!! Technical Stuff 29 16th April 2016 11:39
Replacing Existing Battery with a Cummins Shakti Truck Battery? condor Technical Stuff 12 25th November 2010 15:29
Battery question - Can I use Indica Spec Battery in Scorpio, or other such swaps? shekharlele Technical Stuff 18 7th September 2010 09:05
Using a battery tender to revive discharged battery xxaarraa Technical Stuff 2 14th May 2008 19:56

All times are GMT +5.5. The time now is 20:04.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks