Go Back   Team-BHP > Under the Hood > Modifications & Accessories


Reply
 
Thread Tools Search this Thread
Old 6th March 2007, 17:53   #1
Newbie
 
gallardo_beast's Avatar
 
Join Date: Feb 2007
Location: Noida
Posts: 14
Thanked: 0 Times
Default perfomance exhaust problem

hey people need help, i recently installed a perfomance exhaust in my maruti 800 type 3 , i think it was from Thialand, the car is running very smooth and fast but sometimes when the car touches 120 r above a weird smell comes from inside like somethings burning or when anything gets heats up, but the car is running fine with no problems... i havent installed the pipe actually but only the big n loud exhaust, its installed near the chassis... help me out guys and yeah do let me know what should i do and should i go for the pipe with the mufler also..
thanks.
gallardo_beast is offline   Reply With Quote
Old 24th March 2007, 17:46   #2
BHPian
 
nitroxx's Avatar
 
Join Date: Nov 2004
Location: DXB
Posts: 817
Thanked: 26 Times
Default

theres alot of cars that are facing this issue I'm sure there'll be someone who will help you out
nitroxx is offline   Reply With Quote
Old 24th March 2007, 19:58   #3
BHPian
 
rishibravo's Avatar
 
Join Date: Jul 2006
Location: New Delhi
Posts: 579
Thanked: 6 Times
Default

I think you are saying you just put a new muffler and have the stock manifold. If that is the case do you actually feel that the performance has increased or its just the loud roar which makes you feel you are going fast.

The smell you are referring to comes inside the car when you are speeding?
rishibravo is offline   Reply With Quote
Old 25th March 2007, 07:06   #4
Senior - BHPian
 
ananthkamath's Avatar
 
Join Date: Jul 2005
Location: USA
Posts: 1,194
Thanked: 46 Times
Default

could be oil on either the manifold or the muffler burning when it gets extremely hot and causing the situation you are describing. drive for a few hundred kilometres and this should disappear. Either this, or one of the joints is leaking because it wasnt tightened down properly or a flange is warped.
ananthkamath is offline   Reply With Quote
Old 25th March 2007, 16:52   #5
BHPian
 
16v100bhp's Avatar
 
Join Date: Sep 2005
Location: Middletown CT USA
Posts: 329
Thanked: 10 Times
Default

How long have you been driving with this problem? If you had put any new gaskets/pastes for the exhaust pipe joints then you would have this smell untill its completely set. or even burnt up paint would smell the same. Try driving somemore and this issue should go off on its on.
16v100bhp is offline   Reply With Quote
Old 27th March 2007, 17:57   #6
Newbie
 
gallardo_beast's Avatar
 
Join Date: Feb 2007
Location: Noida
Posts: 14
Thanked: 0 Times
Default

thanks people for ur suggestions, i drive 70-80 kms per day.. its been a month now i dont face such burning smell till now... and yeah i hav installed a manifold only.. roaring sound as well as perfomance has olso increased.... and yeah should i go for the pipe and a big mufler as well.. what kind of sound would it produce same or a lesser and thinner sound .. thanks
PEACE
gallardo_beast is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need perfomance mods for Honda City!! barbar Modifications & Accessories 13 11th September 2015 12:44
Magnaflow perfomance exhausts shazikon Modifications & Accessories 85 13th January 2014 14:55
Perfomance accessories for Alto LXI ashok_lat Technical Stuff 0 27th July 2008 22:44
What do you think is the Sub 20 Lac perfomance car for us Indians ? maxbhp The Indian Car Scene 72 7th September 2006 20:03
guys..Anyone got a perfomance chip for 1.6 Optra angelfire Modifications & Accessories 0 16th December 2005 22:52


All times are GMT +5.5. The time now is 14:35.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks