Go Back   Team-BHP > Under the Hood > Modifications & Accessories


Reply
 
Thread Tools Search this Thread
Old 23rd January 2008, 22:50   #1
BHPian
 
viper316's Avatar
 
Join Date: Dec 2007
Location: BeNgAlUrU/PoNdY
Posts: 61
Thanked: Once
Post Slow Performance On MY Swift ? Need Help

Hi,

I have a Red Swift Vxi which has 205/55 r15 HR mags with cone K & N filter . The filter had shrunk once since they had covered the filter with plastic cover and started in unknowingly . i did replace it . But i feel the initial pick up is very slow and also it take a long time to rave up to 80 . I feel its under performed. Need help with this and also have plans for headers?
viper316 is offline   Reply With Quote
Old 24th January 2008, 05:04   #2
BHPian
 
Join Date: May 2006
Location: bombay
Posts: 440
Thanked: 5 Times
Default

hey man
i think its service time.
how many KM you done man
cyneverdie is offline   Reply With Quote
Old 24th January 2008, 11:47   #3
Senior - BHPian
 
ram_hyundai's Avatar
 
Join Date: Jun 2006
Location: Calicut ,trisur
Posts: 2,019
Thanked: 48 Times
Default

check the air pressure on all tyres and the filter -both fuel and air.these can be the issues which is the reason for the low performance.
ram
ram_hyundai is offline   Reply With Quote
Old 24th January 2008, 17:02   #4
Senior - BHPian
 
Epic's Avatar
 
Join Date: Jan 2007
Location: Mumbai
Posts: 1,248
Thanked: 340 Times
Default

Quote:
Originally Posted by viper316 View Post
Hi,

I have a Red Swift Vxi which has 205/55 r15 HR mags with cone K & N filter . The filter had shrunk once since they had covered the filter with plastic cover and started in unknowingly . i did replace it . But i feel the initial pick up is very slow and also it take a long time to rave up to 80 . I feel its under performed. Need help with this and also have plans for headers?
Hi Viper,

I have a Swift Vxi myself and have upgraded my tyres to 195/60/15 and i already feel that the pick-up of the car is a bit sluggish. This is due to the greater contact patch area of the tyre to the road creating greater traction as compared to the stock 165/80/14s. Your tyres being 205 will have an even more greater traction as compared to 165 OR 205 so pick-up will definitely be a lot slower.

Also as cyneverdie and ram mentioned in their posts, do check the tyre pressure for right psi and fuel and oil filters for blockages. If your car has completed a year, do get the injectors cleaned as well as there could be carbon deposits blocking the injectors. Cleaning the injectors will definitely improve the pick-up to a large extent.

Epic
Epic is offline   Reply With Quote
Old 24th January 2008, 22:43   #5
BHPian
 
viper316's Avatar
 
Join Date: Dec 2007
Location: BeNgAlUrU/PoNdY
Posts: 61
Thanked: Once
Default

Hi,

Its done 5000 km after the service in two months . i had changed the oil filter, fuel filter, coolant , brake fluid. After the changes i had changed it to K & n and also changed the tyres also to 205/15. The tyre pressure is set to 31psi and i fill in super petrol in Shell.
viper316 is offline   Reply With Quote
Old 24th January 2008, 22:44   #6
BHPian
 
viper316's Avatar
 
Join Date: Dec 2007
Location: BeNgAlUrU/PoNdY
Posts: 61
Thanked: Once
Default

The car has completed 22000km in a 18months.
viper316 is offline   Reply With Quote
Old 24th January 2008, 23:14   #7
BHPian
 
viper316's Avatar
 
Join Date: Dec 2007
Location: BeNgAlUrU/PoNdY
Posts: 61
Thanked: Once
Default

Hi,

I am also taking the Car to Tirupathi this Weekend . so need some help?
viper316 is offline   Reply With Quote
Old 25th January 2008, 08:24   #8
Senior - BHPian
 
vikram_d's Avatar
 
Join Date: Jul 2006
Location: Bangalore
Posts: 2,380
Thanked: 936 Times
Default

31psi is too high, stick to around 28-29 psi.
vikram_d is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow thought process but a Swift decision torquarius Test-Drives & Initial Ownership Reports 17 26th October 2010 00:53
Help !! DVD player plays the frames slow benbsb29 Gadgets, Computers & Software 19 7th May 2007 11:00


All times are GMT +5.5. The time now is 03:23.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks