Go Back   Team-BHP > Under the Hood > Modifications & Accessories


Reply
 
Thread Tools Search this Thread
Old 9th February 2011, 18:17   #346
Senior - BHPian
 
Ricky_63's Avatar
 
Join Date: Dec 2006
Location: Gurgaon
Posts: 3,846
Thanked: 375 Times
Default Re: "The First" from the SPEEDSPORT stable !!

Some random shots of the Swift Hella 1000's
Attached Thumbnails
"The First" from the SPEEDSPORT stable !!-d90-005.jpg  

"The First" from the SPEEDSPORT stable !!-d90-001.jpg  

Ricky_63 is offline   Reply With Quote
Old 9th February 2011, 18:36   #347
BANNED
 
Join Date: Nov 2006
Location: London
Posts: 5,012
Thanked: 147 Times
Default Re: "The First" from the SPEEDSPORT stable !!

Dont you get a wobble when you are driving? Do add braces to the top. there is an attachment given there on all Hellas.
Cyrus43 is offline   Reply With Quote
Old 10th February 2011, 09:59   #348
Senior - BHPian
 
Ricky_63's Avatar
 
Join Date: Dec 2006
Location: Gurgaon
Posts: 3,846
Thanked: 375 Times
Default Re: "The First" from the SPEEDSPORT stable !!

Quote:
Originally Posted by Cyrus43 View Post
Dont you get a wobble when you are driving? Do add braces to the top. there is an attachment given there on all Hellas.

The lights are rock steady, as the brackets for mounting them are welded to the steel frame behind the bumper. They'd have wobbled had they been fixed to the bumper.



Cheers
Ricky_63 is offline   Reply With Quote
Old 10th February 2011, 11:05   #349
BHPian
 
lilMonSter's Avatar
 
Join Date: Dec 2008
Location: New delhi
Posts: 181
Thanked: 28 Times
Default Re: "The First" from the SPEEDSPORT stable !!

Quote:
Originally Posted by Ricky_63 View Post
The lights are rock steady, as the brackets for mounting them are welded to the steel frame behind the bumper. They'd have wobbled had they been fixed to the bumper.



Cheers
Did phil fabricate the mounts for your fogs? i need to get proper mounts for my ff200's, they are mounted too low to the ground right now as the mount's are coming from under the bumper. Time to head to chattarpur
lilMonSter is offline   Reply With Quote
Old 15th February 2011, 10:33   #350
Senior - BHPian
 
Ricky_63's Avatar
 
Join Date: Dec 2006
Location: Gurgaon
Posts: 3,846
Thanked: 375 Times
Default Re: "The First" from the SPEEDSPORT stable !!

Quote:
Originally Posted by lilMonSter View Post
Did phil fabricate the mounts for your fogs? i need to get proper mounts for my ff200's, they are mounted too low to the ground right now as the mount's are coming from under the bumper. Time to head to chattarpur


Ya it was done there at Speedsport. I wonder why the mounts on your car are coming from "under the bumper", that may not look very nice + it is way too low, can easily be hit by stuff flying from the road...




Cheers
Ricky_63 is offline   Reply With Quote
Old 17th February 2011, 22:48   #351
BHPian
 
Neil.Bhujbal's Avatar
 
Join Date: Nov 2009
Location: Pune
Posts: 189
Thanked: 57 Times
Default Re: "The First" from the SPEEDSPORT stable !!

Has the morning cranking problem solved ? Because i know a TC'd swift which has similar problems,almost needs 20+ cranks to start in the morning. But when started runs perfectly fine.
Neil.Bhujbal is offline   Reply With Quote
Old 18th February 2011, 10:50   #352
Senior - BHPian
 
Ricky_63's Avatar
 
Join Date: Dec 2006
Location: Gurgaon
Posts: 3,846
Thanked: 375 Times
Default Re: "The First" from the SPEEDSPORT stable !!

Quote:
Originally Posted by Neil.Bhujbal View Post
Has the morning cranking problem solved ? Because i know a TC'd swift which has similar problems,almost needs 20+ cranks to start in the morning. But when started runs perfectly fine.

I think it was the extreme cold here (not sure). Nowadays, the first crank does nothing. On second crank it starts, but stutters, then settles at a smooth idle at around 2k rpm & then after about a minute settles at 900 rpm.

Post the initial start it runs beautifully & starts on first crank like any other normal car does/should.

So far so good.



Cheers
Ricky_63 is offline   Reply With Quote
Old 18th February 2011, 17:38   #353
Senior - BHPian
 
Ricky_63's Avatar
 
Join Date: Dec 2006
Location: Gurgaon
Posts: 3,846
Thanked: 375 Times
Default Re: "The First" from the SPEEDSPORT stable !!

After the recent rains in Gurgaon the car went to a "Shampoo Station" & got a nice rubbing polish as well !!

Some snaps of the process & the result !!
Attached Thumbnails
"The First" from the SPEEDSPORT stable !!-car-wash-suncity-004.jpg  

"The First" from the SPEEDSPORT stable !!-car-wash-suncity-005.jpg  

"The First" from the SPEEDSPORT stable !!-car-wash-suncity-006.jpg  

"The First" from the SPEEDSPORT stable !!-car-wash-suncity-007.jpg  

"The First" from the SPEEDSPORT stable !!-car-wash-suncity-010.jpg  

"The First" from the SPEEDSPORT stable !!-car-wash-suncity-012.jpg  

Ricky_63 is offline   (2) Thanks Reply With Quote
Old 24th February 2011, 18:29   #354
Senior - BHPian
 
Ricky_63's Avatar
 
Join Date: Dec 2006
Location: Gurgaon
Posts: 3,846
Thanked: 375 Times
Default Re: "The First" from the SPEEDSPORT stable !!

Been using STP Octane booster since the last tank full. The starting trouble persists (should I call it that anymore) but the engine is smoother, thru the powerband. Do not know if it is in the head or for real.. fuel is 91 Octane + one bottle of STP = experimental fun




Cheers
Ricky_63 is offline   Reply With Quote
Old 14th March 2011, 18:39   #355
Senior - BHPian
 
Ricky_63's Avatar
 
Join Date: Dec 2006
Location: Gurgaon
Posts: 3,846
Thanked: 375 Times
Default Re: "The First" from the SPEEDSPORT stable !!

I do not if it is the Octane booster or I have gotten used to the car. It is now returning a respectable 10.2 / lt of fuel.

Coolant level needs topping up every now & then, the engine oil is holding up though. I do check both pretty much each week. So all in all it is running well.

I am looking at a tyre rotation front to back, as the front one's are the one's that take the beating !!!

Would be looking at brake pad upgrade & a coat of fresh paint as soon as my pocket allows...



Cheers
Ricky_63 is offline   Reply With Quote
Old 19th April 2011, 16:33   #356
Senior - BHPian
 
Ricky_63's Avatar
 
Join Date: Dec 2006
Location: Gurgaon
Posts: 3,846
Thanked: 375 Times
Default Re: "The First" from the SPEEDSPORT stable !!

Got tyre rotation & wheel balancing done, as per schedule. While the front tyre was being fitted, the fitter noticed a very slight play on the front right wheel. I double checked & yes it is there. Seems like the bearing has developed a very slight play. So I will have to have this looked into & replace the culprit or maybe all it's other cousins as well.

On the way back I was very careful about any telltale sounds - NIL, any steering vibrations - NIL...but still needs a looksie.

Then came a Skoda RS snooping down on me & shift into 2nd pedal to the metal & the RS was a dot in the mirror by the time I got to 4th LOL. Wanted to see the expression on the gentleman's face !! Honestly I never expected this kind of difference in acceleration as we started out side by side.

Anyway, still need to have the bearing looked into / replaced.
Ricky_63 is offline   Reply With Quote
Old 19th April 2011, 22:05   #357
BHPian
 
Safari_Beast's Avatar
 
Join Date: Nov 2009
Location: Faridabad
Posts: 284
Thanked: 196 Times
Default Re: "The First" from the SPEEDSPORT stable !!

Hi Ricky

Your swift looks stunning after a wash .
Well smile on your face when you zipped past VRS would be priceless .
Now one cay say Swift Fun to drive .
One thing need to get changed in your rear bumper the mud guard to cup shape one then they will blend to the shape of rear bumper . Current one dont look good .
Safari_Beast is offline   Reply With Quote
Old 20th April 2011, 00:29   #358
BHPian
 
Neil.Bhujbal's Avatar
 
Join Date: Nov 2009
Location: Pune
Posts: 189
Thanked: 57 Times
Default Re: "The First" from the SPEEDSPORT stable !!

The play in the wheel could be cause of a gone ball-joint or tier rod end.
Wheel bearings when gone make a typical sound which u said u havnet noticed.

Anyways better to get it checked. You getting that done at speed sport ?

And yah i feel sorry for the vrs owner
Neil.Bhujbal is offline   Reply With Quote
Old 20th April 2011, 10:43   #359
Senior - BHPian
 
Ricky_63's Avatar
 
Join Date: Dec 2006
Location: Gurgaon
Posts: 3,846
Thanked: 375 Times
Default Re: "The First" from the SPEEDSPORT stable !!

Quote:
Originally Posted by Safari_Beast View Post
Hi Ricky

Your swift looks stunning after a wash .
Well smile on your face when you zipped past VRS would be priceless .
Now one cay say Swift Fun to drive .
One thing need to get changed in your rear bumper the mud guard to cup shape one then they will blend to the shape of rear bumper . Current one dont look good .

Thanks for the kind words ! As for the mudflaps, the MASS tells me that these are the only one's for my car, being a 2006 model Zxi, the mudflaps you are reffering to are for the newer / revised bumper design which I think came in 2008.


Quote:
Originally Posted by Neil.Bhujbal View Post
The play in the wheel could be cause of a gone ball-joint or tier rod end.
Wheel bearings when gone make a typical sound which u said u havnet noticed.

Anyways better to get it checked. You getting that done at speed sport ?

And yah i feel sorry for the vrs owner

Thanks for the feedback, shall have the same checked. The typical hum of the bearing is certainly not there. The car has just 40k on the odo, anyway a checkup is called for.

As for the vRS, it maybe that he just did not want to accept that a puny little Swift could beat the mighty vRS, so he backed off after a while.







Cheers
Ricky_63 is offline   Reply With Quote
Old 20th April 2011, 21:58   #360
Senior - BHPian
 
m4ugr8's Avatar
 
Join Date: Jul 2007
Location: New Delhi
Posts: 1,291
Thanked: 123 Times
Default Re: "The First" from the SPEEDSPORT stable !!

The vRS guy should take his car and drive it straight through a wall . Nothing can match the feeling of defeating a car twice the price with a small car, reminds me of Redline2 where I took the case of a BMW 320D with my second hand honda city LOL !!

I think its time to go forged now and up the boost.
m4ugr8 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Cayenne" we "XC-eed" in our "Endeavour" to "Safari"? Taking powerful metal off-road SS-Traveller 4x4 Excursions 55 10th November 2016 22:56
'03 Toyota Camry V3 - The "New" Wild Horse in My Stable IQBAL VEERJI Test-Drives & Initial Ownership Reports 66 4th January 2012 23:14


All times are GMT +5.5. The time now is 11:07.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks