Go Back   Team-BHP > BHP India > Motorbikes


Reply
 
Thread Tools Search this Thread
Old 21st August 2012, 15:51   #1
BHPian
 
Join Date: Jun 2012
Location: Bengaluru
Posts: 245
Thanked: 76 Times
Default Odometer not working

Hi,

I have a 2006 model Honda unicorn. A strange problem happened in my bike some time back. The kilometers stopped incrementing and the 5th digit is now not incrementing at all(for example 19999 refuses to become 20000).

Can you please guide me on what needs to be done. I checked with Honda service center and that goof test drove it once and said it will work fine now that he has driven it

Thanks in advance.
shadows123 is offline   Reply With Quote
Old 21st August 2012, 16:14   #2
Senior - BHPian
 
VW2010's Avatar
 
Join Date: Dec 2010
Location: electricity
Posts: 2,567
Thanked: 2,040 Times
Default Re: Odometer not working

Can you check the place where the speedo meter wire meets the wheel?(Worm gear i guess).

This may be the culprit and the service engineer would have pushed it inside when he tested the same.
VW2010 is offline   Reply With Quote
Old 21st August 2012, 16:20   #3
BHPian
 
Join Date: Jun 2012
Location: Bengaluru
Posts: 245
Thanked: 76 Times
Default Re: Odometer not working

Quote:
Originally Posted by VW2010 View Post
Can you check the place where the speedo meter wire meets the wheel?(Worm gear i guess).

This may be the culprit and the service engineer would have pushed it inside when he tested the same.
well. He just test drove and came back. He didnt try anything and anyways it didnt work either. The problem still persists. He spent a good part of 15-20mins trying to convince me it works.

Can you suggest anything which i can do to get rid of this problem.
shadows123 is offline   Reply With Quote
Old 21st August 2012, 19:31   #4
Distinguished - BHPian
 
supremeBaleno's Avatar
 
Join Date: Dec 2005
Location: Weekdays@Chennai, Weekends@Kerala
Posts: 5,164
Thanked: 1,638 Times
Default Re: Odometer not working

Sounds to me like the odometer cable is broken and replacing with a new one should do the trick - has happened atleast 3-4 times with my CD100 during the 15years I had it.
BTW, this is something any local mechanic can identify and fix.
supremeBaleno is offline   Reply With Quote
Old 21st August 2012, 21:24   #5
Distinguished - BHPian
 
libranof1987's Avatar
 
Join Date: Sep 2010
Location: All over!
Posts: 3,728
Thanked: 2,833 Times
Default Re: Odometer not working

Is the speedometer working?

It's the same wire for both the speedometer and odometer; probably changing it could solve it.
libranof1987 is online now   Reply With Quote
Old 21st August 2012, 23:04   #6
Distinguished - BHPian
 
dhanushs's Avatar
 
Join Date: Oct 2009
Location: Bathery/BLR
Posts: 3,446
Thanked: 4,055 Times
Default Re: Odometer not working

I'm not sure about newer unicorn's but, 2006 models came with analogue speedo and odo.

Please check the cable. The end might have worn out.
dhanushs is offline   Reply With Quote
Old 22nd August 2012, 09:36   #7
BHPian
 
Join Date: Jun 2012
Location: Bengaluru
Posts: 245
Thanked: 76 Times
Default Re: Odometer not working

Ya its analog and well the speedometer works fine. Only the odo doesnt!!!
shadows123 is offline   Reply With Quote
Old 22nd August 2012, 10:08   #8
Distinguished - BHPian
 
supremeBaleno's Avatar
 
Join Date: Dec 2005
Location: Weekdays@Chennai, Weekends@Kerala
Posts: 5,164
Thanked: 1,638 Times
Default Re: Odometer not working

^^^ Hmm, I had (still have) the same problem with our 2001 Scooty-ES - speedometer works fine, but odometer stopped at around 8K kms some years ago. When checked with TVS service, they gave some story of having to change the whole panel etc costing 1000bucks and more, so let it stay that way. I wish it was the other way round though ie. speedo did not work, but odo worked, because the odo was a big help in knowing the FE of the bike, while the speed did not really matter.
supremeBaleno is offline   Reply With Quote
Old 22nd August 2012, 10:28   #9
BHPian
 
Join Date: Jun 2012
Location: Bengaluru
Posts: 245
Thanked: 76 Times
Default Re: Odometer not working

Quote:
Originally Posted by supremeBaleno View Post
^^^ Hmm, I had (still have) the same problem with our 2001 Scooty-ES - speedometer works fine, but odometer stopped at around 8K kms some years ago. When checked with TVS service, they gave some story of having to change the whole panel etc costing 1000bucks and more, so let it stay that way. I wish it was the other way round though ie. speedo did not work, but odo worked, because the odo was a big help in knowing the FE of the bike, while the speed did not really matter.
Ya gave it to Honda Service center today. He said he will check and let me know if Speedometer cable is the problem. If its not, i am thinking of letting the problem stay!

btw not really sure what the Honda guys are smoking..700Rs for a oil change???
shadows123 is offline   Reply With Quote
Old 22nd August 2012, 10:47   #10
Senior - BHPian
 
ashis89's Avatar
 
Join Date: Aug 2011
Location: Hyderabad
Posts: 1,313
Thanked: 1,043 Times
Default Re: Odometer not working

Is it only the 5th digit which is not moving or all the digits? Get it checked at some local shops who repair speedometers and alter the readings. Probably the gears(I hope that is what they are called) in the speedo assembly are broken/worn out.

You can also try the Honda A** but they might ask you to replace the whole speedometer assembly.
ashis89 is online now   Reply With Quote
Old 22nd August 2012, 10:49   #11
BHPian
 
Join Date: Jun 2012
Location: Bengaluru
Posts: 245
Thanked: 76 Times
Default Re: Odometer not working

Quote:
Originally Posted by ashis89 View Post
Is it only the 5th digit which is not moving or all the digits? Get it checked at some local shops who repair speedometers and alter the readings. Probably the gears(I hope that is what they are called) in the speedo assembly are broken/worn out.

You can also try the Honda A** but they might ask you to replace the whole speedometer assembly.
Well the first 4 are stuck @ 09999 and the 1 increment doesn't happen. This a kind of an old problem which i had postponed fixing from time to time
shadows123 is offline   Reply With Quote
Old 22nd August 2012, 10:55   #12
Senior - BHPian
 
ashis89's Avatar
 
Join Date: Aug 2011
Location: Hyderabad
Posts: 1,313
Thanked: 1,043 Times
Default Re: Odometer not working

Wait for the findings of the Honda A** and then take a call. IMO, there is some issue with the odo assembly and its crown pins(setup similar to ones found within a watch).

Regarding the Rs.700 for oil change, I paid Rs.380+taxes for oil changes for the 1st free service of my P180 and thought I was being overcharged. I guess I was wrong/luckier than you.
ashis89 is online now   Reply With Quote
Old 22nd August 2012, 11:07   #13
BHPian
 
Join Date: Jun 2012
Location: Bengaluru
Posts: 245
Thanked: 76 Times
Default Re: Odometer not working

Quote:
Originally Posted by ashis89 View Post
Wait for the findings of the Honda A** and then take a call. IMO, there is some issue with the odo assembly and its crown pins(setup similar to ones found within a watch).

Regarding the Rs.700 for oil change, I paid Rs.380+taxes for oil changes for the 1st free service of my P180 and thought I was being overcharged. I guess I was wrong/luckier than you.
Well this is the last time I am giving Engine oil change to a Honda A**. Next time onwards Shell(or Castrol) it is. Shouldn't be that costly compared to this!!
shadows123 is offline   Reply With Quote
Old 22nd August 2012, 15:45   #14
BHPian
 
Join Date: Jun 2012
Location: Bengaluru
Posts: 245
Thanked: 76 Times
Default Re: Odometer not working

A quick update on Honda's ever so brilliant(Not really) A**

1> Engine Oil change: Apparently Engine oil is burnt so the charge was 750Rs. I asked him to drop it since i had changed only 3 months ago. He tried convincing me on how every 3 months if i change Engine oil, the engine will be long lasting and smooth!!(4 times a year * 750-->PATHETICALLY HIGH COST. Thinking of going for Shell Oil . Any idea on what their costs are?

2> Battery Change : Apparently the battery is 2006 model, so it has to be replaced @ a cost of 1400Rs. Doesn't mattter if it works or not, its faulty. Had to convince him that it is working perfectly fine(asked him if he checked the engine start button and well he hadn't) and that a replacement is not necessary!

3> And finally, for the problem of Odometer, he suggested replacing the meter panel @ a cost of 2200Rs. Apparently the speedometer wire is fine so this has to be the problem as per them!

Why i still go there for service i dont know. They are basically trying to rip people off giving vague reasons and excuses!! Dont know how Honda can have a good car A** and a pathetc/arrogant 2 wheeler A**
shadows123 is offline   Reply With Quote
Old 22nd August 2012, 22:20   #15
Distinguished - BHPian
 
dhanushs's Avatar
 
Join Date: Oct 2009
Location: Bathery/BLR
Posts: 3,446
Thanked: 4,055 Times
Default Re: Odometer not working

Quote:
Originally Posted by shadows123 View Post
1> Engine Oil change: Apparently Engine oil is burnt so the charge was 750Rs. I asked him to drop it since i had changed only 3 months ago. He tried convincing me on how every 3 months if i change Engine oil, the engine will be long lasting and smooth!!(4 times a year * 750-->PATHETICALLY HIGH COST. Thinking of going for Shell Oil . Any idea on what their costs are?
Hi,

Go for fully synthetic Mobil1. Costs 1000 bucks per liter, but, you can change them every year or ~3000kms from a local workshop for 50 bucks. Especially being a motorcycle, which revvs high, your engine will thank you after 40000 kms.
Quote:
3> And finally, for the problem of Odometer, he suggested replacing the meter panel @ a cost of 2200Rs. Apparently the speedometer wire is fine so this has to be the problem as per them!
Obviously, as the speedo is working, the cable is fine. So, before replacing, please try to give it outside A.S.S. If possible to the guys who alter the kms in the speedo. They will correct it in a jiffy for less than 200 bucks.
dhanushs is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
rear lights not working 2fast4u Technical Stuff 10 7th June 2015 12:53
Rear defogger not working Venkat Technical Stuff 48 22nd January 2014 16:34
Team-BHP e-mail Subscription service not working mithun Shifting gears 3 8th April 2006 11:13
mp3 cd not working in player a4_attitude In-Car Entertainment 2 15th September 2005 23:04
palio 1.2: starter not working properly... amitverma Technical Stuff 14 3rd April 2005 00:34


All times are GMT +5.5. The time now is 11:06.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks