Go Back   Team-BHP > BHP India > Motorbikes


Reply
 
Thread Tools Search this Thread
Old 30th July 2015, 00:13   #4666
BHPian
 
VijayAnand1's Avatar
 
Join Date: Oct 2013
Location: Nilgiris, Ooty
Posts: 158
Thanked: 82 Times
Post Re: The KTM Duke 390 Ownership Experience Thread

And then this happened.

The KTM Duke 390 Ownership Experience Thread-ktm390duketrophy.jpg

End of OT

http://www.cycleworld.com/2015/07/28...src=SOC&dom=fb

Cheers!
VJ
VijayAnand1 is offline   (6) Thanks Reply With Quote
Old 30th July 2015, 07:25   #4667
BHPian
 
b16h22's Avatar
 
Join Date: Feb 2015
Location: Thrissur
Posts: 108
Thanked: 100 Times
Default

Quote:
Originally Posted by VijayAnand1 View Post
Yeah, saw that yesterday. 390 deserves every bit of praise though. We Indians don't realize how good a motorcycle it really is for the price. It's more on par with the price of N300, r3 there. Maybe a bit more expensive. Still it gets praise in most international reviews. The only negative was braking. Yeah there are some niggling problems but it's still one good piece of kit.
b16h22 is offline   (1) Thanks Reply With Quote
Old 30th July 2015, 11:40   #4668
BHPian
 
MavericK46's Avatar
 
Join Date: Jan 2009
Location: Bangalore
Posts: 135
Thanked: 103 Times
Default Re: The KTM Duke 390 Ownership Experience Thread

Added_Flavor saar:

My speedo showed '0' for a brief moment while we were going past Krishnagiri. This has happened a couple of times in the past as well.

Does this mean the stator coil is on the fritz or is it a faulty speedo that too is a known issue?

Last edited by MavericK46 : 30th July 2015 at 11:41. Reason: Bleh
MavericK46 is offline   Reply With Quote
Old 30th July 2015, 11:44   #4669
BHPian
 
Added_flavor's Avatar
 
Join Date: May 2011
Location: Bangalore
Posts: 584
Thanked: 688 Times
Default Re: The KTM Duke 390 Ownership Experience Thread

Quote:
Originally Posted by MavericK46 View Post
Added_Flavor saar:

My speedo showed '0' for a brief moment while we were going past Krishnagiri. This has happened a couple of times in the past as well.

Does this mean the stator coil is on the fritz or is it a faulty speedo that too is a known issue?
In the case of a stator coil failure, it just never moves beyond zero until the coil is replaced.

Momentary display of zero while on the move is due to the faulty speedometer. You'll notice that the frequency of occurrence of this will gradually increase with time, but it won't leave you stranded.

This is known to be sorted out in the newer lot. You can get it changed under warranty.

Last edited by Added_flavor : 30th July 2015 at 11:47.
Added_flavor is offline   Reply With Quote
Old 30th July 2015, 12:04   #4670
BHPian
 
RiderZone's Avatar
 
Join Date: Oct 2014
Location: Hyderabad
Posts: 121
Thanked: 157 Times
Default Re: The KTM Duke 390 Ownership Experience Thread

Quote:
Originally Posted by MavericK46 View Post
Added_Flavor saar:

My speedo showed '0' for a brief moment while we were going past Krishnagiri. This has happened a couple of times in the past as well.

Does this mean the stator coil is on the fritz or is it a faulty speedo that too is a known issue?
I think this is how the stator coil issue starts, and it's not a problem with the speedo. Now that I've replaced my coil, the speedo is functional again, where it used to intermittently go insane for indeterminate periods of time. The odo is unaffected though.
RiderZone is offline   (1) Thanks Reply With Quote
Old 30th July 2015, 12:07   #4671
Senior - BHPian
 
man_of_steel's Avatar
 
Join Date: Aug 2013
Location: BLR/TVM
Posts: 1,149
Thanked: 972 Times
Default Re: The KTM Duke 390 Ownership Experience Thread

Quote:
Originally Posted by MavericK46 View Post
My speedo showed '0' for a brief moment while we were going past Krishnagiri. This has happened a couple of times in the past as well.
Quote:
Originally Posted by Added_flavor View Post
Momentary display of zero while on the move is due to the faulty speedometer. You'll notice that the frequency of occurrence of this will gradually increase with time, but it won't leave you stranded.

This is known to be sorted out in the newer lot. You can get it changed under warranty.
What a timing saar-s! Noticed the same momentary flash to zero yesterday evening! So, is it the problem with the speedo sensor or the cluster itself?
man_of_steel is offline   Reply With Quote
Old 30th July 2015, 12:18   #4672
BHPian
 
Added_flavor's Avatar
 
Join Date: May 2011
Location: Bangalore
Posts: 584
Thanked: 688 Times
Default Re: The KTM Duke 390 Ownership Experience Thread

Quote:
Originally Posted by RiderZone View Post
I think this is how the stator coil issue starts, and it's not a problem with the speedo. Now that I've replaced my coil, the speedo is functional again, where it used to intermittently go insane for indeterminate periods of time. The odo is unaffected though.
Quote:
Originally Posted by man_of_steel View Post
What a timing saar-s! Noticed the same momentary flash to zero yesterday evening! So, is it the problem with the speedo sensor or the cluster itself?
As fas as I know, there are two separate issues.

1. We have already discussed. The stator coil is burnt, the speedo goes dead zero (Odo and Trip continue to work). After few more minutes you have the 'Low battery' on the console. This is purely a mechanical issue.

2. The stator coil is fine. The speedo just shows zero intermittently and absolutely randomly. This is supposed to be a 'logical' issue with the electronics of the speedo and in this case the entire console is replaced. If I remember correct, a few owners also reported getting a brand new console with 0 km on the odo.

You guys better visit the A.S.S on this and while you are there, also get the stator coil checked.

Last edited by Added_flavor : 30th July 2015 at 12:20.
Added_flavor is offline   (1) Thanks Reply With Quote
Old 30th July 2015, 12:26   #4673
BHPian
 
MavericK46's Avatar
 
Join Date: Jan 2009
Location: Bangalore
Posts: 135
Thanked: 103 Times
Default Re: The KTM Duke 390 Ownership Experience Thread

Quote:
Originally Posted by Added_flavor View Post
.....................
2. The stator coil is fine. The speedo just shows zero intermittently and absolutely randomly. This is supposed to be a 'logical' issue with the electronics of the speedo and in this case the entire console is replaced. If I remember correct, a few owners also reported getting a brand new console with 0 km on the odo.

You guys better visit the A.S.S on this and while you are there, also get the stator coil checked.
Quote:
Originally Posted by man_of_steel View Post
What a timing saar-s! Noticed the same momentary flash to zero yesterday evening! So, is it the problem with the speedo sensor or the cluster itself?
Sudeep, when shall we head to Khivraj then?
MavericK46 is offline   Reply With Quote
Old 30th July 2015, 12:32   #4674
Senior - BHPian
 
man_of_steel's Avatar
 
Join Date: Aug 2013
Location: BLR/TVM
Posts: 1,149
Thanked: 972 Times
Default Re: The KTM Duke 390 Ownership Experience Thread

Quote:
Originally Posted by MavericK46 View Post
Sudeep, when shall we head to Khivraj then?
This weekend itself? BTW, the momentary flash of zero occurs randomly and might not be able to reproduce the issue at SVC! how will they agree for a replacement in that case?
man_of_steel is offline   Reply With Quote
Old 30th July 2015, 12:58   #4675
BHPian
 
MavericK46's Avatar
 
Join Date: Jan 2009
Location: Bangalore
Posts: 135
Thanked: 103 Times
Default Re: The KTM Duke 390 Ownership Experience Thread

Quote:
Originally Posted by man_of_steel View Post
This weekend itself? BTW, the momentary flash of zero occurs randomly and might not be able to reproduce the issue at SVC! how will they agree for a replacement in that case?
Good question that...
I'm very sure that it cannot be reproduced on-demand. I've seen it happen 5 times in total; and am sure that it has happened several times without me noticing as well.

Anyone here who has had the speedo replaced for this reason and have experienced issues in getting the SVC to agree to a warranty-replacement?

Cheers !

Sundar
MavericK46 is offline   Reply With Quote
Old 30th July 2015, 15:08   #4676
BHPian
 
nasirkaka's Avatar
 
Join Date: Dec 2009
Location: Bangalore
Posts: 723
Thanked: 343 Times
Default Re: The KTM Duke 390 Ownership Experience Thread

Quote:
I think this is how the stator coil issue starts, and it's not a problem with the speedo. Now that I've replaced my coil, the speedo is functional again, where it used to intermittently go insane for indeterminate periods of time. The odo is unaffected though.
In my case, i rode the boke for 3 days from first when i observed speedo at zero. Will describe it in a bit of detail.

While going home from office, suddenly see the speedo at 0. As i switch off the headlight, the speedo comes back to life but only when bike it about 40kms +. on lower speeds, it again comes back to zero. When i switch on the headlight, even at higher speeds it remains at 0. next day, i get the LOW BATTERTY warning, and post about it here to learn that it could be a stator coil issue. Rode the bike for two more days, with similar kind of messages. Last night, when returning home, it constantly showed LOW BATTERY warning.

This morning left home for service station and as luck would have it, the bike died in the middle of traffic about 10 kms away from Service station. searched for a new battery in two excise shops without luck. Managed to persuade autoservice to send someone with spare battery. Replaced the battery and bike started. Left it at SS for coil replacement. Diagnostic tool at auto service showed the battery was not charging inspite of revving the bike. :(
nasirkaka is offline   Reply With Quote
Old 30th July 2015, 17:02   #4677
BHPian
 
RiderZone's Avatar
 
Join Date: Oct 2014
Location: Hyderabad
Posts: 121
Thanked: 157 Times
Default Re: The KTM Duke 390 Ownership Experience Thread

I know it doesn't logically add up how the stator coil could make the speedo go bonkers, but in my experience the issues are related. A friend of mine got the stator coil AND the speedo changed, while I only went with stator coil. Now both our bikes are functioning the same, speedo doesn't go to zero at will, and battery is charging properly. The only difference is that his odo says 00000 kms, and mine says 41000
RiderZone is offline   Reply With Quote
Old 31st July 2015, 15:50   #4678
BHPian
 
barcalad's Avatar
 
Join Date: Feb 2014
Location: New Delhi
Posts: 758
Thanked: 1,044 Times
Default Re: The KTM Duke 390 Ownership Experience Thread

Came across a very interesting sight today. At KTM SVC, Kirti Nagar.
Attached Thumbnails
The KTM Duke 390 Ownership Experience Thread-20150731_130816.jpg  

The KTM Duke 390 Ownership Experience Thread-20150731_130822.jpg  

barcalad is offline   Reply With Quote
Old 31st July 2015, 15:53   #4679
Senior - BHPian
 
SunnyBoi's Avatar
 
Join Date: Dec 2006
Location: Mysore / B'lore
Posts: 1,331
Thanked: 1,528 Times
Default Re: The KTM Duke 390 Ownership Experience Thread

Quote:
Originally Posted by barcalad View Post
Came across a very interesting sight today. At KTM SVC, Kirti Nagar.
Looks like someone got real upset due to the lack of center stand. Now I'm sure he doesnt need a stand any time
SunnyBoi is offline   (2) Thanks Reply With Quote
Old 31st July 2015, 15:57   #4680
BHPian
 
barcalad's Avatar
 
Join Date: Feb 2014
Location: New Delhi
Posts: 758
Thanked: 1,044 Times
Default Re: The KTM Duke 390 Ownership Experience Thread

Quote:
Originally Posted by SunnyBoi View Post
Looks like someone got real upset due to the lack of center stand. Now I'm sure he doesnt need a stand any time
Or rather got massively inspired by seeing the Bumblebee pictures in the Superbikes & Imports thread.

P.S - Note that there is a brick under the side stand.
barcalad is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
KTM Duke 390 - Accessories Thread sridhu Motorbikes 106 18th May 2016 17:15
Duke of Ram - My Orange Flame, KTM Duke 390. EDIT : Sold! hillram Motorbikes 65 13th May 2016 07:21
India made KTM Duke 390 & RC 390 to be sold in the USA Tushar Motorbikes 1 7th January 2015 13:59
My Flamberge (KTM Duke 390) Ownership report - A middle aged man's perspective sridhu Motorbikes 165 1st April 2014 07:46
KTM Duke 390 - 375cc, 45 PS, 150 kg djay99 Motorbikes 620 25th June 2013 12:45


All times are GMT +5.5. The time now is 05:40.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks