Go Back   Team-BHP > BHP India > Team-BHP Reviews > Official New Car Reviews


Reply
 
Thread Tools Search this Thread
Old 17th November 2013, 08:13   #1816
Distinguished - BHPian
 
condor's Avatar
 
Join Date: Jun 2006
Location: Speed-brkr City
Posts: 9,812
Thanked: 2,920 Times
Default Re: Tata Safari Storme : Official Review

@storme'd - that should be fine.
Quote:
Originally Posted by J.Ravi View Post
900. My Linea's and Thunderbird 500's idling RPM is 900. Even my previous vehicles, MS Versa/Omni had the same idling RPM.
Thanks, but not quite so. 900 is not sacrosanct. It can & will be different across vehicles.
condor is online now   Reply With Quote
Old 17th November 2013, 12:11   #1817
Senior - BHPian
 
narayan's Avatar
 
Join Date: Aug 2006
Location: chennai
Posts: 2,585
Thanked: 798 Times
Default Re: Tata Safari Storme : Official Review

Just checked -- its more like 750-800rpm
narayan is online now   (1) Thanks Reply With Quote
Old 17th November 2013, 16:54   #1818
BHPian
 
Join Date: Jan 2013
Location: New Delhi
Posts: 171
Thanked: 54 Times
Default

An earlier problem has resurfaced. I had got my Alpine system changed within 1 month of buying the truck as the USB stopped working properly. Since last week whenever I plug the USB in, it keeps saying searching but doesn't play anything. Has anyone faced a similar problem? Need help please.
storme'd is offline   Reply With Quote
Old 17th November 2013, 20:14   #1819
BHPian
 
stormerider's Avatar
 
Join Date: May 2013
Location: Pink City
Posts: 334
Thanked: 471 Times
Default

Quote:
Originally Posted by storme'd View Post
An earlier problem has resurfaced. I had got my Alpine system changed within 1 month of buying the truck as the USB stopped working properly. Since last week whenever I plug the USB in, it keeps saying searching but doesn't play anything. Has anyone faced a similar problem? Need help please.
Happens sometimes. Easiest fix is to take out the drive, connect to a computer and add a folder with some more songs.
This basically changes the no of songs and hence the indexing. Works for me, try yourself.
stormerider is offline   (1) Thanks Reply With Quote
Old 17th November 2013, 20:42   #1820
BHPian
 
Join Date: Jan 2013
Location: New Delhi
Posts: 171
Thanked: 54 Times
Default

Quote:
Originally Posted by stormerider View Post
Happens sometimes. Easiest fix is to take out the drive, connect to a computer and add a folder with some more songs. This basically changes the no of songs and hence the indexing. Works for me, try yourself.
Isint it a more serious problem than that? This USB is recognised in all other mediums!
storme'd is offline   Reply With Quote
Old 17th November 2013, 20:51   #1821
BHPian
 
NST440's Avatar
 
Join Date: May 2010
Location: Jalandhar
Posts: 179
Thanked: 156 Times
Default

Quote:
Originally Posted by storme'd View Post
Isint it a more serious problem than that? This USB is recognised in all other mediums!
I faced similar issues this is common with many alpines. Finally I changed my head unit and I am very happy since that day. Moreover this model does not support playback via bt and not suitable for bigger set up due to lesser pre outs. Now I usually get call from the one to whom I sold the HU regarding USB not working lol.
NST440 is offline   (1) Thanks Reply With Quote
Old 17th November 2013, 21:38   #1822
BHPian
 
Join Date: Jan 2013
Location: New Delhi
Posts: 171
Thanked: 54 Times
Default

Quote:
Originally Posted by NST440 View Post
I faced similar issues this is common with many alpines. Finally I changed my head unit and I am very happy since that day. Moreover this model does not support playback via bt and not suitable for bigger set up due to lesser pre outs. Now I usually get call from the one to whom I sold the HU regarding USB not working lol.
How much did you manage to sell it off for? Also which head unit are you using urgently and what were the damages? Poor chap got stuck with the bad Alpine :(
storme'd is offline   Reply With Quote
Old 17th November 2013, 22:13   #1823
BHPian
 
stormerider's Avatar
 
Join Date: May 2013
Location: Pink City
Posts: 334
Thanked: 471 Times
Default

Quote:
Originally Posted by storme'd View Post
Isint it a more serious problem than that? This USB is recognised in all other mediums!
Never thought of it that way. Once you plug the drive in computer and do as I say, you can again connect to your alpine unit.
A similar problem had occurred in my Sony 4.1 channel speaker system at home almost an year back and the service station had helped me out with this solution saying its pen drives problem and not of the system. Happens because of unsafe ejects.
stormerider is offline   (1) Thanks Reply With Quote
Old 17th November 2013, 22:31   #1824
BHPian
 
NST440's Avatar
 
Join Date: May 2010
Location: Jalandhar
Posts: 179
Thanked: 156 Times
Default

Quote:
Originally Posted by storme'd View Post
How much did you manage to sell it off for? Also which head unit are you using urgently and what were the damages? Poor chap got stuck with the bad Alpine :(
Sold it for 6500, if it would have been a retailer it would ve gone max for 3k thats the max quote I got from the accessory shops.

I am fond of good & clear sound so had an audiophilic set up. My HU which I purchased after lot of research is JVC kd-r 926 bt. It has more than I needed like dsp, time alignment, gold presets and a superb output. Heres the link and above all, it plays lossless files. wav format directly via USB.

http://jvc.co.in/car/cd_receiver/kd-r926bt/

Last edited by NST440 : 17th November 2013 at 22:36. Reason: posting of link to the audio player
NST440 is offline   (1) Thanks Reply With Quote
Old 21st November 2013, 13:30   #1825
BHPian
 
Join Date: Jan 2013
Location: New Delhi
Posts: 171
Thanked: 54 Times
Default

Took my truck for some brake work today; just got a call that the front shockers are leaking and are being replaced under some retro fitment. That too in a car run only 10K Kms. This apart, I love it.
storme'd is offline   Reply With Quote
Old 21st November 2013, 18:58   #1826
BHPian
 
kaviprem's Avatar
 
Join Date: Feb 2010
Location: Bangalore
Posts: 753
Thanked: 427 Times
Default Re: Tata Safari Storme : Official Review

Quote:
Originally Posted by storme'd View Post
Took my truck for some brake work today; just got a call that the front shockers are leaking and are being replaced under some retro fitment. That too in a car run only 10K Kms. This apart, I love it.
I dont hate other "reputed/bullet proof" brands, but, every brand and its new vehicle goes through this.

Honestly, almost all, including the brands like Toyota/Honda goes through these kind of updates/changes. Its just that those are neither discussed nor commented/criticized like these. So, nothing to worry as long the brand takes the responsibility and does it for the customer.

Prem.
kaviprem is offline   Reply With Quote
Old 21st November 2013, 19:15   #1827
Distinguished - BHPian
 
condor's Avatar
 
Join Date: Jun 2006
Location: Speed-brkr City
Posts: 9,812
Thanked: 2,920 Times
Default Re: Tata Safari Storme : Official Review

Quote:
Originally Posted by storme'd View Post
Took my truck for some brake work today; just got a call that the front shockers are leaking and are being replaced under some retro fitment. That too in a car run only 10K Kms. This apart, I love it.
@Storme'd, this replacement is being done for quite sometime. From what I know, many Storme's have had this replacement done under wty. Nothing to worry ..
condor is online now   (1) Thanks Reply With Quote
Old 21st November 2013, 21:51   #1828
BHPian
 
Join Date: Jan 2013
Location: New Delhi
Posts: 171
Thanked: 54 Times
Default

Quote:
Originally Posted by condor View Post
@Storme'd, this replacement is being done for quite sometime. From what I know, many Storme's have had this replacement done under wty. Nothing to worry ..
Would there be a possibility of alignment or balancing getting spoilt due to this activity? While driving the truck back, I found the steering tilting to the left.
storme'd is offline   Reply With Quote
Old 21st November 2013, 21:59   #1829
BHPian
 
Join Date: Nov 2013
Location: Somewhere India
Posts: 85
Thanked: 73 Times
Default Re: Tata Safari Storme : Official Review

I went for a short TD of Safari Storme. As I already own a Safari, these are my experiences -
1. Feels way better built. Doors close with a nice thud
2. Engine is much like the older safari. Just feels a bit more refined and all the vibrations gone
3. Front Looks Good, Back not to my taste, miss the back tyre.
4. Handles and Drives really well. Very Mature ride and Handling. Loved it. The perfect balance of sportiness and comfort and turning radius is unbelievably small
5. Quality of materials used it much much better than XUV and Scorpio.
6. The Speedo Dial looks too similar to the old Safari.
7. Gear Ratios are perfectly tweaked. Should munch miles easy.
8.The sitting position is very commanding and comfortable at the same time. Love it.
9. They changed the front seats to a harder material. Not sofa like anymore.A good thing because mine have already sagged.

To the negatives
1. Tata should have changed the panels and the shape
2. Car could have been a bit wider. the Stance is tall and narrow which is not to my liking.
3. Engine though good is not peppy like scorpio or XUV. I do missed the turbo surge from the old safari.
4. It needs wider tires. 255 would probably have been better.

Would I buy it -
If i was going to shop in this segment, I would buy it with my eyes closed. Even though its way way way better than the last Safari but my heart and mind wouldnt let me upgrade from the older one to new one. For me Safari is a pretty tested Car. Mine has run over 1 lac km and has seen serious offroad too. Still going strong. So I would recommend it in this segment. I went in for a test drive because i wanted to change. Will probably wait for the Automatic Variant of the Safari as I dont want another manual car.
V12Doc is offline   (4) Thanks Reply With Quote
Old 21st November 2013, 22:45   #1830
BHPian
 
maglev's Avatar
 
Join Date: Nov 2008
Location: New Delhi
Posts: 752
Thanked: 69 Times
Default Re: Tata Safari Storme : Official Review

Quote:
Originally Posted by storme'd View Post
Would there be a possibility of alignment or balancing getting spoilt due to this activity? While driving the truck back, I found the steering tilting to the left.
Any suspension work entails an alignment check, my guess is that the operating mechanic failed to report it or the SA did not test drive the vehicle himself.
maglev is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tata Safari Storme 4x4 : Official Review tsk1979 Official New Car Reviews 198 26th November 2015 19:02


All times are GMT +5.5. The time now is 11:40.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks