Go Back   Team-BHP > BHP India > Team-BHP Reviews > Official New Car Reviews


Reply
 
Thread Tools Search this Thread
Old 18th December 2013, 22:31   #1906
Senior - BHPian
 
n.devdath's Avatar
 
Join Date: Jun 2009
Location: Bangalore
Posts: 3,482
Thanked: 1,064 Times
Default Re: Tata Safari Storme : Official Review

Quote:
Originally Posted by ebonho View Post
Investigated how? What do you suggest?
Try to ask SAs if these failures are common. If possible, get your failed shock absorbers taken to a local mechanic who can disassemble them see the reason for the leak. A bent shaft, extra oil, a malfitted 'O' ring etc. If all of them have the same reason, you know the culprit, else start by eliminating the causes one by one.
Tedious? Yes.
Worth the effort? Depends on the amount of passion you have.

Quote:
Originally Posted by condor View Post
Hey - I smell a journalist around here

Quote:
Originally Posted by stormerider View Post
I mean I can literally push my storme with handbrake locked.
Handbrakes are not very effective on a lot of vehicles. However, the remedy is easy. A well lubricated cable, and proper adjustment at the lever and at the wheels.
Quote:
Originally Posted by neel385 View Post
Got my beast home today! Loved the 350 Km drive from the dealer to my place. The truck does have a smooth ride!
Congratulations..!!
Which version/color? Please start your own ownership thread if you have the time for it.
Quote:
Originally Posted by 4x4addict View Post
Hasn't this been Tata's story for a while now?
This is common to TML & M&M Tini.

Look at the Scorpio or the XUV issues thread. There are a lot of issues there as well. In fact, I m yet to notice any serious issues with the Storme when I look at the XUV issues that people have been facing.
n.devdath is offline   (1) Thanks Reply With Quote
Old 18th December 2013, 22:48   #1907
Distinguished - BHPian
 
4x4addict's Avatar
 
Join Date: Nov 2007
Location: Chennai
Posts: 3,727
Thanked: 1,912 Times
Default Re: Tata Safari Storme : Official Review

Quote:
Originally Posted by n.devdath View Post

This is common to TML & M&M Tini.
I am afraid that if I reply in detail, this thread will take a whole new turn , but generally yes, both face it, but I guess the difference is in what components fail, how often it fails, and time taken by the manufacturer to react and rectify the issue.
4x4addict is offline   Reply With Quote
Old 18th December 2013, 22:51   #1908
Senior - BHPian
 
ebonho's Avatar
 
Join Date: Feb 2010
Location: Pune
Posts: 3,942
Thanked: 3,170 Times
Default Re: Tata Safari Storme : Official Review

Quote:
Originally Posted by n.devdath View Post
Try to ask SAs if these failures are common. If possible, get your failed shock absorbers taken to a local mechanic who can disassemble them see the reason for the leak. A bent shaft, extra oil, a malfitted 'O' ring etc. If all of them have the same reason, you know the culprit, else start by eliminating the causes one by one.
Tedious? Yes.
Worth the effort? Depends on the amount of passion you have.
Bro, I don't know of a single company, car or bike, that makes replacements in warranty (FOC), and allows the customer to go home with the defective parts replaced. Please correct me if I am wrong.
ebonho is offline   Reply With Quote
Old 18th December 2013, 23:28   #1909
BHPian
 
stormerider's Avatar
 
Join Date: May 2013
Location: Pink City
Posts: 334
Thanked: 471 Times
Default

Quote:
Originally Posted by n.devdath View Post

Handbrakes are not very effective on a lot of vehicles. However, the remedy is easy. A well lubricated cable, and proper adjustment at the lever and at the wheels.
thanks for the advice, will try to convince the sa's who have a standard reply- all stormes have this problem, even arias also! Somehow this wasn't the problem with my brothers 3l dicor which was even heavier. Pulling the lever requires almost similar effort in storme and dicor, and ladies cannot do that unless you get some from wrestling field!

But I believe the problem is a bit deeper as one of the mechanics explained with whom I had a small chat regarding the handbrake. According to him, handbrake depends upon drum assembly in most cars as secondary brake. Whereas in aria/storme it is working with discs.
Correct me if this is wrong.

Last edited by stormerider : 18th December 2013 at 23:32.
stormerider is offline   (2) Thanks Reply With Quote
Old 19th December 2013, 11:03   #1910
Senior - BHPian
 
n.devdath's Avatar
 
Join Date: Jun 2009
Location: Bangalore
Posts: 3,482
Thanked: 1,064 Times
Default Re: Tata Safari Storme : Official Review

Quote:
Originally Posted by stormerider View Post
According to him, handbrake depends upon drum assembly in most cars as secondary brake. Whereas in aria/storme it is working with discs.
Well, the Storme and the Aria are not the only SUVs with discs up rear and without a drum assembly as a secondary brake assembly. Also, activating the brake (hand or otherwise) is easier on a disc set up because of the hydraulic pressure that multiplies the effort applied.

I feel it is a problem with either brake cable not transmitting enough power to the brake pads or too much free play in the brake cable/lever.

Quote:
Originally Posted by 4x4addict View Post
but generally yes, both face it, but I guess the difference is in what components fail, how often it fails, and time taken by the manufacturer to react and rectify the issue.
To me (we may differ here), today, TML is better than M&M, especially after the XUV gala that their customers have faced, and, the XUV has had far serious component failures than the Storme, till date.


Quote:
Originally Posted by ebonho View Post
Bro, I don't know of a single company, car or bike, that makes replacements in warranty (FOC), and allows the customer to go home with the defective parts replaced. Please correct me if I am wrong.
Investigation is not easy you know.

Last edited by n.devdath : 19th December 2013 at 11:08.
n.devdath is offline   Reply With Quote
Old 19th December 2013, 13:07   #1911
Senior - BHPian
 
ebonho's Avatar
 
Join Date: Feb 2010
Location: Pune
Posts: 3,942
Thanked: 3,170 Times
Default Re: Tata Safari Storme : Official Review

Quote:
Originally Posted by n.devdath View Post
Investigation is not easy you know.
Agreed. That's why I would rather place my faith into someone with the expertise, resources, and means of redressal all under one roof, and leave them to take care of it. That's what I have paid 12.5 lacs for.
ebonho is offline   Reply With Quote
Old 19th December 2013, 18:46   #1912
BHPian
 
sasi405's Avatar
 
Join Date: Sep 2007
Location: Gurgaon
Posts: 258
Thanked: 162 Times
Default

A TD vehicle (Storme) that had run 25K km had all the doors making sone sort of rattling noise (even my 30K i10 also makes similar noise). What's usually the remedy? I don't think its the doors themselves, but the plastic panelling / door pads. Anyone with 25K+ odo on the Storme faced such rattling?
sasi405 is offline   Reply With Quote
Old 21st December 2013, 16:08   #1913
Senior - BHPian
 
ebonho's Avatar
 
Join Date: Feb 2010
Location: Pune
Posts: 3,942
Thanked: 3,170 Times
Default Re: Tata Safari Storme : Official Review

BLUETOOTH MOBILE CALLING/RECEIVING WOES

As some of you know, off late I have been facing continuing problem with my
Bluetooth connected to the OE Alpine HU fitted in my Safari Storme EX.

This is a repeat problem, and the guys at the TASS have simply not been able to get to the bottom of it.

A long time back, some modular (receiver?) unit was found faulty and ordered
from Alpine and replaced in my car, along with batteries in my Remote which was
also not working at the time.

Since that time I have never had issues with making and receiving
phone calls via the Alpine Bluetooth, till recently.

Now neither is the remote working, nor is the Bluetooth. I can
make and receive calls, but the person at the other end cannot hear my voice.

Sometimes the Bluetooth works, but as has been experienced by the TASS guys and others also, there is a lot of static and disturbance heard on the line by the other person and/or my voice also cannot be clearly heard. This is those few times when they CAN at least hear my voice.

Other (most) times the person at the other end cannot hear anything (keeps saying hello, hello ....), even though I myself can hear him clearly inside the car.

On repeatedly bringing this to the notice of the TASS guys (as well as the TATA RSM), I am told that this is a problem they have encountered with Nokia phones. Nothing to do with the ALPINE system. Their solution being to try my system with another mobile (of another brand).

If such is the case, then how was this problem not seen earlier, and why am I facing this problem now? Since I have been using my Nokia phone for as long as I have had the Storme?

Frustratingly, as is often the case, when the TASS guys looked into this issue and came to drop off my car and asked me to check the Bluetooth, it worked perfectly. But immediately the same day, while going home and even on reaching home, the same problem happened when someone called me, and then called him back to reconfirm.

Added to this is the issue that the ALPINE guys cannot come to the TASS workshop to examine my car thoroughly and get to the root of the problem, due to a shortage of staff at their end for Pune region (which is a big region). So the only solution is for the TASS guys to take my car to the ALPINE center near Law College Road, which is a congested mess during peak hours, not to mention a 100 km round trip from the TASS which is outside city limits.

Please help guys. This is bugging me no end, and sounds like such a sill small thing which is why I am surprised they have not been able to sove it.

@BEHRAM DHABAR - sir could you please tell me (by PM/phone if necessary) what I should do to get this issue resolved?
ebonho is offline   Reply With Quote
Old 21st December 2013, 16:25   #1914
Senior - BHPian
 
n.devdath's Avatar
 
Join Date: Jun 2009
Location: Bangalore
Posts: 3,482
Thanked: 1,064 Times
Default Re: Tata Safari Storme : Official Review

Quote:
Originally Posted by ebonho View Post
Now neither is the remote working, nor is the Bluetooth. I can
make and receive calls, but the person at the other end cannot hear my voice.

Sometimes the Bluetooth works, but as has been experienced by the TASS guys and others also, there is a lot of static and disturbance heard on the line by the other person and/or my voice also cannot be clearly heard. This is those few times when they CAN at least hear my voice.

Other (most) times the person at the other end cannot hear anything (keeps saying hello, hello ....), even though I myself can hear him clearly inside the car.
This seems to be a loose connection or a faulty microphone at your end. Has this been checked?

Also, in accordance with what TML says, did you try making a call after pairing another mobile phone to your ICE which was not made by Nokia?
n.devdath is offline   Reply With Quote
Old 21st December 2013, 16:50   #1915
Senior - BHPian
 
ebonho's Avatar
 
Join Date: Feb 2010
Location: Pune
Posts: 3,942
Thanked: 3,170 Times
Default Re: Tata Safari Storme : Official Review

Quote:
Originally Posted by n.devdath View Post
This seems to be a loose connection or a faulty microphone at your end. Has this been checked?
I did think of this and had asked them to check. No idea whether they did. Hope its something so simple/minor.

Quote:
Also, in accordance with what TML says, did you try making a call after pairing another mobile phone to your ICE which was not made by Nokia?
Honestly no I have not. Will try with my wife's Samsung. Though convincing her to let me use it for a couple of days' truck trial purposes is going to be a challenge I do not relish .....
ebonho is offline   Reply With Quote
Old 21st December 2013, 17:17   #1916
BHPian
 
stormerider's Avatar
 
Join Date: May 2013
Location: Pink City
Posts: 334
Thanked: 471 Times
Default Re: Tata Safari Storme : Official Review

Quote:
Originally Posted by n.devdath View Post
This seems to be a loose connection or a faulty microphone at your end. Has this been checked?

Also, in accordance with what TML says, did you try making a call after pairing another mobile phone to your ICE which was not made by Nokia?
Quote:
Originally Posted by ebonho View Post
I did think of this and had asked them to check. No idea whether they did. Hope its something so simple/minor.



Honestly no I have not. Will try with my wife's Samsung. Though convincing her to let me use it for a couple of days' truck trial purposes is going to be a challenge I do not relish .....
No need to, I have paired my iphone4, my wife's bold4 and iphone5, nokia e63, Micromax canvas hd to name a few and have similar issue.
Probably all companies don't know how to make phones! Also checked the connection, it is not loose.
stormerider is offline   (1) Thanks Reply With Quote
Old 21st December 2013, 17:21   #1917
Senior - BHPian
 
n.devdath's Avatar
 
Join Date: Jun 2009
Location: Bangalore
Posts: 3,482
Thanked: 1,064 Times
Default Re: Tata Safari Storme : Official Review

Quote:
Originally Posted by stormerider View Post
Probably all companies don't know how to make phones! Also checked the connection, it is not loose.
Oh, so are you facing the same problem in your Storme?
What does the dealer say and what steps have been taken so far?

It could also be different issues with different vehicles though.
n.devdath is offline   Reply With Quote
Old 21st December 2013, 17:33   #1918
Senior - BHPian
 
ebonho's Avatar
 
Join Date: Feb 2010
Location: Pune
Posts: 3,942
Thanked: 3,170 Times
Default Re: Tata Safari Storme : Official Review

Quote:
Originally Posted by stormerider View Post
No need to, I have paired my iphone4, my wife's bold4 and iphone5, nokia e63, Micromax canvas hd to name a few and have similar issue.
Probably all companies don't know how to make phones! Also checked the connection, it is not loose.
How can we escalate this issue bro?

I have a feeling I am being tossed to and fro between TASS and TATA on this (because 1 they have no idea what's happening and 2 it does not happen when they are around), and if ALPINE also puts its hands up and says its phone's fault, then I have to change my phone.

Then if it again happens with new phone/different brand, are they going to extend "phone fault" to that phone model/brand as well?
ebonho is offline   Reply With Quote
Old 21st December 2013, 23:36   #1919
BHPian
 
smsrini's Avatar
 
Join Date: Sep 2007
Location: Bangalore
Posts: 959
Thanked: 213 Times
Default

Quote:
Originally Posted by ebonho View Post

How can we escalate this issue bro?

I have a feeling I am being tossed to and fro between TASS and TATA on this (because 1 they have no idea what's happening and 2 it does not happen when they are around), and if ALPINE also puts its hands up and says its phone's fault, then I have to change my phone.

Then if it again happens with new phone/different brand, are they going to extend "phone fault" to that phone model/brand as well?
Did you upgrade the phone firmware recently? If yes that could be the cause. Check the compatibility of your phone firmware with the Alpine units Bluetooth version.
smsrini is online now   (1) Thanks Reply With Quote
Old 22nd December 2013, 11:10   #1920
Senior - BHPian
 
narayan's Avatar
 
Join Date: Aug 2006
Location: chennai
Posts: 2,586
Thanked: 798 Times
Default Re: Tata Safari Storme : Official Review

Guys - very urgent. Found a fuse with 15 marking in th driver foot well. Since then the central locking stopped working and the hazard lights are on. Pls help !
narayan is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tata Safari Storme 4x4 : Official Review tsk1979 Official New Car Reviews 198 26th November 2015 19:02


All times are GMT +5.5. The time now is 06:09.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks