Go Back   Team-BHP > BHP India > Team-BHP Reviews > Official New Car Reviews


Reply
 
Thread Tools Search this Thread
Old 29th December 2014, 09:34   #8446
Senior - BHPian
 
wilful's Avatar
 
Join Date: Oct 2007
Location: cochin
Posts: 1,022
Thanked: 718 Times
Default Re: Ford EcoSport : Official Review

I don't know if this is of help but I've been resetting my average speed display each time I fill up the tank. Thus far, my average speed in town has been hovering around the 22 kmph mark and my average consumption has been around 8 kpl. I am neither disappointed nor elated by this figure because my earlier Honda City AT gave me similar kind of figures - as did the one prior to that (maybe half a kml more). I took on a mix of NH and state highway last weekend - did a trip of around 175 kms - and checked out the averages - 34 kmph and a fuel consumption of 11.8 kpl.
(Have done around 1600 kms to date)
wilful is offline   Reply With Quote
Old 29th December 2014, 14:13   #8447
AAD
BHPian
 
Join Date: Dec 2011
Location: Mumbai
Posts: 85
Thanked: 119 Times
Default Re: Ford EcoSport : Official Review

Quote:
Originally Posted by roy_libran View Post
I do too, although the judder is quite faint. My SA is also clueless. Moreover, the judder isn't consistent. I failed to repeat it consistently in front of the Service Advisor(s). From what I have observed, this judder is always between gears 1 and 2.
That's correct Roy. Thanks for confirming what I have been experiencing & glad to know that I am not the only one.

The earlier automatics that I owned including Honda City 1999 & 2007 version + Hyuandai i10 never exhibited such behaviour. Is it something to do with the PowerShift Gearbox (Ford's answer to DSG Gearboxes)?

I plan to escalate this matter further to Ford and have the same resolved as I am sure this judder is not normal. Will keep this post updated.
AAD is offline   Reply With Quote
Old 29th December 2014, 14:46   #8448
BHPian
 
roy_libran's Avatar
 
Join Date: Dec 2009
Location: Ghaziabad
Posts: 966
Thanked: 648 Times
Default Re: Ford EcoSport : Official Review

Quote:
Originally Posted by AAD View Post

I plan to escalate this matter further to Ford and have the same resolved as I am sure this judder is not normal. Will keep this post updated.
Hi,

If you are willing to escalate this to Ford, I would like to join your escalation. Kindly PM me on what details you would require from my side.

Thanks,
Roy
roy_libran is offline   Reply With Quote
Old 29th December 2014, 15:24   #8449
BHPian
 
civic-sense's Avatar
 
Join Date: Dec 2009
Location: Bangalore
Posts: 601
Thanked: 535 Times
Default Re: Ford EcoSport : Official Review

Quote:
Originally Posted by AAD View Post
That's correct Roy. Thanks for confirming what I have been experiencing & glad to know that I am not the only one.

The earlier automatics that I owned including Honda City 1999 & 2007 version + Hyuandai i10 never exhibited such behaviour. Is it something to do with the PowerShift Gearbox (Ford's answer to DSG Gearboxes)?

I plan to escalate this matter further to Ford and have the same resolved as I am sure this judder is not normal. Will keep this post updated.
I am not sure if we are talking about the same thing, but I experience this shudder some times. It looks like, the shudder is due to the car being on a higher gear than what it should be ideally. It is akin to the one in manual cars, if you don't downshift at slow speeds. It, I guess, is because Ford has tuned the transmission shift timings for better mileage.

I never had it in my Civic. Probably because the Civic and the others mentioned above have a torque converter autobox.
civic-sense is offline   Reply With Quote
Old 29th December 2014, 16:00   #8450
BHPian
 
Naman_Ferrari's Avatar
 
Join Date: Apr 2014
Location: Bangalore
Posts: 95
Thanked: 38 Times
Default Re: Ford EcoSport : Official Review

Hey guys!!
I have a small problem with my Ecosport.
The SYNC bluetooth does not work properly with my iPhone.
Anyone knows how I can fix this?
Thanks in advance...
Naman_Ferrari is offline   Reply With Quote
Old 29th December 2014, 16:42   #8451
AAD
BHPian
 
Join Date: Dec 2011
Location: Mumbai
Posts: 85
Thanked: 119 Times
Default Re: Ford EcoSport : Official Review

Quote:
Originally Posted by civic-sense View Post
I am not sure if we are talking about the same thing, but I experience this shudder some times. It looks like, the shudder is due to the car being on a higher gear than what it should be ideally. It is akin to the one in manual cars, if you don't downshift at slow speeds. It, I guess, is because Ford has tuned the transmission shift timings for better mileage.

I never had it in my Civic. Probably because the Civic and the others mentioned above have a torque converter autobox.
What you say, does make sense. I will check if I am able to simulate the same judder in manual mode.
AAD is offline   Reply With Quote
Old 29th December 2014, 16:49   #8452
BHPian
 
Join Date: Apr 2013
Location: Mumbai
Posts: 127
Thanked: 91 Times
Default Re: Ford EcoSport : Official Review

Quote:
Originally Posted by civic-sense View Post
I am not sure if we are talking about the same thing, but I experience this shudder some times. It looks like, the shudder is due to the car being on a higher gear than what it should be ideally. It is akin to the one in manual cars, if you don't downshift at slow speeds. It, I guess, is because Ford has tuned the transmission shift timings for better mileage.

I never had it in my Civic. Probably because the Civic and the others mentioned above have a torque converter autobox.
Even I experience the same on inclines and on slow speeds where it feels like lugging the engine. I started noticing it only after 10000 KM service. I think the culprit may be the engine oil. Ford may be using some other Oil in production (5W-30 as recommended in the manual) but service station guys used Castrol 10W-30.
Count me in for raising this with Ford.
TSIched'Out is offline   Reply With Quote
Old 29th December 2014, 17:12   #8453
BHPian
 
peterjim13's Avatar
 
Join Date: May 2014
Location: Kochi/S.Bathery
Posts: 381
Thanked: 249 Times
Default Re: Ford EcoSport : Official Review

Quote:
Originally Posted by ramzsys View Post
Do they(ford service) do headlight focus adjustment job as a part of scheduled service?

If so, a feedback of the same is awaited!
Thanks for this question. I have been having quite trouble with adjusting my headlamps. Earlier they were aligned to right and last time I had asked them to do some corrections and now its to the left.

As I do a lot of night drives through ghats, it is really difficult.

The whole thing looks normal in about a meter or more , but we can feel the ligthing issue only about 10 or more meters ahead. the light is actually focusing towards one corner and Ford service guys are not able to fix it as yet. My 20K service has been scheduled for next week and need to get this done on top priority.
peterjim13 is offline   Reply With Quote
Old 29th December 2014, 17:30   #8454
Distinguished - BHPian
 
4x4addict's Avatar
 
Join Date: Nov 2007
Location: Chennai
Posts: 3,731
Thanked: 1,937 Times
Default

My Sync is unable to continue playing the USB from where I turned off the car. It starts playing from the first song each time. Only Rarely does it start from the last song played. I am using a 16 GB compact usb . I wonder if Sync has a problem with 16 GB.
4x4addict is offline   Reply With Quote
Old 29th December 2014, 18:09   #8455
BHPian
 
peterjim13's Avatar
 
Join Date: May 2014
Location: Kochi/S.Bathery
Posts: 381
Thanked: 249 Times
Default Re: Ford EcoSport : Official Review

Taking my car for the 20K service next week.

1. How much will the average bill be for the 20K service.

2. It also looks like I might need some major fix on my infotainment unit, my USB does not read my Ipod or any other USB now. Sync automatically disconnected my phones a few times last month. The tracks while being played get a second break, all this in the past one month.
My Ipod and USBs works well in my XUV, so i think the issue is with My ecosport infotainment. Can I get this repaired or replaced without any cost as it is still within 1 year of delivery ?

3. While on handbrake, I hear a scary metal cranking noise from somewhere under the second row seats ? Is this is a known issue ?

4. There was a noise from somewhere behing the steering, probably around front right suspension which is usually heard when the car sways to the left on road. This was there when I got it delivered last Jan, it started coming off again a few weeks back. Last time it was due to some screw which needed some more tightening.

5. Obviously Headlamp alignment. I had upgraded mine to Philips Xtreme Vision +90%. During my high range drives, long drives etc i think I need more lighting, Does anyone suggest any extra off road lighting, like the ones we see on Off road Thars ??
peterjim13 is offline   Reply With Quote
Old 29th December 2014, 18:19   #8456
BHPian
 
civic-sense's Avatar
 
Join Date: Dec 2009
Location: Bangalore
Posts: 601
Thanked: 535 Times
Default Re: Ford EcoSport : Official Review

Quote:
Originally Posted by TSIched'Out View Post
Even I experience the same on inclines and on slow speeds where it feels like lugging the engine. I started noticing it only after 10000 KM service. I think the culprit may be the engine oil. Ford may be using some other Oil in production (5W-30 as recommended in the manual) but service station guys used Castrol 10W-30.
Count me in for raising this with Ford.
I can confirm that I had this even with the original engine oil it came with, so the oil cannot be at fault here.

Moreover this shudder is very small and happens only occasionally. I think it could be ignored.
Quote:
Originally Posted by 4x4addict View Post
My Sync is unable to continue playing the USB from where I turned off the car. It starts playing from the first song each time. Only Rarely does it start from the last song played. I am using a 16 GB compact usb . I wonder if Sync has a problem with 16 GB.
Does it start indexing again? For me sometimes, out of the blue, it starts indexing again and plays from the beginning.
civic-sense is offline   Reply With Quote
Old 29th December 2014, 18:24   #8457
Newbie
 
Join Date: Dec 2014
Location: Mumbai
Posts: 17
Thanked: 7 Times
Default

Quote:
Originally Posted by 4x4addict View Post
My Sync is unable to continue playing the USB from where I turned off the car. It starts playing from the first song each time. Only Rarely does it start from the last song played. I am using a 16 GB compact usb . I wonder if Sync has a problem with 16 GB.

I am using a 16gb myself , but haven't come across this. Mine does play from where I turned the car off

Try a different pendrive and see if the problem persists ?
girish.purswani is offline   Reply With Quote
Old 30th December 2014, 01:52   #8458
BHPian
 
johannskaria's Avatar
 
Join Date: Jul 2013
Location: MH 03 / KL 08
Posts: 596
Thanked: 1,124 Times
Default Re: Ford EcoSport : Official Review

A still from TopGear Special Patagonia part 2!
An EcoSport from Argentina.
Attached Thumbnails
Ford EcoSport : Official Review-patagonia-special-tg.jpg  

johannskaria is offline   (1) Thanks Reply With Quote
Old 30th December 2014, 07:57   #8459
Distinguished - BHPian
 
4x4addict's Avatar
 
Join Date: Nov 2007
Location: Chennai
Posts: 3,731
Thanked: 1,937 Times
Default

Quote:
Originally Posted by civic-sense View Post
Does it start indexing again? For me sometimes, out of the blue, it starts indexing again and plays from the beginning.
Yes, it periodically starts indexing again. Also noticed couple of times that climate control didn't also remember the last setting and started blowing hot air. I think there is some bug in the sync system. Typically Microsoft issues, I guess. Hope ford had just stuck with regular system and controls instead of sync.
4x4addict is offline   Reply With Quote
Old 30th December 2014, 09:17   #8460
ACM
Distinguished - BHPian
 
ACM's Avatar
 
Join Date: Mar 2008
Location: Mumbai
Posts: 4,061
Thanked: 2,193 Times
Default Re: Ford EcoSport : Official Review

Quote:
Originally Posted by 4x4addict View Post
Yes, it periodically starts indexing again. Also noticed couple of times that climate control didn't also remember the last setting and started blowing hot air. I think there is some bug in the sync system. Typically Microsoft issues, I guess. Hope ford had just stuck with regular system and controls instead of sync.
The ACC blowing hot air happens to me as well when I change back from defogging mode or if the outside temp like say in early mornings drops low and have internally kept the temp settings at say 24.

The indexing from start happens in my vehicle as well every now and then.
ACM is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Car for Parents: Hyundai Verna vs Ford EcoSport vs Ford Classic vs Maruti Ertiga iTNerd What Car? 60 12th October 2014 07:53
Ford EcoSport DIESEL Review GTO The Indian Car Scene 0 31st May 2013 11:51


All times are GMT +5.5. The time now is 03:46.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks