Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 8th May 2011, 00:05   #1
BHPian
 
BIBIN004's Avatar
 
Join Date: May 2007
Location: KL-31/KL-01
Posts: 108
Thanked: 190 Times
Default Electrical Issues after fitting Roots Spyder in Hyundai i10 Sportz

Hi guys,
I'm a newbie here.I have got an i10 Sportz here in Banaglore and had fitted a Roots Spyder horn 2 months back.Everything was fine for 2 months and recently my car is showing lots of electrical issues.To add to that...since the horns were not fitted properly there is a rattling sound which comes when the horn vibrates and touches the metal bit inside the bonnet.

I got deeply worried about this and went to Hyundai Advaith showroom in Bangalore (S.R. Road) seeking help, but no joy.The place from where I brought the horns in closed and I'm really worried.

Can someone please help me by letting me know a good place/contact in bangalore where I can get this rectified ?

As far as I remember the relay was also not fitted....

Any help would be really appreciated.
BIBIN004 is offline   Reply With Quote
Old 8th May 2011, 09:10   #2
Distinguished - BHPian
 
Join Date: May 2005
Location: KL
Posts: 4,680
Thanked: 3,507 Times
Default Re: Electrical Issues after fitting Roots Spyder in Hyundai i10 Sportz

The horn fittings issue can be sorted out by getting it tightened or re-locating it to another place. What electrical issues are you finding with the car? Are you sure relays were not fitted? Is the OE horn retained?
Sankar is offline   (1) Thanks Reply With Quote
Old 8th May 2011, 10:20   #3
Distinguished - BHPian
 
libranof1987's Avatar
 
Join Date: Sep 2010
Location: All over!
Posts: 3,722
Thanked: 2,809 Times
Default Re: Electrical Issues after fitting Roots Spyder in Hyundai i10 Sportz

Please mention the electrical issues the car is facing.

Also, where did you get the horn fitted from? From what you have mentioned, Hyundai can pretty well tell you that the warranty has been void.

If the OE horn is still there, I'd suggest you ask Advaith to remove the after-market one and continue using the OE one.

Whoever installed probably must've messed around with the connections at the battery.
libranof1987 is offline   (1) Thanks Reply With Quote
Old 8th May 2011, 17:32   #4
BHPian
 
BIBIN004's Avatar
 
Join Date: May 2007
Location: KL-31/KL-01
Posts: 108
Thanked: 190 Times
Default Re: Electrical Issues after fitting Roots Spyder in Hyundai i10 Sportz

Thanks guys for your response.

I went to "Sachin's Autoshop" in Koramangla today and told them about the problem in my car.Since I was a little hesitant to remove the after market horns (Roots Spyder), they suggested me to connect the after market ones directly without having a switch between the OE and the After Market one

They rewired everything properly but still the electrical issues seem to persist.

@Sankar :- Both the Hyundai as well as "Sachin auto Shop" guys told me that Relay is inbuilt for new vehicles and need not be added.

@Libran :- You are right.... they guys in Advaith told that they can do nothing about it.However I'm not sure if the guys in Advaith did not know how to check out the root cause for the electrical issue.

I got it fitted from a shop named CAR STOP in S.R. Nagar, Bangalore and the shop looks closed permanently...

I even suspected the battery and went to an EXIDE authorized showroom to ensure that it's not a battery issue.

Was wondering if there is no other solution for this problem since I'm sure I would not be the first one to Fit an after market horn in an i10 and may be face electrical issues

The issues that I see in my car are as follows:-

-> The HeadLight gets dim n bright alternately.
-> The indicator lights as well as reverse lamps also show a similiar pattern.
-> The indicator lights near the speedometer also dims n brightens alternately.
BIBIN004 is offline   Reply With Quote
Old 8th May 2011, 22:55   #5
Distinguished - BHPian
 
dhanushs's Avatar
 
Join Date: Oct 2009
Location: Bathery/BLR
Posts: 3,446
Thanked: 4,054 Times
Default Re: Electrical Issues after fitting Roots Spyder in Hyundai i10 Sportz

Quote:
Originally Posted by BIBIN004 View Post
... they suggested me to connect the after market ones directly without having a switch between the OE and the After Market one ...
So you now have only the Roots working?. Bibin, I would strongly suggest you to get a relay.
dhanushs is offline   (1) Thanks Reply With Quote
Old 8th May 2011, 23:07   #6
Distinguished - BHPian
 
SS-Traveller's Avatar
 
Join Date: Jan 2009
Location: New Delhi
Posts: 6,617
Thanked: 10,778 Times
Default Re: Electrical Issues after fitting Roots Spyder in Hyundai i10 Sportz

Quote:
Originally Posted by BIBIN004 View Post
@Sankar :- Both the Hyundai as well as "Sachin auto Shop" guys told me that Relay is inbuilt for new vehicles and need not be added.
That is usually right, but no idea whether that applies to the i20.

Quote:
Originally Posted by BIBIN004 View Post
The issues that I see in my car are as follows:-

-> The HeadLight gets dim n bright alternately.
-> The indicator lights as well as reverse lamps also show a similiar pattern.
-> The indicator lights near the speedometer also dims n brightens alternately.
You appear to have an alternator (rectifier) issue, and not something to do with the horns. The lights dimming while the car is running is due to a drop in output voltage from the alternator. This may have been caused by faulty handling of the electricals or a short circuit when the horns were fitted. Incidentally, has electrowelding been done on the car for any reason (such as fitting horn mounts or extra guards over the bumper)?
SS-Traveller is offline   (1) Thanks Reply With Quote
Old 10th May 2011, 07:39   #7
Distinguished - BHPian
 
Join Date: May 2005
Location: KL
Posts: 4,680
Thanked: 3,507 Times
Default Re: Electrical Issues after fitting Roots Spyder in Hyundai i10 Sportz

Quote:
Originally Posted by BIBIN004 View Post
@Sankar :- Both the Hyundai as well as "Sachin auto Shop" guys told me that Relay is inbuilt for new vehicles and need not be added.

Was wondering if there is no other solution for this problem since I'm sure I would not be the first one to Fit an after market horn in an i10 and may be face electrical issues

The issues that I see in my car are as follows:-

-> The HeadLight gets dim n bright alternately.
-> The indicator lights as well as reverse lamps also show a similiar pattern.
-> The indicator lights near the speedometer also dims n brightens alternately.
I have the OE horms replaced with Bosch aftermarket ones in my car, didn't use any extra relays. Everything works fine.

Roots Vibrosonic is installed in my Dad's i10 alongwith facotry horns. Used a two way switch and relay for this install. Its been two years and there are no problems.

The problems you have listed looks like its due to poor grounding or short circuit.

1) Check the connections at battery post, see if the terminals are tight and doesn't move, make sure if any extra wires connected to the terminals are secure.

2) Since you mentioned this started after horn installation look into how they're installed. Take it to a workshop and check if the horns are well tightened and doesn't move around. Check if the connectors are proper and if any wires stripped are properly insulated. If the fittings are loose the connecors might be grounding on the body if there's any movement.
Sankar is offline   (1) Thanks Reply With Quote
Old 10th May 2011, 14:07   #8
BHPian
 
BIBIN004's Avatar
 
Join Date: May 2007
Location: KL-31/KL-01
Posts: 108
Thanked: 190 Times
Default Re: Electrical Issues after fitting Roots Spyder in Hyundai i10 Sportz

@dhanush :- Since the guys were not confident about fitting a relay,I couldnot support them either.

@SS Traveller :- I have given the car back to Advaith again and asked them to check it for me once again.Lets c what findings they come up with.

@sankar :- Can you please tell me where in Kerala did you get that fixed since I would be taking my car back to kerala this weekend.


@ll :- thanks guys for helping me out......
BIBIN004 is offline   Reply With Quote
Old 10th May 2011, 16:08   #9
Distinguished - BHPian
 
Join Date: May 2005
Location: KL
Posts: 4,680
Thanked: 3,507 Times
Default Re: Electrical Issues after fitting Roots Spyder in Hyundai i10 Sportz

Quote:
Originally Posted by BIBIN004 View Post
@sankar :- Can you please tell me where in Kerala did you get that fixed since I would be taking my car back to kerala this weekend.
Hyundai authorised service centre. Popular Hyundai, Trivandrum
Sankar is offline   (1) Thanks Reply With Quote
Old 10th May 2011, 17:55   #10
BHPian
 
BIBIN004's Avatar
 
Join Date: May 2007
Location: KL-31/KL-01
Posts: 108
Thanked: 190 Times
Default Re: Electrical Issues after fitting Roots Spyder in Hyundai i10 Sportz

Heyy thanks guys.Just got a call from Advaith Hyundai.Happy News the issue is rectified finally.The grounding was improper when the wiring was done initially.
BIBIN004 is offline   Reply With Quote
Old 10th May 2011, 18:35   #11
Distinguished - BHPian
 
Join Date: May 2005
Location: KL
Posts: 4,680
Thanked: 3,507 Times
Default Re: Electrical Issues after fitting Roots Spyder in Hyundai i10 Sportz

Quote:
Originally Posted by BIBIN004 View Post
Heyy thanks guys.Just got a call from Advaith Hyundai.Happy News the issue is rectified finally.The grounding was improper when the wiring was done initially.
Glad that its sorted. I knew that there wouldn't be anything serious to worry about.

First thing to look when such symptoms occur, especially after electrical accessory installation, is for proper grounding and short circuit.
Sankar is offline   (1) Thanks Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hyundai i10 - Electrical Problems EDIT - New Issue (Page 2) blue_pulsar Technical Stuff 25 12th April 2015 14:03
Dad goes back to his roots after 40 years! MYB Travelogues 10 21st November 2012 13:14
Hyundai i10 AT Sportz - Hyundai Stock / Brand Value in the Eyes of a customer ACM Test-Drives & Initial Ownership Reports 16 18th November 2012 13:53
Bangalore - Tirunelveli: Back to my roots Ice Travelogues 33 14th November 2012 15:32
i10 Magna (1.2 Kappa) Vs i10 Sportz (1.2 Kappa) MutantX Hatchbacks 52 12th September 2010 00:55


All times are GMT +5.5. The time now is 19:55.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks