Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 25th February 2006, 11:53   #1
Senior - BHPian
 
cooldude1988765's Avatar
 
Join Date: Feb 2006
Location: Bangalore
Posts: 1,005
Thanked: 106 Times
Default WagonR problem

Hi everybody
I have a wagonR Which is 2.5 years old and has done 20k kms.Of late there has been a decrease in the performance of the car i.e the pick up has reduced and even for mild slopes i have to change to 1st gear.
I always give the car for servicing to Varun Motors at regular intervals.
I am in a fix as to what the problem could be.I fill speed petrol from a reputed BP outlet(I have been going to the same petrol bunk from the time i bought the car).I am filling speed from the past 1 year.Do you think the problem is due to the fuel? please help
cooldude1988765 is offline   Reply With Quote
Old 25th February 2006, 13:31   #2
Senior - BHPian
 
extreme_torque's Avatar
 
Join Date: Feb 2005
Location: Melbourne
Posts: 3,546
Thanked: 1,317 Times
Default

Finish the remaining petrol in the tank and fill from another outlet. If this doesnt help, clean the injectors. There is nothing much that can go worng with a MPFi car.... lest its something terrible.
extreme_torque is offline   Reply With Quote
Old 25th February 2006, 13:44   #3
BHPian
 
luv_bikelover's Avatar
 
Join Date: Feb 2006
Location: MUMBAI
Posts: 45
Thanked: 0 Times
Default

hi i too own a wogonr , my car hasnt given such kinda trouble but i guess check the injection system give it a clean and maybe fuel is problem so tyr filling premium speed for sometime else take a summary for a engine i dont think mpfi engines face this kind of problems
luv_bikelover is offline   Reply With Quote
Old 25th February 2006, 14:53   #4
SLK
Senior - BHPian
 
SLK's Avatar
 
Join Date: Feb 2004
Location: DL XX XX XXXX
Posts: 1,290
Thanked: 185 Times
Default

1st gear?.... then it 'should' be clogged injectors.
Better take it to Maruti Service Station.
SLK is offline   Reply With Quote
Old 25th February 2006, 16:00   #5
Senior - BHPian
 
cooldude1988765's Avatar
 
Join Date: Feb 2006
Location: Bangalore
Posts: 1,005
Thanked: 106 Times
Default

I dont have any doubt on the fuel because i have been filling there from many years even for my previous cars
cooldude1988765 is offline   Reply With Quote
Old 26th February 2006, 01:51   #6
Senior - BHPian
 
nitrous's Avatar
 
Join Date: May 2004
Location: UAE/Lon/Madras
Posts: 6,966
Thanked: 282 Times
Default

Get a tune-up for ur engine from a good garage in Hyd.
That must solve the problem.
nitrous is offline   Reply With Quote
Old 26th February 2006, 02:20   #7
BHPian
 
Join Date: Feb 2006
Location: New Delhi
Posts: 33
Thanked: 0 Times
Default

check engine oil, check spark plugs, and as everybody else mentioned get the injectors cleaned. i'm sure this should solve the problem.
abhishek2 is offline   Reply With Quote
Old 26th February 2006, 03:44   #8
Team-BHP Support
 
.anshuman's Avatar
 
Join Date: Dec 2004
Location: Good-Gaon
Posts: 7,714
Thanked: 9,000 Times
Default

the problem is definitely with the injectors or any of sensors malfunctioning,i had a jerking problem with my accent that was solved by cleaning the injectors.
.anshuman is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Maruti WagonR over Hyundai Eon? EDIT : Bought WagonR with ABS / Airbags BoneCollector Hatchbacks 35 22nd May 2015 11:49
Only a WagonR can replace a WagonR ! From F10D to K10B.. DCEite Test-Drives & Initial Ownership Reports 27 19th April 2014 23:02
Problem with WagonR central locking paish Technical Stuff 7 18th December 2007 16:45
WagonR or Swift?(calling swift and wagonR owners) rajshenoy Hatchbacks 43 29th March 2007 09:54


All times are GMT +5.5. The time now is 20:39.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks