Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 28th February 2006, 17:37   #1
BHPian
 
Join Date: Jul 2004
Location: Utopia!
Posts: 577
Thanked: 84 Times
Default Tata Indigo LX Problem: Car Constantly Pulling Sideways

I'm facing a peculiar, but nagging problem with my Tata Indigo. It has done roughly 18K kms and digilently followed all service schedules till date.

Recently it was observed that the vehicle is pulling to the left even on flat roads. I suspected road banking to be the issue initially but even on perfectly flat surfaces (No banking), the vehicle is not able to keep its path straight once we keep the hands off the steering leaving it in the centre position. Even tyre pressure was checked routinely and are at specified levels.

I've reported this to the Tata dealer during the 4th service. I was told that the problem is because of the Wheel Alignment and they did wheel alignment and wheel rotation and gave the car back after the routine service.

Unfortunately the problem persisted and the car was still pulling in the left direction. After constant complaining and repeated checks at the dealer making no difference, the dealer themselves took the vehicle to another Wheel Alignment centre to obiviate the possibility of error in the in-house wheel alignment equipment. Surprisingly the problem remained even after this. They even tried changing to new Bridgestones all around but to no effect.

I was getting sick of this already and after around 3 days of constant followup, The dealer in consultation with the regional TATA office decided to change the Power Steering Unit

I must say that (or i felt) there was a slight improvement initially in the behaviour, but the problem was not completely avoided.

To make matters still worse, After a couple of days of driving, The car now pulls to the right side more often than left and the vehicle is not comfortable taking corners at decent speeds. It feels a lot more wobbly than before and requires constant correction in the steering wheel to keep the car in a straight line.

The vehicle has not met with even a minor accident or hit and was always under my personal use which is generally mild except for a few high speed(~155 kmph indicated) runs on long and empty highways.

Please put down your expert views on what could be the problem since it appears like the dealer inspite of putting his sincere efforts has almost exhausted with his options to check now.

Last edited by Digital Vampire : 28th February 2006 at 17:54.
Digital Vampire is offline   Reply With Quote
Old 28th February 2006, 17:59   #2
Senior - BHPian
 
shuvc's Avatar
 
Join Date: May 2005
Location: Kolkata
Posts: 2,895
Thanked: 283 Times
Default

I had a similar problem .. not exactly the same though .. with my Indica. It used to pull to the left and the steering used to 'shiver' over 80kmph.
The dealer I bought it from did some work on the steering column and rectified the problem. It never re-surfaced.
I was a lot less informed about cars then (since I still had not subscribed to T-BHP ), and hence am not aware exactly what they did to the steering column.
shuvc is offline   Reply With Quote
Old 28th February 2006, 18:02   #3
BANNED
 
Join Date: Nov 2004
Location: Bangalore / Madras
Posts: 1,980
Thanked: 14 Times
Default

How is the wear in the front tyres? Is is uniform on both tyres?
hrag is offline   Reply With Quote
Old 28th February 2006, 18:06   #4
BHPian
 
Join Date: Jul 2004
Location: Utopia!
Posts: 577
Thanked: 84 Times
Default

The tyre wear appears uniform across all the tyres and the scheduled tyre rotation was followed. The behaviour is the same even after tyre rotation.

The problem exists even when we replaced with a completely new set of bridgestones on new rims. So I guess uneven wear is not an issue
Digital Vampire is offline   Reply With Quote
Old 15th May 2006, 17:05   #5
BHPian
 
mtnrajdeep's Avatar
 
Join Date: Feb 2006
Location: Bangalore
Posts: 648
Thanked: 88 Times
Question Maruti Zen LX pulling to the side

Hi Guys

I recently observed that my car was pulling ever so slightly to the right side after a month of driving on bangalore's roads. I took the car to a MASS last saturday and got the wheels balanced and aligned. After that, when the service advisor was road testing the car, we observed that it was pulling slightly to the right. Then the service advisor asked the mechanic to interchange the front tyres and told me that if the problem persisted, it would be a case of defective tyres. Now, when the tyres were interchanged, the car started pulling towards the left!!

Could anyone point towards what the issue could be? Can it be a case of this one wheel not being balanced properly? This issue was not there when I bought the car an year back from truevalue. My car has run 57k km and I have got the suspension lower arms replaced at 55k km.

Thanks
Rajdeep
mtnrajdeep is offline   Reply With Quote
Old 15th May 2006, 17:08   #6
Senior - BHPian
 
amitoj's Avatar
 
Join Date: Nov 2004
Location: Nashua, NH
Posts: 2,954
Thanked: 1,591 Times
Default

I wont recommend a MASS for wheel balancing and alignment. Instead, try out TyreTech near richmond circle... very thorough folks...
amitoj is offline   Reply With Quote
Old 15th May 2006, 17:59   #7
BHPian
 
Join Date: Jul 2004
Location: Utopia!
Posts: 577
Thanked: 84 Times
Default

Quote:
Originally Posted by mtnrajdeep
Now, when the tyres were interchanged, the car started pulling towards the left!!
I guess this has to do with defective tyres. Try rotating with the spare tyre.

Interestingly, my problem got sorted out automatically after a few weeks !!!
Digital Vampire is offline   Reply With Quote
Old 11th October 2007, 12:50   #8
BHPian
 
adheesh's Avatar
 
Join Date: May 2007
Location: Bombay
Posts: 526
Thanked: 34 Times
Default

Does this happen while braking ? Anyways get the wheel alignment checked.
adheesh is offline   Reply With Quote
Old 11th October 2007, 16:57   #9
v&v
Senior - BHPian
 
v&v's Avatar
 
Join Date: Aug 2007
Location: Delhi
Posts: 1,538
Thanked: 1,068 Times
Default

have you checked the shokers, even a leaky or weak shoker can have this problem. is the tyre threads wearing. if its and alignment is ok, supect the shoker.
v&v is offline   Reply With Quote
Old 11th October 2007, 17:43   #10
BHPian
 
adityamunshi's Avatar
 
Join Date: May 2007
Location: Baroda
Posts: 771
Thanked: 6 Times
Default

I had a similar problem in my Indica a year and a half ago, dont remember what was done but it had something to do with the steering system. I cant be sure but I remember them changing a ball-joint or something like that. Hope it helps.
adityamunshi is offline   Reply With Quote
Old 11th October 2007, 17:53   #11
Senior - BHPian
 
rjstyles69's Avatar
 
Join Date: Sep 2006
Location: Bengalooru..
Posts: 4,345
Thanked: 789 Times
Default

Folks this thread is over a year old. Please check dates while posting..
rjstyles69 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Santro xing Pulling problem jayraj Technical Stuff 6 31st March 2009 14:05
Pulling problem, but not on plains - Swift Surprise Technical Stuff 26 13th January 2009 17:04
FI warning light constantly on - Palio Stile SLX PatchyBoy Technical Stuff 4 30th May 2008 12:14
Wiered Car Pulling Problem humyum Technical Stuff 14 2nd August 2006 18:28


All times are GMT +5.5. The time now is 20:10.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks