Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 2nd April 2012, 11:04   #196
BHPian
 
naveenchhillar's Avatar
 
Join Date: Nov 2011
Location: Rohtak-Noida
Posts: 128
Thanked: 31 Times
Default Re: XUV 500 niggles and their solutions

Want to update all about the ICE Upgrade that I did with my W6.

About 15 days back, got Digital Design speakers at front & back, alongwith a hi-low convertor (Audison) & a DD 4 channel amplifier. However, it was still sounding low.

Yesterday, went back to vendor & got the HI-LOW convertor removed & got a Bit Ten Sound Processor installed & it is rocking now
naveenchhillar is offline   Reply With Quote
Old 3rd April 2012, 19:50   #197
BHPian
 
Join Date: Feb 2009
Location: Bangalore
Posts: 73
Thanked: 21 Times
Default Re: XUV 500 niggles and their solutions

A quick update for all XUV5oo owner's suffering from brake pad issue.

had been to India garage white field yesterday to get my beast's first service and I was told that the re-designed brake pads has arrived.

please check with your service centres and get it rectified ASAP.

-Cheers
SAMUDRA is offline   (4) Thanks Reply With Quote
Old 3rd April 2012, 23:03   #198
BHPian
 
rohitbagai's Avatar
 
Join Date: Aug 2006
Location: New Delhi
Posts: 401
Thanked: 226 Times
Default

Quote:
Originally Posted by SAMUDRA
A quick update for all XUV5oo owner's suffering from brake pad issue.

had been to India garage white field yesterday to get my beast's first service and I was told that the re-designed brake pads has arrived.

please check with your service centres and get it rectified ASAP.

-Cheers
Those so called new design breaks have same problems. You can check after 2-3k km the sound will resurface. They have yet to find the real culprit. I think it's the problem with disc as they have excessive rust formation and when the shoe clears it while breaking it results in premature wear and hence the grinding sound.
rohitbagai is offline   (2) Thanks Reply With Quote
Old 4th April 2012, 11:35   #199
BHPian
 
Join Date: Feb 2009
Location: Bangalore
Posts: 73
Thanked: 21 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by rohitbagai View Post
Those so called new design breaks have same problems. You can check after 2-3k km the sound will resurface. They have yet to find the real culprit. I think it's the problem with disc as they have excessive rust formation and when the shoe clears it while breaking it results in premature wear and hence the grinding sound.
Rohitbagai, one thing that I am aware of is the fact that not all XUV's is having this problem. the reason for me to say this is due to the fact that my XUV has done around 3500 kms (on OEM break pads) and I'm yet to hear this grinding noise. and this was also the reason for me not opting for break pad change while I visited the service centre.

PS: I dont use my XUV on a daily basis but manage to do around 1200 kms / month by my visits outside Bengaluru.
SAMUDRA is offline   Reply With Quote
Old 4th April 2012, 14:38   #200
BHPian
 
Join Date: May 2008
Location: Mumbai
Posts: 217
Thanked: 27 Times
Default Re: XUV 500 niggles and their solutions

Hi,

I got my XUV delivery on 25th Feb 12, The VIN decoding says its a Jan 12 manufactured vehicle, but the the print on the winshield & all the glasses says 11 at the bottom.

Waht I understand that this printing on glasses is the last thing which happens on any car when it is coming out of plant.

Those who got the 2012 xuv, pls check .

cheers!
Crazy4Power is offline   Reply With Quote
Old 5th April 2012, 21:01   #201
BHPian
 
sheelapratosh's Avatar
 
Join Date: Feb 2012
Location: Bangalore
Posts: 82
Thanked: 66 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by rohitbagai View Post
Those so called new design breaks have same problems. You can check after 2-3k km the sound will resurface. They have yet to find the real culprit. I think it's the problem with disc as they have excessive rust formation and when the shoe clears it while breaking it results in premature wear and hence the grinding sound.
Yes sir. You are right. My RM accepted this out of record. I have changed my pads two times - still the issues resurfaces after 500-600 KMs.. I could see some circumstances under which this issue seems prevalent.

1. When you drive in a road filled with multiple speed breakers.
2. Long drives - if a section of your road is a mud road - and if you apply brakes in a speed breaker you'll feel this issue.
3. If you keep driving in slow speeds, you won't get this issue in all probability - at least I don't.

Btw.. If any of the seasoned folks know how to run a poll on the issues faced by XUV owners, it would help the followers to get a handle on the magnitude of issues related to different areas of XUV.
sheelapratosh is offline   (1) Thanks Reply With Quote
Old 6th April 2012, 21:58   #202
BHPian
 
patil's Avatar
 
Join Date: Oct 2007
Location: Shorapur
Posts: 337
Thanked: 54 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Crazy4Power View Post
Hi,

I got my XUV delivery on 25th Feb 12, The VIN decoding says its a Jan 12 manufactured vehicle, but the the print on the winshield & all the glasses says 11 at the bottom.

Waht I understand that this printing on glasses is the last thing which happens on any car when it is coming out of plant.

Those who got the 2012 xuv, pls check .

cheers!
Its the glass manufacturer who puts the date of manufacture of glass and not the actual car manufacturer. So the glass would have been manufactured in 2011 and shipped to the car manufacturer who then assembles it during 2012 and ships the vehicle out of factory in 2012. So nothing to worry about the year printed on the glass.
patil is offline   Reply With Quote
Old 10th April 2012, 11:11   #203
BHPian
 
moleculez's Avatar
 
Join Date: Aug 2008
Location: Mumbai
Posts: 49
Thanked: 24 Times
Default Re: XUV 500 niggles and their solutions

Got news!

Software version 4.0 is out! Yet to go and get it installed, but I really pray they resolve some majot issues.


Also about brakes, I was very confy driving at high speed on the scorpio even with 2 disk brakes as I was sure it would stop, with XUV i always feel its not gonna stop!

Response to the brake is very very slow.

Yes I have the new brake pads on.
How to identify those:
The old brake pads have a single cut on them
the new ones have 2!

Check it out guys!

Honestly the result after new and old brakepad is the same!
moleculez is offline   (1) Thanks Reply With Quote
Old 10th April 2012, 11:24   #204
BHPian
 
naveenchhillar's Avatar
 
Join Date: Nov 2011
Location: Rohtak-Noida
Posts: 128
Thanked: 31 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by moleculez View Post
Got news!

Software version 4.0 is out! Yet to go and get it installed, but I really pray they resolve some majot issues.



Honestly the result after new and old brakepad is the same!
Would like to advise here that version 4.0 is only for W8s, not for W6. Not sure about your vehicle though.

As far as braking is concerned, I think they give an impression that they are not on spot. However, if you try to apply them when required (with a bit of force) - they seem to do their job perfectly.
naveenchhillar is offline   Reply With Quote
Old 10th April 2012, 11:59   #205
BHPian
 
Join Date: Aug 2011
Location: Mumbai
Posts: 104
Thanked: 46 Times
Thumbs up Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by sheelapratosh View Post
.....
Btw.. If any of the seasoned folks know how to run a poll on the issues faced by XUV owners, it would help the followers to get a handle on the magnitude of issues related to different areas of XUV.
I think thats a great suggestion. Putting a poll on this thread will help people really understand which are the most common issues.
vinod332002 is offline   Reply With Quote
Old 12th April 2012, 20:12   #206
BHPian
 
moleculez's Avatar
 
Join Date: Aug 2008
Location: Mumbai
Posts: 49
Thanked: 24 Times
Default Re: XUV 500 niggles and their solutions

I got the W8 upgraded to the 4.0 SW verison today. Didnt get time to explore but one feature which are really really wanted was to SHUT THE STARUP noise which can happen as they have a option given for it now. Have attaced a image of the new SW for you guys.
Attached Thumbnails
XUV 500 niggles and their solutions-img_1343.jpg  

moleculez is offline   Reply With Quote
Old 12th April 2012, 20:16   #207
BHPian
 
Gerardfdz's Avatar
 
Join Date: Feb 2004
Location: Mumbai
Posts: 207
Thanked: 55 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by moleculez View Post
I got the W8 upgraded to the 4.0 SW verison today. Didnt get time to explore but one feature which are really really wanted was to SHUT THE STARUP noise which can happen as they have a option given for it now. Have attaced a image of the new SW for you guys.
I hope to get it done tomorrow then drive to Pune! So should see if it has resolved the tyretronics error alarm.
What do you mean by" SHUT THE STARUP" noise?
Has anyone updated the maps to ver7.0?

Last edited by Gerardfdz : 12th April 2012 at 20:17.
Gerardfdz is offline   Reply With Quote
Old 12th April 2012, 23:42   #208
BHPian
 
rohitbagai's Avatar
 
Join Date: Aug 2006
Location: New Delhi
Posts: 401
Thanked: 226 Times
Default

Quote:
Originally Posted by moleculez
I got the W8 upgraded to the 4.0 SW verison today. Didnt get time to explore but one feature which are really really wanted was to SHUT THE STARUP noise which can happen as they have a option given for it now. Have attaced a image of the new SW for you guys.
That option was always there under Sounds/volume and is not "new"
^^ the MMI ver 7.0 is not yet customized for XUV according to Nippon guys at A.S.S.

Last edited by rohitbagai : 12th April 2012 at 23:44.
rohitbagai is offline   Reply With Quote
Old 12th April 2012, 23:51   #209
BHPian
 
dockap's Avatar
 
Join Date: Jun 2007
Location: Mangalore
Posts: 842
Thanked: 364 Times
Default

Hey guys i have this problem with my xuv. couple of times it has failed to start. I then removed the key and waited for a min and tried again and it started. anyone else have this problem with their xuv and any idea about the cause of this problem and solution

I have installed the rear view camera but there is 1 problem with the display. when i start the XUV the entertainment system starts booting and takes some time to display the rear view camera so i have to wait at least 30 secs before i can start reversing the XUV. I had a lcd rear view camera lying around from my magnum so i got a local accessory installer to fix in on my XUV by connecting it to the av cable from the rear view camera and the reverse light wire so now i have instantaneous rear view display when i want to reverse.
In the photo below you can see the rear view in the lcd rear view mirror in my xuv while mahindra is still rising in the entertainment system in the bottom portion of the photo.
Attached Thumbnails
XUV 500 niggles and their solutions-20120412-23.56.10.jpg  


Last edited by suhaas307 : 13th April 2012 at 00:36. Reason: Merged consecutive posts. Thanks :)
dockap is offline   (1) Thanks Reply With Quote
Old 13th April 2012, 10:31   #210
BHPian
 
naveenchhillar's Avatar
 
Join Date: Nov 2011
Location: Rohtak-Noida
Posts: 128
Thanked: 31 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by dockap View Post
Hey guys i have this problem with my xuv. couple of times it has failed to start. I then removed the key and waited for a min and tried again and it started. anyone else have this problem with their xuv and any idea about the cause of this problem and solution

.
Hello,
Please refer to my post here, had the same issue:

http://www.team-bhp.com/forum/offici...eview-149.html (Mahindra XUV500 : Test Drive & Review)

Post from 10th April, 2012.
naveenchhillar is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Metro and City Discrimination By Mahindra- XUV 500 Launch anjan_c2007 The Indian Car Scene 18 29th November 2011 15:10
Niggles, problems (Tyre and Stalling) in Palio 1.6 Sports 2007 anurag_p80 Technical Stuff 31 19th July 2010 17:31


All times are GMT +5.5. The time now is 09:45.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks