Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 12th March 2014, 14:53   #2536
Senior - BHPian
 
nitinralli's Avatar
 
Join Date: Jun 2005
Location: Delhi
Posts: 1,117
Thanked: 438 Times
Default Re: XUV 500 niggles and their solutions

There seems to be a humming sound from dash when i park my car after a drive. It stays there for few seconds like 10/15 secs and then gone. I think this was discussed before too but not able to see where it is. Anyone knows that page or the reason for this, Please.
nitinralli is online now   Reply With Quote
Old 13th March 2014, 00:20   #2537
rlg
BHPian
 
Join Date: Jan 2013
Location: Bangalore
Posts: 39
Thanked: 48 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by onyxgaze View Post
Hi,

I just started using torque pro with an obd2 dongle in my Xuv.

Could you advise what finally happened with your diagnosis of the Xuv turbo.

Looks like I am also reading a low turbo boost pressure.

Thanks in advance.
I thought I had posted updates here, but looks like I didn't. Sorry about that.

The analysis of the graphs by mahindra's R&D through my personal contacts was that the solenoid valve was the issue. Either the valve itself or its driver. But it was hard convincing the service center about it. They insisted on their own diagnosis and said that the turbo had to be replaced. Well, I didn't mind getting a new turbo though I wasn't convinced it will solve the problem, so told them to go ahead. After replacing the turbo didn't feel any significant improvement. I was frustrated, but can't blame the service center not trying to address my concerns. So decided to give it some time before I go back. May be running in the turbo will help was my thought.

After a few weeks I started feeling improvement. It kept getting better for some time and stabilized in about 1000kms. Not sure if it was the turbo or the solenoid getting some life back (loose connection ? leak ?). The graphs also showed some improvement.

However, the feel of my original turbo and new one is different.

Old turbo before the problem cropped up: surge of power comes on at 1500-1600RPM.
New turbo: turbo starts spooling up at lower RPMs, can hear at 1000-1100 itself. The power delivery increases linearly, the surge at 1600 not as prominent as with the old turbo. Turbo whine is not as loud either. I feel the power above 1600 is still a little less than earlier, but since it spools up early, it is better for city roads. Also I'm able squeeze out better mileage out of it since I can upshift earlier. Now this could also be due to engine running in. I read somewhere on this forum that Mahindra engine's running in is not really over by 1000km and keeps getting better upto 10000 or even 20000kms.

In the end, I'm still a bit confused if I'm getting the best out of the turbo. My low end power and mileage is certainly better after the replacement, I'm delighted with that. My feeling is that while it is better below 1600RPM, the old one gave me more power above it. But unless I compare with another vehicle with a known good turbo, it is hard to tell if it is just my feeling or reality.

Considering how clueless ASS was, I'm not sure there is anything to gain by going to them for analysis. Most of my driving is in the city and it works fine in that band, so not too keen on taking it to ASS again.

Here is a recent plot I recorded. Turbo boost is not a linear function of RPM as I believe HCP pointed out in one of his replies. The demand also matters. I found looking at plot against RPM as well as the accelerator position gives a better correlation. The more the delta between demand (accelerator) and RPM, the more the boost.
XUV 500 niggles and their solutions-screenshot_20140312235156.png
XUV 500 niggles and their solutions-screenshot_20140312235219.png

PS: I created a web page to help me create these plots easily on the phone itself. The processing is local on the device, so it will work offline too once loaded. You don't need data connection on all the time. Link here
rlg is offline   (2) Thanks Reply With Quote
Old 13th March 2014, 00:25   #2538
rlg
BHPian
 
Join Date: Jan 2013
Location: Bangalore
Posts: 39
Thanked: 48 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by nitinralli View Post
There seems to be a humming sound from dash when i park my car after a drive. It stays there for few seconds like 10/15 secs and then gone. I think this was discussed before too but not able to see where it is. Anyone knows that page or the reason for this, Please.
Looking for this one ?
http://www.team-bhp.com/forum/techni...ml#post3298077 (XUV 500 niggles and their solutions)
rlg is offline   (1) Thanks Reply With Quote
Old 13th March 2014, 00:51   #2539
Senior - BHPian
 
nitinralli's Avatar
 
Join Date: Jun 2005
Location: Delhi
Posts: 1,117
Thanked: 438 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by HotChillyPepper View Post
Looking at the way the technicians responded to this issue, it seems to be a common one. As soon as they heard of the sound, they were certain that the modulator needs to be changed.
Mine is a April 2012 batch vehicle.

Thanks
HCP
HCP how much time did they take to replace this issue? I am facing the same one after two and a half year of ownership.
nitinralli is online now   Reply With Quote
Old 13th March 2014, 17:37   #2540
BHPian
 
Monaro's Avatar
 
Join Date: Jun 2007
Location: Noida
Posts: 119
Thanked: 48 Times
Default Re: XUV 500 niggles and their solutions

Carrying on my thoughts from another thread:

Quote:
Hi guys,

I recently drove a friend's new 2013 W6 and found the suspension to be really soft as it rolled over the speed bumps with ease. It also felt well planted on the tarmac and i just loved the entire feel of it.

In comparison, my 2012 W8 appears to have a harder suspension and going over the hard-plastic-like bumps rattles the entire vehicle (especially when not fully loaded).
So, are the older XUV owners like me eligible for the upgrade in shockers/brakes? Has anyone else got the upgrade done?

Thanks!
Monaro is offline   Reply With Quote
Old 14th March 2014, 06:41   #2541
BHPian
 
magikrider's Avatar
 
Join Date: Mar 2009
Location: MH-01
Posts: 441
Thanked: 80 Times
Default Re: XUV 500 niggles and their solutions

Hello. Posting after a really long time.. I am going outta town tomorrow in my XUV and my front wiper blades have gone bad. The left side blade has split in between and kinda dangerous to use as it might scratch the windshield. so I want to replace the front wiper blades. Tried looking for Bosch wiper blades for XUV at Opera House, Mumbai, but couldn't find anywhere. so can anyone please help me with a Bosch wiper blades dealer in South Mumbai. Its urgent. Thanks.

Also when I checked with a dealer, he measured to see if he's got in his stock. and the front right side wiper was 26" and the front left side was 19". But when I checked online, Bosch makes Aerotwins for XUV which are 20". So how will they fit? or is the 20" only for the front left?

So Please let me know the correct size Bosch wipers and the model. Thank you.

Last edited by magikrider : 14th March 2014 at 06:53.
magikrider is offline   Reply With Quote
Old 17th March 2014, 12:25   #2542
Senior - BHPian
 
J.Ravi's Avatar
 
Join Date: Mar 2009
Location: Bangalore
Posts: 3,143
Thanked: 3,833 Times
Unhappy First Niggle In My Mahindra XUV500 W8 FWD

Today, I tried in vain to fix the tow-eye properly into the threaded slot on the LHS of the rear bumper. The details are here. Fellow-XUV500 owners, who successfully fixed the rear tow-hook, may kindly guide me.
J.Ravi is offline   Reply With Quote
Old 17th March 2014, 22:45   #2543
Senior - BHPian
 
mail4ajo's Avatar
 
Join Date: Mar 2006
Location: San Antonio, TX
Posts: 1,808
Thanked: 206 Times
Default Re: XUV 500 niggles and their solutions

XUV users, please let me know the issues that has not been resolved with the recent update. The intended purchase model is W6.
mail4ajo is offline   Reply With Quote
Old 17th March 2014, 23:45   #2544
BHPian
 
Join Date: Feb 2008
Location: manipal
Posts: 54
Thanked: 91 Times
Unhappy Re: XUV 500 niggles and their solutions

Hello friends
I have noticed a tat-tat-tat sound whenever i switch on the aircon since 15-20 days, I opened the bonnet today and confirmed the same. My provisional diagnosis is that it may be of the belt as it fades off after about 2 - 3mins. Kindly enlighten with your thoughts and experience.
manipal is offline   Reply With Quote
Old 20th March 2014, 12:52   #2545
Newbie
 
Sanju Bedi's Avatar
 
Join Date: Aug 2012
Location: Chandigarh
Posts: 13
Thanked: 2 Times
Default Re: XUV 500 niggles and their solutions

Hey Kartik, it's pretty easy modding your system without tinkering with the head unit. I got a kenwood amp & woofer fitted along with jbl component speakers. The accessories guys take the input for the amp from the rear speaker wire & the head unit is not tinkered with. It's a fairly routine thing to do, I've had it for the last two years, working just fine & haven't faced any probs so far. Also, if u normally use the last row of seats, then thinner woofer enclosures are available which fit behind the seats. Hope this helps��
Sanju Bedi is offline   Reply With Quote
Old 20th March 2014, 16:02   #2546
BHPian
 
kARTIK IYER's Avatar
 
Join Date: Dec 2007
Location: NaviMumbai
Posts: 161
Thanked: 12 Times
Default

Quote:
Originally Posted by Sanju Bedi View Post
Hey Kartik, it's pretty easy modding your system without tinkering with the head unit. I got a kenwood amp & woofer fitted along with jbl component speakers. The accessories guys take the input for the amp from the rear speaker wire & the head unit is not tinkered with. It's a fairly routine thing to do, I've had it for the last two years, working just fine & haven't faced any probs so far. Also, if u normally use the last row of seats, then thinner woofer enclosures are available which fit behind the seats. Hope this helps��
Thanks Sanju..

I have got the infinity component speakers in rear door. Got amps connected. I have a slim woofer in last row. All working fine. I have a switch to on/off amp if required too, I have no issues. Only issue I am facing from day 1 even before ICE fitting is that on blue tooth my voice does not come clear ans has lot of airy noise. I suspect mic issue.
kARTIK IYER is offline   Reply With Quote
Old 20th March 2014, 16:05   #2547
BHPian
 
kARTIK IYER's Avatar
 
Join Date: Dec 2007
Location: NaviMumbai
Posts: 161
Thanked: 12 Times
Default

Xuv owners could you share experiences on mileage ? Mine is fairly new XUV with 1k on odo and gave me 11kmpl on an average.
kARTIK IYER is offline   Reply With Quote
Old 21st March 2014, 10:47   #2548
BHPian
 
shrk_18's Avatar
 
Join Date: Mar 2013
Location: Bangalore
Posts: 62
Thanked: 83 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by kARTIK IYER View Post
Xuv owners could you share experiences on mileage ? Mine is fairly new XUV with 1k on odo and gave me 11kmpl on an average.
Please specify where? If in the city, its very good, if on the highway its too low !!!
shrk_18 is offline   Reply With Quote
Old 21st March 2014, 11:11   #2549
BHPian
 
kARTIK IYER's Avatar
 
Join Date: Dec 2007
Location: NaviMumbai
Posts: 161
Thanked: 12 Times
Default

Quote:
Originally Posted by shrk_18 View Post
Please specify where? If in the city, its very good, if on the highway its too low !!!
So my driving is mix of highways and city. I find city hovers around 11 to 11.5 but highway drops to 9 to 10. Sounds strange.
kARTIK IYER is offline   Reply With Quote
Old 21st March 2014, 11:22   #2550
BHPian
 
shrk_18's Avatar
 
Join Date: Mar 2013
Location: Bangalore
Posts: 62
Thanked: 83 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by kARTIK IYER View Post
So my driving is mix of highways and city. I find city hovers around 11 to 11.5 but highway drops to 9 to 10. Sounds strange.
That is very very strange, you should check mileage on a pure highway run and a pure city run to get the numbers. If something looks fishy you should ask M&M to look at it. I generally get 9-10 in the city (Bangalore traffic) and around 17 on the highway with speeds hovering around 100kmph
shrk_18 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Metro and City Discrimination By Mahindra- XUV 500 Launch anjan_c2007 The Indian Car Scene 18 29th November 2011 15:10
Niggles, problems (Tyre and Stalling) in Palio 1.6 Sports 2007 anurag_p80 Technical Stuff 31 19th July 2010 17:31


All times are GMT +5.5. The time now is 19:53.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks