Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 22nd May 2014, 22:59   #2626
Senior - BHPian
 
mpksuhas's Avatar
 
Join Date: Sep 2009
Location: KA03/KL11
Posts: 2,455
Thanked: 2,628 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by pgupta View Post
2. Vehicle pulling left/right
Now to top it all he also faced another major issue where the clutch got stuck and he was unable to apply gears.
Can you let know what are the brand of tyre which your friends W4 has. I have read on forum that the left pull is mostly on JK tyres and that is the reason AWD comes now with only Bridgestone's.

Regarding clutch failure I was under impression that it was due to design fault in earlier XUV's and sometime around last year start they fixed this issue. Now, this happening in a later generation car and that too just 2 month old one is bit scary.
I guess earlier failures were accompanied with low break fluid warning, was your friend able to notice any such warnings ?
mpksuhas is offline   Reply With Quote
Old 22nd May 2014, 23:13   #2627
BHPian
 
pgupta's Avatar
 
Join Date: Dec 2009
Location: Bangalore
Posts: 158
Thanked: 96 Times
Default

Quote:
Originally Posted by mpksuhas View Post
Can you let know what are the brand of tyre which your friends W4 has. I have read on forum that the left pull is mostly on JK tyres and that is the reason AWD comes now with only Bridgestone's.



Regarding clutch failure I was under impression that it was due to design fault in earlier XUV's and sometime around last year start they fixed this issue. Now, this happening in a later generation car and that too just 2 month old one is bit scary.

I guess earlier failures were accompanied with low break fluid warning, was your friend able to notice any such warnings ?

Yes it has JK tyres. My W4 also has JK and I also have this left pulling problem.

The clutch failure is really a major concern as I was also under the impression that this issue has been resolved and new XUV's do not have this problem. Also in this case there was no low brake fluid warning.

It would be worth knowing if any other W4 has similar clutch issue ?
pgupta is offline   (1) Thanks Reply With Quote
Old 26th May 2014, 20:07   #2628
BHPian
 
live2drive's Avatar
 
Join Date: Oct 2008
Location: New Delhi
Posts: 523
Thanked: 25 Times
Default Re: XUV 500 niggles and their solutions

My XUV's AC was not performing well in this scorching heat. Complained this to the RM at Koncept, NOIDA, he agreed to service the entire unit including a new evaporator coil within warranty.

They ripped apart the dashboard (scary sight) and replaced the evaporator coil with a brand new one. Blower unit was also cleaned with compressed air, entire thing was then put back into place and finally gas charging was done.

The results are phenomenal, AC chills like anything, like it was when the car was new, if not better.

PS: I saw similar work being done on atleast 4 XUVs while i was there at the ASC . Asked him if the new coil has a different design but he was clueless.

As always, satisfied by Koncept Mahindra's service.
live2drive is offline   (1) Thanks Reply With Quote
Old 26th May 2014, 20:19   #2629
BHPian
 
Join Date: Feb 2014
Location: Bangalore
Posts: 29
Thanked: 8 Times
Default Re: XUV 500 niggles and their solutions

Faced a niggle after a drive to Chennai. The start/stop function stopped working. Is anybody else facing this issue ? I will be talking to the ASS soon. I also found that driving at 80 Km/l on cruise control gives 18 Km/l, increasing it to 90 makes it 17.4 Km/l. AC was on at 24.
sriram.raghavan is offline   (1) Thanks Reply With Quote
Old 26th May 2014, 22:55   #2630
BHPian
 
gopu.g's Avatar
 
Join Date: Aug 2013
Location: Kochi.
Posts: 29
Thanked: 4 Times
Default

Yup..I just returned from a drive from kochi to bangalore n back...The start/stop stopped working on return trip. This is the second time the issue is happening. Switching off the engine n back cleared the issue. Also the infotainment restarted completely due course of the trip once. Absolutely no clue on this. Anyone else facing similar issues do let me know n ways of mitigation. By mine is a 2014 March W8 XUV 5OO.
gopu.g is offline   Reply With Quote
Old 27th May 2014, 08:20   #2631
SDP
Team-BHP Support
 
SDP's Avatar
 
Join Date: Jan 2010
Location: Mumbai
Posts: 3,486
Thanked: 6,751 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by sriram.raghavan View Post
Faced a niggle after a drive to Chennai. The start/stop function stopped working. Is anybody else facing this issue ? I will be talking to the ASS soon. I also found that driving at 80 Km/l on cruise control gives 18 Km/l, increasing it to 90 makes it 17.4 Km/l. AC was on at 24.
That's a good data point. I have been recently trying to find the sweet point in terms of RPM and/or speed that delivers best FE and even I came to similar conclusion that in 6th gear in RPM of 1250-1500 (speeds of 70-80kmph) gives best FE.

Quote:
Originally Posted by gopu.g View Post
Yup..I just returned from a drive from kochi to bangalore n back...The start/stop stopped working on return trip. This is the second time the issue is happening. Switching off the engine n back cleared the issue. Also the infotainment restarted completely due course of the trip once. Absolutely no clue on this. Anyone else facing similar issues do let me know n ways of mitigation. By mine is a 2014 March W8 XUV 5OO.
Start/Stop is a fairly useless feature and I rarely use it, but if you use it, you should get it rectified.

The main infotainment system restarting, even I faced that during a 1000kms trip over last weekend. Mine is June'2012 vehicle. I was expecting that it would have been sorted in newer vehicles. Most likely a software glitch and as you know the more complex the software, the more difficult it is to be bug-free. I would be reporting the problem during 2nd service. Not very critical for me as it has happened for just about 4-5 times in last 2 years. Let's see if there is a latest version of software that fixes it.
SDP is offline   Reply With Quote
Old 27th May 2014, 10:17   #2632
BHPian
 
fundagenie's Avatar
 
Join Date: Feb 2005
Location: Bangalore
Posts: 443
Thanked: 387 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by pgupta View Post
4. Outside smell inside cabin even if the inner circulation air flow mode is on
I also face this issue. Seems some of the owners had got it resolved. But its not an easy task as per my understanding. Appears they have to remove the entire front dash to get it resolved and again its a 1 day job. I thought I will live with it for the time being, rather than have the dash pulled out and not getting back the factory fit and finish.

FundaG.
fundagenie is offline   Reply With Quote
Old 27th May 2014, 16:02   #2633
Senior - BHPian
 
mpksuhas's Avatar
 
Join Date: Sep 2009
Location: KA03/KL11
Posts: 2,455
Thanked: 2,628 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by pgupta View Post
The clutch failure is really a major concern as I was also under the impression that this issue has been resolved and new XUV's do not have this problem.
Pgupta, is there any update regarding this clutch issue. Any reason for failure mentioned by service center?
mpksuhas is offline   Reply With Quote
Old 27th May 2014, 16:27   #2634
BHPian
 
raj.barcode's Avatar
 
Join Date: Jun 2008
Location: Bangalore
Posts: 674
Thanked: 55 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by pgupta View Post
My friend who bought a W4 a few weeks back has been facing a series of issues since then.
1. False door open alarm
2. Vehicle pulling left/right
3. Steering jerks when speed exceeds >110-120 km
4. Outside smell inside cabin even if the inner circulation air flow mode is on

.
1. False door open alarm error pops up if the sensor contact on the doors aren't properly calibrated. I had same issue and have put double side tape, now contact is alright and no problems till date

2. Check for "road force balancing"; guess Madhus enterprises does it and issue should be rectified

3. no idea why it is happening?

4. That is a Mahindra trademark ; even I had the same problem and it took a full day at service center to rectify it
raj.barcode is offline   Reply With Quote
Old 27th May 2014, 17:56   #2635
BHPian
 
pgupta's Avatar
 
Join Date: Dec 2009
Location: Bangalore
Posts: 158
Thanked: 96 Times
Default

Quote:
Originally Posted by mpksuhas View Post
Pgupta, is there any update regarding this clutch issue. Any reason for failure mentioned by service center?

They did a "clutch bleeding " and now it is fine since then. I am not too sure what a clutch bleeding is but if it addresses the problem then it should be fine.
pgupta is offline   (1) Thanks Reply With Quote
Old 28th May 2014, 14:29   #2636
rlg
BHPian
 
Join Date: Jan 2013
Location: Bangalore
Posts: 39
Thanked: 48 Times
Default Re: XUV 500 niggles and their solutions

I had a tyre puncture repaired a few weeks back. After the repair and air filling, TPMS low pressure warning was still on and reported 17psi. Checking with a couple of gauges showed that the real pressure was 31psi. Didn't bother taking to ASC immediately. After about a week the warning went away by itself and TPMS started reporting correct air pressure of 31psi. I never filled air in between. Anybody experienced anything similar ?
rlg is offline   Reply With Quote
Old 28th May 2014, 14:41   #2637
Team-BHP Support
 
Vid6639's Avatar
 
Join Date: Jul 2006
Location: Bangalore
Posts: 13,764
Thanked: 16,897 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by gopu.g View Post
Yup..I just returned from a drive from kochi to bangalore n back...The start/stop stopped working on return trip. This is the second time the issue is happening. Switching off the engine n back cleared the issue. Also the infotainment restarted completely due course of the trip once. Absolutely no clue on this. Anyone else facing similar issues do let me know n ways of mitigation. By mine is a 2014 March W8 XUV 5OO.
What do you mean by not working? It will not work under certain conditions like excess heat or cold engine. Sometimes if outside temp is too much it will disable start/stop.
Vid6639 is offline   Reply With Quote
Old 28th May 2014, 16:53   #2638
BHPian
 
Join Date: Feb 2014
Location: Bangalore
Posts: 29
Thanked: 8 Times
Default Re: XUV 500 niggles and their solutions

In my case it has completely stopped working. Today morning my drive to work, it refused to stop and start at signals which is a regular routine.
sriram.raghavan is offline   Reply With Quote
Old 29th May 2014, 12:07   #2639
BHPian
 
Join Date: Mar 2007
Location: KA-01
Posts: 76
Thanked: 15 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by rlg View Post
I had a tyre puncture repaired a few weeks back. After the repair and air filling, TPMS low pressure warning was still on and reported 17psi. Checking with a couple of gauges showed that the real pressure was 31psi. Didn't bother taking to ASC immediately. After about a week the warning went away by itself and TPMS started reporting correct air pressure of 31psi. I never filled air in between. Anybody experienced anything similar ?
Was the tyre removed for fixing the puncture? If yes, TPMS has to be reset manually else it will report wrong value.

Please check this Video for more info.

Chuchan is offline   (2) Thanks Reply With Quote
Old 29th May 2014, 16:05   #2640
rlg
BHPian
 
Join Date: Jan 2013
Location: Bangalore
Posts: 39
Thanked: 48 Times
Default Re: XUV 500 niggles and their solutions

I never did reset as I thought it was for acknowledging the swap. Never got the prompt as shown in the video either. Probably because I didn't drive long enough with the tyres swapped at over 40km before changing it back.
rlg is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Metro and City Discrimination By Mahindra- XUV 500 Launch anjan_c2007 The Indian Car Scene 18 29th November 2011 15:10
Niggles, problems (Tyre and Stalling) in Palio 1.6 Sports 2007 anurag_p80 Technical Stuff 31 19th July 2010 17:31


All times are GMT +5.5. The time now is 11:43.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks