Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 8th June 2014, 21:19   #2656
BHPian
 
pgupta's Avatar
 
Join Date: Dec 2009
Location: Bangalore
Posts: 158
Thanked: 96 Times
Default Re: XUV 500 niggles and their solutions

I am not sure if this is an issue. Whenever I start to move the vehicle and move to 2nd gear from the 1st, the moment the clutch is released completely there is a sudden surge of power and the car just accelerates without me pushing the accelerator at all.

This happens every time when I engage 2nd gear later in course of driving and it is most felt if I engage the 2nd gear and drive in half clutch (for example to manage a pothole) then release the clutch a little later. The car almost leaps forward and at times I had to apply brake to be in control. The power subsides if you allow the car to move freely for some distance. It seems that the power somehow builds up and gets released when you release the clutch completely. Due to this while in traffic I have to drive very cautiously or drive in half clutch which of course will eventually increase the clutch wear and tear.

Is this normal or is there something wrong in my driving style ?
pgupta is offline   Reply With Quote
Old 8th June 2014, 22:21   #2657
BHPian
 
Join Date: Apr 2014
Location: Hyderabad
Posts: 141
Thanked: 111 Times
Default

Quote:
Originally Posted by pgupta View Post
I am not sure if this is an issue. Whenever I start to move the vehicle and move to 2nd gear from the 1st, the moment the clutch is released completely there is a sudden surge of power and the car just accelerates without me pushing the accelerator at all.

This happens every time when I engage 2nd gear later in course of driving and it is most felt if I engage the 2nd gear and drive in half clutch (for example to manage a pothole) then release the clutch a little later. The car almost leaps forward and at times I had to apply brake to be in control. The power subsides if you allow the car to move freely for some distance. It seems that the power somehow builds up and gets released when you release the clutch completely. Due to this while in traffic I have to drive very cautiously or drive in half clutch which of course will eventually increase the clutch wear and tear.

Is this normal or is there something wrong in my driving style ?
It is normal. What you are experiencing is turbo, and I like how it feels. The car pulls on its own. 2nd gear has great pull and the pull decreases with higher gear.
At first I felt the same way you did, and you learn to control it. Once you do you will also enjoy the ride and will be more confident.
falconion is offline   (1) Thanks Reply With Quote
Old 9th June 2014, 00:27   #2658
BHPian
 
Join Date: Jun 2014
Location: New Delhi
Posts: 30
Thanked: 65 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by pgupta View Post
I am not sure if this is an issue. Whenever I start to move the vehicle and move to 2nd gear from the 1st, the moment the clutch is released completely there is a sudden surge of power and the car just accelerates without me pushing the accelerator at all.

This happens every time when I engage 2nd gear later in course of driving and it is most felt if I engage the 2nd gear and drive in half clutch (for example to manage a pothole) then release the clutch a little later. The car almost leaps forward and at times I had to apply brake to be in control. The power subsides if you allow the car to move freely for some distance. It seems that the power somehow builds up and gets released when you release the clutch completely. Due to this while in traffic I have to drive very cautiously or drive in half clutch which of course will eventually increase the clutch wear and tear.

Is this normal or is there something wrong in my driving style ?
I know what you are talking about - but I have gotten used to driving around it. Just try and release the clutch a little slowly than you are doing now.

Also, I find this thing is much more prominent when the car is started after a long gap - say in the mornings or after being parked the whole day at office. Once the car warms up it sort of reduces on its own.
kk21 is offline   (1) Thanks Reply With Quote
Old 9th June 2014, 07:50   #2659
SDP
Team-BHP Support
 
SDP's Avatar
 
Join Date: Jan 2010
Location: Mumbai
Posts: 3,502
Thanked: 6,787 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by pgupta View Post
I am not sure if this is an issue. Whenever I start to move the vehicle and move to 2nd gear from the 1st, the moment the clutch is released completely there is a sudden surge of power and the car just accelerates without me pushing the accelerator at all.

This happens every time when I engage 2nd gear later in course of driving and it is most felt if I engage the 2nd gear and drive in half clutch (for example to manage a pothole) then release the clutch a little later. The car almost leaps forward and at times I had to apply brake to be in control. ...
Couple of scenarios:

1. You start from standstill in first and then up-shift to 2nd gear. If you have revved quite a lot in first, you could be in relatively high rpms even when you switch to 2nd and that can give a strong acceleration, with the car being in the turbo-zone.

2. When you slow down to tackle a speed-breaker, many a times the RPM drops to a quite a low level (below 800 rpm) and then when you release the clutch in 2nd gear, the engine catches up to the idling rpm of 800 without any accelerator input and you feel a strong tug.

Please pay attention to your RPMs and see if any one of these 2 scenarios are happening in your case.

Last edited by SDP : 9th June 2014 at 07:52.
SDP is offline   (2) Thanks Reply With Quote
Old 9th June 2014, 15:37   #2660
BHPian
 
Sisu's Avatar
 
Join Date: Mar 2012
Location: NEW DELHI
Posts: 112
Thanked: 73 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by pgupta View Post
I am not sure if this is an issue. Whenever I start to move the vehicle and move to 2nd gear from the 1st, the moment the clutch is released completely there is a sudden surge of power and the car just accelerates without me pushing the accelerator at all.

This happens every time when I engage 2nd gear later in course of driving and it is most felt if I engage the 2nd gear and drive in half clutch (for example to manage a pothole) then release the clutch a little later. The car almost leaps forward and at times I had to apply brake to be in control. The power subsides if you allow the car to move freely for some distance. It seems that the power somehow builds up and gets released when you release the clutch completely. Due to this while in traffic I have to drive very cautiously or drive in half clutch which of course will eventually increase the clutch wear and tear.

Is this normal or is there something wrong in my driving style ?
Hi,

This is an anti-stall feature. In RPM's below 800-900, the engine is programmed to increase revs on its own and catch upto the minimum idling RPM. This is felt as the tug that you described. In effect its the car increasing the RPM without any driver input. So one feels that the car is accelerating on its own.

In the absence of this feature, the engine would sputter and the clutch would need to be slipped to prevent the car from stalling.

Rest assured that this is a feature and not any defect in your car.

Hope this helps.

Cheeerzzz
Sisu is offline   (7) Thanks Reply With Quote
Old 9th June 2014, 16:33   #2661
BHPian
 
me_sid's Avatar
 
Join Date: May 2008
Location: Kolkata
Posts: 293
Thanked: 180 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by pgupta View Post
Due to this while in traffic I have to drive very cautiously or drive in half clutch which of course will eventually increase the clutch wear and tear.
This, my friend you should refrain from doing. XUV's are legendary for clutch failure in the initial stage. So Please don't ride on the clutch.I suggest you alter your driving style. For shifting from 1st. to 2nd. don't go to the turbo zone at all. Shift at 1K. Moreover release the clutch gently and gradually and then step on the gas pedal. For potholes etc, what I do is from 2nd or 3rd I brake and then depending on the speed I am travelling I either downshift to 1st. ( almost standstill) or if I am at around 1K zone after braking downshift to 2nd.
me_sid is offline   Reply With Quote
Old 11th June 2014, 22:51   #2662
BHPian
 
magikrider's Avatar
 
Join Date: Mar 2009
Location: MH-01
Posts: 441
Thanked: 80 Times
Default URGENT HELP Required!

Guys, I think there is some serious issue with my XUV and the service centre guys are also not able to detect/help! So need some URGENT HELP!

The problem is when I start my car in the morning or at night time after a day's rest mostly and sometimes even after few hours of rest, it starts making this strange Kat Kat noise. the noise is like theres no engine oil at all. then after a minute or so it goes and the car gets back to normal. this noise is not your regular knocking sound which is present in diesel engines. and also the Oil Lamp shows on when this thing happens.

usually it lasts for a minute or so but the last time it was on and on for 2-3 minutes, thats when i took video. after that I stopped and restarted the car and it was gone.

also this thing has started from a couple of months I think. earlier it never happened. I had also complained about the same issue with the service centre guys and told them that maybe the oil level is low so please get the oil at my place and check for leakage as I won't be able to drive the car to the service centre. and two guys showed up also at my place but that time it was all fine and the noise didn't start at the start up and they also checked the engine oil level which was normal. then it started again so I took it to the service centre and kept my car with them for a few days but they didn't find anything unusual and it didn't show any error. also when I went there to take the deliver, I was told that the car was lying there since yesterday and not moved or started. but when I started there it didn't show the same problem in front of the RM!

So I am again going to take the car tomorrow and keep there and maybe go there again the next day and start again in front of the RM and the technician so they can come to know the exact problem.

my cousin also has a XUV and he told me that he had faced such problem in his brand new (barely a week old) XUV and his car was towed to the service centre and some part which releases the oil into the engine was replaced. and he advised me not to drive the car till then as it can damage the engine. but the RM said I can drive as its normal for the car to make knocking sound at cold start till the engine oil reaches the engine. but this isn't the normal engine knocking at all and has started recently. never faced this problem in the year and a half almost. also I stay in mumbai and not some cold weather that cold start would be an issue in this scorching summer heat. also the problem is usually at morning and night time. not much at afternoon time.

So has any XUV owner faced such problem and if yes how was it solved? what should be done.

I have also taken a video with my iPhone which is in .MOV format and around 89.5MB. so I am not able to upload the video here. is there some way I can upload it here so you guys can see and know the exact problem?

P.S. - My car is 1 year and seven months old. has run for around 17500kms. the third free service is still not done as I am waiting for the car to touch 20 thousand kms. I had replaced the engine oil once after 1000kms as advised here on team-bhp and then I think it was replaced at 5000kms by the company.

Last edited by magikrider : 11th June 2014 at 23:21.
magikrider is offline   (1) Thanks Reply With Quote
Old 11th June 2014, 23:00   #2663
Team-BHP Support
 
Vid6639's Avatar
 
Join Date: Jul 2006
Location: Bangalore
Posts: 13,786
Thanked: 16,930 Times
Default Re: XUV 500 niggles and their solutions

If you search this thread, I remember reading about some oil pressure issue. That is most probably the issue you are facing.
Vid6639 is offline   (2) Thanks Reply With Quote
Old 11th June 2014, 23:46   #2664
BHPian
 
magikrider's Avatar
 
Join Date: Mar 2009
Location: MH-01
Posts: 441
Thanked: 80 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Vid6639 View Post
If you search this thread, I remember reading about some oil pressure issue. That is most probably the issue you are facing.
are you by any chance referring to this thread??

http://www.team-bhp.com/forum/techni...-replaced.html (My Mahindra XUV5OO goes DEAD. Update: Engine Replaced)

because he too had oil pressure problem. I am now scared as what if my engine has been damaged due to this oil pressure issue. the last time I drove the car after the kat kat noise, the engine didn't felt as smooth and normal. I had to go somewhere out so took the car out after the noise stopped.
magikrider is offline   Reply With Quote
Old 12th June 2014, 00:22   #2665
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,610
Thanked: 14,894 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by magikrider View Post
are you by any chance referring to this thread??

http://www.team-bhp.com/forum/techni...-replaced.html (My Mahindra XUV5OO goes DEAD. Update: Engine Replaced)

because he too had oil pressure problem. I am now scared as what if my engine has been damaged due to this oil pressure issue. the last time I drove the car after the kat kat noise, the engine didn't felt as smooth and normal. I had to go somewhere out so took the car out after the noise stopped.
Your car is under warranty?
Right?
What I have seen with Tata and Mahindra is that they like proverbs, but they do not understand.

So they read "A stich in time saves nine".
So they think "Gee 9 stiches better than one because 9rs salary better than 1rs salary". Think of Moose in Archies comics.

So they want 9 stiches.
So you go to them wanting one stitch, they will go all matrix on you and say "There is no spoon".

So just jeep driving, no need to be slow or careful, and when it goes "booom" "poooof", you get a new engine.
tsk1979 is offline   (1) Thanks Reply With Quote
Old 12th June 2014, 00:32   #2666
BHPian
 
magikrider's Avatar
 
Join Date: Mar 2009
Location: MH-01
Posts: 441
Thanked: 80 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by tsk1979 View Post
Your car is under warranty?
Right?
What I have seen with Tata and Mahindra is that they like proverbs, but they do not understand.

So they read "A stich in time saves nine".
So they think "Gee 9 stiches better than one because 9rs salary better than 1rs salary". Think of Moose in Archies comics.

So they want 9 stiches.
So you go to them wanting one stitch, they will go all matrix on you and say "There is no spoon".

So just jeep driving, no need to be slow or careful, and when it goes "booom" "poooof", you get a new engine.
you are joking right?

yes the car is under warranty but I don't want it to be turned into a major issue because of negligence and failure to detect and rectify the problem on time by mahindra guys. and can't afford to leave the car in service centre for a long duration as I regularly drive from mumbai to panvel for work in this car. I hope mahindra people are able to help me solve my problem. also what if the engine goes "boooom" "poooof" just after the warranty expires or what if they turn into a skoda and give me a nightmare with engine replacement later on? so better to try and get this thing resolved before any major stuff happens no
magikrider is offline   Reply With Quote
Old 12th June 2014, 08:33   #2667
Newbie
 
Join Date: May 2014
Location: Tezpur
Posts: 8
Thanked: 0 Times
Talking Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by kARTIK IYER View Post
Guys,

I am wanting to fit a night vision reverse camera on my XUV Wanted help on the following :-

1. Which brand is the best.
2. I have heard that you cant fit it from external vendor as mahindra guys need to connect it to HU.
3. If I install camera only in the centre, will the OEM sensors on sides still operate(sorry but I lack knowledge on this).

Please advise
I am myself trying to find a solution. However here is what i have found out till now:-
1. Buying a camera from the open market is much cheaper as compared to dealership. Xenon brand 18.5 day night camera available for Rs 1600/- with warranty in Lucknow.
2. The camera needs to be fixed by dealership as the infotainment system is encoded by Mahindra.
3. I have searched images on internet and it appears that sensors work in addition to the camera. You will get to see the sensor display superimposed on camera output.
4. Only question, will the dealership install a camera purchased from open market.
dubeneeraj is offline   Reply With Quote
Old 12th June 2014, 09:56   #2668
BHPian
 
shrk_18's Avatar
 
Join Date: Mar 2013
Location: Bangalore
Posts: 62
Thanked: 83 Times
Default Re: URGENT HELP Required!

Quote:
Originally Posted by magikrider View Post
Guys, I think there is some serious issue with my XUV and the service centre guys are also not able to detect/help! So need some URGENT HELP!

The problem is when I start my car in the morning or at night time after a day's rest mostly and sometimes even after few hours of rest, it starts making this strange Kat Kat noise. the noise is like theres no engine oil at all. then after a minute or so it goes and the car gets back to normal. this noise is not your regular knocking sound which is present in diesel engines. and also the Oil Lamp shows on when this thing happens.

usually it lasts for a minute or so but the last time it was on and on for 2-3 minutes, thats when i took video. after that I stopped and restarted the car and it was gone.

also this thing has started from a couple of months I think. earlier it never happened. I had also complained about the same issue with the service centre guys and told them that maybe the oil level is low so please get the oil at my place and check for leakage as I won't be able to drive the car to the service centre. and two guys showed up also at my place but that time it was all fine and the noise didn't start at the start up and they also checked the engine oil level which was normal. then it started again so I took it to the service centre and kept my car with them for a few days but they didn't find anything unusual and it didn't show any error. also when I went there to take the deliver, I was told that the car was lying there since yesterday and not moved or started. but when I started there it didn't show the same problem in front of the RM!

So I am again going to take the car tomorrow and keep there and maybe go there again the next day and start again in front of the RM and the technician so they can come to know the exact problem.

my cousin also has a XUV and he told me that he had faced such problem in his brand new (barely a week old) XUV and his car was towed to the service centre and some part which releases the oil into the engine was replaced. and he advised me not to drive the car till then as it can damage the engine. but the RM said I can drive as its normal for the car to make knocking sound at cold start till the engine oil reaches the engine. but this isn't the normal engine knocking at all and has started recently. never faced this problem in the year and a half almost. also I stay in mumbai and not some cold weather that cold start would be an issue in this scorching summer heat. also the problem is usually at morning and night time. not much at afternoon time.

So has any XUV owner faced such problem and if yes how was it solved? what should be done.

I have also taken a video with my iPhone which is in .MOV format and around 89.5MB. so I am not able to upload the video here. is there some way I can upload it here so you guys can see and know the exact problem?

P.S. - My car is 1 year and seven months old. has run for around 17500kms. the third free service is still not done as I am waiting for the car to touch 20 thousand kms. I had replaced the engine oil once after 1000kms as advised here on team-bhp and then I think it was replaced at 5000kms by the company.
Do you see the low oil pressure light when you hear the sound? If so, please turn your engine off immediately.

This I believe is an intermittently failing oil pump. I had this issue in my car and the oil pump was replaced. The oil pump is fused to the timing case in the mHawk engines and hence the entire timing case needs replacement.

Please don't run the vehicle with the oil pump in this state, it can cause serious engine damage, in the worst case an engine failure. In my case there were a very minor scorings on the rings around the crankshaft (please forgive me if my terminology is wrong) and those rings were replaced.

Please have your ASC analyze this angle as this is most likely what you are facing.
shrk_18 is offline   (2) Thanks Reply With Quote
Old 12th June 2014, 12:47   #2669
BHPian
 
magikrider's Avatar
 
Join Date: Mar 2009
Location: MH-01
Posts: 441
Thanked: 80 Times
Default Re: URGENT HELP Required!

Quote:
Originally Posted by shrk_18 View Post
Do you see the low oil pressure light when you hear the sound? If so, please turn your engine off immediately.

This I believe is an intermittently failing oil pump. I had this issue in my car and the oil pump was replaced. The oil pump is fused to the timing case in the mHawk engines and hence the entire timing case needs replacement.

Please don't run the vehicle with the oil pump in this state, it can cause serious engine damage, in the worst case an engine failure. In my case there were a very minor scorings on the rings around the crankshaft (please forgive me if my terminology is wrong) and those rings were replaced.

Please have your ASC analyze this angle as this is most likely what you are facing.
Yes I do see the Oil light on when I hear the sound. the sound and the oil light usually goes in a minute or two. then it becomes normal again and I drive the car. have tried to explain different technicians and RM from mahindra the same but they are not ready to understand and say that "abhi kaha hai?" don't know how to explain them. so I have taken a video of the same and will show them. hope they will understand it then at least.

also you have said that because of this you had minor scorings on the crankshaft, which were replaced. but how would they know if there is any damage inside the engine due to this oil pump issue? coz it would be really difficult to explain them and make them accept and check the engine for any damage. I doubt they would do anything. I am fed up of the mahindra service staff incompetence, that will think ten times next time before buying any mahindra product!
Attached Thumbnails
XUV 500 niggles and their solutions-img_8723.png  


Last edited by magikrider : 12th June 2014 at 12:49.
magikrider is offline   (1) Thanks Reply With Quote
Old 12th June 2014, 12:53   #2670
Team-BHP Support
 
Vid6639's Avatar
 
Join Date: Jul 2006
Location: Bangalore
Posts: 13,786
Thanked: 16,930 Times
Default Re: XUV 500 niggles and their solutions

I suspect oil pump issue as well. Don't use the car if the oil light comes on. It means that the oil is not being circulated properly. As a result the parts are not getting lubricated and will get damaged. Hence the rough sound when you start the car.

If not attended to it will lead to engine seizure and will be extremely painful to fix.
Vid6639 is offline   (2) Thanks Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Metro and City Discrimination By Mahindra- XUV 500 Launch anjan_c2007 The Indian Car Scene 18 29th November 2011 15:10
Niggles, problems (Tyre and Stalling) in Palio 1.6 Sports 2007 anurag_p80 Technical Stuff 31 19th July 2010 17:31


All times are GMT +5.5. The time now is 09:45.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks