Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 26th April 2012, 16:14   #271
BHPian
 
rohitbagai's Avatar
 
Join Date: Aug 2006
Location: New Delhi
Posts: 401
Thanked: 226 Times
Default

Quote:
Originally Posted by moleculez
Steering rack for me was replaced a month before this problem showed up for me! And the most socking was , the mechanic told me " Aisa Hota hai, common hai"

Weird!
Why was it replaced a month back? Seems like a case of shoddy workmanship this time around?
rohitbagai is offline   Reply With Quote
Old 26th April 2012, 16:38   #272
BHPian
 
Rossiter's Avatar
 
Join Date: Apr 2009
Location: Bangalore
Posts: 117
Thanked: 40 Times
Default

Pavan15 also faced the same power steering fluid leaking issue. They've made it a point to check all cars for this point as well. Mine was checked during the 10k service and was found ok.

Upgraded to 4.0 firmware, and the biggest relief is the mic volume improvement. The navigation through the folders when playing from USB could use an improvement.
Rossiter is offline   Reply With Quote
Old 26th April 2012, 19:05   #273
BHPian
 
anandtheleo's Avatar
 
Join Date: Jan 2007
Location: Chennai
Posts: 329
Thanked: 161 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by moleculez View Post
Steering rack for me was replaced a month before this problem showed up for me! And the most socking was , the mechanic told me " Aisa Hota hai, common hai"

Weird!
This has got me worried. I did feel the steering being hard after the change, but I convinced myself its my imagination.
anandtheleo is online now   Reply With Quote
Old 26th April 2012, 19:49   #274
BHPian
 
vrrraju's Avatar
 
Join Date: Jan 2007
Location: Hyderabad
Posts: 185
Thanked: 26 Times
Default Re: XUV 500 niggles and their solutions

Today I took my XUV to the workshop as it had a problem with Airbag light glowing continuously. When I asked Service executive why is it so, he came up with an absurd answer that you have installed the floor mats. How can floor mats disturb the Airbag, then he came up with an explanation indicating that the connections to the Airbag sensors are very delicate and they get disconnected. But he resolved the issue in 10 mins and when I asked him what he did, he replied saying the Firmware was upgraded. How do I know what revision is it upgraded to. I heard from other members that version 4.0 is available for W6, how can I check it on the console or there any other way to do it.

I will be visiting the workshop once again as they need to replace my Bridgestone Tyre which had a faulty valve. They have taken photographs and they want to investigate the same along with Bridgestone team before they can replace a tyre free of cost. It seems I need to fight with both BS and M&M to get a new tyre.

It is a very scary place in the workshop in AML Hyderabad where almost 95% of the vehicles where XUV and one or two scoprio's. It seems the workshop was also used as God down. But I could see number of XUV's which have come up the service (with TR numbers) and most of them had some or the other issue of left/right front wheel. Most of them were W8 and I could see that most of them are from FEB manufactured slot. So I guess the people who got vehicles in the 2nd lot are also facing the same issues that were faced by the people who got earlier.
vrrraju is offline   Reply With Quote
Old 26th April 2012, 20:15   #275
Senior - BHPian
 
AutoIndian's Avatar
 
Join Date: Aug 2010
Location: PCMC, Pune-MH14
Posts: 2,863
Thanked: 3,338 Times
Default Re: XUV 500 niggles and their solutions

This is really worrisome. Was M&M so overwhelmed with the orders pouring in for XUV5OO that they started cutting corners to ramp up the production? Poor workmanship or quality issues should not mar such a wonderful product. I appreciate the efforts of all the XUV owners here on TBHP to bring forth these issues & make everyone aware of them & trying to get these resolved collaboratively. This is a wake up call for M&M, rather than focusing their energies on opening the new bookings & garnering as many as they can, they should go all out to fix these niggling issues for the current owners, else the negative word of mouth publicity could result in irreversible damage not just to the XUV brand, but the company as a whole.
AutoIndian is online now   Reply With Quote
Old 26th April 2012, 21:53   #276
BHPian
 
Gerardfdz's Avatar
 
Join Date: Feb 2004
Location: Mumbai
Posts: 207
Thanked: 55 Times
Default Re: XUV 500 niggles and their solutions

Has any one faced these issues
1) When you brake hard there is a squealing sound from the rear tyres.
2) If you take a curve a little fast - there is rear tyre squeal

This has started recently, after my tyres were changed. Could it be an alignment issue. Though the car does not pull at all to any side, even with I leave the steering.

One more question.
When I purchased the vehicle I got the impression that we would be entitled to at least one upgrade of the maps during the first year. Now I understand that we have to pay for the upgrade!! Worse still don't know till when we will be allowed to keep using the maps!
Has anyone else heard this.
Gerardfdz is offline   Reply With Quote
Old 27th April 2012, 09:47   #277
BHPian
 
sheelapratosh's Avatar
 
Join Date: Feb 2012
Location: Bangalore
Posts: 82
Thanked: 66 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Gerardfdz View Post
Has any one faced these issues
1) When you brake hard there is a squealing sound from the rear tyres.
2) If you take a curve a little fast - there is rear tyre squeal

This has started recently, after my tyres were changed. Could it be an alignment issue. Though the car does not pull at all to any side, even with I leave the steering.

One more question.
When I purchased the vehicle I got the impression that we would be entitled to at least one upgrade of the maps during the first year. Now I understand that we have to pay for the upgrade!! Worse still don't know till when we will be allowed to keep using the maps!
Has anyone else heard this.
Gerardfdz

Looks similar to my problem. please see my post in the previous page. I think its a suspension unit issue - No so much an alignment issue.
sheelapratosh is offline   Reply With Quote
Old 27th April 2012, 09:55   #278
BHPian
 
JeepSomeday's Avatar
 
Join Date: Oct 2011
Location: New Delhi
Posts: 42
Thanked: 34 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by naveenchhillar View Post
Faced one strange issue last night:

When I took a break in the middle of a 110 kms long ride & then, started again - AC was throwing hot blown air despite the fact that the temperature was set around 23-24 degrees. When I decided to make it further below it - same story again. Now, when I made it lowest possible (around 17 or 17.5, I guess) - then only it started giving some cool air. Strange, isn't it ??
Hi Naveen. Did you find out what this issue was. I have started facing the same since the last 3 days. Has happened twice already. AC only start throwing cold air when I bring it ti Lowest temperature. Then I have to gradually start increasing the temp to what I want.

Im taking my car for service tomorrow. Would be great if I could help the RMs with what the possible problem and solution could be.
JeepSomeday is offline   Reply With Quote
Old 27th April 2012, 10:00   #279
Senior - BHPian
 
m_upreti's Avatar
 
Join Date: Feb 2008
Location: Mumbai/Medellin
Posts: 1,556
Thanked: 282 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by vrrraju View Post
I will be visiting the workshop once again as they need to replace my Bridgestone Tyre which had a faulty valve. They have taken photographs and they want to investigate the same along with Bridgestone team before they can replace a tyre free of cost. It seems I need to fight with both BS and M&M to get a new tyre.

It is a very scary place in the workshop in AML Hyderabad where almost 95% of the vehicles where XUV and one or two scoprio's. It seems the workshop was also used as God down. But I could see number of XUV's which have come up the service (with TR numbers) and most of them had some or the other issue of left/right front wheel. Most of them were W8 and I could see that most of them are from FEB manufactured slot. So I guess the people who got vehicles in the 2nd lot are also facing the same issues that were faced by the people who got earlier.
My 2 cents out of past experience, please be very firm with both BS & the A.S.S./Mahindra on the tyre replacement issue. BS would give a detailed investigation report which would be the basis for the replacement liability with them. (In my case (Scorpio) they clearly pointed to faulty tyre alignment which lead to all the 4 tyres getting damaged and mentioned that it could lead to accidents. M&M & A.S.S. forked out 2 tyres each after the report)

It is a shame that despite so much feedback issues continue in the new lots also. I guess the vehicle would take another year or so to stabilise as far as broad level issues are concerned
m_upreti is offline   Reply With Quote
Old 27th April 2012, 14:25   #280
BHPian
 
HotChillyPepper's Avatar
 
Join Date: Jan 2006
Location: Bang_a_lore
Posts: 605
Thanked: 215 Times
Default Re: XUV 500 niggles and their solutions

Anyone tried converting the XUV halogen projector to Xenon?
HotChillyPepper is offline   Reply With Quote
Old 28th April 2012, 08:43   #281
BHPian
 
Gerardfdz's Avatar
 
Join Date: Feb 2004
Location: Mumbai
Posts: 207
Thanked: 55 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by sheelapratosh View Post
Gerardfdz

Looks similar to my problem. please see my post in the previous page. I think its a suspension unit issue - No so much an alignment issue.
well -I just hope it is not the case! As so far not had any mechanical problem other than slight pull to left which with proper alignment equipment had been resolved. This has happened only after my tyres were swapped!.
Hope to have it looked into today.
Gerardfdz is offline   Reply With Quote
Old 30th April 2012, 11:41   #282
BHPian
 
naveenchhillar's Avatar
 
Join Date: Nov 2011
Location: Rohtak-Noida
Posts: 128
Thanked: 31 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by JeepSomeday View Post
I'm taking my W8AWD for its service (5000k). These are the 21 issues/things-to-do that I'll be informing them of. Ive had a great experience with the Koncept Auto service team at Okhla. Santosh and Anil are both great RMs and go all the way to solve things. But some of these problems are just not going away. Hope they will this time...

12. While using my pen drive to play music, when I restart my car, the music plays from the first song in the album, and not where I had left it when switching off.
18 Windows rattle when half open


Will update on each of these post service
Hello,
I had faced above issues in my W6. For problem no. 12, I did found a solution that works most of the times. Get your pendrive formatted & then, copy all the songs/ lists again to the same pen drive & try it again. It has worked for me almost 4 out of 5 times. Only time I was not able to use it - then, I formatted it again & it worked
Though, there is no theory to it because the Head Unit display shows that the media is disconnected & connected again. That's the precise reason, Head Unit thinks that it is a new pen drive inserted in it. But, formatting the same did wonders for me. Please try that & let me know if it is solved or not.

18. Yea, same problem with me as well. Either you make them completely down or completely up. Will get it solve during my 1st service. Please update if yours has been provided with a solution for the same or not.
naveenchhillar is offline   Reply With Quote
Old 30th April 2012, 11:43   #283
BHPian
 
naveenchhillar's Avatar
 
Join Date: Nov 2011
Location: Rohtak-Noida
Posts: 128
Thanked: 31 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by JeepSomeday View Post
Hi Naveen. Did you find out what this issue was. I have started facing the same since the last 3 days. Has happened twice already. AC only start throwing cold air when I bring it ti Lowest temperature. Then I have to gradually start increasing the temp to what I want.

Im taking my car for service tomorrow. Would be great if I could help the RMs with what the possible problem and solution could be.
Hello again,
I did felt this issue only twice (I guess) - both times in nights or when outside temperature was low. However, in the second time - I did changed the mode from AuTO to the one that is just below the button to AUTO (please forgive me for forgetting the name) :(
It did worked then.
naveenchhillar is offline   Reply With Quote
Old 30th April 2012, 18:06   #284
PGA
BHPian
 
Join Date: Apr 2012
Location: Ludhiana
Posts: 113
Thanked: 112 Times
Default Re: XUV 500 niggles and their solutions

Hi
I was going through the thread and realised that I could add up to the data. My silver spirit (W6) is now 25 days old and 815km down the black macadam. The niggles are:-
- Info reads mileage figures of 18-21kpl but actually comes to about 13-15 km/lt.
- Funny (mild) vibrations in steering coloumn around 1800-2000 rpm while accelerating, feels as if something is rubbing around the drive shaft.
- ABS wx light comes on after 10-12 mins of drive in stop/move traffic.
- Headlights come on in the night while locking the vehicle and go off while unlocking.
- Brakes on the softer side. Tires tend to squeak on mildly harsh braking.
- Engine does not feel as responsive as being brought out by members but still not tested adequately. Waiting for odo to cross 1K.
Still infatuated with the beauty to be bothered too much with these niggles. Will wait for the symptons to develop further before taking it to the service yard. Till then will continue to 'bash on regardless'
PGA is offline   Reply With Quote
Old 30th April 2012, 21:07   #285
BHPian
 
rohitbagai's Avatar
 
Join Date: Aug 2006
Location: New Delhi
Posts: 401
Thanked: 226 Times
Default

Quote:
Originally Posted by PGA
Hi
I was going through the thread and realised that I could add up to the data. My silver spirit (W6) is now 25 days old and 815km down the black macadam. The niggles are:-
- Info reads mileage figures of 18-21kpl but actually comes to about 13-15 km/lt.
- Funny (mild) vibrations in steering coloumn around 1800-2000 rpm while accelerating, feels as if something is rubbing around the drive shaft.
- ABS wx light comes on after 10-12 mins of drive in stop/move traffic.
- Headlights come on in the night while locking the vehicle and go off while unlocking.
- Brakes on the softer side. Tires tend to squeak on mildly harsh braking.
- Engine does not feel as responsive as being brought out by members but still not tested adequately. Waiting for odo to cross 1K.
Still infatuated with the beauty to be bothered too much with these niggles. Will wait for the symptons to develop further before taking it to the service yard. Till then will continue to 'bash on regardless'
The mileage figures are bit of the mark may be a 10% in my case. Remember to reset before you actually start calculating the difference.
That vibration is known as torque stear and I don't think it could be classified as a niggle but a flaw.
The headlight on when you lock is a feature known as follow me home and is not a niggle.
My two cents,..
rohitbagai is offline   (2) Thanks Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Metro and City Discrimination By Mahindra- XUV 500 Launch anjan_c2007 The Indian Car Scene 18 29th November 2011 15:10
Niggles, problems (Tyre and Stalling) in Palio 1.6 Sports 2007 anurag_p80 Technical Stuff 31 19th July 2010 17:31


All times are GMT +5.5. The time now is 17:43.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks