Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 30th October 2014, 10:44   #2866
BHPian
 
Join Date: Sep 2007
Location: Kochi
Posts: 111
Thanked: 47 Times
Default

Today I had a talk with the service manager of ktc Mahindra kochi. They seems to have found the solution to the issue of reverse camera not showing up when selected through infotainment screen. Usually reverse cam is connected such that it gets power when reverse gear is engaged. They swapped a wiring so that it gets power always and that solved the problem. I am yet to get mine fixed. Will get that done soon.
gpriyesh is offline   (1) Thanks Reply With Quote
Old 30th October 2014, 19:29   #2867
BHPian
 
kARTIK IYER's Avatar
 
Join Date: Dec 2007
Location: NaviMumbai
Posts: 161
Thanked: 12 Times
Default

Hi guys,

Need some help.

1. I had taken my XUV for a wheel alignment and done a tire swap of spare and right front. I am getting a message as FR tire swap. Is it some warning
2. I want fix a carrier which i can dismantle easily. Any recommendations and dealers in Mumbai.
kARTIK IYER is offline   Reply With Quote
Old 30th October 2014, 19:44   #2868
Team-BHP Support
 
Zappo's Avatar
 
Join Date: Oct 2005
Location: Hyderabad
Posts: 5,478
Thanked: 1,803 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by kARTIK IYER View Post
Hi guys,

Need some help.

1. I had taken my XUV for a wheel alignment and done a tire swap of spare and right front. I am getting a message as FR tire swap. Is it some warning
I will leave the Pt2. for someone from Mumbai to respond. In terms of your first query, yes, it is a warning that your tyretronic needs a calibration. The front right tyre is not the front right anymore. This warning comes in only when you swap 1 set of tyre. If all the tyres change positions then tyretronics gets confused. It does not mention any swap but reports wrong pressure for the tyres.

Get the tyretronics calibrated (check your manual).
Zappo is offline   Reply With Quote
Old 31st October 2014, 18:12   #2869
Senior - BHPian
 
undead's Avatar
 
Join Date: Jan 2008
Location: Bhavani - Komarapalayam
Posts: 1,187
Thanked: 164 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by falconion View Post
There is a "khad khad khad" sound which is quiet loud and has been there from the start. It occurs in AWD lock mode and heard during the following sequence:

- vehicle should be on an incline (incline does not have to be very steep)
- AWD lock mode enabled
- drive the vehicle to a speed of 5-10 kmph in 1st gear
- suddenly fully depress the clutch and release the accelerator
- you will then here the "khad khad khad" sound.

Anyone with the AWD vehicle want to try and see if they have similar sound??

You can download the video that demonstrates the sound in my vehicle from this link: XUV500 AWD Sound video download link
Many XUV owners including me hearing the same sound even in 2WD models. We dont know the exact reason for it.
I am getting it even while driving in 1st gear sometimes (ie) when i am driving at higher rpm and release the throttle suddenly, the sudden deceleration also causes this sound from the font suspension .
undead is offline   (1) Thanks Reply With Quote
Old 31st October 2014, 21:16   #2870
BHPian
 
Join Date: Nov 2010
Location: New Delhi
Posts: 375
Thanked: 80 Times
Default Re: XUV 500 niggles and their solutions

I only hear a "tak" sound when the vehicle goes over uneven patch. Anybody to suggest anything.
Honda Monk is offline   Reply With Quote
Old 1st November 2014, 12:40   #2871
Senior - BHPian
 
m_upreti's Avatar
 
Join Date: Feb 2008
Location: Mumbai/Medellin
Posts: 1,556
Thanked: 282 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by undead View Post
Many XUV owners including me hearing the same sound even in 2WD models. We dont know the exact reason for it.
I am getting it even while driving in 1st gear sometimes (ie) when i am driving at higher rpm and release the throttle suddenly, the sudden deceleration also causes this sound from the font suspension .
Quote:
Originally Posted by Honda Monk View Post
I only hear a "tak" sound when the vehicle goes over uneven patch. Anybody to suggest anything.
The "Tak" noise I have been hearing once every morning for the last 6 years in my Scorpio. I raised is to the A.S.S. and M&M umpteen times but no solution

Conditions:
1. First start in the morning
2. 1st Gear
3. Speed 5-10 Kmh
m_upreti is offline   (1) Thanks Reply With Quote
Old 2nd November 2014, 11:25   #2872
BHPian
 
narendra.vw's Avatar
 
Join Date: Apr 2010
Location: Bangaloru
Posts: 286
Thanked: 383 Times
Default Re: XUV 500 niggles and their solutions

XUV 500 Mid row head rest Mod.

Making Mid row head rest user friendly.

Tools needed.
XUV 500 niggles and their solutions-1.jpg

Method to remove the cover.
XUV 500 niggles and their solutions-2.jpg

Once the cover is out of the way, Head rest cushion is marked to remove the nasty hump.
XUV 500 niggles and their solutions-3.jpg

The cushion is reshaped. A small Bottom hump is for neck support.
XUV 500 niggles and their solutions-4.jpg

Reversing the removal method, we get the finished HR. Slight slack in the HR cover, we have to live with it.
XUV 500 niggles and their solutions-5.jpg
Hope, this(do it yourself) Mod should be useful to XUV 500 Owners.
narendra.vw is offline   (2) Thanks Reply With Quote
Old 2nd November 2014, 19:44   #2873
BHPian
 
abhinavinc's Avatar
 
Join Date: Jul 2012
Location: Ludhiana
Posts: 72
Thanked: 38 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by peterjim13 View Post
I am giving my car for the next service by mid November.

Just wanted to know get a huge set of works/check done on my 2012-W8.

2. The noises from within the cabin is still very active : From the steering console (speedometer), second row seats, and somewhere from the front passenger seat.

3. I can now hear a small not so common noise when the car starts in the morning, or say when put to ignition after long rests. Its hardly a 10 to 20 sec noise, and then it gets to normal. Is there something which needs to be checked urgently.
2. This will never get sorted out no matter how many times the service center fixes it. This is my experience.
3. Even my XUV has also started making this rough noise on startup for about 5 seconds. This rough clatter lasts approximately only till duration of the Mahindra video on the ICE system. My car is a July 2012 model and I have been experiencing the same rough noise as mentioned by you. In fact if you go through the pages there are posts by at least two other members mentioning about the same noise on startup. Till now no satisfactory reply has been received, hope someones gives a proper explanation of the above niggle.
abhinavinc is offline   Reply With Quote
Old 3rd November 2014, 17:19   #2874
BHPian
 
Join Date: Oct 2014
Location: Navi Mumbai
Posts: 38
Thanked: 16 Times
Default Re: Mahindra XUV500 : Test Drive & Review

All,

on my XUV - W8, I have not been able to connect Ipod via USB. Initially it didnt recognize it at all. Then I restored it. Now it shows as "unsupported device".

Any inputs on how to resolve this issue?
balpreetsingh is offline   Reply With Quote
Old 3rd November 2014, 18:34   #2875
BHPian
 
peterjim13's Avatar
 
Join Date: May 2014
Location: Kochi/S.Bathery
Posts: 381
Thanked: 249 Times
Default Re: XUV 500 niggles and their solutions

To all BHPians in Cochin.

What is your take on the new KTC Mahindra. The showroom looks far better than the TVS one. How about the service.

Thanks
Jim
peterjim13 is offline   Reply With Quote
Old 3rd November 2014, 22:35   #2876
BHPian
 
Join Date: Sep 2007
Location: Kochi
Posts: 111
Thanked: 47 Times
Default

Quote:
Originally Posted by peterjim13 View Post
To all BHPians in Cochin.

What is your take on the new KTC Mahindra. The showroom looks far better than the TVS one. How about the service.

Thanks
Jim
Jim - I bought my XUV from ktc since I felt they are more professional than TVS. They have hired a new service manager and I know him personally. He used to service my ford fiesta before and is an excellent guy. So I am sure with him as service manager at KTC it cannot go bad.
gpriyesh is offline   Reply With Quote
Old 4th November 2014, 06:35   #2877
BHPian
 
abhinavinc's Avatar
 
Join Date: Jul 2012
Location: Ludhiana
Posts: 72
Thanked: 38 Times
Default Re: XUV 500 niggles and their solutions

No offences but kindly refrain from making such posts in the niggles thread.


Quote:
Originally Posted by peterjim13 View Post
To all BHPians in Cochin.

What is your take on the new KTC Mahindra. The showroom looks far better than the TVS one. How about the service.

Thanks
Jim
abhinavinc is offline   (1) Thanks Reply With Quote
Old 4th November 2014, 07:35   #2878
BHPian
 
Jred's Avatar
 
Join Date: Sep 2013
Location: Bangalore
Posts: 27
Thanked: 27 Times
Default

I have had my W6 since 15 months. I noticed the following after my third service and 2,200 kms (just over 15 days after the service) on the ODO

1. The dashboard display shows the OBD lamp constantly glowing. I looked up the manual and found there could be an issue with fuel management.

2. The dashboard area does have some noise coming on fairly uneven roads. I understand this is from the oversized hood that's covering display being loose.

3. I experienced a very similar plight as a post earlier. Although the breaks were a bit weaker (rather than failed) or so I felt and didn't stop in the time it should have - no damage done. It did work but was lot weaker and slower. The break pads were replaced during the third service.

I have driven just over 22,600 Kms until now and have to say I am pleased and love it.

Last edited by Aditya : 5th November 2014 at 13:09. Reason: Readability
Jred is offline   Reply With Quote
Old 9th November 2014, 02:32   #2879
BHPian
 
HotChillyPepper's Avatar
 
Join Date: Jan 2006
Location: Bang_a_lore
Posts: 605
Thanked: 215 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by abhinavinc View Post
Even my XUV has also started making this rough noise on startup for about 5 seconds. This rough clatter lasts approximately only till duration of the Mahindra video on the ICE system. My car is a July 2012 model and I have been experiencing the same rough noise as mentioned by you. In fact if you go through the pages there are posts by at least two other members mentioning about the same noise on startup. Till now no satisfactory reply has been received, hope someones gives a proper explanation of the above niggle.
My car also have this "FEATURE". The rough clatter remains only for 5 - 8 seconds and then everything will become normal. As per my service engineer, this is normal and nothing to worry about. He said it is because the the initial few seconds the engine oil pressure is less, and a normal thing in all cars. But still he is unable to give a satisfactory explanation on why it wasn't there till 30K on odo.

thanks
HCP

Last edited by HotChillyPepper : 9th November 2014 at 02:34.
HotChillyPepper is offline   Reply With Quote
Old 9th November 2014, 12:44   #2880
BHPian
 
Join Date: Apr 2006
Location: Noida
Posts: 33
Thanked: 0 Times
Default Re: XUV 500 niggles and their solutions

One of the remote key for central locking is not for my XUV Feb , 2014 (8500km).

Can it be a Battery (remote key battery) failure ? Does a remote key battery lasts only 4-5 months ?

I have not checked it yet with a replaced Battery . What about the warranty
virender is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Metro and City Discrimination By Mahindra- XUV 500 Launch anjan_c2007 The Indian Car Scene 18 29th November 2011 15:10
Niggles, problems (Tyre and Stalling) in Palio 1.6 Sports 2007 anurag_p80 Technical Stuff 31 19th July 2010 17:31


All times are GMT +5.5. The time now is 02:22.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks