Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 22nd January 2015, 10:45   #3061
BHPian
 
fundagenie's Avatar
 
Join Date: Feb 2005
Location: Bangalore
Posts: 443
Thanked: 387 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Jred View Post
Hello folks, I have recently noticed noise while turning the steering wheel. More squealing kind than squeaking. It is intermittent but happens only when I slow down to negotiate a turn- mostly left turns I guess. I had noticed this first time while backing the car to park. I did speak with the RM but haven't been able to visit the service centre yet. Will post an update once I do.

Cheers, Jay
I also faced a similar issue a few months back. But the service guys could not recreate it at during the test drives. They however, removed the tyres, checked the suspension etc. Final diagnosis was it could have been some stone or something lodged in between the tyre or suspension and got dislodged by itself. Anyways have not heard the sound while turning the steering wheel after that, so far.

FundaG
fundagenie is offline   Reply With Quote
Old 22nd January 2015, 21:36   #3062
BHPian
 
abhinavinc's Avatar
 
Join Date: Jul 2012
Location: Ludhiana
Posts: 72
Thanked: 38 Times
Default Re: XUV 500 niggles and their solutions

I am hearing a sound from the right wheel side of 2012 W8 every time i take my car out for a drive. It sounds like rotating metal is rubbing against metal, only when car is on the move.It is a continuous shrrr shrrrr metallic sound- Any pointers on the source and the reason?
P.S. - No stone is stuck in the tyres !
abhinavinc is offline   Reply With Quote
Old 29th January 2015, 15:31   #3063
BHPian
 
HotChillyPepper's Avatar
 
Join Date: Jan 2006
Location: Bang_a_lore
Posts: 605
Thanked: 215 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by abhinavinc View Post
I am hearing a sound from the right wheel side of 2012 W8 every time i take my car out for a drive. It sounds like rotating metal is rubbing against metal, only when car is on the move.It is a continuous shrrr shrrrr metallic sound- Any pointers on the source and the reason?
P.S. - No stone is stuck in the tyres !
Could be the brake pad spring clips came off and they held loose within the caliper assembly causing rubbing against the rotor.

thanks
HCP
HotChillyPepper is offline   Reply With Quote
Old 29th January 2015, 16:04   #3064
BHPian
 
Join Date: Mar 2006
Location: Mumbai
Posts: 133
Thanked: 20 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by SDP View Post
Yes, its quite a loud boom from the speakers. It caught me unawares a couple of times. No particular pattern in terms of when the system reboots.

I understand the system rebooting, may be because of software complexity. I do not understand why the speakers give such a loud boom when that happens.
Yes SDP. You reminded me also of similar episode which i faced almost a year back. This happened when the maps were ON and we were on a vacation to Rajasthan. All of a sudden the infotainment system restarted with a big sound from the speaker. As if something had fused. But I had completely forgotten about this episode and never reported it to the RM. Now i need to get this checked. Will share my findings on this.

Cheers
sumitdongerkery is offline   Reply With Quote
Old 29th January 2015, 17:53   #3065
SDP
Team-BHP Support
 
SDP's Avatar
 
Join Date: Jan 2010
Location: Mumbai
Posts: 3,486
Thanked: 6,751 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by sumitdongerkery View Post
Yes SDP. You reminded me also of similar episode which i faced almost a year back. This happened when the maps were ON and we were on a vacation to Rajasthan. All of a sudden the infotainment system restarted with a big sound from the speaker. As if something had fused. But I had completely forgotten about this episode and never reported it to the RM. Now i need to get this checked. Will share my findings on this.

Cheers
This issue can not be reproduced. There is no pattern. Even at the risk of sounding negative, my guess is that the RM and the service center are just going to ignore it.

But, please do try.
SDP is offline   Reply With Quote
Old 29th January 2015, 18:18   #3066
BHPian
 
Join Date: Aug 2014
Location: Bangalore
Posts: 42
Thanked: 21 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by mpksuhas View Post
I am guessing your car crossed 10K KMS now and that is when the warning got displayed. Nothing to be alarmed about, the system just displays service due alert when you cross service interval based on odo readings (5K, 10K, 20K etc).

When you take the car for service, they clear the alert along with any system updates if any.

I guess since you took the car for service before the alert came at 9.2 K KMS, the service center forgot to clear / was unable to clear the alert.
Hey mpksuhas, took the car to the service centre and as you said, they said that they had forgotten to update the alert and the alert is now gone. Thought of updating the same here. Thanks!
carChef is offline   (1) Thanks Reply With Quote
Old 31st January 2015, 07:28   #3067
Newbie
 
Join Date: Jun 2010
Location: Chennai
Posts: 12
Thanked: 3 Times
Default Re: XUV 500 niggles and their solutions

Hi All,

My XUV 500 W8 is about 2 months, 3400 KM old. Been a pleasure so far. I live in Chennai - use the car primarily for city commute - about 20 KM each day.
About 4 days ago, while returning from office, received an alert in the dash, and it said Low Pressure in Rear Left tire.
Went to the nearest petrol bunk, and it was indeed around 18, while other 3 were at 32. Got the RL upped to 32
Next morning, as soon as I left home, the alert came again.
Drove to India Garage service center and they said they would look at it.
Received a call later in the day that it needed a censor correction, and they fixed it. Free!

Picked up the car in the evening, and just as I left their compound, the alert came back again. Returned to the center and showed them. They were certain it is not a puncture. Since I was in a hurry, they pumped air into that tire to bring it back to 32 and asked me to check overnight. (Pressure was 23)

Next morning, when I left home, the alert is back again. (29th Jan). Went back to India Garage again. End of day, they said it was a small leak in the beading between the rim and the tire and that they fixed it. It was a smooth ride back home.

24 hours later, last evening, on my way back home, the alert came back again (as soon as I pulled out from parking lot). Same tire, same alert.

Will be visiting the service center again in the next couple of hours.

Any clues on why this is happening? I see some old posts from 2012 that referred to niggles with tyretronics. Nothing recent.

Regards,
kk
kkbv is offline   Reply With Quote
Old 31st January 2015, 08:21   #3068
BHPian
 
Sanjunair5's Avatar
 
Join Date: Oct 2010
Location: Pune, India
Posts: 130
Thanked: 142 Times
Default Re: XUV 500 niggles and their solutions

Does XUV tiretronics display pressure now (I know it does in the new Scorp)? Mine doesnt, it is a May 2014 model.
Sanjunair5 is offline   Reply With Quote
Old 31st January 2015, 11:41   #3069
Senior - BHPian
 
m_upreti's Avatar
 
Join Date: Feb 2008
Location: Mumbai/Medellin
Posts: 1,556
Thanked: 282 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Sanjunair5 View Post
Does XUV tiretronics display pressure now (I know it does in the new Scorp)? Mine doesnt, it is a May 2014 model.
It should display, this is available even in the old Scorpio (since 2007) where the display is analogue and you need to press the stick.
m_upreti is offline   Reply With Quote
Old 31st January 2015, 13:24   #3070
BHPian
 
Join Date: Sep 2007
Location: Kochi
Posts: 111
Thanked: 47 Times
Default

Quote:
Originally Posted by m_upreti View Post
It should display, this is available even in the old Scorpio (since 2007) where the display is analogue and you need to press the stick.
Xuv does not display tire pressure. You can see the tire pressure using Mahindra blue sense app in your mobile phone
gpriyesh is offline   (1) Thanks Reply With Quote
Old 31st January 2015, 14:02   #3071
Senior - BHPian
 
m_upreti's Avatar
 
Join Date: Feb 2008
Location: Mumbai/Medellin
Posts: 1,556
Thanked: 282 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by gpriyesh View Post
Xuv does not display tire pressure. You can see the tire pressure using Mahindra blue sense app in your mobile phone
I was not aware of this, then what is the use of TPMS, in my Scorpio it shows both the pressure and temperature of all 5 tyres, when you start the vehicle and to see on the fly you have to press the stick provided in the speedo console.
m_upreti is offline   Reply With Quote
Old 31st January 2015, 15:46   #3072
BHPian
 
djpeesh's Avatar
 
Join Date: Sep 2007
Location: Mumbai
Posts: 537
Thanked: 635 Times
Default

Anyone replaced the stock wipers in the XUV? My LHS wiper is leaving streaks and the rubber seems to have come off. Any good, low noise aftermarket options that have been used by people here?
djpeesh is offline   Reply With Quote
Old 31st January 2015, 18:40   #3073
Newbie
 
Join Date: Jun 2010
Location: Chennai
Posts: 12
Thanked: 3 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Sanjunair5 View Post
Does XUV tiretronics display pressure now (I know it does in the new Scorp)? Mine doesnt, it is a May 2014 model.
No - it doesnt! Sorry if my message was misleading! Merely shows there is a low pressure in a certain tyre.

And, the technicians at India Garage finally found a "small" puncture on the inner wall of the rear left tyre and fixed it before lunch.

I have been happier since then!

Regards,
kk
Attached Thumbnails
XUV 500 niggles and their solutions-wp_20150129_001.jpg  

kkbv is offline   Reply With Quote
Old 31st January 2015, 21:43   #3074
BHPian
 
fundagenie's Avatar
 
Join Date: Feb 2005
Location: Bangalore
Posts: 443
Thanked: 387 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Sanjunair5 View Post
Does XUV tiretronics display pressure now (I know it does in the new Scorp)? Mine doesnt, it is a May 2014 model.
Quote:
Originally Posted by m_upreti View Post
It should display, this is available even in the old Scorpio (since 2007) where the display is analogue and you need to press the stick.
Quote:
Originally Posted by gpriyesh View Post
Xuv does not display tire pressure. You can see the tire pressure using Mahindra blue sense app in your mobile phone
Quote:
Originally Posted by m_upreti View Post
I was not aware of this, then what is the use of TPMS, in my Scorpio it shows both the pressure and temperature of all 5 tyres, when you start the vehicle and to see on the fly you have to press the stick provided in the speedo console.
Quote:
Originally Posted by kkbv View Post
No - it doesnt! Sorry if my message was misleading! Merely shows there is a low pressure in a certain tyre.

And, the technicians at India Garage finally found a "small" puncture on the inner wall of the rear left tyre and fixed it before lunch.

I have been happier since then!

Regards,
kk
The pressure is shown if there is tyre pressure low alert. I think you need to press on the particular tyre on the screen and it shows the pressure. Else you will need to check it with the bluesense app.

FundaG
fundagenie is offline   Reply With Quote
Old 31st January 2015, 21:51   #3075
Senior - BHPian
 
undead's Avatar
 
Join Date: Jan 2008
Location: Bhavani - Komarapalayam
Posts: 1,187
Thanked: 164 Times
Default

Quote:
Originally Posted by kkbv View Post
No - it doesnt! Sorry if my message was misleading! Merely shows there is a low pressure in a certain tyre.

And, the technicians at India Garage finally found a "small" puncture on the inner wall of the rear left tyre and fixed it before lunch.

I have been happier since then!

Regards,
kk
Bluesense app shows tire pressure reading, but not sure whether its accurate.
I had the same experience like you. Once i had the RL tire low pressure a warning (26psi) and i went to the nearest gas station and topup the air . Again after 1 month , i received the same warning. Visited a tire shop and found it had a puncture. Since xuv has a bigger tire , the tire loses the air very slowly compared to sedan tires ? Again few days back had the same warning and another puncture (19psi) . Two punctures on the same tyre and hence sent to spare .
Hats off to Mahindra for providing a full size spare with alloy.
undead is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Metro and City Discrimination By Mahindra- XUV 500 Launch anjan_c2007 The Indian Car Scene 18 29th November 2011 15:10
Niggles, problems (Tyre and Stalling) in Palio 1.6 Sports 2007 anurag_p80 Technical Stuff 31 19th July 2010 17:31


All times are GMT +5.5. The time now is 03:26.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks