Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 29th April 2015, 21:50   #3271
BHPian
 
superbhikari's Avatar
 
Join Date: Jul 2008
Location: Muzaffarnagar
Posts: 411
Thanked: 143 Times
Default Re: Mahindra XUV500 : Test Drive & Review

Quote:
Originally Posted by reevester View Post
Just got back from the Sahyadri Motors Service Center in Wakad, Pune. The Aircon of my 3 year old XUV500 stopped working randomly (and it was a terrible two days in this sweltering heat).

Surprisingly, the A.S.S. told me that there were 7 more cars in the service center with the same issue. Said it had to do with the Aircon reservoir valve getting ruptured after a period of time.

Thought I'd share this info with the rest of the folks here. Will post an update when I get the car back.

Note from Support - Post moved to the relevant thread.
I faced some strange issue in February. The AC blower speed reduced and it cools upto a certain time well and after that no cooling. I get it checked with the A.S.S. and they recommended AC service (ODO was 43k 3yrs.) costing 6k something which i refused then hoping to get exact picture in proper summers of April month. The issue crop up a couple of times more till March. But now all of a sudden, it's working perfectly fine by itself. Now planning to get it checked at next service of 50k.
superbhikari is offline   Reply With Quote
Old 1st May 2015, 22:24   #3272
BHPian
 
Hrishiz's Avatar
 
Join Date: Aug 2009
Location: Kochi
Posts: 72
Thanked: 28 Times
Default Re: XUV 500 niggles and their solutions

I faced a couple of strange issues
  1. Whistling Noise of the turbo
  2. Steering tighter than usual
  3. Infotainment acting weird - The bluetooth gets paired, but when I make a call from the phone it does not 'capture'(the infotanment does not pick up the call). I am able to receive calls and if it is dialled from the infotainment then too the call gets connected to the system.
  4. Brake Pads replacement at 25K

Current Status:
Point - 1
Of all this. The point no. 1 was fixed at KTC, Kochi. And 2nd day after that I hear a sudden fizzle out kind out sound (something like releasing gas from a cylinder) and the XUV lost its pick up. Basically the turbo wen haywire.
Now it will be taken to TVS Maradu on recommendation from Sujai from Mahindra.

Point - 2
Initially they kept telling there is nothing wrong with technical parameters(God knows what those parameters are). The SA at KTC agreed that the steering was tight, showed him a couple of other XUVs (both pre and post 2014 models) where the steering was butter smooth compared to mine. When I got my vehicle it was tighter than it already was and the positioned it incorrectly (Centre was turned sidewards). This too was fixed to around 60% by TVS again as directed by Sujai from Mahindra.

Point - 3
I was told that it is because of the Lolipop update to the OS. Anyone with Samsung Note 3 and Lolipop facing this issue?

Point - 4
I am not sure if this early, my XUV is predominantly driven in city traffic.

All said and done I just love this machine, no matter what I am a fan, cause once I get behind the wheel I just start smiling automatically
Hrishiz is offline   (1) Thanks Reply With Quote
Old 2nd May 2015, 13:11   #3273
BHPian
 
rahul_kej's Avatar
 
Join Date: Jul 2014
Location: Siliguri
Posts: 205
Thanked: 228 Times
Default

Quote:
Originally Posted by Hrishiz View Post
Point - 3
I was told that it is because of the Lolipop update to the OS. Anyone with Samsung Note 3 and Lolipop facing this issue?
I am facing the similar issue after my Nexus is updated to lollipop. It was working absolutely fine with KitKat, hope its sorted out by some software update either by Google or Mahindra.

After pairing, though you can receive calls and but to make a call, first change the source to Bluetooth in infotainment system after that dial the number from the phone.
Me not able to access the phone book in the infotainment system at all, thanks to lollipop.
rahul_kej is offline   Reply With Quote
Old 2nd May 2015, 16:59   #3274
BHPian
 
Wind's Avatar
 
Join Date: Jun 2005
Location: Bangalore
Posts: 276
Thanked: 74 Times
Default Re: XUV 500 niggles and their solutions

Today on my onward drive towards Bangalore airport ( KIAL) I was not able to engage the sixth gear. The gear shift would go all the way to the neutral position and would not go beyond.
However, during my return drive it worked normally. I am perplexed now! Has anyone else experienced this phenomenon?

-- Wind
Wind is offline   Reply With Quote
Old 2nd May 2015, 18:02   #3275
Senior - BHPian
 
humyum's Avatar
 
Join Date: Feb 2006
Location: Leicester/Mumbai
Posts: 2,253
Thanked: 1,783 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Hrishiz View Post

Point - 2
Initially they kept telling there is nothing wrong with technical parameters(God knows what those parameters are). The SA at KTC agreed that the steering was tight, showed him a couple of other XUVs (both pre and post 2014 models) where the steering was butter smooth compared to mine. When I got my vehicle it was tighter than it already was and the positioned it incorrectly (Centre was turned sidewards). This too was fixed to around 60% by TVS again as directed by Sujai from Mahindra.
This my friend according to me is an alignment being out. Can you go to a competent alignment guy in your area and get it sorted ?

Sign one of their alignment machine being faulty ? The steering comes back off center. Usually if everything is okay with the alignment machine, the centering part too is taking care off while they are adjusting the toe.
humyum is offline   Reply With Quote
Old 2nd May 2015, 20:34   #3276
BHPian
 
Hrishiz's Avatar
 
Join Date: Aug 2009
Location: Kochi
Posts: 72
Thanked: 28 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by humyum View Post
This my friend according to me is an alignment being out. Can you go to a competent alignment guy in your area and get it sorted ?
I guess I should have mentioned, the steering was centered while I had given it for the service. In the name of checking every 'parameter' they seems to have fiddled around and managed to give it back by moving it off the center.

I do my alignment checks frequently and the Tyre rotations too.
Hrishiz is offline   Reply With Quote
Old 3rd May 2015, 14:09   #3277
BHPian
 
Join Date: Sep 2007
Location: Kochi
Posts: 111
Thanked: 47 Times
Default Re: XUV 500 niggles and their solutions

Today while cleaning the XUV, I noticed this in the folding seat (one which gains your access to the 3rd row). My XUV is just 7 months old. Frustrating to see this in 15L car. Has anyone else seen such in their vehicles?
Attached Thumbnails
XUV 500 niggles and their solutions-img_20150503_125741967_hdr.jpg  

XUV 500 niggles and their solutions-img_20150503_125810140_hdr.jpg  

gpriyesh is offline   Reply With Quote
Old 3rd May 2015, 16:43   #3278
Senior - BHPian
 
undead's Avatar
 
Join Date: Jan 2008
Location: Bhavani - Komarapalayam
Posts: 1,187
Thanked: 164 Times
Default

Quote:
Originally Posted by gpriyesh View Post
Today while cleaning the XUV, I noticed this in the folding seat (one which gains your access to the 3rd row). My XUV is just 7 months old. Frustrating to see this in 15L car. Has anyone else seen such in their vehicles?
You should show this to the service centre.
I checked my car. There are no rust. Mine is a W8 , puchased on Mar 2014
undead is online now   Reply With Quote
Old 3rd May 2015, 23:25   #3279
BHPian
 
rahul_kej's Avatar
 
Join Date: Jul 2014
Location: Siliguri
Posts: 205
Thanked: 228 Times
Default Re: XUV 500 niggles and their solutions

Since many months I am getting a noise from behind the dash on the left side of the vehicle. The noise comes only on uneven roads, speed breakers, broken roads and while turning the steering wheel. The noise is very plasticky. ASC were not able to solve the issue and has asked me to leave the vehicle with them as they want to remove and check the cross member.

Me really not very keen to get the cross member removed in a 7th month new vehicle. Has anyone come across this similar issue, please share with me as it will be of great help. I am facing no other issues with it, but this sound is becoming irritating.

Last edited by rahul_kej : 3rd May 2015 at 23:28. Reason: spelling error
rahul_kej is offline   Reply With Quote
Old 4th May 2015, 07:15   #3280
BHPian
 
Join Date: Sep 2007
Location: Kochi
Posts: 111
Thanked: 47 Times
Default

Quote:
Originally Posted by rahul_kej View Post
Since many months I am getting a noise from behind the dash on the left side of the vehicle. The noise comes only on uneven roads, speed breakers, broken roads and while turning the steering wheel. The noise is very plasticky. ASC were not able to solve the issue and has asked me to leave the vehicle with them as they want to remove and check the cross member.

Me really not very keen to get the cross member removed in a 7th month new vehicle. Has anyone come across this similar issue, please share with me as it will be of great help. I am facing no other issues with it, but this sound is becoming irritating.
I had a similar sound in the initial months. But it disappeared by itself. Mine is 7 months old.
gpriyesh is offline   Reply With Quote
Old 4th May 2015, 18:18   #3281
BHPian
 
ansumaan's Avatar
 
Join Date: Sep 2014
Location: Bangalore
Posts: 29
Thanked: 11 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by rahul_kej View Post
Since many months I am getting a noise from behind the dash on the left side of the vehicle. The noise comes only on uneven roads, speed breakers, broken roads and while turning the steering wheel. The noise is very plasticky. ASC were not able to solve the issue and has asked me to leave the vehicle with them as they want to remove and check the cross member.

Me really not very keen to get the cross member removed in a 7th month new vehicle. Has anyone come across this similar issue, please share with me as it will be of great help. I am facing no other issues with it, but this sound is becoming irritating.
I have the same issue and my baby is 7 months old too .
it's a noise as if something is loosely dangling in side the lower glove box. Many times I had cleaned the glove box thinking some coin /a small bolt is moving freely inside , But the sound is back next day. Though its a not a consistent irritating rattle , its annoying . Need to check with the SA this week during 10K service.
ansumaan is offline   Reply With Quote
Old 4th May 2015, 18:55   #3282
BHPian
 
ansumaan's Avatar
 
Join Date: Sep 2014
Location: Bangalore
Posts: 29
Thanked: 11 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by rahul_kej View Post
I am facing the similar issue after my Nexus is updated to lollipop. It was working absolutely fine with KitKat, hope its sorted out by some software update either by Google or Mahindra.

After pairing, though you can receive calls and but to make a call, first change the source to Bluetooth in infotainment system after that dial the number from the phone.
Me not able to access the phone book in the infotainment system at all, thanks to lollipop.
After my Moto-G2 (2nd Gen) was upgraded to Lollipop I am also facing the same issue. Though I am able to make /receive calls, the call setup time seems longer and the ring back tone is not heard on the car speaker. I directly hear the "Hello" from other side. May be you guys should wait few sec and see what the phone is doing after you dial.
In the similar lines when I use Google maps I do not hear the turn by turn navigation instruction on speaker / phone (it was audible before upgrade). Same is audible on the phone after disconnecting the bluetooth.

I believe its more of a lollipop problem because the bluetooth soundbar also behaves the same way with Moto G2.
ansumaan is offline   Reply With Quote
Old 4th May 2015, 21:11   #3283
BHPian
 
rahul_kej's Avatar
 
Join Date: Jul 2014
Location: Siliguri
Posts: 205
Thanked: 228 Times
Default

Quote:
Originally Posted by ansumaan View Post
Need to check with the SA this week during 10K service.
So its a common issue in some of the XUVs. If you get it sorted out please let me know how was it done. I don't want the ASC to keep experimenting with my XUV to get it sorted, hope your ASC is experienced enough and know the root of the issue.
rahul_kej is offline   Reply With Quote
Old 5th May 2015, 00:06   #3284
BHPian
 
maglev's Avatar
 
Join Date: Nov 2008
Location: New Delhi
Posts: 752
Thanked: 69 Times
Default Re: XUV 500 niggles and their solutions

Asking on behalf of a friend who has just bought a used XUV 5OO W8 (December 2011)

Which is the best Mahindra Authorised Service Centre in Delhi/ NCR (preferably around South Delhi) ?
maglev is offline   Reply With Quote
Old 5th May 2015, 09:43   #3285
Senior - BHPian
 
mpksuhas's Avatar
 
Join Date: Sep 2009
Location: KA03/KL11
Posts: 2,456
Thanked: 2,630 Times
Default Re: XUV 500 niggles and their solutions

^^ Regarding the rattling from dashboard mentioned about, my XUV (2014 May) also has this issue.
The sound was less noticable during initial days, later around time of 5K service it got more noticiable and I asked the RM to check the same. Since the same is noticed only in certain speeds on certain roads (small undulations) RM was not able to get make out the source of the same.
Again complained the same during 10 K service and they readily agreed to pull apart dash board and check. Since I didnt want to do a trial and error method, decided against the same.

Strangely, the sound subsided around ~13K Kms, however has resurfaced now at about 18K Kms.

My doubt is that some part is loose behind the infotainment system towards right of glove box. This sound is not audible when driving over smooth roads, its only when you drive over broken roads it crops up.
mpksuhas is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Metro and City Discrimination By Mahindra- XUV 500 Launch anjan_c2007 The Indian Car Scene 18 29th November 2011 15:10
Niggles, problems (Tyre and Stalling) in Palio 1.6 Sports 2007 anurag_p80 Technical Stuff 31 19th July 2010 17:31


All times are GMT +5.5. The time now is 06:10.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks