Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 4th June 2015, 19:44   #3331
BHPian
 
PADAS's Avatar
 
Join Date: Apr 2015
Location: Bangalore
Posts: 66
Thanked: 49 Times
Unhappy Re: XUV 500 niggles and their solutions

Finally got the opportunity to take my XUV for a long drive. Drove to Calicut & back over the last weekend with some detours in Wayanad. Overall drive was awesome, but wasn't niggle free . Fortunately nothing new, all had been reported earlier.

Issues faced
- The map interface froze at some point. Stopped responding to touch/key-press. A restart fixed it. Faced the issue only once through the 1000km trip.
- The cruise control shut off itself while trying to increase speed using "+" control button. This happened twice and both times, a restart fixed it. The second time, I continued for a few kms to see if it gets back to normal, but nothing happened.
- Rattling noise from the hood over instrument panel. This ones really irritating. Any DIY suggestions to fix it temporary until the next visit to MASS ?
- The 12v point for the second row seems to be not working. I haven't checked it earlier, so not sure if it was not working from day 1.
- Outside air/odour creeps in even while the AC is in "re-circulation" mode.

Mine is a W8 FWD, Mar 2015 manufactured.
PADAS is online now   Reply With Quote
Old 4th June 2015, 20:51   #3332
BHPian
 
rahul_kej's Avatar
 
Join Date: Jul 2014
Location: Siliguri
Posts: 206
Thanked: 228 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by PADAS View Post

Issues faced
- The map interface froze at some point. Stopped responding to touch/key-press. A restart fixed it. Faced the issue only once through the 1000km trip.
- The cruise control shut off itself while trying to increase speed using "+" control button. This happened twice and both times, a restart fixed it. The second time, I continued for a few kms to see if it gets back to normal, but nothing happened.
- Rattling noise from the hood over instrument panel. This ones really irritating. Any DIY suggestions to fix it temporary until the next visit to MASS ?
- The 12v point for the second row seems to be not working. I haven't checked it earlier, so not sure if it was not working from day 1.
- Outside air/odour creeps in even while the AC is in "re-circulation" mode.

Mine is a W8 FWD, Mar 2015 manufactured.
Will try solving your issues point wise.

- Map freezing once a while is common, as reported by W8 users, I drive W6 so cant give a certain reply, still you can bring this to the notice of MASS.

- Once you increase the speed more than 30kmph with the + button, the cruise control auto shuts and can be used again once switching off and again starting the car. Try not using it as a accelerator.

- The rattle can be solved at the service centre, they wont take much time. Some have tried DIY for this issue by inserting some sponge or rubber material.

- You can try inserting the charger firmly inside the point, still if doesnt work, might be fuse issue or contact terminal problem, MASS can help.

-Outside air creeping in is very minimal in my case, happens with other cars even. I notice it only when driving through smoke or when crossing highly polluting commercial vehicles.

These are minor issues, nothing that cant be sorted out. I was prepared for them before the purchase, so dont be too bothered and enjoy your drive.

Last edited by rahul_kej : 4th June 2015 at 20:52.
rahul_kej is offline   (1) Thanks Reply With Quote
Old 5th June 2015, 08:18   #3333
BHPian
 
triedeverything's Avatar
 
Join Date: Jun 2007
Location: Bangalore
Posts: 492
Thanked: 162 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by rahul_kej View Post
Will try solving your issues point wise.

- Once you increase the speed more than 30kmph with the + button, the cruise control auto shuts and can be used again once switching off and again starting the car. Try not using it as a accelerator.
Quote:
Originally Posted by PADAS View Post
- The cruise control shut off itself while trying to increase speed using "+" control button. This happened twice and both times, a restart fixed it. The second time, I continued for a few kms to see if it gets back to normal, but nothing happened.
Actually, it works like this. If you press and hold the + button for more than 10 seconds (I think!), it automatically disengages the cruise control for that ignition cycle. It's a safety feature. The system does not want a scenario where the button gets stuck.

The correct way to increase speed using the + button (without the risk of stopping the car to reset the system) is to press once, release, again press and leave. You can do this till you attain the desired speed. Each time you press and leave, the speed increases by 2kmph.

I got my button changed thinking it was a flaw. Then I read the manual, and the ASC folks were also not aware. This 'feature' is clearly explained in the manual. Was a good reason to read the manual, cover to cover
triedeverything is offline   (2) Thanks Reply With Quote
Old 5th June 2015, 17:48   #3334
BHPian
 
PADAS's Avatar
 
Join Date: Apr 2015
Location: Bangalore
Posts: 66
Thanked: 49 Times
Smile Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by triedeverything View Post
Actually, it works like this. If you press and hold the + button for more than 10 seconds (I think!), it automatically disengages the cruise control for that ignition cycle. It's a safety feature. The system does not want a scenario where the button gets stuck.
You are right . I too found it in the owners manual later. Manual says "If switch is pressed for more than 12 secs, the switch is assumed to be malfunctioning and the cruise functionality ceases to function in that ignition cycle. To resume functionality, ignition has to toggled."
PADAS is online now   Reply With Quote
Old 7th June 2015, 08:06   #3335
BHPian
 
Join Date: May 2009
Location: bangalore
Posts: 211
Thanked: 55 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by PADAS View Post
- Rattling noise from the hood over instrument panel. This ones really irritating. Any DIY suggestions to fix it temporary until the next visit to MASS ?
-ed.
I found out, during a wash recently that the Plastic Engine Cover on my friends W8 was loosely strung. I tried pressing it snap in place many times, but did not succeed. Then I removed the cover only to realize that the rubber grommets that hold the cover to the engine body (actually 2 of them) were missing.
Wonder how, when the vehicle is just over an year old! This could be a reason for rattle from the hood at times I guess.
gopa99 is offline   (1) Thanks Reply With Quote
Old 8th June 2015, 00:00   #3336
BHPian
 
Join Date: Sep 2013
Location: At sea
Posts: 44
Thanked: 22 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by gopa99 View Post
I searched the thread, I could not find any user complaining of black smoke. I have a dear colleague's W8, which has completed 12K and a little more than a year since purchase. I can find thick black smoke from the car when revving from idle or when climbing a ramp. Though the smoke disappears in mid RPMs, it still comes back with full glory at high RPMs. The fuelling is always from SHELL bangalore. Has other users experienced this?
Last year after completing my Ladakh trip, I had a similar issue. The problem was compounded together with sluggish pick up. I had the engine air filter exchanged but did not help. Finally it turned out that the air mass sensor, which controls the quantity of air intake to the engine was clogged with dust and mud. Just ask your ASC in investigate along these lines.
Hope this helps.
msk016 is offline   (1) Thanks Reply With Quote
Old 8th June 2015, 13:27   #3337
BHPian
 
Join Date: Oct 2008
Location: Chennai
Posts: 50
Thanked: 25 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by PADAS View Post
- The cruise control shut off itself while trying to increase speed using "+" control button. This happened twice and both times, a restart fixed it. The second time, I continued for a few kms to see if it gets back to normal, but nothing happened.
Quote:
Originally Posted by rahul_kej View Post
- Once you increase the speed more than 30kmph with the + button, the cruise control auto shuts and can be used again once switching off and again starting the car. Try not using it as a accelerator.
Quote:
Originally Posted by triedeverything View Post
Actually, it works like this. If you press and hold the + button for more than 10 seconds (I think!), it automatically disengages the cruise control for that ignition cycle. It's a safety feature. The system does not want a scenario where the button gets stuck.
Quote:
Originally Posted by PADAS View Post
You are right . I too found it in the owners manual later. Manual says "If switch is pressed for more than 12 secs, the switch is assumed to be malfunctioning and the cruise functionality ceases to function in that ignition cycle. To resume functionality, ignition has to toggled."
That is right, keep pressing it for 8 or 9 seconds, it gets off for the ignition cycle. Two ways to increase the speed:

option 1) press the + button one time to increase by 2 kmph, repeat this as many times as you need or
option 2) simply press the accelerator pedal to go the desired speed and press the + button 3 times in quick succession.

option 2 is much better since it avoids hearing the click sound too many times and fear of the cruise getting disengaged for the ignition cycle.

When you want to reduce speed on cruise, you could use the '-' button or, cruise off and when reduced to desire speed, press + button 3 times to set that speed as cruise speed.
krishnaraja is offline   (1) Thanks Reply With Quote
Old 8th June 2015, 13:42   #3338
BHPian
 
triedeverything's Avatar
 
Join Date: Jun 2007
Location: Bangalore
Posts: 492
Thanked: 162 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by krishnaraja View Post

When you want to reduce speed on cruise, you could use the '-' button or, cruise off and when reduced to desire speed, press + button 3 times to set that speed as cruise speed.

Why press 3 times? It works with just a single long press for me. The advantage with method 1 is that you will probably get better FE since it increases the speed optimally, as compared to a heavy foot. Yeah, the clicks can be irritating.
triedeverything is offline   Reply With Quote
Old 8th June 2015, 14:40   #3339
BHPian
 
Join Date: Oct 2008
Location: Chennai
Posts: 50
Thanked: 25 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by triedeverything View Post
Why press 3 times? It works with just a single long press for me. The advantage with method 1 is that you will probably get better FE since it increases the speed optimally, as compared to a heavy foot. Yeah, the clicks can be irritating.
why 3 times - well, if you are not using option 1, going with option 2, to set the cruise at the increased speed, press 3 times.

optimal increase with single press, yes that depends on ones need to speed up. accelerating faster is not always heavy foot
krishnaraja is offline   Reply With Quote
Old 8th June 2015, 15:22   #3340
BHPian
 
triedeverything's Avatar
 
Join Date: Jun 2007
Location: Bangalore
Posts: 492
Thanked: 162 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by krishnaraja View Post
why 3 times - well, if you are not using option 1, going with option 2, to set the cruise at the increased speed, press 3 times.
Watch No need the set button or the + - 3 times.
triedeverything is offline   (1) Thanks Reply With Quote
Old 9th June 2015, 18:52   #3341
BHPian
 
Join Date: Jun 2013
Location: Hyderabad
Posts: 40
Thanked: 44 Times
Default Re: XUV 500 niggles and their solutions

Posting on behalf of a friend, who owns a 2014 XUV.

While on recent visit to service center, dealer has suggested that clutch is on harder side and would need replacement @ 40 K.

Currently the car is running @ 35 K.

Now the question:
What is the average life of clutch in XUV? Is it approximately the same suggested for all OR is it some sales gimmick?

We have seen some Scorpios going strong even with 1 Lac KM without replacement, so was just puzzled with XUV part.

Thanks in advance for your help !
SRKHYD is offline   Reply With Quote
Old 9th June 2015, 21:18   #3342
BHPian
 
rahul_kej's Avatar
 
Join Date: Jul 2014
Location: Siliguri
Posts: 206
Thanked: 228 Times
Default

Quote:
Originally Posted by SRKHYD View Post
Posting on behalf of a friend, who owns a 2014 XUV.

While on recent visit to service center, dealer has suggested that clutch is on harder side and would need replacement @ 40 K.

Currently the car is running @ 35 K.

Now the question:
What is the average life of clutch in XUV? Is it approximately the same suggested for all OR is it some sales gimmick?

We have seen some Scorpios going strong even with 1 Lac KM without replacement, so was just puzzled with XUV part.

Thanks in advance for your help !
If it's on a harder side your friend should feel so. Ask him to check on some other XUV before concluding. If your friend feels fine with the clutch then he should continue using it.

The life of a clutch is not fixed and vary from vehicle to vehicle and driving style and condition.
rahul_kej is offline   (1) Thanks Reply With Quote
Old 10th June 2015, 13:49   #3343
BHPian
 
Join Date: Jun 2013
Location: Hyderabad
Posts: 40
Thanked: 44 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by SRKHYD View Post

Posting on behalf of a friend, who owns a 2014 XUV.
Small correction. It is a 2013 XUV.

Does the 2012 / 13 vehicles had more issues in this regard than 2014 / 15 ones?
SRKHYD is offline   Reply With Quote
Old 12th June 2015, 10:58   #3344
BHPian
 
supertinu's Avatar
 
Join Date: Aug 2010
Location: Bangalore
Posts: 697
Thanked: 321 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by SRKHYD View Post
Small correction. It is a 2013 XUV.

Does the 2012 / 13 vehicles had more issues in this regard than 2014 / 15 ones?
Yes. I believe Mahindra rolled up improvements till end of 2013 time frame based on what I have read on TBHP. So cars from 2014 onward would certainly be more niggle free relatively.
supertinu is offline   (1) Thanks Reply With Quote
Old 12th June 2015, 14:47   #3345
BHPian
 
Join Date: Aug 2013
Location: Namma Bengaluru
Posts: 972
Thanked: 955 Times
Default Re: XUV 500 niggles and their solutions

Folks, has anybody come across a rattling sound near passenger front door while moving from a standstill or after negotiating a speed breaker. I am facing this sound as I move the vehicle from standstill or in 2nd gear after crossing a speed breaker. It will be there for couple of seconds and once the car gains momentum it disappears. Any help will be appreciated! Thanks in advance.

Last edited by fusionbang : 12th June 2015 at 14:48.
fusionbang is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Metro and City Discrimination By Mahindra- XUV 500 Launch anjan_c2007 The Indian Car Scene 18 29th November 2011 15:10
Niggles, problems (Tyre and Stalling) in Palio 1.6 Sports 2007 anurag_p80 Technical Stuff 31 19th July 2010 17:31


All times are GMT +5.5. The time now is 19:21.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks