Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 12th June 2015, 16:10   #3346
BHPian
 
wads78's Avatar
 
Join Date: Sep 2008
Location: Hyderabad
Posts: 113
Thanked: 3 Times
Default Re: XUV 500 niggles and their solutions

What is the average fuel consumption for a 2014 model ? i recently purchased a W6 (not the facelift) and have done about 900 kms till now, i am getting an average of 7 kms/litre
wads78 is offline   Reply With Quote
Old 12th June 2015, 16:14   #3347
BHPian
 
Join Date: Aug 2013
Location: Namma Bengaluru
Posts: 964
Thanked: 937 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by wads78 View Post
What is the average fuel consumption for a 2014 model ? i recently purchased a W6 (not the facelift) and have done about 900 kms till now, i am getting an average of 7 kms/litre
Average fuel consumption should be around 11- 12 KMPL during the initial days, I recently got a April 2014 manufactured W8 model and it is returning an average of 10.9 KMPL in Bangalore city traffic with 100% AC on with 930Kms on the ODO.

Is the mileage quoted by you from the infotainment or from tankful method?
fusionbang is online now   Reply With Quote
Old 12th June 2015, 16:18   #3348
BHPian
 
wads78's Avatar
 
Join Date: Sep 2008
Location: Hyderabad
Posts: 113
Thanked: 3 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by fusionbang View Post
Average fuel consumption should be around 11- 12 KMPL during the initial days, I recently got a April 2014 manufactured W8 model and it is returning an average of 10.9 KMPL in Bangalore city traffic with 100% AC on with 930Kms on the ODO.

Is the mileage quoted by you from the infotainment or from tankful method?
The infotainment shows 9.0 KMPL. I measured using the tankful method, will get it checked
wads78 is offline   Reply With Quote
Old 12th June 2015, 16:39   #3349
BHPian
 
Join Date: Feb 2014
Location: Pune
Posts: 144
Thanked: 194 Times
Default

Quote:
Originally Posted by fusionbang View Post
Folks, has anybody come across a rattling sound near passenger front door while moving from a standstill or after negotiating a speed breaker.

I don't own a XUV; I have had a few opportunities to drive it however that rattle was the first thing that caught my attention. My diagnosis basis this limited experience says that it's the number plate that vibrates to create that metallic noise. The examples mentioned in your post are situations where there could be excess vibrations from the engine due to clutch release/load increase

However as mentioned, I ain't qualified enough to provide more insights, I just hope it helps you to diagnose and fix it
Rajiv0909 is offline   (1) Thanks Reply With Quote
Old 12th June 2015, 18:46   #3350
BHPian
 
live2drive's Avatar
 
Join Date: Oct 2008
Location: New Delhi
Posts: 523
Thanked: 25 Times
Default Re: XUV 500 niggles and their solutions

Any idea what the bulb type is on the high beam?

I know the low beam is a H7 and the cornering light bulbs are H1.
live2drive is offline   Reply With Quote
Old 12th June 2015, 19:17   #3351
BHPian
 
Join Date: Aug 2013
Location: Namma Bengaluru
Posts: 964
Thanked: 937 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Rajiv0909 View Post
I don't own a XUV; I have had a few opportunities to drive it however that rattle was the first thing that caught my attention. My diagnosis basis this limited experience says that it's the number plate that vibrates to create that metallic noise. The examples mentioned in your post are situations where there could be excess vibrations from the engine due to clutch release/load increase

However as mentioned, I ain't qualified enough to provide more insights, I just hope it helps you to diagnose and fix it
I am sure it is not from outside, it is from inside and somewhere near the upper glove box or on the left passenger door.

Can anybody confirm if the top glove box is properly aligned in their cars or is it slightly projected out?

Quote:
Originally Posted by live2drive View Post
Any idea what the bulb type is on the high beam?

I know the low beam is a H7 and the cornering light bulbs are H1.
Even the High beams are H7 55W. Refer the image below

XUV 500 niggles and their solutions-bulb-specs-xuv.jpg
fusionbang is online now   (2) Thanks Reply With Quote
Old 13th June 2015, 00:17   #3352
BHPian
 
Join Date: Sep 2007
Location: Kochi
Posts: 111
Thanked: 47 Times
Default

Quote:
Originally Posted by fusionbang View Post
I am sure it is not from outside, it is from inside and somewhere near the upper glove box or on the left passenger door.

Can anybody confirm if the top glove box is properly aligned in their cars or is it slightly projected out

Attachment 1381291
Top glove box is not perfectly aligned in my car. It is slightly projected out. Mine is Aug 2014 w8
gpriyesh is offline   (1) Thanks Reply With Quote
Old 13th June 2015, 00:48   #3353
BHPian
 
tamojoym's Avatar
 
Join Date: Dec 2007
Location: Bangalore
Posts: 67
Thanked: 26 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by gpriyesh View Post
Top glove box is not perfectly aligned in my car. It is slightly projected out. Mine is Aug 2014 w8
The clip of the top dash board needs a firm push to get it into place mostly on the left side .There are 2 clips on each side of the cover .So if you are opening the glove box from the drivers seat you generally apply force on the right side of it to close it and the left side remains out .

Another thing I noticed that the lap belt in the middle row is not sufficient to belt up an adult .Am I missing anything could not find any way to adjust the length .
tamojoym is offline   (1) Thanks Reply With Quote
Old 15th June 2015, 10:32   #3354
BHPian
 
Join Date: Sep 2007
Location: Kochi
Posts: 111
Thanked: 47 Times
Default

I got my first niggle after 9 months of ownership, but it looks minor though. For the past one week, the hill descent and ascent warning lamp glows intermittently. It goes off if you switch off and on the engine. Took it to ASS and they found an error code coming from a coupler and tightened it. But this issue is still persisting. It came back again today morning. ASS is going to sent someone to my place tomorrow to check this. Has anyone else experienced this?
gpriyesh is offline   Reply With Quote
Old 16th June 2015, 10:29   #3355
Newbie
 
Join Date: Jan 2014
Location: Mumbai
Posts: 17
Thanked: 2 Times
Default Re: XUV 500 niggles and their solutions

Hey all, I had got my beast (a W8) last September and now I am experiencing driving the beast in the rains for the first time with the onset of monsoons.

I am having a problem of fogging in the front windshield. I switched on the defogger switch for the front windshield but still no improvement. Anybody has any tips on this?

I was planning on some long drives during the monsoons so this would really help.

Thanks
Vivek
vivekiyer20 is offline   Reply With Quote
Old 16th June 2015, 11:05   #3356
BHPian
 
tamojoym's Avatar
 
Join Date: Dec 2007
Location: Bangalore
Posts: 67
Thanked: 26 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by vivekiyer20 View Post
I am having a problem of fogging in the front windshield. I switched on the defogger switch for the front windshield but still no improvement. Anybody has any tips on this?
When you have the defogger on increase the temperature to something hotter than outside temperature -the fog will go .This was told during the explanation of features during delivery .I tested it and it works .
tamojoym is offline   (1) Thanks Reply With Quote
Old 17th June 2015, 09:06   #3357
BHPian
 
triedeverything's Avatar
 
Join Date: Jun 2007
Location: Bangalore
Posts: 492
Thanked: 162 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by vivekiyer20 View Post
I am having a problem of fogging in the front windshield. I switched on the defogger switch for the front windshield but still no improvement.
The trick is to switch on the defogger in moderation, and then switch it off. It takes less than 15 seconds to clear the droplets. What usually happens is that we forget about it and it chills the windscreen to such an extent that water starts forming on the outside. This can be wiped away using the wiper, but it continues to form.

One thing that's always worked for me in such a scenario is to turn the knob to hot air. Remember to switch off in time!

I love the single touch function of de humidifying the windscreen. No need to turn knobs, change recirculation, direction, etc. It would have helped if in addition to recirculation, it would have also automatically changed to hot air. Would have valued it more that some of the other gimmicks they've recently come up with.
triedeverything is offline   (1) Thanks Reply With Quote
Old 17th June 2015, 16:42   #3358
BHPian
 
Join Date: Oct 2006
Location: Trivandrum
Posts: 195
Thanked: 39 Times
Default Re: XUV 500 niggles and their solutions

Hi All,

I've a 2014 November XUV 500 W8 with me, which has just crossed 10K mark. I am facing a weird problem, not sure whether anyone in our forum has faced this issue.

When I shift the gear from first to second, I hear a moderately loud "Thud" sound from below the body. A few observations

- this sound is heard/noticed only when I shift from first to second gear.
- this sound comes once in a while only. One observation is that I start hearing the sound after driving the beast within the city (which includes a lot of gear shifts, half-clutch) for quite some time. But I have also observed this during long trips, where I have to negotiate city traffic in between.

During the recent second service, I had complained about this issue, and I took the car for a test drive along with the service adviser. As is usually the case, we could not reproduce the scenario. Anyone has any idea about this issue?

Apart from this one issue, the car is just superb to drive - specially long distance. I'm also getting very good mileage - I'm a sedate driver, and I easily get 18+ kmpl during my highway drives - by keeping it in the range of 1500-2000 RPM.

Regards,
Vivek
vivekkr_99 is offline   (1) Thanks Reply With Quote
Old 18th June 2015, 11:55   #3359
Newbie
 
Join Date: Jun 2013
Location: Bangalore
Posts: 15
Thanked: 6 Times
Default Re: XUV 500 niggles and their solutions

My XUV's steering has become tight. I've gone 4 times to the service center. Earlier there was a metallic noise coming while turning right. The SA said it is some "back plate" touching. It got repaired in the first 2 visits - repaired in the first visit, then came back and the repaired permanently in the second. I thought the steering tightness would go away with that fix but it didn't. The 3rd time I read up the niggles thread and asked the SA to check the power steering fluid. He said its full and isn't leaking as others here have seen. Went a 4th time again, and complained again about the steering while getting other issues fixed like brake noise. This time I was firmer with the SA and told him to take it seriously. After the repair he said they've drained the entire power steering fluid and filled it again.

The tightness is still there!

Mind you this is not a wee bit tight, but a "use two hands and all your muscular strength while maneuvering in traffic" tight. I see that wheel alignment is a bit off (to the left) but that has been there since a long time and was bearable. Don't think it is because of that.

Anyone has any pointers on what could be the problem here? Some worn out belt? The motor itself worn out. Car is just 14k driven. It was all butter smooth till 13k and then suddenly got so hard..

Please help. Alternatively any leads on which service center in bangalore to go for this kind of issue? I've been going to Sireesh auto, marathahalli.
singhangad is offline   Reply With Quote
Old 18th June 2015, 12:09   #3360
BHPian
 
Join Date: Jun 2014
Location: Shimla
Posts: 63
Thanked: 22 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by wads78 View Post
What is the average fuel consumption for a 2014 model ? i recently purchased a W6 (not the facelift) and have done about 900 kms till now, i am getting an average of 7 kms/litre
I am facing the same issue wads78. The infotainment was showing 12.x earlier but after I reset the infotainment to default values its not moving beyond 9 no matter how sedately I drive. I have not measured the mileage using the tankful method. Mine is a Sept, 2014 W6

One thing which I am confused about is if the ARAI certified mileage of XUV prefacelift is 15.1 is it possible for the car to return figures of 16,17 or even 18 kmpl as many members have experienced.
Ritesh_Dogar is online now   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Metro and City Discrimination By Mahindra- XUV 500 Launch anjan_c2007 The Indian Car Scene 18 29th November 2011 15:10
Niggles, problems (Tyre and Stalling) in Palio 1.6 Sports 2007 anurag_p80 Technical Stuff 31 19th July 2010 17:31


All times are GMT +5.5. The time now is 19:25.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks