Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 13th November 2015, 17:45   #3646
BHPian
 
rahul_kej's Avatar
 
Join Date: Jul 2014
Location: Siliguri
Posts: 205
Thanked: 228 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by mpksuhas View Post
I too face this issue with my Moto G Lollipop, it used to work fine with my LG KitKat model.

The issue is when you dial any number from phone, however if you select call to any contact from infotainment systems call history it works fine.

Mine is W8, so I guess it's present across variants.
In my case i even cant access call history or dial from infotainment system. The only positive i see is that it is encouraging me to go for i phone. Hope there is no such issue with latest ios.
rahul_kej is offline   Reply With Quote
Old 13th November 2015, 18:12   #3647
Senior - BHPian
 
Join Date: May 2013
Location: Namma Bengaluru
Posts: 1,027
Thanked: 1,386 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by rahul_kej View Post
The only positive i see is that it is encouraging me to go for i phone. Hope there is no such issue with latest ios.
I use iPhone 6 with iOS 9.1. And no issues so far after infotainment firmware upgrade in Sept during first service.
abirnale is offline   Reply With Quote
Old 13th November 2015, 18:45   #3648
BHPian
 
bejoy's Avatar
 
Join Date: Mar 2004
Location: Bangalore
Posts: 587
Thanked: 364 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by rahul_kej View Post
Hello Bhpians,

I am owning a 2014 XUV w6. The bluetooth was working fine with my Nexus 5 Kitkat version of Android, but since my phone was updated to Android 5 that's Lollipop, the calling feature through Bluetooth is not working, though its playing the songs over it. I though the issue will be solved when my phone is updated to Android 6 i.e Marshmallow, but the problem still persists. Anyone facing this issue.
I use Windows Phone. But thought I will check with my wife's Moto G3 running 5.1.1 Lolipop. Everything works - dialing, receiving call, phonebook, including the call history (which does not work with my Windows phone).

Since you mention that the music plays, just to make sure, have you selected the phone device with the correct one? And when you paired the phone did you initiate it from the car?
bejoy is online now   Reply With Quote
Old 13th November 2015, 19:35   #3649
BHPian
 
djpeesh's Avatar
 
Join Date: Sep 2007
Location: Mumbai
Posts: 537
Thanked: 635 Times
Default

Quote:
Originally Posted by mpksuhas View Post
I too face this issue with my Moto G Lollipop, it used to work fine with my LG KitKat model.

The issue is when you dial any number from phone, however if you select call to any contact from infotainment systems call history it works fine.

Mine is W8, so I guess it's present across variants.
I have the same issue with my Xperia z3 running Marshmallow. No issues with Samsung Galaxy S5. Even on Kitkat, the xperia had the same issue.

With the s5, it even reads out text messages and an alert pops up on the display.
djpeesh is offline   Reply With Quote
Old 13th November 2015, 20:40   #3650
BHPian
 
rahul_kej's Avatar
 
Join Date: Jul 2014
Location: Siliguri
Posts: 205
Thanked: 228 Times
Default

Quote:
Originally Posted by bejoy View Post
I use Windows Phone. But thought I will check with my wife's Moto G3 running 5.1.1 Lolipop. Everything works - dialing, receiving call, phonebook, including the call history (which does not work with my Windows phone).

Since you mention that the music plays, just to make sure, have you selected the phone device with the correct one? And when you paired the phone did you initiate it from the car?
Will try with my dads Moto g3 then. Yes tried all the above, result is still the same.

Tried adding my phone with both the options as shown in picture, result is the same.
Attached Thumbnails
XUV 500 niggles and their solutions-1447427370156.jpg  

rahul_kej is offline   Reply With Quote
Old 17th November 2015, 17:08   #3651
BHPian
 
Join Date: Jun 2014
Location: Shimla
Posts: 63
Thanked: 22 Times
Default Re: XUV 500 niggles and their solutions

This Sunday while taking my XUV to my parking I faced the clutch stuck issue for the first time.
The parking has a steep incline and to top it off the ramp at the start of the incline is too steep and has a sharp angle on the right side.
I have not taken my vehicle to the parking till now and it was usually parked on the road as I feared scratching/denting it from any of the sides while taking it to the parking.
I was reversing the XUV all the way upto the parking, when I was done with the incline and the XUV reached the parking spot I pressed the clutch, it didnt come up for the first time but came back to its resting position the second time. The foul smell of clutch plate taking pressure and burning was present without any smoke. I pressed the clutch a few more times, it felt a little hard for some time but became normal after that.

I fear the dreaded clutch plate failure issue might come up with my XUV as well.
Can anyone who had faced the issue suggest anything (inspection or some testing) that can be/needs to be done to identify if the clutch plate is about to fail or not.
Ritesh_Dogar is offline   Reply With Quote
Old 17th November 2015, 17:38   #3652
BHPian
 
HotChillyPepper's Avatar
 
Join Date: Jan 2006
Location: Bang_a_lore
Posts: 605
Thanked: 215 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Ritesh_Dogar View Post
This Sunday while taking my XUV to my parking I faced the clutch stuck issue for the first time.
The parking has a steep incline and to top it off the ramp at the start of the incline is too steep and has a sharp angle on the right side.
I have not taken my vehicle to the parking till now and it was usually parked on the road as I feared scratching/denting it from any of the sides while taking it to the parking.
I was reversing the XUV all the way upto the parking, when I was done with the incline and the XUV reached the parking spot I pressed the clutch, it didnt come up for the first time but came back to its resting position the second time. The foul smell of clutch plate taking pressure and burning was present without any smoke. I pressed the clutch a few more times, it felt a little hard for some time but became normal after that.

I fear the dreaded clutch plate failure issue might come up with my XUV as well.
Can anyone who had faced the issue suggest anything (inspection or some testing) that can be/needs to be done to identify if the clutch plate is about to fail or not.
Looks like in the process of parking you rode on clutch. But since the clutch pedal didn't return to the original position I guess there could be leakage in slave cylinder (the notorious XUV clutch issue). Since XUV has the slave cylinder built inside the transmission case, the fluid would have made the clutch plate wet and would have caused more slippage and burn it further. First thing would be to check the brake fluid level in the reservoir. If it is well below Max mark, most probably we have a failed clutch. Its better to get this attended by the service centre. When they open the transmission if there is leakage inside you are entitled to get the clutch and slave cylinder replacement under warranty.

-HCP

Last edited by HotChillyPepper : 17th November 2015 at 17:40.
HotChillyPepper is offline   (2) Thanks Reply With Quote
Old 20th November 2015, 12:37   #3653
Newbie
 
Join Date: Jun 2014
Location: Hyderabad
Posts: 5
Thanked: 4 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by bejoy View Post
I use Windows Phone. But thought I will check with my wife's Moto G3 running 5.1.1 Lolipop. Everything works - dialing, receiving call, phonebook, including the call history (which does not work with my Windows phone).
Which windows phone version do you have on your phone. Call history works fine for me with 8.1 and the recent 10 .

Thanks,
Gaurav
gnarang is offline   Reply With Quote
Old 20th November 2015, 18:53   #3654
BHPian
 
bejoy's Avatar
 
Join Date: Mar 2004
Location: Bangalore
Posts: 587
Thanked: 364 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by gnarang View Post
Which windows phone version do you have on your phone. Call history works fine for me with 8.1 and the recent 10 .
I am on Win 8.1. The call history works, but its flaky.


Another bug I found in the ICE is that it uses only the last 7 digits when getting the name details. That is, if you are getting a call, the phonebook is digged for only the last 7 digit match. I found this the hard way. And finally found out those two guys who had the similar numbers
(it could be 7 or lower, since those two numbers had its last 7 digits same)

Initially I thought it was some phonebook sync issue with my phone.

Last edited by bejoy : 20th November 2015 at 18:57.
bejoy is online now   Reply With Quote
Old 21st November 2015, 17:35   #3655
BHPian
 
Join Date: Feb 2014
Location: Bangalore
Posts: 29
Thanked: 8 Times
Default Re: XUV 500 niggles and their solutions

Found another niggle with my Dec2013 manufactured XUV. The lug nuts and the wheel did not budge/come out even after I stood one it. I have explained the puncture ordeal in the below thread with tips to prevent getting stranded.
http://www.team-bhp.com/forum/techni...ml#post3852756 (Pictorial Guide: How to change a flat tyre!)

This is definitely related to the niggle I mentioned in the below posts.
http://www.team-bhp.com/forum/techni...ml#post3378845 (XUV 500 niggles and their solutions)

http://www.team-bhp.com/forum/techni...ml#post3378805 (XUV 500 niggles and their solutions)

Is there any rubber compound or something else that can be safely applied between the wheel and the hub to prevent jamming up of the wheel ? The manual clearly mentions no oil inside the lug nuts though.
sriram.raghavan is offline   Reply With Quote
Old 21st November 2015, 23:38   #3656
BHPian
 
Join Date: Jun 2014
Location: Shimla
Posts: 63
Thanked: 22 Times
Default

This happens when the rattle gun was used to tighten the nuts on the wheelafter an alignment/wheel balancing/ puncture repair. Usually this is done by guys at alignment shops or puncture repair shops instead of tightening the nuts with the wrench provided for the purpose. Its being done by technicians in mahindra service in my area too. In many cases it goes unnoticed, I have faced the issue once with my XUV and Chevy Spark too. After those incidents i tell the RM strictly to not use the rattle gun while tightening the screws on the wheels
Ritesh_Dogar is offline   Reply With Quote
Old 23rd November 2015, 17:00   #3657
Senior - BHPian
 
Tanveer_2558's Avatar
 
Join Date: Apr 2015
Location: Mumbai
Posts: 1,305
Thanked: 1,236 Times
Default Re: XUV 500 niggles and their solutions

My New Age, W10 is at the service centre past more than a week, due to a gear lever issues, Which was making gear vibrations and noises while accelerating, They don't have it in stock and for some reason its taking more than the usual 2-3 days to arrange it.
Tanveer_2558 is online now   Reply With Quote
Old 23rd November 2015, 22:19   #3658
BHPian
 
Join Date: Feb 2014
Location: Bangalore
Posts: 29
Thanked: 8 Times
Default Re: XUV 500 niggles and their solutions

Its not just the lug nuts, The wheel itself was jammed up and did not get out. Please read my post.
sriram.raghavan is offline   Reply With Quote
Old 26th November 2015, 13:02   #3659
BHPian
 
triedeverything's Avatar
 
Join Date: Jun 2007
Location: Bangalore
Posts: 492
Thanked: 162 Times
Default Re: XUV 500 niggles and their solutions

A friend has an XUV and it's getting it's 40K service being done. The brake pads were replaced at 20K. Now at 40K, they say that both the brake pads and DISCs need to be replaced. Couldn't find any previous thread about replacing both. They say the disc cannot be machined. Is that true?
triedeverything is offline   Reply With Quote
Old 26th November 2015, 13:30   #3660
Senior - BHPian
 
Tanveer_2558's Avatar
 
Join Date: Apr 2015
Location: Mumbai
Posts: 1,305
Thanked: 1,236 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by triedeverything View Post
A friend has an XUV and it's getting it's 40K service being done. The brake pads were replaced at 20K. Now at 40K, they say that both the brake pads and DISCs need to be replaced. Couldn't find any previous thread about replacing both. They say the disc cannot be machined. Is that true?
Either the dealership is scamming your friend, Or your friend drives or rather brakes like a maniac, I was given a suggestion to replace the disc's at my 80K service, Pads were first changed at 30k service as faar as i can recall.
Tanveer_2558 is online now   (1) Thanks Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Metro and City Discrimination By Mahindra- XUV 500 Launch anjan_c2007 The Indian Car Scene 18 29th November 2011 15:10
Niggles, problems (Tyre and Stalling) in Palio 1.6 Sports 2007 anurag_p80 Technical Stuff 31 19th July 2010 17:31


All times are GMT +5.5. The time now is 03:43.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks