Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 2nd November 2012, 22:14   #1111
BHPian
 
Vasuki's Avatar
 
Join Date: Jul 2011
Location: Venice of East
Posts: 305
Thanked: 178 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Zappo View Post
Just not sure now whether it makes sense to again knock on M&M's doors for something so petty. Nothing much will come out by talking to the dealer/A$$
Normally during service schedule they give us back a filled form where the fuel level is mentioned(Hyundai had a detailed form, I expect every vehicle service centre has similar forms).

You can use that to take the service centre to task.
Vasuki is offline   (1) Thanks Reply With Quote
Old 2nd November 2012, 22:31   #1112
Senior - BHPian
 
parsh's Avatar
 
Join Date: Aug 2010
Location: Bombay
Posts: 1,453
Thanked: 873 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Xryder View Post
What is the manufacture month and year of your friend's XUV?
Thats the Sep 2011 one of the first batches of XUV5OO. But I doubt it has anything to do with it given that even the later batches are showing PS failure.
parsh is offline   Reply With Quote
Old 3rd November 2012, 00:11   #1113
BHPian
 
rohitbagai's Avatar
 
Join Date: Aug 2006
Location: New Delhi
Posts: 401
Thanked: 226 Times
Default

Quote:
Originally Posted by Zappo
Nothing of the sorts sseems to have happened. No long TD (even as per the odo). Heck they struggled to finish the work on the 3rd day as they were seriously slipping and I had read out the riot act to them to finish it by Wednesday evening come what may. Before it got repaired the dead PS meant the car was absolutely like a 2 tonne slab of concrete with almost a jammed steering.

Also, my car returns above 12 kmpl in city. So even if I take a conservative estimate of 15 ltrs diesel gone that will require close to a 200 kms drive. Anyway, its futile talking about these. I know someone siphoned off the diesel when my vehicle was standing like an orphan in a corner of that A.S.S. for the first 2 days.

Just not sure now whether it makes sense to again knock on M&M's doors for something so petty. Nothing much will come out by talking to the dealer/A$$
When the job card is opened it has a section to indicate the level as per the fuel indicator. If you find it below that level you can ask for their explanation.
EDIT: Just saw the above post so please ignore mine.

Last edited by rohitbagai : 3rd November 2012 at 00:12.
rohitbagai is offline   (2) Thanks Reply With Quote
Old 3rd November 2012, 02:58   #1114
anm
BHPian
 
Join Date: Sep 2010
Location: Delhi
Posts: 35
Thanked: 3 Times
Default Re: XUV 500 niggles and their solutions

I am feeling a little nervous. Maybe my car has some niggle and I may not notice it. I was thinking of a small xuv owners get together/ club where people can see each other's XUVs and discuss their set of issues.
anm is offline   (1) Thanks Reply With Quote
Old 3rd November 2012, 05:30   #1115
BHPian
 
Vasuki's Avatar
 
Join Date: Jul 2011
Location: Venice of East
Posts: 305
Thanked: 178 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by parsh View Post
Thats the Sep 2011 one of the first batches of XUV5OO. But I doubt it has anything to do with it given that even the later batches are showing PS failure.
I had a detailed chat with RM regarding this. They say this problem of PS failure has to do with earlier batches. They have done the needful in the recent batches, also she is yet to encounter the issue with current batches.

Anyway let's hope this stays true and such issues gets rectified asap.

@ Zappo : can you pls specify your manufacturing month, also to

@debuda : as your cousin encountered similar issue, I presume.
Vasuki is offline   Reply With Quote
Old 3rd November 2012, 06:44   #1116
BHPian
 
debuda's Avatar
 
Join Date: Sep 2012
Location: Kolkata
Posts: 402
Thanked: 1,287 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Vasuki View Post
I had a detailed chat with RM regarding this. They say this problem of PS failure has to do with earlier batches. They have done the needful in the recent batches, also she is yet to encounter the issue with current batches.

Anyway let's hope this stays true and such issues gets rectified asap.

@ Zappo : can you pls specify your manufacturing month, also to

@debuda : as your cousin encountered similar issue, I presume.
My nephew's XUV-W6 which recently had a PS failure (ruptured hydraulic pipe) was purchased in mid-June 2012 at Bombay, so it should be an end-May / early-June batch.
debuda is offline   Reply With Quote
Old 3rd November 2012, 15:44   #1117
BHPian
 
magikrider's Avatar
 
Join Date: Mar 2009
Location: MH-01
Posts: 441
Thanked: 80 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by debuda View Post
Hi Magikrider -- Looks like both of us got our Oct 2012 batch XUV's around the same time, i.e., end October. It will be nice to keep exchanging notes as we experience our XUV's over the months / years.
sure sir, after all thats what this forum is all about.. share experiences and help fellow bhpians if possible.

Quote:
Originally Posted by debuda View Post
Alignment : IMHO, you should take the car to the service centre right away and get the problem rectified. But before that, do check that air pressure in both your front wheels is the same.

Some guys have reported on this forum that their front wheels were interchanged and the problem (car pulling to one side) went away -- but I'm unable to comprehend the technical rationale behind this fix. Brand new wheels are supposed to be identical and it should not matter where in the car they are positioned. Please observe closely how they rectify your problem and share it with us.
Quote:
Originally Posted by SDP View Post
Clearly an alignment issue. Unless you are driving large number of kms every day and unless the issue is severe, I would suggest accumulate a few issues before visiting the service center.

If you start visiting the service center for every single thing, slowly you migt start getting irritated and might feel that the vehicle is spending too much time at the service center.

PS: Although the fuel-lid open switch caved in on day-1 for my car, I went to the service center only after about a month. By that time, I had a list of 4-5 small things to be fixed/adjusted.
I haven't checked the air-pressure yet. will get it checked first. but still I think the pull to one direction shouldn't happen. haven't noticed such a thing in any of my previous cars despite of varied psi on different tyres manny times.

also the demo guy from the showroom had told that the tyres come filled with nitrogen, which i think may not be true as SDP also said earlier, but still was thinking what to fill now, regular air or nitrogen.

I have already covered some 350+ kms now. and my running so far has been good. and though I have noticed the pulling towards left, its not too serious or something which requires immediate attention and I think I can manage it till 1000 kms or so when I plan to visit the service centre for the engine oil change. and besides makes sense as SDP said, will cover more miles and note everything till then, if any more issues pops up, can get it all sorted together.

Quote:
Originally Posted by debuda View Post
First service / oil change : I thought this is at 5000 km.
It is according to the company. but the experts here suggest to get it changed after the first 1000 kms. specially for diesels, if I am not mistaken. keeps the engine smooth and improves the performance and life.

Quote:
Originally Posted by debuda View Post
Dimming of instrument cluster lights : When the headlights are switched on, the instrument cluster lights are dimmed. I think this is by design -- headlights would be switched on only in the night and the instrument cluster lights need to be brighter during daytime.
I too thought the same.. but you get a bit paranoid with your new car and want to be double sure about everything.

anyways... took my car for its first long highway drive yesterday and covered 150kms. all nice and good. the engine is a bit restrained and not as free and open as what I found on the test drive car. maybe its still very new and just 350 kms old yet so. hope it gets smooth and peppy soon.

noticed one more small issue if you can call it that, the AC blow in the middle row is very less. front and last row has controls to select the speed so its much more but the middle row is very less. hope its normal.

overall I am very happy with the car and would recommend it to anyone in this price range looking for a spacious long distance cruiser for stress free traveling.
magikrider is offline   (2) Thanks Reply With Quote
Old 3rd November 2012, 18:38   #1118
BHPian
 
Join Date: Aug 2009
Location: Hyderabad
Posts: 24
Thanked: 5 Times
Default Re: XUV 500 niggles and their solutions

Guys, this is not a niggle really. My XUV W8 is about 3 months old now and I have started noticing that for the first couple of minutes each morning when the AC starts off, the smell is foul. It goes off after the first 2 - 3 minutes.
The Service Engineer here says that this is normal and is caused by mould and other stuff growing in the air filters and ducts of the HVAC system.
Anybody else noticed this?

Also, the Service Engineer showed me the filters - they are a simple wire nylon mesh one. Its nothing like the HEPA filters you get in the imported vehicles (the Honda CRV for example)

The AC system air filers for the XUV are located near the footwell on the driver's side. It comes as two rectangular cassettes that need to be inserted one after another into the holder.
Are there any replacements (may be imported ones) that are HEPA filters and reduce odor.

I know the car perfumes may be seen as a solution, but I am more interested in solving the root cause of the problem and not masking it.
iride is offline   (1) Thanks Reply With Quote
Old 4th November 2012, 20:13   #1119
BHPian
 
Wind's Avatar
 
Join Date: Jun 2005
Location: Bangalore
Posts: 276
Thanked: 74 Times
Default Re: XUV 500 niggles and their solutions

Late September I took the car for the three month service. Along with the regular service following were the niggles that were fixed.

1. Left front window stuck in the closed position - The motor was replaced.
2. Outside odor/air coming in when the flaps are set in the re-circulation mode - As per RM this was an issue of flaps not closing completely and they fixed it by consulting with Mahindra.
3. Right side mirror rubbing against the door when closing
4. AC sometimes would only start after five to ten minutes of driving -As per RM, this was a software issue and they have updated the software. The problem has reappeared once in the last one month.

After I got back the car after service, I realized that the steering column was not centered . After few days, the left window was again stuck. Took it back, to A$$ and they replaced the motor and fixed the steering correctly.

After that I had gone on a 1500 KM round trip to Kerala and I did not encounter any niggles during the drive.


-- Wind
Wind is offline   (1) Thanks Reply With Quote
Old 5th November 2012, 01:19   #1120
BHPian
 
magikrider's Avatar
 
Join Date: Mar 2009
Location: MH-01
Posts: 441
Thanked: 80 Times
Default Re: XUV 500 niggles and their solutions

Ok so one more thing I have noticed which might not be a niggle but not sure so posting here.

My building is on a slope so when I stop in between the slope and pull the handbrake, I noticed that even after the hand brake is deactivated the car still remains stopped in the middle of the slope for 3 secs or so and then it starts going back!! and all this while the Hill hold button was not pressed and not activated! and its not like the handbrake is stuck even after deactivating or anything because the car can move forward but it wont go back for 3 secs or so even if I have not pressed brakes. so does the hill hold function work after deactivating the handbrake even if you have not activated the hill hold function for safety so that you get the time of 3 secs to push the handbrake lever back and press the accelerator and move ahead? is this a feature in the car?

Last edited by magikrider : 5th November 2012 at 01:23.
magikrider is offline   Reply With Quote
Old 5th November 2012, 03:00   #1121
Newbie
 
Join Date: Oct 2012
Location: Vadodara
Posts: 16
Thanked: 3 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by magikrider View Post
Ok so one more thing I have noticed which might not be a niggle but not sure so posting here.
Hill hold function cannot be deactivated, it's always on. The button on the centre console is for Hill descent control, which provides engine-assisted braking while going downhill.
raj.singh is offline   (2) Thanks Reply With Quote
Old 5th November 2012, 05:29   #1122
BHPian
 
kaiserketkar's Avatar
 
Join Date: Sep 2007
Location: Pune
Posts: 182
Thanked: 81 Times
Default

Quote:
Originally Posted by magikrider
Ok so one more thing I have noticed which might not be a niggle but not sure so posting here.

My building is on a slope so when I stop in between the slope and pull the handbrake, I noticed that even after the hand brake is deactivated the car still remains stopped in the middle of the slope for 3 secs or so and then it starts going back!! and all this while the Hill hold button was not pressed and not activated! and its not like the handbrake is stuck even after deactivating or anything because the car can move forward but it wont go back for 3 secs or so even if I have not pressed brakes. so does the hill hold function work after deactivating the handbrake even if you have not activated the hill hold function for safety so that you get the time of 3 secs to push the handbrake lever back and press the accelerator and move ahead? is this a feature in the car?
The button is not for the hill hold control, it's for hill descent control. Hill hold function is perpetually active and it is because of that, I that your car didn't move backwards for 3 secs.
kaiserketkar is offline   (1) Thanks Reply With Quote
Old 8th November 2012, 12:32   #1123
BHPian
 
Xryder's Avatar
 
Join Date: Aug 2010
Location: Banana Republic
Posts: 207
Thanked: 74 Times
Default

First of all, a big thanks to sheelapratosh for this elaborate post which covers most of the common issues.

When I started facing issues, started searching for this post and proved quite helpful.

Now I will try to add to sheelapratosh's post and list out the issues and the solutions.

Mine is a May12 manufactured W8. Totally run 1777KMs as of date.


Quote:
Originally Posted by sheelapratosh

1.Brake effectiveness: Mahindra used steel pads instead of the traditional ceramic pads for the XUV. Hence they are experiencing the "effectiveness" issue. Their R&D is working on this issue as their top priority. Based on my conversation with the Customer Support and R&D teams, once reconfigured/updated pads are introduced, all old vehicles will be recalled and fixed.

What should you do: Drive safely, get used to the braking distance.
Solution : New modified pads available at all service centers. Replacement done and issue solved.


Quote:
Originally Posted by sheelapratosh
2.Noise from front wheel brakes: Same explanation applies here. For those who complain, Mahindra is replacing the pads with new sets of pads. Until the issue is fixed by R&D, there is no other go.

What should you do: Get used to the annoying noise for the time being. Hope Mahindra will fix the issue in next 1-2 months.
Solution : Replacement with modified pads fixes this.

Quote:
Originally Posted by sheelapratosh
3.Tiretronics malfunction: You will get erroneous display in your center console (W8) whenever you exceed 90kmph or so. If you experience this problem, it means that your vehicle has a faulty tire pressure sensor.

What should you do: Get to the dealership - They will change the sensor propmptly.
Solution : Sensor replacement along with the coupling fixes this.


Quote:
Originally Posted by sheelapratosh
4.Hill descent and ascent erroneous display: This display pops up even when you drive thru speed breakers..

What should you do: Software patch fixes this issue.
Solution : Software upgrade to version 4.x should resolve this. As per the RM, all the new deliveries carry v3.8. An upgrade is recommended.


Quote:
Originally Posted by sheelapratosh
5.Clutch throwback & notchy gears(1/2nd) : I have experienced this in my car.

What should you do: The service folks did some tweaking. It fixed the issue to a great extent. But not fully resolved. Based on the information I gathered from a parts supplier to the clutch maker (A French company).. It looks like the first set of vehicles came out with a faulty clutch. A minor tweaking/modification was needed. Newer vehicles have been fixed. If you visit a dealership, they seem to fix this issue.
Solution : Experienced the notchy gears but not that frequently. So the issue was not reproducible.


Quote:
Originally Posted by sheelapratosh
6.Excessive fan noise from the center console: In the W8 variants, if you have observed closely, you will notice that the fan noise from the entertainment system is too high. Try to mute your audio system and switch off the engine - Don't pull out the keys - You will notice what I am writing about. (Try in a quiet place please..)

What should you do: Based on NIPPO engineers(I got to talk), this issue might get resolved in newer batches. I insisted on a replacement whenever this issue is resolved. Let's see how that goes. IF you are a super sensitive person like me, please bring this up with your RM & insist on a replacement.
Solution : Not seen so far. Assuming that mine has the fix.


Quote:
Originally Posted by sheelapratosh
7.Center console switches off automatically: Software issue

What should you do: Get the latest patch applied. In my case, the frequency reduced. However, I still have this issue once in a while.
Solution : Not seen so far.

Quote:
Originally Posted by sheelapratosh
8.Car drags towards right: The service folks claimed that they fixed the wheel alignment. However, the issue is still unresolved.

Latest software patch as of last week fixes this issue. I had this problem and its completely resolved.

9. ABS, ESP and Hill Ascent+Descent lights up at start. Constantly on and not just once.

Solution : OBD diagnosis showed error from rear right wheel speed sensor+wiring+coupling. Replacement fixed this issue.


If anyone else has faced any new issue or if the same issues with a different approach to the solution, please do add to the list.

Cheers.
X

Last edited by Xryder : 8th November 2012 at 12:53.
Xryder is offline   (2) Thanks Reply With Quote
Old 8th November 2012, 21:48   #1124
SDP
Team-BHP Support
 
SDP's Avatar
 
Join Date: Jan 2010
Location: Mumbai
Posts: 3,502
Thanked: 6,787 Times
Default Re: XUV 500 niggles and their solutions

I have a doubt about my XUV.
The dome light in my car appears like the picture shown below.
XUV 500 niggles and their solutions-dsc_1111.jpg

What I have marked in white circles are what I believe are small LEDs which are either not working or are significantly weaker than the remaining LEDs in the same part.

Can other owners please check and comment?
SDP is offline   Reply With Quote
Old 8th November 2012, 23:37   #1125
BHPian
 
debuda's Avatar
 
Join Date: Sep 2012
Location: Kolkata
Posts: 402
Thanked: 1,287 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by SDP View Post
I have a doubt about my XUV.
The dome light in my car appears like the picture shown below.
Attachment 1012355

What I have marked in white circles are what I believe are small LEDs which are either not working or are significantly weaker than the remaining LEDs in the same part.

Can other owners please check and comment?
After reading your post, I checked my own car. My light looks similar.

IMHO the dots you have circled are not LEDs but built-in protrusions in the plastic cover which are used as fasteners for locking the cover in place. When light passes through a transparent / translucent object which has different thicknesses or appendages in different areas, the brightness of the emerging light appears non-uniform due to varying refractive index and attenuation of the different areas.
debuda is offline   (1) Thanks Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Metro and City Discrimination By Mahindra- XUV 500 Launch anjan_c2007 The Indian Car Scene 18 29th November 2011 15:10
Niggles, problems (Tyre and Stalling) in Palio 1.6 Sports 2007 anurag_p80 Technical Stuff 31 19th July 2010 17:31


All times are GMT +5.5. The time now is 07:42.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks