Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
LinkBack Thread Tools Search this Thread
Old 23rd February 2012, 09:44   #106
BHPian
 
Behemoth's Avatar
 
Join Date: Jul 2011
Location: Gurgaon
Posts: 747
Thanked: 590 Times
Default Re: XUV 500 niggles and their solutions

So far in the 5800 Kms of our ownership of a W6 XUV.
Some issues faced:
1) we have seen sometimes that the Infotainment unit hangs, which can be solved by turning off the ignition and turning back on. This has happened 3 times so far in 3 months of ownership.
2) Also, the 2nd Gear and the 6th gear are a little hard to slot, compared to the other gears (even after the oil change to synthetic oil).
3) Low beam headlights have become 50% of what they were initially and output is very low. High beam is still perfect.
4) Brake discs are rusting very badly - I know this is normal, but the amount of rusting is abnormally high as compared to any of our other cars, so it can be a pointer to a lower quality of metal (cast Iron with higher impurities in this case) used for the brake disk.
5) The XUV continues to pull towards the left, inspite of being serviced 3 weeks back and alignment having being done at the workshop

Clutch is not too hard - Though it does have a sharp recoil, it is not too hard to press and is comparable to other diesel cars (even our Yeti).

Regards,
Behemoth

Last edited by Behemoth : 23rd February 2012 at 09:55.
Behemoth is offline   (2) Thanks Reply With Quote

Old 23rd February 2012, 19:37   #107
BHPian
 
sheelapratosh's Avatar
 
Join Date: Feb 2012
Location: Bangalore
Posts: 81
Thanked: 66 Times
Default

Friends,

This is my first post. Thought I will make it as a useful post by giving you some tips and trics of how to handle your initial XUV issues.

My current car: XUV W8 FWD
My previous cars: CAMRY LE 2002(US), CAMRY XLE 2007(US), SWIFT VXi(INDIA)

Since the mods were to edit this post, I used a text format instead of presenting this in a table. Hope this is useful.

Unfortunately, I had all the issues mentioned below.

1.

Brake effectiveness: Mahindra used steel pads instead of the traditional ceramic pads for the XUV. Hence they are experiencing the "effectiveness" issue. Their R&D is working on this issue as their top priority. Based on my conversation with the Customer Support and R&D teams, once reconfigured/updated pads are introduced, all old vehicles will be recalled and fixed.

What should you do: Drive safely, get used to the braking distance

2.

Noise from front wheel brakes: Same explanation applies here. For those who complain, Mahindra is replacing the pads with new sets of pads. Until the issue is fixed by R&D, there is no other go.

What should you do: Get used to the annoying noise for the time being. Hope Mahindra will fix the issue in next 1-2 months.

3.

Tiretronics malfunction: You will get erroneous display in your center console (W8) whenever you exceed 90kmph or so. If you experience this problem, it means that your vehicle has a faulty tire pressure sensor.

What should you do: Get to the dealership - They will change the sensor propmptly.

4.

Hill descent and ascent erroneous display: This display pops up even when you drive thru speed breakers..

What should you do: Software patch fixes this issue.

5.

Clutch throwback & notchy gears(1/2nd) : I have experienced this in my car.

What should you do: The service folks did some tweaking. It fixed the issue to a great extent. But not fully resolved. Based on the information I gathered from a parts supplier to the clutch maker (A French company).. It looks like the first set of vehicles came out with a faulty clutch. A minor tweaking/modification was needed. Newer vehicles have been fixed. If you visit a dealership, they seem to fix this issue.

6.

Excessive fan noise from the center console: In the W8 variants, if you have observed closely, you will notice that the fan noise from the entertainment system is too high. Try to mute your audio system and switch off the engine - Don't pull out the keys - You will notice what I am writing about. (Try in a quiet place please..)

What should you do: Based on NIPPO engineers(I got to talk), this issue might get resolved in newer batches. I insisted on a replacement whenever this issue is resolved. Let's see how that goes. IF you are a super sensitive person like me, please bring this up with your RM & insist on a replacement.

7.

Center console switches off automatically: Software issue

What should you do: Get the latest patch applied. In my case, the frequency reduced. However, I still have this issue once in a while.

8.

Car drags towards right: The service folks claimed that they fixed the wheel alignment. However, the issue is still unresolved.

Quote:
Originally Posted by mshooli View Post
Another problem I have noticed is that the ICE restarts .... just like that. It happened for the first time a few days back when I was driving and it did happen again yesterday when I was driving. Not sure what the problem is. It seems to be a very minor one and hence reluctant to take it to a service center where they might mess up the whole thing. Anyone face this kind of issue ?
Latest software patch as of last week fixes this issue. I had this problem and its completely resolved.

Last edited by Zappo : 28th February 2012 at 21:48. Reason: Consecutive posts merged
sheelapratosh is offline   (7) Thanks Reply With Quote
Old 25th February 2012, 22:08   #108
BHPian
 
nikhileshgrover's Avatar
 
Join Date: Sep 2007
Location: Bangalore
Posts: 52
Thanked: 6 Times
Default

Quote:
Originally Posted by sheelapratosh

Latest software patch as of last week fixes this issue. I had this problem and its completely resolved.
Is there any version number of the software that's running on the Xuv?

Has anyone used Blaupunkt G series sun film on the Xuv? I am getting a quote of Rs. 6200/- for G20 on back and sides and G70 for windshield. Any feedback on this brand from existing users. They are offering a 6 year warranty on the film. It metal based and is 1.5 ply in construction .
nikhileshgrover is offline   Reply With Quote
Old 26th February 2012, 20:17   #109
BHPian
 
Gerardfdz's Avatar
 
Join Date: Feb 2004
Location: Mumbai
Posts: 202
Thanked: 55 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by nikhileshgrover View Post
Is there any version number of the software that's running on the Xuv?
The latest version is 3.06.

Just had my first service done vehicle has done 3100kms, They have re-flashed the software- some how the vehicle feels smoother and more hope fully the infortainment system works well.
Gerardfdz is offline   (1) Thanks Reply With Quote
Old 27th February 2012, 12:04   #110
Senior - BHPian
 
m_upreti's Avatar
 
Join Date: Feb 2008
Location: Mumbai
Posts: 1,447
Thanked: 212 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by sheelapratosh View Post
Friends,

This is my first post. Thought I will make it as a useful post by giving you some tips and trics of how to handle your initial XUV issues.<<snip>>
Great knowledge base for the current owners and hope for the prospects that these would be resolved before the next lot is shipped.

Last edited by noopster : 29th February 2012 at 14:33. Reason: Edited quoted text
m_upreti is offline   Reply With Quote
Old 27th February 2012, 18:39   #111
Newbie
 
Perplexed's Avatar
 
Join Date: Nov 2011
Location: Bengaluru
Posts: 9
Thanked: 7 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Gerardfdz View Post
Well just back from an overnight trip to Nashik. The vehicle ran fine, cruse control too!
Few niggles
1. The tyretronics started acting up. On the way up- the rear right then on the way back the rear left! Screen shows error and the gauge too displays the tyre symbol.
2 often on restarting -the whole system would go blank and an "Application error" message would flash. Tried taking a photo with the phone but text could be seen! Some HDMI.exe ........ Something or the other?
3 after parking the car and locking up few minutes later alarm goes off- went to check if I had not locked properly or a cat trying to get comfortable between the front axel - notice water dripping - could it be the A/C has frozen the cooling coil?
Could anyone comment.

Will be talking to M&M or Nippon
Rgds
Hi Gerardfdz,

I am also having the problem with the alarm going off on my W8. I had mentioned about this issue to the RM during the first service and he said its a software issue on the ICE. They updated the software, but the issue still persists! Has your problem been resolved? If it has been resolved, could you please share what was done to rectify the issue?

Regards,
Nithin
Perplexed is offline   Reply With Quote
Old 28th February 2012, 21:29   #112
BHPian
 
Gerardfdz's Avatar
 
Join Date: Feb 2004
Location: Mumbai
Posts: 202
Thanked: 55 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Perplexed View Post
Hi Gerardfdz,

I am also having the problem with the alarm going off on my W8. I had mentioned about this issue to the RM during the first service and he said its a software issue on the ICE. They updated the software, but the issue still persists! Has your problem been resolved? If it has been resolved, could you please share what was done to rectify the issue?

Regards,
Nithin
Well I have not been getting the alarm recently - so fingers crossed- it could be that the upgrade has rectified that issue. Check your SW version and lets know.

However -recent observation-New niggle!
After a phone call- the music goes back to radio! even if I was listening to the iPod before the call!
I need to keep a eye open to see if this happens again.
Rgds
Gerardfdz is offline   Reply With Quote
Old 28th February 2012, 21:32   #113
BHPian
 
nikhileshgrover's Avatar
 
Join Date: Sep 2007
Location: Bangalore
Posts: 52
Thanked: 6 Times
Default

Quote:
Originally Posted by Gerardfdz

Well I have not been getting the alarm recently - so fingers crossed- it could be that the upgrade has rectified that issue. Check your SW version and lets know.

However -recent observation-New niggle!
After a phone call- the music goes back to radio! even if I was listening to the iPod before the call!
I need to keep a eye open to see if this happens again.
Rgds
Pardon my ignorance, but how do we check the software version?
nikhileshgrover is offline   Reply With Quote
Old 28th February 2012, 22:21   #114
BHPian
 
Gerardfdz's Avatar
 
Join Date: Feb 2004
Location: Mumbai
Posts: 202
Thanked: 55 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by nikhileshgrover View Post
Pardon my ignorance, but how do we check the software version?
Sorry I thought it was common knowledge -
well just press the Mute and >>Seek buttons together.
The latest upgrade is Ver3.06

If you press the TR and List together you can see the Maps version.

Regards

Last edited by Gerardfdz : 28th February 2012 at 22:22.
Gerardfdz is offline   (2) Thanks Reply With Quote
Old 28th February 2012, 22:32   #115
BHPian
 
nikhileshgrover's Avatar
 
Join Date: Sep 2007
Location: Bangalore
Posts: 52
Thanked: 6 Times
Default

350 kms done so far. Issues that I am currently facing

1. Notchy gear shift
2. Infotainment system rebooted once
3. Peculiar sound coming while accelerating in 2nd and 3rd gears. Is this the infamous grating that has been reported earlier?
4. Front LHS speaker is cracking. Need to remove some stuff from door pockets and check if cracking sound continues
5. Minor rattles inside the cabin. Need to check if its because of the nicks and knacks kept in the car

Will report these during the first service. Otherwise it's an awesome machine
nikhileshgrover is offline   Reply With Quote
Old 28th February 2012, 22:37   #116
Newbie
 
Perplexed's Avatar
 
Join Date: Nov 2011
Location: Bengaluru
Posts: 9
Thanked: 7 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by Gerardfdz View Post
Check your SW version and lets know.
The software was upgraded to 3.06 during the first service. The issue persists and it is really embarrassing to the extent that I dread taking the vehicle to public places! The problem appears after the vehicle has run for half an hour or more. The alarm does not go off after shorter runs. As you had pointed out earlier, am trying to figure out if it has something to do with condensation from the AC.

And yeah, I too had some issues with the 3.06 upgrade - the screen would show "USB Reading" whenever I pressed the "Phone" button to make a call! Luckily this happened only on one of my trips and has not surfaced again. Hope it stays that way.

Regards,
Nithin
Perplexed is offline   Reply With Quote
Old 28th February 2012, 23:16   #117
BHPian
 
tachobells's Avatar
 
Join Date: Oct 2007
Location: bangalore
Posts: 227
Thanked: 115 Times
Default Re: XUV 500 niggles and their solutions

Quote:
Originally Posted by nikhileshgrover View Post
350 kms done so far. Issues that I am currently facing

3. Peculiar sound coming while accelerating in 2nd and 3rd gears. Is this the infamous grating that has been reported earlier?
Yes, it is. Seems like this is a feature, not a bug.
Temporary solution - keep the music playing all the time.
tachobells is offline   (1) Thanks Reply With Quote
Old 29th February 2012, 02:06   #118
BHPian
 
rohitbagai's Avatar
 
Join Date: Aug 2006
Location: New Delhi
Posts: 400
Thanked: 210 Times
Default

Quote:
Originally Posted by Perplexed

The software was upgraded to 3.06 during the first service. The issue persists and it is really embarrassing to the extent that I dread taking the vehicle to public places! The problem appears after the vehicle has run for half an hour or more. The alarm does not go off after shorter runs. As you had pointed out earlier, am trying to figure out if it has something to do with condensation from the AC.

And yeah, I too had some issues with the 3.06 upgrade - the screen would show "USB Reading" whenever I pressed the "Phone" button to make a call! Luckily this happened only on one of my trips and has not surfaced again. Hope it stays that way.

Regards,
Nithin
Nithin, in my case the alarm is activated mostly at night time when the follow me home lights are activated and I don't shut them down manually by pressing the unlock button. The alarm activates after 10-15 minutes in that case. However when I manually switch off the follow me home lights the alarm does not activate. Does in your case the alarm activates at day time too?
rohitbagai is offline   Reply With Quote
Old 29th February 2012, 10:43   #119
BHPian
 
Join Date: Feb 2009
Location: Bangalore
Posts: 70
Thanked: 19 Times
Default Re: XUV 500 niggles and their solutions

WIERD ISSUE WITH XUV500

For some strange reason my XUV blinks Engine Check light.
I was able to re-create this scenario more than twice, not sure if anybody has come across this issue.

to recreate the scenario
1. Unlock the XUV and then insert the key and switch on (dont crank the engine)
2. Connect your iPhone (I have a iPhone 4) to the system using the USB connector to the cars system
3. List the playlist using the button "List" and using the jogdial select one of the playlist and start playing the songs
you will then notice that the engine check light is now blinking.
Cranking your engine will not work no matter how much you try.

A quick fix was to turn off the key without removing the key and then switch on after which the engine check light will dissappear.
now you will be able to start the car.

my question is
1. has anybody come across such issue on their XUV?
2. Any Theory why and how such a thing can happen?
SAMUDRA is offline   Reply With Quote
Old 29th February 2012, 11:53   #120
BHPian
 
moleculez's Avatar
 
Join Date: Aug 2008
Location: Mumbai
Posts: 49
Thanked: 24 Times
Default Re: XUV 500 niggles and their solutions

Have driven my XUV 500 W8 almost 8000 Kms till now. I am facing the following issues

1) The cluster switch ( On the left side of tachometer ) does not function anymore hence the tyretronics were unable to be calibrated.

Solution: M&M replaces the entire Cluster for free.

2) All the windows rattle lowered down a little

Solution: M&M replaces the window motor or something and the noise is gone for another 1000 kms and u can start hearing it again. :(

3) AC gives out a foul oudor when u turn on the car after it had not been used for over 2-3 hrs. The odour is felt for a min and then goes off

Solution: Issues not resolved yet

4) Screeaching noise when u take a steep left turn even at the speed of 30Km/lt

Solution: Issue not resolved yet

5) GPS not working

Solution: The GPS antenna is faulty and needs to replaced.

6) The Milage never goes below 9.0 Kmpl and never exceeds 15.0 Kmpl. This was not the case with the previous versions.

Solution: Maybe the next software Version rectifies it.

7) The Silver color on Gear knob and door handles (inside) have started to give way

Solution: None Yet


None of these problems are so big that I cant live without solving them, but they are really small and need more attention at the time of manufacturing. I know M&M replaces everything but its a pain going to the service centers and waiting to get the work done.


Also I do my car work from G3 motors New Mumbai. Which dealers have u got good experience. When I drove the scorpio for 5 yrs (over 1 Lakh Km) and got my car serviced from Milestone (Parel). Had very good experience but now they dont deal with XUV!
moleculez is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
ICE for the Mahindra XUV 500 kedarwalke Ask the Gurus 142 17th December 2014 14:54


All times are GMT +5.5. The time now is 23:24.

Copyright 2000 - 2014, Team-BHP.com
Proudly powered by E2E Networks