Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 27th February 2012, 09:59   #31
BHPian
 
S5157's Avatar
 
Join Date: Sep 2009
Location: Muvattupuzha, KL
Posts: 298
Thanked: 161 Times
Default Re: Ritz VXi Issue - Weird Odor on Redlining

Quote:
Originally Posted by roadrunner_nv View Post
Hi Fellow T-Bhpians. I have a query and this has been eating my brains for the last three weeks.

I started ripping my 2100 km old Ritz VXi a few weeks ago and have noticed a weird odor creeping in whenever I redline (if that's what you call shifting at 5K). I have noticed that this odor strangely comes at the rear of the car and then moves forward. This odor is noticeable with the windows closed irrespective of the AC status.

I do not ride the clutch, all the tyres are properly inflated, fill up only at Shell and maintain all the vital fluids in the car.

The odor is feels like a cross between a hydrogen sulphide and dust/oil...cant really categorize.

I had posted this in some other thread earlier but did not get any replies.
Finally i have found someone who share the same problem what I have with my SX4 1.6 VVT.

For me, the issue occurs intermittently.

The road to my house is around 750 meters which has to drivern in first or second gear( I leave in a hilly area and roads are not good). Once I stop in the garage the odour ( Like Hydrogen sulphide) comes from underneath the car(No odour inside thankfully).

I couldn't reproduce the same at the dealership so no fix for last 1 and half years. My car has done 29,000 kms in 18 months and issue still occurs but the frequency is less.

I do have a wagon r 1.1 and i10 1.2 auto but they don't have this issue.
S5157 is offline   Reply With Quote
Old 4th March 2012, 07:30   #32
BHPian
 
Join Date: Mar 2011
Location: Pune
Posts: 28
Thanked: 28 Times
Default Re: Ritz VXi Issue - Weird Odor on Redlining

Quote:
Originally Posted by S5157 View Post
Finally i have found someone who share the same problem what I have with my SX4 1.6 VVT.

For me, the issue occurs intermittently.

The road to my house is around 750 meters which has to drivern in first or second gear( I leave in a hilly area and roads are not good). Once I stop in the garage the odour ( Like Hydrogen sulphide) comes from underneath the car(No odour inside thankfully).

I couldn't reproduce the same at the dealership so no fix for last 1 and half years. My car has done 29,000 kms in 18 months and issue still occurs but the frequency is less.

I do have a wagon r 1.1 and i10 1.2 auto but they don't have this issue.
I have observed that this issue was encountered by someone on this forum. cant really pinpoint who and which thread.

It seems that no-one has had any luck with this problem/phenomenon.
Seems like we have special cars
roadrunner_nv is offline   Reply With Quote
Old 7th March 2012, 22:14   #33
Distinguished - BHPian
 
Join Date: Jul 2009
Location: Kolkata
Posts: 3,506
Thanked: 2,067 Times
Default Re: Ritz VXi Issue - Weird Odor on Redlining

^^^
rr, your case is normal, S5s (at ~30k Km) isn't.

Regards
Sutripta
Sutripta is offline   Reply With Quote
Old 16th April 2014, 13:59   #34
BHPian
 
ankan.m.blr's Avatar
 
Join Date: Dec 2011
Location: Bangalore
Posts: 596
Thanked: 491 Times
Default Re: Ritz VXi Issue - Weird Odor on Redlining

For the past 1 month , I am experiencing this problem. My drive is Ritz zxi with 24K on the odo. At 60+ speeds (couldn't pinpoint the exact speed), I am smelling burnt petrol fumes intermittently. I have to switch off in-car air-circulation to let fresh air in. This is spoiling my long drives; my better-half feels nauseous after an hour in the car. Can any one please suggest what can be the problem.
ankan.m.blr is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Leaking Getz - weird issue - solved risga Technical Stuff 26 23rd October 2014 17:34
2010 WagonR Vxi Vs Ritz Lxi EDIT: Its Ritz ! akshay Hatchbacks 24 25th July 2014 12:57
Starting issue with my Ritz Vxi 2010 sharmaruns Technical Stuff 13 9th January 2012 12:11
Weird issue with Goodyear GT3 Tubeless Tyres XetaGLGRocks Tyre & Alloy wheel Section 22 4th February 2011 21:59
Pungent exhaust odor from my Wagon R johy Technical Stuff 17 24th June 2009 11:55


All times are GMT +5.5. The time now is 05:24.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks