Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 8th January 2012, 15:32   #1
BHPian
 
Join Date: Dec 2006
Location: Bangalore
Posts: 409
Thanked: 109 Times
Default Brand new Swift ZDI : Glow plugs indicators not working

Hi All,

Have 3weeks old swift ZDI, noticed that glow plug sensor indicator which is suppose to be in the dash does not glow at all on ignation on, even when the coolent is very cool, with outside tempertature at 13-16 degC.

Manual says there is glow plug sensor and indicator in car dash board and should glow at the start if the coolent is cool. However MASS informs that new Swift ZDI doesn't have glowplug indicators.

Can other ZDI owner confirm, whether they have noticed glow plug indicator in their dash board or not.
manjubp is offline   Reply With Quote
Old 8th January 2012, 21:40   #2
BHPian
 
Join Date: Dec 2006
Location: Bangalore
Posts: 409
Thanked: 109 Times
Default Re: Brand new Swift ZDI : Glow plugs indicators not working

Apprecaite if any new swift diesel owner can confirm that the glow plugs indicators are working in their cars.
manjubp is offline   Reply With Quote
Old 8th January 2012, 22:58   #3
BHPian
 
fuel_addict's Avatar
 
Join Date: Jul 2010
Location: Mumbai
Posts: 688
Thanked: 111 Times
Default

I have a 2 day old ZDi and the glow plug indication does not show up even in my car. I think that is perfectly normal. 13-16C isn't cold enough for the indication to light up IMO. This is my first diesel car, do I could be wrong.
fuel_addict is offline   Reply With Quote
Old 11th January 2012, 23:03   #4
BHPian
 
Join Date: Dec 2006
Location: Bangalore
Posts: 409
Thanked: 109 Times
Default Re: Brand new Swift ZDI : Glow plugs indicators not working

Surprised, with so many All new swift owners, no one has responded or seeing this issue. Appreciate if you guys can give your observation on glow plug glowing.
manjubp is offline   Reply With Quote
Old 11th January 2012, 23:36   #5
BHPian
 
rajanprash's Avatar
 
Join Date: Jul 2011
Location: Chennai
Posts: 109
Thanked: 35 Times
Default

IIRC I have never seen glow plug indicators on my friends Swift. It may be that the plugs heat soon enogh for the indicators to light up.
Gurus please advice, even i am getting curious about this now.
rajanprash is offline   Reply With Quote
Old 11th January 2012, 23:49   #6
Senior - BHPian
 
coolboy007's Avatar
 
Join Date: Mar 2009
Location: New Delhi
Posts: 1,717
Thanked: 1,440 Times
Default Re: Brand new Swift ZDI : Glow plugs indicators not working

We only have a Scorpio as the diesel vehicle in our house and the glow plugs do come on these days as the temperature over north india has plunged below 10 degrees.

I think the new swift owners in north india should comment if they are getting the indication or not.

Could it be that maruti omitted the glow plug indicator? Like the last one didnt have the low fuel light.
coolboy007 is offline   Reply With Quote
Old 12th January 2012, 00:09   #7
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,748
Thanked: 7,463 Times
Default Re: Brand new Swift ZDI : Glow plugs indicators not working

It happens very fast and will switch off under a sec or two. Atleast thats how it happens in old swift. Maybe thats a check light, and will come up if the plugs have failed like other warning light.
Jaggu is offline   Reply With Quote
Old 12th January 2012, 09:10   #8
Senior - BHPian
 
rakesh_r's Avatar
 
Join Date: Nov 2009
Location: PNQ/MUM/PKD
Posts: 1,071
Thanked: 695 Times
Default Re: Brand new Swift ZDI : Glow plugs indicators not working

Quote:
Originally Posted by manjubp View Post
Hi All,

Have 3weeks old swift ZDI, noticed that glow plug sensor indicator which is suppose to be in the dash does not glow at all on ignation on, even when the coolent is very cool, with outside tempertature at 13-16 degC.

Manual says there is glow plug sensor and indicator in car dash board and should glow at the start if the coolent is cool. However MASS informs that new Swift ZDI doesn't have glowplug indicators.

Can other ZDI owner confirm, whether they have noticed glow plug indicator in their dash board or not.
I have never seen the glow plug indicator glow on in my 2010 vdi.Maybe for a second or so.
rakesh_r is offline   Reply With Quote
Old 12th January 2012, 22:21   #9
BHPian
 
Join Date: Dec 2006
Location: Bangalore
Posts: 409
Thanked: 109 Times
Default Re: Brand new Swift ZDI : Glow plugs indicators not working

MUL's user manual mentions that glow plug indicator glows. At least I have seen in Dezire the glow plug indicator on for 4-6 seconds. But suprprise to see non of the guys with new swift are seeing glow plug indicator.

Now MASS guys are saying that there is nto such indicator and manul has a bug.
manjubp is offline   Reply With Quote
Old 12th January 2012, 22:53   #10
Senior - BHPian
 
sachinj12's Avatar
 
Join Date: Nov 2009
Location: Los Angeles
Posts: 1,188
Thanked: 161 Times
Default Re: Brand new Swift ZDI : Glow plugs indicators not working

Quote:
Originally Posted by manjubp View Post
MUL's user manual mentions that glow plug indicator glows. At least I have seen in Dezire the glow plug indicator on for 4-6 seconds.
.
+1. The glow plug glows for about 4-5 seconds. Noticed it every time. It never glows longer than that, at least in mine.
sachinj12 is offline   Reply With Quote
Old 13th January 2012, 12:31   #11
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,748
Thanked: 7,463 Times
Default Re: Brand new Swift ZDI : Glow plugs indicators not working

I checked today, it glows only for fraction of a second and switches off.
Jaggu is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Jeep: Problem with glow plugs lugnut 4x4 Technical 5 18th August 2014 21:04
Punto console indicating "check glow plugs". ironshark Technical Stuff 4 13th December 2010 12:08
Should i replace all four glow plugs ? rajivanoj Technical Stuff 14 26th September 2010 12:18
Glow Plugs for Indica V2 fariborzpz Technical Stuff 4 1st September 2009 13:40


All times are GMT +5.5. The time now is 16:36.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks