Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 21st July 2013, 13:58   #1
BHPian
 
jocreative's Avatar
 
Join Date: Sep 2009
Location: Dubai, UAE
Posts: 179
Thanked: 6 Times
Unhappy Chevrolet Lumina: Random acceleration & cruise control problem

I have a 2009 Lumina LTZ 3.6L with 2 main problems -

1. The acceleration suddenly stops randomly when my feet is on the pedal. This happens between any speed, 0-60 or 60-100KMPH. It happens completely random to me which is why I fail to explain it to any technician. The tech said there is no error code so he cannot do anything. I have to raise my feet off the pedal and give it another go to engage acceleration.
Its not like the acceleration doesn't work at all.. .maybe it goes 0-60 or 70 and then stops revving. I will have to give it another go to continue. Any idea what this could be?

2. My cruise control does not engage. The visual indicator says Cruise On, but it does not say Cruise Active. Earlier, it used to say Cruise Active but it used to dis-engage 5-10 minutes later. Now it doesn't go active at all. The tech again said.. no error code for this so cannot tell.

They usually recommend some random part to be replaced but they are not completely sure if that would do the fix and result in a hefty bill. Any insight on these problems could help me a lot. Thanks in advance.
jocreative is offline   Reply With Quote
Old 21st July 2013, 14:46   #2
Senior - BHPian
 
govigov's Avatar
 
Join Date: Oct 2007
Location: Cochin!!!!!
Posts: 1,314
Thanked: 431 Times
Default re: Chevrolet Lumina: Random acceleration & cruise control problem

Does the 2009 Lumina have drive by wire technology for the accelerator? Or is it the accelerator with the throttle position sensor?
govigov is offline   Reply With Quote
Old 21st July 2013, 15:12   #3
BHPian
 
jocreative's Avatar
 
Join Date: Sep 2009
Location: Dubai, UAE
Posts: 179
Thanked: 6 Times
Default re: Chevrolet Lumina: Random acceleration & cruise control problem

Not sure. I did some googling and found out that the equivalent holden commodore uses throttle sensors, so this should too.
jocreative is offline   Reply With Quote
Old 21st July 2013, 22:28   #4
Senior - BHPian
 
Join Date: Sep 2006
Location: zxc
Posts: 3,394
Thanked: 658 Times
Default re: Chevrolet Lumina: Random acceleration & cruise control problem

get your accelerator pedals checked.
SirAlec is offline   Reply With Quote
Old 22nd July 2013, 13:37   #5
Distinguished - BHPian
 
dhanushs's Avatar
 
Join Date: Oct 2009
Location: Bathery/BLR
Posts: 3,446
Thanked: 4,055 Times
Default re: Chevrolet Lumina: Random acceleration & cruise control problem

Please check:
  • Block in fuel lines
  • Ignition
  • Throttle Position Sensor

Last edited by GTO : 22nd July 2013 at 16:25. Reason: Typo
dhanushs is offline   (1) Thanks Reply With Quote
Old 22nd July 2013, 22:47   #6
BHPian
 
Catalyst_delhi's Avatar
 
Join Date: Oct 2011
Location: Noida/Coimbator
Posts: 339
Thanked: 148 Times
Default Re: Chevrolet Lumina: Random acceleration & cruise control problem

I have never seen or driven the Lumina but I had this problem - The Pressure sensor for the power steering was acting up , I cleaned the contacts and it was fixed. The clutch pedal position sensor also gives almost the same error. The car I am referencing is a Ford Ikon 1.6.
Catalyst_delhi is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
SCOOP Pics! Swift with Suzuki Diesel Engine, Keyless entry / go & cruise control VeyronSuperSprt The Indian Car Scene 242 6th January 2014 12:07
First Impressions - Chevrolet Lumina SS Steeroid The International Automotive Scene 26 11th August 2006 00:22
Installing a cruise control Tarun Modifications & Accessories 52 27th March 2005 21:24


All times are GMT +5.5. The time now is 23:42.

Copyright ©2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks