Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 31st March 2014, 17:56   #1
BHPian
 
MadRash's Avatar
 
Join Date: May 2008
Location: Madras
Posts: 241
Thanked: Once
Default Radiator fan - Low speed not working

Hi,

I own a Fabia PD TDI 1.4 2008 model. I noticed drop in the AC cooling effect and visited a AC mechanic for refrigerant refill. He identified that the radiator fan is not working at low speed (it has 2 speeds). He showed a broken fuse in the battery compartment. Due to which the aircon is not cooling the cabin effectively when I'm within the city. Actually I changed this fan 3 months back @ a Skoda service. So I'm wondering whether there is any other component causing this trouble.

Can anyone please guide me what would have gone wrong?
Attached Thumbnails
Radiator fan - Low speed not working-skodafabia008-2.jpg  


Last edited by MadRash : 31st March 2014 at 18:01. Reason: upload image
MadRash is offline   Reply With Quote
Old 31st March 2014, 20:27   #2
Senior - BHPian
 
vigsom's Avatar
 
Join Date: Feb 2006
Location: AUH<->MAA
Posts: 1,722
Thanked: 581 Times
Default re: Radiator fan - Low speed not working

best way is to hook up a multimeter to the fan circuit on another "untouched" Fabia and test the amps drawn.

Then provide direct power supply to your car's fan and see how the amps compare.

That will tell you whether the fan motor is drawing hi current.

PS:Why and when did you have the fan changed?what symptoms did you experience before the fan was changed?

Last edited by vigsom : 31st March 2014 at 20:33. Reason: addition
vigsom is offline   (2) Thanks Reply With Quote
Old 1st April 2014, 07:45   #3
BHPian
 
Catalyst_delhi's Avatar
 
Join Date: Oct 2011
Location: Noida/Coimbator
Posts: 339
Thanked: 148 Times
Default re: Radiator fan - Low speed not working

Had this issue with the ikon - the issue was with the cooling fan resistor. The resistor steps down voltage to give a slower speed. I am not sure how it is done in Fabia but you could check that as well.
Catalyst_delhi is offline   (1) Thanks Reply With Quote
Old 1st April 2014, 09:57   #4
BHPian
 
chaudh2s's Avatar
 
Join Date: Jul 2010
Location: Gurgaon
Posts: 197
Thanked: 243 Times
Default re: Radiator fan - Low speed not working

Had this issue with my MJD punto, the high speed fan was not working (low speed fan was working though). The kale made radiator fan was the culprit, and it was changed under warranty. This transformed the cooling capacity to normal levels.
chaudh2s is offline   (1) Thanks Reply With Quote
Old 1st April 2014, 11:09   #5
Senior - BHPian
 
mayankk's Avatar
 
Join Date: Apr 2010
Location: New Delhi
Posts: 4,115
Thanked: 3,489 Times
Default re: Radiator fan - Low speed not working

I dont understand. Has not the mechanic identified the fault, and the cause?
Have you tried what he is suggesting? It seem to be easy enough to test with a little bit of wire.
mayankk is offline   Reply With Quote
Old 1st April 2014, 11:21   #6
Senior - BHPian
 
sandeepmohan's Avatar
 
Join Date: Feb 2010
Location: Wellington
Posts: 1,942
Thanked: 1,624 Times
Default re: Radiator fan - Low speed not working

Quote:
Originally Posted by Catalyst_delhi View Post
Had this issue with the ikon - the issue was with the cooling fan resistor. The resistor steps down voltage to give a slower speed.
Never thought of this. Ford as usual, changed my fan and that meant around 7K down the drain. Should have approached a FNG first.
sandeepmohan is offline   (1) Thanks Reply With Quote
Old 1st April 2014, 12:47   #7
BHPian
 
MadRash's Avatar
 
Join Date: May 2008
Location: Madras
Posts: 241
Thanked: Once
Default Re: Radiator fan - low speed not working

Quote:
Originally Posted by vigsom View Post

PS:Why and when did you have the fan changed?what symptoms did you experience before the fan was changed?
Quote:
Originally Posted by mayankk View Post
I dont understand. Has not the mechanic identified the fault, and the cause?
Have you tried what he is suggesting? It seem to be easy enough to test with a little bit of wire.
I faced the same issue earlier and two mechanics confirmed that the fault is with the fan. So I changed the fan at a Skoda service. Now again same issue is cropping up with the new fan as well. That's why I want to confirm the issue before going to mechanics
MadRash is offline   Reply With Quote
Old 2nd April 2014, 13:50   #8
Senior - BHPian
 
sandeepmohan's Avatar
 
Join Date: Feb 2010
Location: Wellington
Posts: 1,942
Thanked: 1,624 Times
Default Re: Radiator fan - low speed not working

Quote:
Originally Posted by MadRash View Post
So I changed the fan at a Skoda service. Now again same issue is cropping up with the new fan as well.
Go back to Skoda and have them check it again. A new fan cannot go defective in such a short time period.
sandeepmohan is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radiator Fan keeps running, even after the ignition is off! newcoolgadgets Technical Stuff 47 5th November 2016 22:24
Urgent: Fiat Palio 1.2 Radiator Fan Not Working extreme_torque Technical Stuff 13 27th May 2010 12:01
Ikon 1.8 Radiator Fan not Working!! Born 2 Be Wild Technical Stuff 4 13th April 2009 00:29
Strange problem with Petra - Radiator fan jraj Technical Stuff 8 24th August 2008 14:00
Radiator Fan Blues tsk1979 Technical Stuff 14 29th October 2007 17:31


All times are GMT +5.5. The time now is 16:10.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks