Go Back   Team-BHP > Under the Hood > Technical Stuff

Thread Tools Search this Thread
Old 27th November 2004, 02:31   #1
cheatingdeath's Avatar
Join Date: Jun 2004
Location: Mumbai
Posts: 275
Thanked: 3 Times

ppl ..... 2 day my car conqued up it dint start .. the battery was ok and everything else was all rite tooo.. i suspected that petrol was not sucked in the engine .. so it was..the helpline guyz of hyndai fixed the problem ... the fuel pump valve was a bit loose.. guyz . the service guy even said that the fuelpump was ok... buit i wonder why did this happen .. as of now the car back smooth and silent
cheatingdeath is offline   Reply With Quote
Old 27th November 2004, 12:05   #2
Team-BHP Support
GTO's Avatar
Join Date: Feb 2004
Location: Bombay
Posts: 43,751
Thanked: 63,004 Times

Sounds like a similar problem to what the 2003-early 2004 Honda Accords faced. Lose fuel pump valve = No fuel supply. The Accords faced this problem due to bad roads.

GTO is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tyre pressure gauge and portable inflator pump / foot pump adityapd Modifications & Accessories 600 23rd October 2016 08:59
8 Valve SOHC vs 16 Valve SOHC shineshine Technical Stuff 6 12th February 2016 22:23
Aircheckers by Petes- Show tyre pressure by valve cap pranil Tyre & Alloy wheel Section 72 7th October 2015 15:33
Wanted: 2nd hand Fuel Pump / Fuel Pump Body ramie2400 Shifting gears 2 6th October 2007 11:16
Accords Fuel pump pressure regulatory valve cheatingdeath Technical Stuff 2 8th June 2004 11:13

All times are GMT +5.5. The time now is 04:17.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks