Go Back   Team-BHP > Under the Hood > Technical Stuff

Thread Tools Search this Thread
Old 23rd November 2006, 15:30   #16
Senior - BHPian
normally_crazy's Avatar
Join Date: Feb 2004
Location: Mumbai
Posts: 4,363
Thanked: 374 Times

Ok fellows - sorted the problem out.

Along with the problem , I had also noticed a few drops of oil that accumulated near my feet daily. Got it checked and the problem was identified. It was a faulty leaking Clutch Slave Cylinder. Had to get it replaced.....cost was 980 + 130 labour.

The problem of the revs not dropping has vanished and the car is back running like before. Also the oil leakage has stopped. Guess both the problems came from the same source.

normally_crazy is offline   Reply With Quote
Old 23rd November 2006, 16:15   #17
elf's Avatar
Join Date: Jan 2005
Location: Bombay
Posts: 1,034
Thanked: 9 Times

Hi N_C.

Now that the forum's back, would appreciate an update on your problem.

elf is offline   Reply With Quote
Old 23rd November 2006, 17:27   #18
Senior - BHPian
iraghava's Avatar
Join Date: Oct 2005
Location: Bhaiyyaland
Posts: 8,022
Thanked: 140 Times

He already answered it Elf!
iraghava is offline   Reply With Quote
Old 28th November 2006, 13:43   #19
Join Date: Nov 2006
Location: Pune
Posts: 4
Thanked: 0 Times
Default Revs increase on engaging the clutch in my Alto VXI

I have this problem sporadically. When I press the clutch pedal in my Alto VXI, the revs increase instead of coming down. This does not happen all the time but once in a week or so. And then car takes jerks. Problem goes away when I park and rev the engine in neutral gear for a minute or two.

It is a 2002 Alto VXI (1100 cc). I took it to the Maruti Service Center but as they could not recreate the problem at that time, they said that everything is normal and not to worry.

Any ideas as to what can cause this ? has anybody else faced a similar problem with Alto ? Otherwise it is a trouble free car.
Ankur426 is offline   Reply With Quote
Old 28th November 2006, 16:55   #20
Team-BHP Support
benbsb29's Avatar
Join Date: Nov 2006
Location: Brisbane
Posts: 7,694
Thanked: 2,593 Times

I have an ikon Flair, just about 2 months old. I have noticed the same thing happening on my Ikon, specially when shifting from 3rd to 4th. I usually keep the clutch pressed till the RPM drops in about 2-3 seconds, else the car moves with a jerk. My car has completed 1990 kms.

Looks like this is not an isolated incident. There is also a thread on the same at the Ford Ikon community on Orkut.

@ Normally_Crazy : Do u suppose this is the same problem as with ur car?
benbsb29 is offline   Reply With Quote
Old 29th November 2006, 10:29   #21
santhoshx's Avatar
Join Date: Aug 2006
Location: Bangalore/New Jersey
Posts: 46
Thanked: 0 Times

I have the same problem in my zen. But its not consistant and usually happens in the morning . I fellt like some accelarator cable issue. Will be checking this out some time this week and let all know
santhoshx is offline   Reply With Quote
Old 7th December 2006, 12:14   #22
Join Date: Nov 2006
Location: Pune
Posts: 4
Thanked: 0 Times

how much should the RPM go normally when accelerating and ALTO VXI ?

My car does 3000 normally when I press the acc pedal for acceleration at 3rd and 4rth gear. Can be becasue of clutch setting. I got a new clutch plate recently.
Ankur426 is offline   Reply With Quote
Old 8th March 2009, 18:57   #23
Join Date: Nov 2007
Location: Bangalore
Posts: 8
Thanked: 0 Times

Hi! Normaly_Crazy,

We were dicussing a problem in this thread of revs not dropping
http://www.team-bhp.com/forum/techni...-brakes-3.html (the Ikon.. bad brakes)

I seem to have the same problem that you had with the revs but unlike your issue I havent noticed any oil accumalation.
How is the problem now, think changing the clutch cylinder will resolve the issue?
BlackWagon is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Xing: High rev when pressing the clutch during gear change raghu Technical Stuff 11 11th October 2009 07:06
Why not realistic pricing, and effect of price dropping? sgiitk The Indian Car Scene 15 10th July 2009 12:07
Swift : weird noise during gear change manjubp Technical Stuff 10 6th February 2008 21:11
Dropping FE of my SWIFT-VXI raja748 Technical Stuff 5 2nd October 2007 06:21
revs too high during fst 5 mins... babe_on_wheels Technical Stuff 4 16th March 2006 17:09

All times are GMT +5.5. The time now is 03:13.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks