Go Back   Team-BHP > Under the Hood > Technical Stuff

Thread Tools Search this Thread
Old 11th October 2009, 23:22   #106
Senior - BHPian
danlalan's Avatar
Join Date: Nov 2005
Location: mumbai,JUHU
Posts: 1,582
Thanked: 120 Times

One more problem to add to the list.

Just today i started up the car after two days and it worked perfectly for the 1st 100 meters.
Then suddenly the a/c switch button light goes off. The horn goes on singe tone and the rear speakers go off too. The A/c blower suddenly started blowing more air upon acceleration and less at de-acceleration. Put the headlights on at high beam and it blows the headlights too. Even 1 parking light bulb.
Shouldnt the fuse box handle all these hiccups...??
i did find a road elec and he put the volt meter to the battery that showed erratic changes in the reading from 13.5v it jumps fast to 15 onto 18 and then back.
He said the alternator is overcharging.

Whats the reason for this..?? Whats my next step..??
danlalan is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virus problems/spyware problems! post here! SirAlec Gadgets, Computers & Software 10 16th July 2014 00:05
An Ikonic Story sidindica The Indian Car Scene 58 4th February 2011 17:20
Ikonic journeys : Bangalore to Ooty & Coonor benbsb29 Travelogues 56 30th June 2010 22:16
One last drive, those iKONic moments. Jaggu Long-Term Ownership Reviews 22 7th July 2008 12:14
Ikonic Troubles wolfinstein Technical Stuff 18 27th June 2008 15:52

All times are GMT +5.5. The time now is 20:28.

Copyright ©2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks