Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 6th January 2007, 01:31   #1
BHPian
 
Join Date: May 2006
Location: Chennai
Posts: 29
Thanked: 0 Times
Default Swift ZXI Climate Control not working at 18C

Hi,

The automatic climate control air conditioning in my Swift ZXI doesnt seem to work if the temp is set at 18C - it runs continuously at full power. However, if I set it to any other temp 18.5 upwards, it works fine. Any ideas why this is happening? I'm planning to take it across to the service centre to have a look but just wondering if theres a simple solution to this.

Thanks!
skiddyrow is offline   Reply With Quote
Old 6th January 2007, 10:37   #2
BHPian
 
car_crazy1400's Avatar
 
Join Date: Feb 2005
Location: DL/UP16/PB10
Posts: 526
Thanked: 173 Times
Default

Your climate control doesn't seem to work at 18 degrees is because it will not go beyond that temp. setting or will show cool as a lowest setting , so it works on full blast to keep ur car cool.
Same is the case with my corolla also.

However, when you increase the temp, it will lower the blower settings as soon as you approach about 20 deg. as after all it is an automatic climate control system
car_crazy1400 is offline   Reply With Quote
Old 6th January 2007, 12:10   #3
Team-BHP Support
 
theMAG's Avatar
 
Join Date: May 2006
Location: Long Island, NY
Posts: 7,034
Thanked: 1,470 Times
Default

It depends on the internal cabin temperature at that time. If its alrady 18 the auto control wont do anything.
theMAG is offline   Reply With Quote
Old 6th January 2007, 12:39   #4
BHPian
 
Join Date: May 2006
Location: Chennai
Posts: 29
Thanked: 0 Times
Default

ok let me rephrase that. previously when I set the temp on 18C, the fan goes to full until the internal temp starts lowering, after which the fan speed gradually decreases. in the daytime this can take a while (im in chennai), and in the night this usually starts lowering within 10 minutes. Now however, the fan speed does not lower at all even after running it at 18 for 40 minutes in the night (thats as much as I tested before i gave up). The moment I take it up a notch to 18.5 the fan speed automatically lowers drastically, which means the sensor is working. so how come its not working at 18?
skiddyrow is offline   Reply With Quote
Old 10th January 2007, 17:00   #5
BHPian
 
Join Date: May 2006
Location: Chennai
Posts: 29
Thanked: 0 Times
Default

Can any other ZXI owner let me know if I've got this wrong? I can swear that the automatic control used to work at 18C as well, gradually lowering the temps, but I'm starting to wonder. If any other ZXI owner can let me know if the fan always stays on max at 18C that should put my mind at ease! Thanks!
skiddyrow is offline   Reply With Quote
Old 10th January 2007, 18:27   #6
Senior - BHPian
 
vikram_d's Avatar
 
Join Date: Jul 2006
Location: Bangalore
Posts: 2,380
Thanked: 936 Times
Default

There are two sensors inside the cabin which check temperature. Check if anything is blocking or obstructing these sensors. I faced this problem when I kept a cloth on the sensor near the windhield by mistake. Removed the cloth and everything went back to normal.
vikram_d is offline   Reply With Quote
Old 10th January 2007, 20:10   #7
BHPian
 
theEnd's Avatar
 
Join Date: Nov 2005
Location: Bombay
Posts: 534
Thanked: 5 Times
Default

Yes my Zxi does the full blower thing for a few minutes, after which it reduces the blast. I'll check again on the way to dinner tonight.

I think your sensor might be damaged. The sensor is just to the right of the place where the music system head unit goes. There are two or three slots in the dashboard right there.. Might have gotten damaged by water etc.

Try starting the AC with the temp set at 18.5 or 19 and see if it behaves normally then. Cuz usually as soon as you adjust the temp upwards the blower reduces.

Overall I think you're quite fortunate. Now you can cool your car to way below 18 C if you want to.
theEnd is offline   Reply With Quote
Old 10th January 2007, 23:37   #8
BHPian
 
Join Date: May 2006
Location: Chennai
Posts: 29
Thanked: 0 Times
Default

Ok let me check if the sensors are blocked in any way - though I think not as it works on all temps 18.5 upwards. its stuck only at 18...
skiddyrow is offline   Reply With Quote
Old 11th January 2007, 11:03   #9
Senior - BHPian
 
Join Date: Jul 2006
Location: Bombay
Posts: 1,007
Thanked: 229 Times
Default

Never have yet set the temp on 18 at all. Usually 25-26 works during daytime and 23-24 at night. But let me check next time and let you know.
sandeep108 is offline   Reply With Quote
Old 12th January 2007, 15:04   #10
Senior - BHPian
 
vikram_d's Avatar
 
Join Date: Jul 2006
Location: Bangalore
Posts: 2,380
Thanked: 936 Times
Default

Ok This thing happens in my car also. So I called up my friendly neighbourhood Maruti Technical guy and he told me that this is the way the system functions. At both the outer extremeties of the temperature range that is 18 deg & 32 deg C in the case of the Swift the fan will always run at full blast and will not slow down.

Also he mentioned that all climate control systems in all cars work like this. Can somebody with any other climate controlled car besides Swift please clarify this?
vikram_d is offline   Reply With Quote
Old 18th January 2007, 14:56   #11
BHPian
 
Join Date: Feb 2006
Location: Bangalore
Posts: 53
Thanked: 5 Times
Default

Well.. in a Baleno, the lowest you can set is 19.. and I avoid 19 as I hate the aircraft engine style noise it results in!
Never had it on 19 and auto for longer than 10 mins. And the blower does slow down after a while!
kgc_cool is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
AC vs climate control LandCruiser Technical Stuff 82 1st November 2017 12:04
Swift automatic climate control - blinking 'auto' sjohn Technical Stuff 11 14th November 2010 21:39
Be a hero and Save the Climate at UN Climate Summit in Copenhagen December 19th serpente Shifting gears 0 27th November 2009 20:49
Swift ZXi Climate control_improve fuel efficiency pranil Technical Stuff 21 13th March 2006 18:16
Climate control Baleno VXi ! shuvc Sedans 30 23rd January 2006 15:55


All times are GMT +5.5. The time now is 21:41.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks