Go Back   Team-BHP > Under the Hood > Technical Stuff

Closed Thread
Thread Tools Search this Thread
Old 8th January 2007, 17:31   #16
rks's Avatar
Join Date: Nov 2005
Location: ??
Posts: 1,237
Thanked: 7 Times

vabS, as Psycho said, could be due to an ecu problem or maybe the ecu needs some time to adjust itself to your engine. My advice is pls do not frequently rev your new car too hard just to keep testing its peak performance -- that can only harm your engine. I hope that you are at least through with the free services and oil change. Pls take it to the garage, get it checked and if they say its OK, do not worry about it unless you feel a drop in normal (rather then peak) performance.

Last edited by rks : 8th January 2007 at 17:33.
rks is offline  
Old 8th January 2007, 19:21   #17
Join Date: Nov 2006
Location: Delhi
Posts: 8
Thanked: 0 Times

Shuvc, I used to drive a Santro earlier. Well, everything seems normal to me except for the peak performance as you mentioned rks. I went to the dealer and the guy there drove it and said it seems perfectly fine to him..He went upto 60Kmph on a busy road and could have done more if the traffic permitted. I guess, its just that I am not used to it (probably). I have ripped my baby enough today and don't want to continue with the same treatment and develop some other problem as its still very new. For my driving style and regular gear shifts I don't think anyone would even notice any difference (if at all its there).

Thanks everyone for your inputs..Your time and help is much appreciated!!

Mods please close this thread.
vabS is offline  
Old 8th January 2007, 19:55   #18
Senior - BHPian
adya33's Avatar
Join Date: Apr 2005
Location: Pune
Posts: 1,839
Thanked: 77 Times

Thread closed on request of thread starter.
adya33 is offline  
Closed Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Baleno: Jerk trouble in 1st and 2nd gear FJhustler Technical Stuff 25 23rd May 2012 11:08
Mahindra Bolero - Low torque in 2nd gear? THE OFFROADER Technical Stuff 13 7th June 2010 17:18
Swift 2nd Gear Problem EDIT: Now first gear problem BUSA Technical Stuff 85 2nd September 2009 18:47
SWIFT - Shifting to 2nd gear problem eflanker Technical Stuff 45 31st January 2009 16:49

All times are GMT +5.5. The time now is 12:25.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks