Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 28th June 2012, 09:29   #16
BHPian
 
RM2488's Avatar
 
Join Date: Jun 2012
Location: Thane
Posts: 170
Thanked: 117 Times
Default Re: Ford Ikon 1.6 ZXI Engine Stall Problem - need any expert comments?

Other solution: Worked for my Ikon 1.3 Flair
I had the same issue- car would stall (Now I realise it was only while downshifting. It always happened only on highways-shifting from 5th to 2nd or 3rd. Or city streets- clutch-brake-turn, then downshift). There was nothing wrong with my clutch sensor. However, a cleaning of the throttle body and fuel injectors ended the problem.
RM2488 is offline   Reply With Quote
Old 29th June 2012, 07:42   #17
BHPian
 
wantarangerover's Avatar
 
Join Date: May 2006
Location: Vadodara, IN
Posts: 154
Thanked: 134 Times
Default Re: Ford Ikon 1.6 ZXI Engine Stall Problem - need any expert comments?

Suppose the VIN will give some clue? As to the readily seen differences, what about the idler pulley (plastic vs metla) that you mentioned? Its the same in both?
Quote:
Originally Posted by Catalyst_delhi View Post
I have checked , the changes are only with the internals between the 1.3 and 1.6. Anyone who can help with some differences?
wantarangerover is offline   Reply With Quote
Old 29th June 2012, 10:05   #18
BHPian
 
Catalyst_delhi's Avatar
 
Join Date: Oct 2011
Location: Noida/Coimbator
Posts: 339
Thanked: 148 Times
Default Re: Ford Ikon 1.6 ZXI Engine Stall Problem - need any expert comments?

Quote:
Originally Posted by wantarangerover View Post
Suppose the VIN will give some clue? As to the readily seen differences, what about the idler pulley (plastic vs metla) that you mentioned? Its the same in both?
Idler pulley if original can help otherwise it wont. I am yet to find a concrete method other than pulling the head open and measuring the cylinder dia.

Last edited by Catalyst_delhi : 29th June 2012 at 10:07. Reason: grammar
Catalyst_delhi is offline   Reply With Quote
Old 13th October 2014, 22:41   #19
BHPian
 
sbalagru6's Avatar
 
Join Date: Sep 2006
Location: Bangalore
Posts: 134
Thanked: 64 Times
Default Re: Ford Ikon 1.6 ZXI Engine Stall Problem - need any expert comments?

Sorry to bump the old thread...

My Ikon 1.6 engine is stalling frequently when clutch is pressed for changing gears, this happens only when AC is switched ON. If I drive without AC there is no problem..

Any pointers?!
sbalagru6 is offline   Reply With Quote
Old 23rd November 2014, 22:10   #20
BHPian
 
Join Date: Nov 2008
Location: Chennai
Posts: 121
Thanked: 80 Times
Unhappy Engine stalls when clutch pressed

I was driving my 2008 Swift petrol car which has done 72000KM this evening. When shifting gears, I could feel car dropping speed; I mean, if you change to 3rd gear at 90km/hr speed, the kind of reaction a car will give, it was giving at every gear change. Moments later engine started ceasing every time clutch was pressed. Car is able to idle fine, but when clutch is pressed, the engine stalls.

My car has a custom fit header and FFE. Off late, from the right side of the rear wheel, there is a noise every time, I run over a speed bump or a pothole. A noise as though some thing had become lose. Could something holding the exhaust have come out? I don't see it hanging though. Can a faulty FFE cause this engine behavior?

I am confused on whether to take the car to the people who fitted the header and FFE, or should I take it to a authorized MSS. Please advice.
k149in is offline   Reply With Quote
Old 23rd November 2014, 22:26   #21
Senior - BHPian
 
zenren's Avatar
 
Join Date: Oct 2008
Location: CLT/TVM/HYD
Posts: 2,576
Thanked: 1,723 Times
Default Re: Engine stalls when clutch pressed

Quote:
Originally Posted by k149in View Post
I was driving my 2008 Swift petrol car which has done 72000KM this evening. When shifting gears, I could feel car dropping speed; I mean, if you change to 3rd gear at 90km/hr speed, the kind of reaction a car will give, it was giving at every gear change. Moments later engine started ceasing every time clutch was pressed. Car is able to idle fine, but when clutch is pressed, the engine stalls.
Are you still on original clutch? Could be clutch issue.
zenren is offline   Reply With Quote
Old 23rd November 2014, 22:26   #22
Senior - BHPian
 
humyum's Avatar
 
Join Date: Feb 2006
Location: Leicester/Mumbai
Posts: 2,306
Thanked: 2,188 Times
Default Re: Engine stalls when clutch pressed

The stall when you press the clutch is because of a faulty clutch sensor which is present right behind the clutch pedal. Ask your MASS to check that.
humyum is offline   (1) Thanks Reply With Quote
Old 23rd November 2014, 23:25   #23
BHPian
 
poised2drive's Avatar
 
Join Date: Sep 2014
Location: Hyderabad
Posts: 265
Thanked: 286 Times
Default Re: Engine stalls when clutch pressed

Quote:
Originally Posted by zenren View Post
Are you still on original clutch? Could be clutch issue.
I second that.
I too had similar problems with the clutch @ 75k on Odo which had become really hard and wasn't engaging properly. If that's the case, it might be the faulty clutch that seeks your attention.
poised2drive is offline   Reply With Quote
Old 24th November 2014, 10:06   #24
BHPian
 
amitpunjani's Avatar
 
Join Date: Jul 2007
Location: Delhi
Posts: 451
Thanked: 101 Times
Default Re: Engine stalls when clutch pressed

Quote:
Originally Posted by humyum View Post
The stall when you press the clutch is because of a faulty clutch sensor which is present right behind the clutch pedal. Ask your MASS to check that.
Hello Humyum,



Does Swift Petrol have a clutch sensor? In case yes, what is the function? I thought the diesel one had the sensor?

Amit
amitpunjani is offline   (1) Thanks Reply With Quote
Old 24th November 2014, 10:23   #25
BHPian
 
Join Date: Aug 2009
Location: Trivandrum
Posts: 922
Thanked: 378 Times
Default Re: Engine stalls when clutch pressed

Quote:
Originally Posted by humyum View Post
The stall when you press the clutch is because of a faulty clutch sensor which is present right behind the clutch pedal. Ask your MASS to check that.
Please also check the alternator. RPM changes on pressing clutch can also be a result of alternator issues (can be easily found out by checking at a battery shop).
jinojohnt is offline   Reply With Quote
Old 24th November 2014, 10:46   #26
BHPian
 
wantarangerover's Avatar
 
Join Date: May 2006
Location: Vadodara, IN
Posts: 154
Thanked: 134 Times
Default Re: Engine stalls when clutch pressed

In addition to all the suggestions given here, check for any vacuum leaks in the intake side.
wantarangerover is offline   (1) Thanks Reply With Quote
Old 24th November 2014, 11:15   #27
BHPian
 
Join Date: Nov 2008
Location: Chennai
Posts: 121
Thanked: 80 Times
Default Re: Engine stalls when clutch pressed

Today morning, the car was just alright. Drove it to the ABT Maruti ASS without any issues. The service personnel told that only swift diesel has clutch sensor and rules out vacuum leak/alternator. The clutch assembly was replaced at 60k KM. He drove the vehicle for some distance and told that the vehicle seems to be fine. But still they are now checking for any error codes. I will update when the car is out of service station.
k149in is offline   Reply With Quote
Old 24th November 2014, 15:03   #28
BHPian
 
Join Date: Nov 2008
Location: Chennai
Posts: 121
Thanked: 80 Times
Default Re: Engine Stalling Problem

In the MASS, they checked for any error codes and returned saying that there were no problem. So unless the problem is repeatable, I don't think much investigation at this point of time. I am just hoping that such a behavior does not turn up in the highways. Thanks to everyone for the their suggestions.
k149in is offline   Reply With Quote
Old 24th November 2014, 18:58   #29
Senior - BHPian
 
humyum's Avatar
 
Join Date: Feb 2006
Location: Leicester/Mumbai
Posts: 2,306
Thanked: 2,188 Times
Default Re: Engine stalls when clutch pressed

Quote:
Originally Posted by amitpunjani View Post
Hello Humyum,



Does Swift Petrol have a clutch sensor? In case yes, what is the function? I thought the diesel one had the sensor?

Amit
Oh forgive me, I thought his was a diesel until I re read the post again. No, the petrol swift does not have a clutch sensor.
humyum is offline   Reply With Quote
Old 18th January 2015, 23:24   #30
BHPian
 
prguru's Avatar
 
Join Date: Jan 2010
Location: Bangalore
Posts: 155
Thanked: 19 Times
Default Strange issue of my Fiesta Tdci: Engine stalls after de clutch

Hi Friends,

I have a ford fiesta tdci 2010 model , had been to cousin's engagement when I noticed this strange behavior of the car. I stay in bangalore and was heading to mysore, after mandya if you are heading towards mysore you can find a road hump every couple of kms. Now coming to the issue I faced :

I was in 5th gear doing about 80 kms, spotted the hump so applied breaks, de clutched , shifted to 2nd and I released the clutch and the car jerked. I realized the car had stalled , I thought may be I did not engage the clutch properly and it stalled. Did not want that to happen again so next time the hump came I slowed down to about 35 -40 in 5th gear with out de clutching then put it to neutral and went over the hump then engaged 1st/2nd gear and continued. While returning I thought may be I was not de clutching properly so on a few humps ( between mysore and mandya return journey) I pressed the pedal hard to make sure the pedal goes all the way down. On few humps it worked and then again from around 80 I de clutched and shifted to neutral and again it stalled . This never happens during city driving and seems to happen when I try to slow down from 80-100 to go over a hump or stop at a signal etc. It is strange and dangerous too as the power steering does not work and the brakes become hard when the engine is shut off. I missed rear ending one Etios which was going over a hump because the steering became hard after the car stalled.

P.S: Mods: Please move the thread to relevant section if I have posted in the wrong section.


About 7 months back oil was leaking from underneath, took it to metro ford, they checked and replaced the clutch slave cylinder. Have not faced any issue with the clutch since then but not sure if this issue am facing now is connected to the slave cylinder etc.

Now please help me understand what could be the issue :
Could this be an issue with the clutch or could this be because am not de clutching properly ? Has any ford owners faced this earlier ? How to get it fixed ? I do not know how to reproduce this problem if I take it to the service station . Please help !

Last edited by prguru : 18th January 2015 at 23:26. Reason: p.s addition
prguru is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Volvo recalling 7,000 diesel cars (including S60 & XC60) for engine stalling problem cbatrody The International Automotive Scene 0 21st February 2016 19:59
New Swift Diesel - Stalling problem paramjeet Technical Stuff 4 13th July 2014 11:11
Engine stalling at low revs / idle kaushik_s Technical Stuff 37 4th March 2014 16:24
Swift VDi - Engine stalling. Is it my driving style? username Technical Stuff 5 5th August 2009 20:53
Ford Ikon 1.6 stalling problem gaurav_diavolo Technical Stuff 37 8th June 2009 08:15


All times are GMT +5.5. The time now is 04:19.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks