Go Back   Team-BHP > Under the Hood > Technical Stuff

Thread Tools Search this Thread
Old 23rd April 2007, 16:10   #1
Join Date: Jan 2007
Location: Bangalore
Posts: 21
Thanked: 0 Times
Default LPG mis-firing/back-firing/sluggish


Anybody ever felt their cars with LPG GAS back firing/misfiring .

Anybody got any technical advice on how to reduce this in an Opel corsa 2002 model 1.4 GLS sedan. I have a broken Air filter case now because of back firing and last week i had to spend a good amount on my fuel pump since it got stuck and refused to start the engine and i had to tow the vehicle to the service centre (which i suspect was a case of back firing again)

Was this a problem due to improper installation . any help would be appreciated

ranjithbalan is offline   Reply With Quote
Old 23rd April 2007, 17:12   #2
Senior - BHPian
esteem_lover's Avatar
Join Date: Jul 2006
Location: Madras/Py
Posts: 7,551
Thanked: 430 Times

There are umpteen number of threads for LPG queries, if you search. Please post in the appropriate thread & i will try to answer your query.
esteem_lover is offline   Reply With Quote
Old 25th April 2007, 23:41   #3
thoufique's Avatar
Join Date: Sep 2006
Location: chennai
Posts: 12
Thanked: 0 Times

hey ranjith balan,
i have the exact same problem on my corsa. It is a problem with faulty installation. I had my gas condenser changed to a bigger one with bigger tubes.After tht it did misfire once on the highway but seems fine other than that. Anyway its definitely a problem with installation.
thoufique is offline   Reply With Quote
Old 26th April 2007, 01:10   #4
nitroxx's Avatar
Join Date: Nov 2004
Location: DXB
Posts: 816
Thanked: 26 Times

check cylinders also bro,theres this vague tendency for LPG kits to cause issues with them.Had a few corsas with that issue in the workshop a year ago and 2 of them had the misfiring due to one cylinder being weak.
nitroxx is offline   Reply With Quote
Old 26th April 2007, 14:55   #5
Senior - BHPian
gigy's Avatar
Join Date: Jul 2006
Location: mumbai
Posts: 1,321
Thanked: 40 Times

buddy try increasing the gas flow amount and see if it is corrected. dont keep mixture lean. have a check on the mixer.( who made it?)
gigy is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ikon Shudders and mis-fires on cold start Kary Technical Stuff 28 16th May 2016 19:00
Cop mis-using authority / Do I really deserve this for driving safe all this while? Furebo Street Experiences 43 2nd May 2011 21:46
Suzuki Fiero mis-fires GreenDay Motorbikes 11 15th February 2011 22:10
mis-firing of OHC dhananjay Technical Stuff 9 21st August 2009 20:24

All times are GMT +5.5. The time now is 18:40.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks