Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 4th February 2009, 16:09   #136
Senior - BHPian
 
vikram_d's Avatar
 
Join Date: Jul 2006
Location: Bangalore
Posts: 2,380
Thanked: 936 Times
Default

@Adi99 - I dont have the contact information with me right now. I will get the contact information and PM it to you. Also MUL have made a number of changes on the stock clutch. The newer ones dont wear out as early as the old ones. IF your car is stock then I would still recommend a stock clutch.

@Fountainheader - Stage 2 is extremely hard and I dont recommend it for city driving. More over it will be over kill for a stock engine. I had a Stage 2 Exedy in my car earlier and it is very difficult to control in traffic situations.

Last edited by vikram_d : 4th February 2009 at 16:12.
vikram_d is offline   Reply With Quote
Old 4th February 2009, 16:21   #137
BHPian
 
adi99's Avatar
 
Join Date: May 2007
Location: Bangalore
Posts: 274
Thanked: 2 Times
Default

@ Vikram - Thank you so much.

@Anil - I was in Race Dynamics yesterday. I just asked about stage 2 clutch. They said its better and wise to go for stage 1 for a stock enigne. Stage 2 is hard and is very difficult to drive in the city traffic. Its meant for highly modded or drag cars.
adi99 is offline   Reply With Quote
Old 5th March 2009, 16:01   #138
BHPian
 
d_himan's Avatar
 
Join Date: Nov 2006
Location: Bombay
Posts: 728
Thanked: 591 Times
Default

Strange stuff on my Swift VXi. No problems during running-in etc. From 11k -13K on the odo, there was a severe clutch judder in 1st gear which went away after driving around for 10-15 min. Just stopped after that and now its normal. However, I always feel that the clutch is 'delicate' and is to be treated with immense care and kindness!
d_himan is offline   Reply With Quote
Old 5th March 2009, 16:43   #139
BHPian
 
Join Date: Jan 2008
Location: NewDelhi/Noida
Posts: 220
Thanked: 5 Times
Default

Hi,

Well my Swift VDI ABS is 70k in less than 2 years and i have driven most of it in New Delhi n surrounding regions. Still no problems from the clutch.

Maybe some Quality Control issues
Piyush_Vroom is offline   Reply With Quote
Old 5th March 2009, 19:02   #140
Senior - BHPian
 
Surprise's Avatar
 
Join Date: Feb 2005
Location: Chennai
Posts: 2,299
Thanked: 129 Times
Default

Quote:
Originally Posted by Surprise View Post
I too have this problem for the past 12000 kms. Since it occurs only when we are in first gear for long time (heavy traffic), I ignored it. Even last night, I struggled a lot in a heavy traffic for 3-4 kms.
------------------------------------------------------------------
Tech Gurus:

Is it advisable to get the clutch assembly changed nowitself or we can run till we can manage. I do not want to end up replacing lot other stuffs due to prolonged running with these jerks.

ps: as mentioned earlier, i have been managing with these jerks in 1st gear at heavy traffics for the past 12000 kms

As mentioned earlier I was able to manage with jerk and stiffness, but will that result in damaging any other parts?
Surprise is offline   Reply With Quote
Old 21st April 2009, 14:11   #141
Newbie
 
Join Date: Apr 2009
Location: Pune
Posts: 9
Thanked: 0 Times
Default

Hi Folks - not sure if this is the clutch problem in my Swift. I constantly hear this whirring sound (seems to come from right side of the bonnet) whenever I go beyond 1500 RPM and in gear. The moment I depress the clutch completely, the sound goes away. I spoke to Sai Service, Pune over phone, he seems to suggest that probably the bearing the gear is gone? Does anyone have any similar problems? Or know what could be the damages?
dasukhija is offline   Reply With Quote
Old 21st April 2009, 17:24   #142
BHPian
 
jithudigitised's Avatar
 
Join Date: Nov 2006
Location: Thiruvananthapuram
Posts: 329
Thanked: 58 Times
Default

Quote:
Originally Posted by dasukhija View Post
Hi Folks - not sure if this is the clutch problem in my Swift. I constantly hear this whirring sound (seems to come from right side of the bonnet) whenever I go beyond 1500 RPM and in gear. The moment I depress the clutch completely, the sound goes away. I spoke to Sai Service, Pune over phone, he seems to suggest that probably the bearing the gear is gone? Does anyone have any similar problems? Or know what could be the damages?
Check whether that sound also comes when you switch on the AC.
Does it only comes when you start your car or during a drive?

Well, I almost had a similar kind of problem and that was caused because of the belt in the engine.It was loose.
jithudigitised is offline   Reply With Quote
Old 21st April 2009, 23:00   #143
BHPian
 
aerohit's Avatar
 
Join Date: Aug 2007
Location: India
Posts: 883
Thanked: 590 Times
Default

Doesnt look like belt sound

Its more like - Kirrrr

It is easily audible when you are driving slow and can definately hear it with windows rolled up and while bending down a little bit.

Put it in 2, and leave the Accelerator Pedal, Push Pedal again - sound comes, let off pedal - no sound - repeat.
aerohit is offline   Reply With Quote
Old 27th April 2009, 10:55   #144
Newbie
 
Join Date: Apr 2009
Location: Pune
Posts: 9
Thanked: 0 Times
Default

Quote:
Originally Posted by aerohit View Post
Doesnt look like belt sound

Its more like - Kirrrr

It is easily audible when you are driving slow and can definately hear it with windows rolled up and while bending down a little bit.

Put it in 2, and leave the Accelerator Pedal, Push Pedal again - sound comes, let off pedal - no sound - repeat.
Pretty much right. More than driving slow, it comes when the RPM goes above 1500, regardless of gear, AC, speed. Does it seem like an issue with the bearing in the gear? That was what was the initial analysis of the Sai Service person on the phone.
dasukhija is offline   Reply With Quote
Old 11th May 2009, 16:11   #145
Newbie
 
Join Date: Apr 2009
Location: Pune
Posts: 9
Thanked: 0 Times
Default

Folks - I am going to Sai Service tomorrow to get this 'Kirrr' sound fixed, will let you all know what was the issue and the damages. Also I have anotehr query on the service. @Mod - I searched all around where to post this query, but it seems the search feature isnt working today and hence positing it here. Apologies for inconvenience.

My car has done 11K and the 3rd service was done in Nov-08 (car was bought in nov-07) along with wheel balancing. The car manual says that 4th service should happen at end of 2 years or 20K whichever is earlier. However, Sai is suggesting that I get my 4th service done right now. Please suggest should I also get it serviced? hoping for some quick replies. Thanks.
dasukhija is offline   Reply With Quote
Old 11th May 2009, 17:02   #146
Senior - BHPian
 
vikram_d's Avatar
 
Join Date: Jul 2006
Location: Bangalore
Posts: 2,380
Thanked: 936 Times
Default

Why would they suggest something like that. The car has only run 11k kms. Stick to the owner manual prescribed service cycle and don't do it earlier.
vikram_d is offline   Reply With Quote
Old 11th May 2009, 17:18   #147
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,752
Thanked: 7,478 Times
Default

No need to do 20 k service and land up with bigger bill, stick to 10k service for now.
Jaggu is offline   Reply With Quote
Old 13th May 2009, 22:33   #148
Newbie
 
Join Date: Apr 2009
Location: Pune
Posts: 9
Thanked: 0 Times
Default

Thanks Jaggu and Vikram. Just to let you know the 10K service (3rd service) was done in Nov-08. That time the car reading was 7K. So I ll get the service done in November 09 now (when 2 years will be done). I dont think I will do 20K by Nov 09.
dasukhija is offline   Reply With Quote
Old 11th June 2009, 15:51   #149
BHPian
 
Join Date: Sep 2007
Location: Bangalore
Posts: 58
Thanked: 4 Times
Default

Seems my Clutch is packing up too.. My Swift has done only 11K in 2 years. I now sense sudden drop in pick up and my engine revs withouth transmitting power most of the time, though I have released the clutch.. Is this could be a clutch adjustment problem if not a wear? I had showed it to a MASS repair guy some 2 months back and he advised to replace the clutch just by driving the car with no inspection.
I don't want to end up getting towed! Any idea on this?
Kiyon is offline   Reply With Quote
Old 21st June 2009, 11:02   #150
BHPian
 
msbehave's Avatar
 
Join Date: Mar 2009
Location: Bombay
Posts: 84
Thanked: 32 Times
Default

Swift clutch - Mine didn't work a month after I got the car! I was driving home late one night after hanging out with friends and I stopped at the signal after Mahalaxmi Station, to take the right onto Tulsi Pipe road. All of a sudden, when it turned green and I put my car into gear, nothing moved. After repeated attempts, someone helped me move my car onto the side. Had to get it towed.

The next day, I get a call from Vitesse saying - "You drive with your foot on the clutch continously so your clutch plate has gone." They refused to take my word for not doing so, until I showed them the other cars I have owned and driven. Only then did they fix it for free. Now, about 3 years and 23K km down the line, I haven't faced any problem.
msbehave is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Maruti using weak engine mounts? commonman Technical Stuff 4 12th January 2017 23:24
Swift D-Clutch/Gear Problem : Competent Motors unable to solve the clutch shudder Eddy Technical Stuff 48 8th September 2013 23:03
Ikon 1.6 with weak clutch takes us to Darjeeling and a few forests of North Bengal. 1100D Travelogues 99 16th August 2009 10:43
Weak clutch on Esteem - Car speed not matching engine RPM gaurav.28ch Technical Stuff 2 26th November 2008 17:47


All times are GMT +5.5. The time now is 13:37.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks