Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 16th September 2015, 16:52   #16
BHPian
 
Join Date: Jul 2015
Location: Pune
Posts: 99
Thanked: 44 Times
Default Re: Indica AC problem....Please help!

Can someone point me to the location of the cabin air filter in indica V2? Is it under the passenger storage bin?
AveekKumar is offline   Reply With Quote
Old 16th September 2015, 17:28   #17
BHPian
 
Join Date: Sep 2011
Location: Bangalore
Posts: 164
Thanked: 40 Times
Default Re: Indica AC problem....Please help!

Quote:
Originally Posted by AveekKumar View Post
Can someone point me to the location of the cabin air filter in indica V2? Is it under the passenger storage bin?
Indica doesn't have a filter for a/c system..
ameaa is offline   (1) Thanks Reply With Quote
Old 7th March 2016, 16:06   #18
Senior - BHPian
 
greenhorn's Avatar
 
Join Date: Apr 2007
Location: TN-14
Posts: 6,839
Thanked: 1,319 Times
Default Re: Indica AC problem....Please help!

Quote:
Originally Posted by bharatbits View Post
The AC in my Indica V2 DLS is behaving weird. A couple of months ago when i went on a long drive on a sunny day the AC just did not cool. There was no cooling at all. However, while returning from the drive in the night it cooled just fine.

Now, after i drive for 45 minutes or so the AC just stops cooling. The orange light on the AC button is on. I can feel the load on the engine as if the AC was on. When i turn the AC on after sometime it is fine again. This happened twice in the last two days. I think there might be some loose connection.

Experienced folks on the forum, could you please help?
Anyone have any idea why this happens?

I have the same problem, but thankfully, it kicks in only after 1-2 hours.

One diagnosis is that the coolant is low, which leads to the condenser freezing. Another one was that the condenser is packed with dirt which causes it to pack up after a while.
Any idea?
greenhorn is offline   Reply With Quote
Old 7th March 2016, 19:56   #19
BHPian
 
bharatbits's Avatar
 
Join Date: Jun 2010
Location: Hyderabad
Posts: 142
Thanked: 42 Times
Default Re: Indica AC problem....Please help!

Get it diagnosed quickly. I recommend not using the AC in the mean time. I did the same mistake. AC unit service would have sufficed had i got it done in time. I kept using it like that and the compressor went kaput. Had to replace them all costing me around 15000 Rs at Subros authorised service centre.
bharatbits is offline   Reply With Quote
Old 7th March 2016, 20:52   #20
BHPian
 
chaudh2s's Avatar
 
Join Date: Jul 2010
Location: Gurgaon
Posts: 197
Thanked: 243 Times
Default Re: Indica AC problem....Please help!

Quote:
Originally Posted by greenhorn View Post
Anyone have any idea why this happens?

I have the same problem, but thankfully, it kicks in only after 1-2 hours.

One diagnosis is that the coolant is low, which leads to the condenser freezing. Another one was that the condenser is packed with dirt which causes it to pack up after a while.
Any idea?
Check if the radiator high speed fan is working or not. To check this, open the bonnet when the engine reaches normal operating temperature. Ask someone to race the engine till the fan starts to spin. Once the fan starts spinning, stop racing the engine and switch on the ac. There should be a perceptible increase in the rpm of radiator fan. If the rpm doesn't increase, its time to repair/replace the radiator fan. This could also be the culprit for ac not cooling effectively during high ambient temperatures or during rush hour traffic, as the condenser doesn't get sufficient cooling.
chaudh2s is offline   Reply With Quote
Old 8th March 2016, 13:41   #21
Senior - BHPian
 
greenhorn's Avatar
 
Join Date: Apr 2007
Location: TN-14
Posts: 6,839
Thanked: 1,319 Times
Default Re: Indica AC problem....Please help!

I checked the radiator & condensor fans, both are working with the ac on.
greenhorn is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Missing Problem in Santro - Please Help rareone Technical Stuff 49 3rd January 2017 15:45
Help Required Indica Vista Safire or Indica Vista TDI Logical Hatchbacks 63 30th October 2011 08:57
Several flat tyre with Indica V2 Turbo please help Tsixty1 Tyre & Alloy wheel Section 18 30th August 2011 11:41
insurance problem - please help S@!l_-oR Shifting gears 4 6th November 2006 21:09


All times are GMT +5.5. The time now is 20:47.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks