Go Back   Team-BHP > Under the Hood > Technical Stuff

Thread Tools Search this Thread
Old 7th May 2007, 16:01   #1
Join Date: Dec 2006
Location: Bangalore
Posts: 1
Thanked: 0 Times
Question Input required for swift VXI initial torque

I purchased a maruti swift VXI model(petrol) in Dec 06. I have driven ~3000 kms till now. There are no modifications from the original condition.
I have been feeling that for last 3 months, the car's initial torque has dropped. With A/c on, it is worse. When I reported to Maruti service center, they first told that it is OK. After lot of cajoling, they adjusted clutch plate/accelerator plate & told that it should be OK now. That worked for only few days. These days it has initial torque has become worse. I always use Shell petrol so bad fuel quality can not be the reason. My observation is that when the vehicle is in stationary position at traffic circle or I start from cold, I just keep on accelator & it moves like maruti 800 or Alto. Have any adjustments/tuning to be made in engine???

njain is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Swift Vxi -petrol Oil Change Diy Required biju.bala DIY - Do it yourself 18 4th June 2013 21:44
swift-vxi,logan-dlx,esteem-vxi which one is better ???? uvais Hatchbacks 4 17th October 2007 10:17
Swift vxi or Esteem vxi ? bsm3477 Hatchbacks 11 15th October 2006 13:38
Input required for Swift accessories Clairvoyant Modifications & Accessories 2 14th September 2005 17:33

All times are GMT +5.5. The time now is 21:03.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks