Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 1st June 2007, 20:57   #1
BHPian
 
prateek's Avatar
 
Join Date: Jul 2006
Location: lucknow
Posts: 126
Thanked: 0 Times
Default facing problem with my turbo setup.

i was facing problem in oha from many days.i got it turbo charged from nivit bhasin of delhi (which i have to say was very shoby job).he used 90 degree turns in the cai and other turbo pipes.at the time of delivery car was working smooth nd powerfull,but from last 1 month i was facing serious problem with pickup of the car.at 1-2k rpm car had no pickup but after 3k rpm car returns to normal nd becomes smooth.
today i went to authorized honda showroom- got turbo's pipe removed from throtel and car was smooth.i figured out that my turbo is not is not giving enough air to throttel at 1-2k rpm and when rpm increases air supply also increase by which car becomes smooth.here is a pic of my engine bay.
http://i16.photobucket.com/albums/b3...4/DSC00201.jpg

http://i16.photobucket.com/albums/b3...4/DSC00200.jpg


please guys help me with it.what to do?i dont think turbo is damage beause after 3000 rpm it works normally.
prateek is offline   Reply With Quote
Old 1st June 2007, 21:46   #2
BHPian
 
rdas45's Avatar
 
Join Date: Feb 2007
Location: Mumbai
Posts: 72
Thanked: 0 Times
Default

Hi, I see your pipe setup, they are little weird, 90 degree turns, Can you post pics of how the pipe is coming to the throttle. You can do one thing, remove the piping from the filter to the turbo. Remove that and drive the car. If you find it smooth there then you know what is to be done to those bends.

If you still are experiecing the problem, then it could be the Standalone Ignition your using. If its a MSD then that could also be a problem.

But 1st, remove the airfilter and that pipe. Then drive it, if it doesnt solve the problem. Post me a pic of your throttle pipe. Also pics of other piping will help. What is your turbo size? Are you running stock Injectors? Which fuel management system are you using?

Last edited by rdas45 : 1st June 2007 at 21:47. Reason: spelling
rdas45 is offline   Reply With Quote
Old 1st June 2007, 22:01   #3
BHPian
 
prateek's Avatar
 
Join Date: Jul 2006
Location: lucknow
Posts: 126
Thanked: 0 Times
Default

thanks rdas.i m using stock ignition nd fuel managment.whae car was delivered it was smooth and power full.from last 1 month i m facing this problem.if this problem is because of cold air intake pipe then it shoud be there before also?
prateek is offline   Reply With Quote
Old 1st June 2007, 23:40   #4
Senior - BHPian
 
veyron1's Avatar
 
Join Date: Mar 2005
Location: Mumbai
Posts: 1,426
Thanked: 37 Times
Default

Get an AFR first. Check your setup. From what I can see from the pics, the plumbing's all wrong. So are your headers/collector. The order has to be odd. From what you say, it seems that your turbo's conked. Unfortunately. Check the oil lines as well.

Did the car emit black/white smoke while accelerating? Also, any idea what boost you were running? Got turbo timer/boost gauge? The stock internals cannot handle much mods without FPR, bigger injectors, etc....

Psycho, Sideways & Ford Rocam could help you out in detail. PM them.

Last edited by veyron1 : 1st June 2007 at 23:43.
veyron1 is offline   Reply With Quote
Old 2nd June 2007, 00:31   #5
BHPian
 
speed0mania's Avatar
 
Join Date: Jun 2005
Location: new delhi
Posts: 463
Thanked: 5 Times
Default

i remember seeing pics of your car on the forum before!! and i think everyone commented on how the plumbing was the worst possible!! i think it was a bad decision to goto hyperperformance (nivit bhasin) i mean i wouldn't trust someone with a turbo setup if thats what he knows about intake plumbing!!!

anyways as far as your problem goes! there will always be turbo lag! it is a TC setup and not SC setup so it does take a while for the turbo to build up enough speed and hence pressure to give boost! but since you say it was working fine earlier i guess your tubo's in trouble! get it checked with someone who knows his job!! no one i know of in delhi whose done succesful tc's! everyone experienced ive heard of is in mumbai or down south!!
p.s. how the hell did he add a turbo w/o any ECU remap or piggy bak device?? and if you are running on stock pistons and rings you could be in trouble dude!! you have to rectify that asap!!

Last edited by speed0mania : 2nd June 2007 at 00:32.
speed0mania is offline   Reply With Quote
Old 2nd June 2007, 00:44   #6
Senior - BHPian
 
BUSA's Avatar
 
Join Date: Aug 2005
Location: Bombay
Posts: 5,130
Thanked: 10 Times
Default

First and foremost change your CAI piping, your engine is not able to breathe smoothly, even a stock setting will make you breathe better.

P.S Why Hyper..... Is he the only one, how much did it cost you, i see many people going to him, though its quite evident that he is the worst tuner in the world, selling crap like intake chargers, volt stabilizer and putting bike filters on cars.
BUSA is offline   Reply With Quote
Old 2nd June 2007, 00:46   #7
Senior - BHPian
 
BUSA's Avatar
 
Join Date: Aug 2005
Location: Bombay
Posts: 5,130
Thanked: 10 Times
Default

Oh ya to give you the best advice, go to him and tell him to make the car stock totally and then go to some other tuner to go for a turbo, thats the best solution, tell him you are selling your car and want to take all the parts out as you selling it as stock. Go to another tuner give him parts and tell him what is usable to use on the new setup. This i think will save you from all kinds of problems in the future.
BUSA is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Front facing Vs Rear facing Vs Side facing seats in MUVs/SUVs ritz830 The Indian Car Scene 20 11th July 2009 16:55
Facing problem with Getz ignition wmax Technical Stuff 6 13th February 2008 12:58
Help!! Alto facing a weird vibration problem wanderluster The Indian Car Scene 0 8th September 2007 01:15
facing problem in my accord. prateek Technical Stuff 39 17th June 2007 12:34
Facing a problem in Palio 1.2 engine amitverma Technical Stuff 18 24th April 2006 09:06


All times are GMT +5.5. The time now is 23:24.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks