Go Back   Team-BHP > Under the Hood > Technical Stuff

Thread Tools Search this Thread
Old 11th July 2007, 13:59   #1
Join Date: Jun 2006
Location: Noida
Posts: 30
Thanked: 0 Times
Default Starting trouble in my one year Old Petra 1.6 ELX

Hi Experts
I am having Fiat Petra 1.6 ELX(bought in 2006 June. All three free services completed.
Since last 15 days (may be more), I am facing one problem: When the engine is cold, it requires two to three long cranking for engine to start. During hot conditions too, it does not start on first immediate cranking.
I went to Dunamic motors, Noida, they said that I will have to leave the car overnight. I did not agree. The third service was done on 3rd June 2007 by Samyak Motors, Patpadganj.
I used normal BP Petrol till May 07. Since June 07, I have shifted to IOC Xtra Premium. Could this be reason.
recently, I visited Nanital / Ranikhet etc. Would it because of some fuel adultration.
Advice pleas.

Regards and thanks in anticipation

Subodh Kumar is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Two Classics, One Car - 81 year old Packard and 101 year old owner karlosdeville Beyond Borders 5 29th August 2016 00:42
96 year old sells 55 year old Italian Fiat for Nano !! emkay456 Shifting gears 14 11th May 2009 14:02
Palio 1.2 ELX makes way for a 2 year old Scorpio 2.6 DX Jammy70 Test-Drives & Initial Ownership Reports 11 9th September 2008 10:39
1 Year / 9500km Fiat Petra ELX report Subodh Kumar Long-Term Ownership Reviews 12 8th June 2007 19:58
Petra 1.6 ELX? Samurai The Indian Car Scene 33 20th July 2005 13:24

All times are GMT +5.5. The time now is 18:31.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks